Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Выбрать дату в календареВыбрать дату в календаре

Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 19 След.
Выпадающий список со смещением
 
Добрый вечер! В модуль листа
Код
Private Sub Worksheet_Change(ByVal Target As Range)
If Target.Row > 1 And Target.Row < 8 And Target.Column = 5 Then
    spisok = ListObjects("reestr").Range.Value2
        For i = 1 To UBound(spisok)
        If Target.Value = spisok(i, 1) Then Cells(Target.Row, Target.Column) = spisok(i, 2): Exit Sub
    Next i
End If
End Sub
Прописание несложного макроса, Невозможность закрытия книги без заполнения всех ячеек + сохранение как
 
OFF
Len_Ka, не лучше ли сделать переключатель для ответа? Мое личное мнение - очень напрягало бы постоянно из выпадающего списка выбирать ответ...
А вообще солидарна с Михаил Витальевич С., только я бы для сбора ответов использовала гугл-формы, думаю для Вас идеальный вариант (можно отвечать с телефона)
Подсчет текстовых значений в диапазоне, при этом учитывая несколько условий.
 
Индекс в Вашем случае выводит всю строку со всеми столбцами, т.к. указали только номер строки, столбец не указали, следовательно берем не ячейку, а массив.
PS "объяснятель" из меня никакущий, так что сами разбирайтесь)
Динамический диапазон с первого не н/д
 
По-моему только макросом можно задать динамический диапазон значений для диаграмм...
Подсчет текстовых значений в диапазоне, при этом учитывая несколько условий.
 
может так?
Код
=СЧЁТЕСЛИМН(Дни_недели;F$36;ИНДЕКС(График[[1]:[31]];ПОИСКПОЗ($C37;График[ФИО];0););"Вых.")
Изменить цвет фона Лабела по событию MouseMove
 
Сделала на "лабел "Дотати"", остальное допиливайте сами по примеру
Код
Private Sub Fr_Kl_Fon_MouseMove(ByVal Button As Integer, ByVal Shift As Integer, ByVal X As Single, ByVal Y As Single)
Lbl_FrKl_AddKlienta.BackStyle = 0
End Sub
Код
Private Sub Lbl_FrKl_AddKlienta_MouseMove(ByVal Button As Integer, ByVal Shift As Integer, ByVal X As Single, ByVal Y As Single)
Lbl_FrKl_AddKlienta.BackStyle = 1
Lbl_FrKl_AddKlienta.BackColor = 255
End Sub
Подсчет СУММЫ относительно даты начала
 
Цитата
Алексей Алекс написал:
Тоесть например ДАНО
Прикрепите файл-пример
Выделение цветом ячеек с формулами
 
Здравствуйте! А УФ =ЕФОРМУЛА(A1) не подходит?
Вставляю текст из блокнота, его разрывает по ячейкам реагируя на пробел, как отключить "разрыв текста"?
 
а как нужно? все в одну ячейку?
Выделить из строки отдельные текстовые и числовые данные по разделителю "скобка"
 
=ЛЕВСИМВ(A1;ПОИСК("2)";A1)+2)&ПСТР(A1;ПОИСК("6)";A1)+3;999)&ПСТР(A1;ПОИСК("3)";A1)-1;ПОИСК("6)";A1)-ПОИСК("3)";A1)+4)&ПСТР(A1;ПОИСК("2)";A1)+3;ПОИСК("3)";A1)-ПОИСК("2)";A1)-3)
Выделить из строки отдельные текстовые и числовые данные по разделителю "скобка"
 
Покажите в примере ручками что должно получиться в итоге
Суммирование остатков по признаку
 
Добрый день. Формула МАССИВА
=СУММ(ЕСЛИ(ЕСЛИОШИБКА(ЛЕВСИМВ($B$2:$B$1289;ПОИСК("№";ПОДСТАВИТЬ($B$2:$B$1289;"-";"№";3))-1);$B$2:$B$1289)=ЕСЛИОШИБКА(ЛЕВСИМВ(B2;ПОИСК("№";ПОДСТАВИТЬ(B2;"-";"№";3))-1);B2);$C$2:$C$1289;0))
Изменено: Настя_Nastya - 2 окт 2020 11:31:53
Номер строки выбранной ячейки
 
Код
Function Stroka() As Long
    Stroka = Selection.Row
End Function
Перенос данных с одного листа на другой и обратно
 
Михаил Лебедев, ааа, ну, значит опять подпольщина))
Преобразовать дату из ДД.ММ.ГГГГ в ГГГГ.ММ.ДД
 
здравствуйте
в лоб =ТЕКСТ(A1*1;"гггг.ММ.дд")
Из плоской таблицы сделать отсортированные сводные данные формулой (без доп.столбцов и без макросов)
 
Добрый вечер, а сводная не подходит?
Изменено: Настя_Nastya - 23 сен 2020 20:10:46
Перенос данных с одного листа на другой и обратно
 
пишу в личку
обсуждаем
ТС отписался, что заказом занимается другой исполнитель, написавший ему ранее
Изменено: Настя_Nastya - 24 сен 2020 22:15:53
Объединение таблиц по заголовкам
 
Цитата
Ranker Dark написал:
как такое сделать без ctrl+c/ctr
тоже на картинке показать? сделайте пример в файле
Подсветить дубликаты в двух столбцах
 
Цитата
Микос001 написал:
какой формулой можно подсветить эти дубликаты
Код
=СЧЁТЕСЛИ($B$2:$B$5;A2)>0
здравствуйте
Добавление в одну ячейку гистограммы и условия, как сделать так что бы после заполнения гистограммы выполнялось определенное условие
 
Добрый день! Измените формулу в S15 и ниже на
=ЕСЛИ(L15>=I15;"Работы выполнены на 100%";L15/I15)
затем добавьте УФ на ячейки в S столбце:
Изменено: Настя_Nastya - 22 сен 2020 12:44:27
требуется макрос для сравнения двух столбцов, гугл таблицы
 
Пишу в личку
ТС пропал
Изменено: Настя_Nastya - 23 сен 2020 13:43:38
Формула расчета для определения минимальной цены
 
Два доп.столбца
=ЕСЛИ(C5="";D4;C5)
=ЕСЛИ(B5<D5;D5;B5)
Точки как граница ячеек по умолчанию. Как избавиться?
 
Добрый день! В настройках попробуйте выбрать цвет "авто" (если выбран другой цвет, то линия будет точечками отображаться)
Из текстовой строки дата с временем получить только дату VBA
 
Добрый вечер!
Код
Sub Дата_из_текста()
    Dim r, c As Range
    With ActiveSheet
        Set r = Intersect(.UsedRange, .[a:a]).Offset(1)
        r.FormulaLocal = r.FormulaLocal
        r.NumberFormat = "dd.mm.yyyy"
        For Each c In r
            .Cells(c.Row, c.Column) = Format(c.Value2, "dd.mm.yyyy")
        Next c
    End With
End Sub
Изменено: Настя_Nastya - 16 сен 2020 21:53:42
Автоматизация обработки путевых листов (Доработать существующую таблицу)
 
Пишу в личку
Обсуждаем
В работе
Готово
Изменено: Настя_Nastya - 21 сен 2020 18:42:57
Универсальный макрос вставки значений и форматирования чисел из буфера обмена в выделенную ячейку. Возможно ли?
 
Неа, тогда попробуйте одним макросом копировать, а другим вставлять
Код
Public s As Range
Sub Copy()
Set s = Selection
s.Copy
End Sub
Sub Paste()
Selection.PasteSpecial xlPasteValues
Selection.PasteSpecial xlPasteFormats
s.ClearContents
End Sub
Изменено: Настя_Nastya - 16 сен 2020 11:33:12
Универсальный макрос вставки значений и форматирования чисел из буфера обмена в выделенную ячейку. Возможно ли?
 
Здравствуйте! попробуйте этот код:
Код
Sub Paste ()
Selection.PasteSpecial xlPasteValues
Selection.PasteSpecial xlPasteFormats
End Sub
Изменено: Настя_Nastya - 16 сен 2020 11:06:28
Преобразовать сумму 0,00 в 0 рубл. 00 коп.
 
добрый день! Пользовательский формат
Проверка данных с поиском как в Google Sheets
 
Добрый день! mike31, может это Вам подойдет?)
Не работает авторасчет суммы и формула не вставляется
 
Беймбет Кушкалиев, в ячейку, где нужно посчитать сумму по Дебету!
Ну или просто нажмите Ctrl+H и замените точку на запятую.
Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 19 След.
Наверх