Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Выбрать дату в календареВыбрать дату в календаре

Страницы: 1 2 3 4 5 6 7 8 9 След.
Скопировать строки по определенному критерию на другой лист для этого же критерия
 
Если четко по примеру, то можно так:
=ИНДЕКС(Sheet2!A$1:A$9;ПОИСКПОЗ($F2;Sheet2!$F$1:$F$9;0))
=ИНДЕКС(Sheet2!A$1:A$9;ПОИСКПОЗ($F3;Sheet2!$F$1:$F$9;0)+1)
(чередующиеся строки)
Преобразовать текстовую дату в краткий формат даты, Преобразовать текстовую дату в краткий формат даты
 
доброе утро! davaispoem, Не месяц в датах перевести на русский, а названия функций в формуле...
Цитата
БМВ написал:
потрудитесь перевести все функции на ваши привычные русские
Нужно перевести сами функции в формуле...TEXT - ТЕКСТ и тд
Изменено: Настя_Nastya - 15 Окт 2019 09:29:21
В каждой строке таблицы проставить статус задачи, найдя соответствующий идентификатор в другой таблице
 
Добрый вечер, доп. столбец:
Код
=ЕСЛИ(ИЛИ(ПСТР(Sheet1!A2:A58;1;1)="e";ПСТР(Sheet1!A2:A58;1;1)="m");ЕСЛИ(ПРАВСИМВ(ЛЕВСИМВ(A2;4);1)=" ";ЛЕВСИМВ(A2;3);ЛЕВСИМВ(A2;2));ЕСЛИ(ПРАВСИМВ(ЛЕВСИМВ(B2;4);1)=" ";ЛЕВСИМВ(B2;3);ЛЕВСИМВ(B2;2)))
Подтянуть попробуйте сами)
Извлечь текст из последних скобок и удалить непечатные символы
 
caspian1977, замените этот пробел (код символа 160) на обычный пробел, а затем используйте функцию СЖПРОБЕЛЫ
формула в иксель, опять завсегдатаи резвятся )
 
Цитата
БМВ написал:
не уводите от темы
я и не думала)
Цитата
БМВ написал:
стенография того что написано в #1
все чисто по заданию
формула в иксель, опять завсегдатаи резвятся )
 
Вот формула для Икселя, вдруг кому понадобится: =(А1-А1+А2)/2+А1
Цитата
stolll написал:
Блин очень надеюсь что понятно.
Извлечь текст из последних скобок и удалить непечатные символы
 
Что за народ пошел? А поздороваться? Осталось только сроки обозначить и в конце прикрикнуть "да поживее!!!"
Проверка по условиям и выбор ближайшего значения
 
попробуйте так:
Код
=ЕСЛИ(И(B3<=C3;B3<=D3);B3;ЕСЛИ(КОРЕНЬ((D3-B3)*(D3-B3))>КОРЕНЬ((C3-B3)*(C3-B3));C3;D3))
Построчное дублирование значений по условию
 
Товарищ Вит, добрый вечер, Вы бы отредактировали свой текст в сообщении, а то глаза сломать можно...
Как найти минимальные значение >0, с каждой стороны возрастающей-убывающей кривой
 
Цитата
Cappadonna написал:
про такую функцию я не знала
Хмм, странно... довольно популярная функция)
Как найти минимальные значение >0, с каждой стороны возрастающей-убывающей кривой
 
Второй минимум с доп. строками
Как найти минимальные значение >0, с каждой стороны возрастающей-убывающей кривой
 
Формулы МАССИВА:
первый МИН
Код
=ИНДЕКС(C3:AV3;ПОИСКПОЗ(МИН(ЕСЛИ(C4:AV4>=0;C4:AV4;""));C4:AV4;0))
второй МИН
Код
=СУММЕСЛИМН(A3:AV3;A4:AV4;ЕСЛИ(A4:AV4>=0;A4:AV4;"");A3:AV3;"<>"&$A$8)
МАКС
Код
=ИНДЕКС(C3:AV3;ПОИСКПОЗ(МАКС(ЕСЛИ(C4:AV4>=0;C4:AV4;""));C4:AV4;0))
Как найти минимальные значение >0, с каждой стороны возрастающей-убывающей кривой
 
Судя по описанию в строке 4 максимальное 7, у Вас же 15... если смотреть по строке 1, то там только 15 и нули...
В какой сроке искать МИН и покажите в примере - что должно получиться, не формулы, ест-но, а просто числа.
Поместить все согласные буквы в одну ячейку
 
Цитата
and.kaa написал:
А можно то же самое сделать с гласными
Не обязательно быть программистом, просто немножко подумать...
Вот часть кода
Код
[^йцкнгшщзхъфвпрлджчсмтьб]
- это список букв (в данном случае согласные), который выделяется...
Изменено: Настя_Nastya - 13 Окт 2019 16:33:29
Найти максимальное значение по условию и критерию
 
Формулы МАССИВА
Макс. сумма продажи:
=МАКС(СУММЕСЛИМН($C$2:$C$238;$A$2:$A$238;A2:A238;$D$2:$D$238;"";$B$2:$B$238;$F$2))
Номер недели этой макс.суммы:
=ИНДЕКС($A$2:$A$238;ПОИСКПОЗ($G$2;СУММЕСЛИМН($C$2:$C$238;$A$2:$A$238;A2:A238;$D$2:$D$238;"");0))
Изменено: Настя_Nastya - 13 Окт 2019 13:59:27
Извлечь из таблицы несколько товаров под одним номером, ВПР берет только первый товар
 
Сводная со всей таблицей справится...
но, хозяин - барин...
Изменено: Настя_Nastya - 12 Окт 2019 10:35:25
Выделить строки таблицы по совпадению в столбце
 
Цитата
evgen740102 написал:
Если значение в колонке "Part Number:" совпадает,
Совпадает с чем?!
Извлечь из таблицы несколько товаров под одним номером, ВПР берет только первый товар
 
сводная
формула в иксель, опять завсегдатаи резвятся )
 
Максим В.,я лучше в сторонке пока постою)))
Какой формулой можно вернуть букву столбца?
 
Код
=ПСТР(АДРЕС(1;СТОЛБЕЦ();2);1;ДЛСТР(АДРЕС(1;СТОЛБЕЦ();2))-НАЙТИ("$";АДРЕС(1;СТОЛБЕЦ();2)))
Вставка картинки по условию, .
 
сделайте что-то типа справочника с картинками и номерами и пусть макрос, в зависимости от номера, вставляет из справочника нужную картинку.
тему, наверное лучше переименовать на "Вставка картинки по условию"
Как обращаться к создаваемому листу, имя которому присваивается сцеплением текста?
 
БМВ, vikttur, я просто поняла, что в этом же коде ниже нужно обращаться
Обновление данных из одного листа в другой по номеру ячейки
 
Макрос скопирует строку из листа Form во все строки Kot, где есть совпадение по Вашему ключу:
Код
Sub ccc()
Dim LastRow, i
LastRow = ThisWorkbook.Sheets("Kot").Range("A10000").End(xlUp).Row
    For i = 2 To LastRow
        If ThisWorkbook.Sheets("Kot").Range("A" & i) = ThisWorkbook.Sheets("Form").Range("B47") Then
            ThisWorkbook.Sheets("Form").Range("C47:I47").Copy
            ThisWorkbook.Sheets("Kot").Range("B" & i & ":H" & i).PasteSpecial Paste:=xlPasteValues
        End If
    Next
End Sub
Как обращаться к создаваемому листу, имя которому присваивается сцеплением текста?
 
можно имя листа сначала в переменную загнать...
Код
NameList1="7" & "." & wbI.Sheets("Вх").Cells(277, 1).Text
wbO.Worksheets.Add.Name = NameList1
wbO.Worksheets(NameList1)
Изменено: Настя_Nastya - 11 Окт 2019 12:54:24
Сортировка сгруппированных данных, слетают дочерние строки
 
А главные строки отличаются от дочерних? Судя по скринам, главные с "жирным" шрифтом, а дочерние - с обычным, верно?
Сортировка сгруппированных данных, слетают дочерние строки
 
Здравствуйте, в начале названия дочерней строки продублируйте название главной (пример: "Строка 5. АБВ Данные строки 5")
Кнопки назад и вперед не работают с макросом
 
Ну, зашейте в начало кода макроса - сохранение копии в туже папку, например, где основная, под опред. названием...
Изменено: Настя_Nastya - 8 Окт 2019 16:55:57
Проблема при работе PasteSpecial в 2013 Excel VBA. Ошибка PasteSpecial
 
А в какой тогда "не тот" диапазон у Вас в 2013 копируется? если не секрет, конечно...
Проблема при работе PasteSpecial в 2013 Excel VBA. Ошибка PasteSpecial
 
qwerty64, ну у Вас прям клешнями нужно все вытаскивать. Выложите пример с кодом...
Гиперссылка на нужную таблицу
 
:D да какие же тут обиды?))))
Страницы: 1 2 3 4 5 6 7 8 9 След.
Наверх