Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Выбрать дату в календареВыбрать дату в календаре

Страницы: 1
Номер диапазона, в котором находится промежуточное значение
 
Я наверное все таки не правильно таблицу для примера составил. Хотелось более универсальное решение, нежели в рамках этого примера.
В итоге у меня получилось:
Код
=ИНДЕКС($D$2:$F$11;ПОИСКПОЗ(ИСТИНА;A2<=$E$2:$E$11*ИЛИ(ЕСЛИ(A2>=$D$2:$D$11;A2<=$E$2:$E$11));0);3)
Соответственно нет необходимости упорядочивать диапазоны по возрастанию и если число не входит ни в один диапазон - оно исключается (в случае с впр у меня все равно находило ближайший наименьший диапазон)
 
Изменено: dale92 - 8 апр 2021 17:01:00
Номер диапазона, в котором находится промежуточное значение
 
Приложил :)  
Номер диапазона, в котором находится промежуточное значение
 
Если я хочу в условии добавить два логических выражения

=ИНДЕКС($D$2:$F$11;ПОИСКПОЗ(ИСТИНА;И(A2>$D$2:$D$11;A2<$E$2:$E$11);0);3) выводит Н/Д

По такому условию смогу проверять непоследовательные интервалы и с пропущенными значениями между ними.
таблицу эту привел для примера (видимо не совсем удачного) в основной таблице нужна гибкая формула к положениям ячеек, поэтому чрез впр не вариант.
Изменено: dale92 - 8 апр 2021 14:20:36
Номер диапазона, в котором находится промежуточное значение
 
Не получается только поиск позиции по двум условиям И(А>числа1;A<числа2), что не так с синтаксисом??
Номер диапазона, в котором находится промежуточное значение
 
Спасибо, я все же решил формулой массива:
Код
=ИНДЕКС($D$2:$F$11;ПОИСКПОЗ(ИСТИНА;A2<$E$2:$E$11;0);3)
Нужно вставить две пустые ячейки, заполенные сместить вправо
 
Спасибо!
Номер диапазона, в котором находится промежуточное значение
 
Добрый день!

Есть таблица:


Нужно значению 3 присвоить значение 2, при условии, что значения 1 входит в соответствующий диапазон.

Если я через =ИЛИ(ЕСЛИ(А2>=$D$2:$D$10;A2<=$E$2:$E$10)) нахожу наличие значения в указанных диапазонах, то как мне определить в какой именно диапазон(т.е. строку) я попал, или я все же не в ту сторону думаю?

Спасибо.
Нужно вставить две пустые ячейки, заполенные сместить вправо
 
Добрый день!

Дано: таблица в Nом-столбце каждой строки расположена кнопка.

Нужен макрос для кнопки: При нажатии на кнопку, справа от нее, вставляются две пустые ячейки, а заполненые ячейки соответственно смещаются право.

И еще вопрос, есть ли смысл вместо кнопки использовать гиперссылку в ячейки для "облегчения" таблицы (таких строк ~2000шт)?
Как адать адресный поиск в диапазоне?
 
БМВ,еще раз огромное спасибо! не знал, что нулевые значения и ячейки без данных расцениваются тождественно.

Цитата
2.Могу ли я массив для "индекса" задавать не строками, а столбцами, соответственно вместо Счетчики!$1:$1048576 пишу  Счетчики!$А:$А, после чего результат в ячейке  #ССЫЛКА!.  

не проснулся похоже еще(рука/лицо), сейчас только понял что чушь написал.
Как адать адресный поиск в диапазоне?
 
БМВ, спасибо!

Два вопроса:
1.По первой позиции все правильно считает(там где ТТ000694), добавляю новые данные все корректно отображается, а вот чтобы в последующих базах отображалось корректно нужно их удалить и полностью их перебивать по новой, в противном случае отображается только первый счетчик, независимо, сколько идет следом. T.е. для ТТ000808 выводится ЦЭ6308В, вместо СЕ303. В чем моя ошибка?

2.Могу ли я массив для "индекса" задавать не строками, а столбцами, соответственно вместо Счетчики!$1:$1048576 пишу  Счетчики!$А:$А, после чего результат в ячейке  #ССЫЛКА!.  
Как адать адресный поиск в диапазоне?
 
Доброго времени суток!

Имеем два листа, на первом выводим информацию, на втором соответственно добавляем новую в процессе работы. Соответственно необходимо по номеру базы определить последние данные и перенести их из рабочего листа в информационный лист.

Вопрос в следующем, как задать поиск диапазона массива, в котором ищем нужное значение.
Т.е. если бы я мог(выделил жирным):  
Код
=ДВССЫЛ(АДРЕС(ПОИСКПОЗ(A2;Счетчики!A:A;0);ПОИСКПОЗ(;[B]Счетчики!2:2[/B];-1)-2;;;"Счетчики"))

данный массив задать через тот же поиск позиций, в принципе все бы работало. Но как это реализовать мозгов не хватает:)

Заранее спасибо!!

 p.s. понимаю как решить задачу макросом, но необходимо именно формулой, так как макросы на рабочем пк отключены ит-департаментом  
Изменено: dale92 - 2 ноя 2019 00:57:38
Страницы: 1
Наверх