Выбрать дату в календареВыбрать дату в календаре

Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 23 След.
Замена букв слова в одной ячейке на другие символы, Замена букв слова в одной ячейке на другие символы
 
Код
=ОБЪЕДИНИТЬ("";1;ИНДЕКС(ФИЛЬТР.XML("<j><i>"&ПОДСТАВИТЬ("1;2;3;4;5;6;7;8;9;1;2;3;4;5;6;7;8;9;1;2;3;4;5;6;7;8";";";"</i><i>")&"</i></j>";"//i");ПОИСКПОЗ(ПСТР(A1;ПОСЛЕД(ДЛСТР(A1));1);СИМВОЛ(СТРОКА(65:90));0)))
=СЦЕП(ИНДЕКС(ФИЛЬТР.XML("<j><i>"&ПОДСТАВИТЬ("1;2;3;4;5;6;7;8;9;1;2;3;4;5;6;7;8;9;1;2;3;4;5;6;7;8";";";"</i><i>")&"</i></j>";"//i");ПОИСКПОЗ(ПСТР(A1;ПОСЛЕД(ДЛСТР(A1));1);СИМВОЛ(СТРОКА(65:90));0)))
=СУММ(ИНДЕКС(ФИЛЬТР.XML("<j><i>"&ПОДСТАВИТЬ("1;2;3;4;5;6;7;8;9;1;2;3;4;5;6;7;8;9;1;2;3;4;5;6;7;8";";";"</i><i>")&"</i></j>";"//i");ПОИСКПОЗ(ПСТР(A1;ПОСЛЕД(ДЛСТР(A1));1);СИМВОЛ(СТРОКА(65:90));0)))
Изменено: Тимофеев - 22.10.2021 19:11:00
Можно ли формулой избавиться от экспоненциального числа
 
Код
=ЗНАЧЕНИЕВТЕКСТ(D5)
Можно ли формулой избавиться от экспоненциального числа
 
vikttur, написал ДЛСТР(D5)-2
Можно ли формулой избавиться от экспоненциального числа
 
верно.
тогда никак
Изменено: Тимофеев - 20.10.2021 13:44:12
Можно ли формулой избавиться от экспоненциального числа
 
число
Можно ли формулой избавиться от экспоненциального числа
 
Код
=ФИКСИРОВАННЫЙ(D5;ДЛСТР(D5))
Как разнести данные из одной ячейки в строки в нескольких массивах
 
в G2:
Код
=ЕСЛИ(E2="";G1;E2)

на ячейке G2 Ctrl+Shift+End - выберется нужный диапазон и далее жмем Ctrl+D
В зависимости от суммы диапазона ячеек и их запоненности вывести один из четырех вариантов сообщения.
 
Код
=ВЫБОР(ЕСЛИ(СЧЁТЗ(C1:C10)*ЗНАК(СУММ(C1:C10))=-10;СЧЁТЗ(C1:C10)*ЗНАК(СУММ(C1:C10))/10-1;СЧЁТЗ(C1:C10)*ЗНАК(СУММ(C1:C10))/10)+3;"Долг на конец года";"Текущий долг";"Текущая переплата";"Переплата на конец года")
Как транспонировать строку через каждые 8 столбцов ?
 
Код
=ИНДЕКС(A1:CB1;1;ПОСЛЕД(СЧЁТЗ(A1:CB1)/8;8;1;1))
Какие возможности есть у ФИЛЬТР.XML ?
 
да, пробелы он всегда обрезает
Перечислить числа, указанные в диапазоне a-b
 
Код
=ОБЪЕДИНИТЬ(", ";1;МОДА.НСК(ПОСЛЕД(ПРАВБ(F2;4)-ЛЕВБ(F2;4)+1;1;ЛЕВБ(F2;4);1);СТРОКА(A1:A2021)))
=ОБЪЕДИНИТЬ(", ";1;НАИМЕНЬШИЙ(СТРОКА(A1:A2021);ПОСЛЕД(--ПРАВБ(F2;4)-ЛЕВБ(F2;4)+1;1;--ЛЕВБ(F2;4);1)))
Изменено: Тимофеев - 12.10.2021 12:50:35
Перечислить числа, указанные в диапазоне a-b
 
Код
=ОБЪЕДИНИТЬ(",";;СТРОКА(ДВССЫЛ("A"&--ЛЕВСИМВ(D2;4)&":A"&--ПРАВСИМВ(D2;4))))
=ОБЪЕДИНИТЬ(",";;СТРОКА(ДВССЫЛ("A"&--ЛЕВБ(D2;4)&":A"&--ПРАВБ(D2;4))))
Изменено: Тимофеев - 12.10.2021 09:35:32
Перечислить числа, указанные в диапазоне a-b
 
массивно
Перечислить числа, указанные в диапазоне a-b
 
Код
=ОБЪЕДИНИТЬ(", ";1;ЕСЛИ(СТРОКА($A$1:$A$2021)*(СТРОКА($A$1:$A$2021)>=--ЛЕВСИМВ(D2;4))*(СТРОКА($A$1:$A$2021)<=--ПРАВСИМВ(D2;4))=0;"";СТРОКА($A$1:$A$2021)*(СТРОКА($A$1:$A$2021)>=--ЛЕВСИМВ(D2;4))*(СТРОКА($A$1:$A$2021)<=--ПРАВСИМВ(D2;4))))
Изменено: Тимофеев - 11.10.2021 10:07:09
Перечислить числа, указанные в диапазоне a-b
 
печальный эксель
Перечислить числа, указанные в диапазоне a-b
 
Код
=ОБЪЕДИНИТЬ(", ";1;СОРТ(СЛМАССИВ(ФИЛЬТР.XML("<j><i>"&ПОДСТАВИТЬ(D2;" — ";"</i><i>")&"</i></j>";"//i[2]")-ФИЛЬТР.XML("<j><i>"&ПОДСТАВИТЬ(D2;" — ";"</i><i>")&"</i></j>";"//i[1]")+1;1;ФИЛЬТР.XML("<j><i>"&ПОДСТАВИТЬ(D2;" — ";"</i><i>")&"</i></j>";"//i[1]");ФИЛЬТР.XML("<j><i>"&ПОДСТАВИТЬ(D2;" — ";"</i><i>")&"</i></j>";"//i[2]");1)))
=ОБЪЕДИНИТЬ(", ";1;ПОСЛЕД(ПРАВСИМВ(D2;4)-ЛЕВСИМВ(D2;4)+1;1;ЛЕВСИМВ(D2;4);1))
Изменено: Тимофеев - 11.10.2021 09:11:02
Помощник при написании формулы, состоящей из нескольких вложенных функций ЕСЛИ()
 
нет и не было лямбды в 365 ! Только Let пока в общем пользовании
Протянуть формулу на определенное количество ячеек, которое равно количеству ячеек в столбце с данными таблицы на другом листе
 
Код
=ИНДЕКС(Лист2!A:A;ПОСЛЕД(СЧЁТЗ(Лист2!A:A)-1;1;2))

Протянуть формулу на определенное количество ячеек, которое равно количеству ячеек в столбце с данными таблицы на другом листе
 
New, для полезности такое оформление как у Вас и нужно  
Сумма по нескольким условиям с диапазоном суммирования из нескольких строк
 
поглядите пару блоков раскопировал ниже
Сумма по нескольким условиям с диапазоном суммирования из нескольких строк
 
примерно так
Поиск текста в двух столбцах с помощью ВПР, не срабатывает функция ВПР, когда искомое значение в диапазоне поиска стоит в конце текста
 
как Минимум потому что Груша и груша это разные слова
Сумма по нескольким условиям с диапазоном суммирования из нескольких строк
 
не равно - вернет массив 0,0,0,0,0,1,0,0 Причем Красный 0 потому что Пенсия с большой буквы
Если так написать, то будет не важен регистр и вернет 0,0,0,0,0,1,1,1
Код
=--ЕСЛИОШИБКА(ПОИСК(A30;$A$19:$A$26)>0;0)
Изменено: Тимофеев - 08.10.2021 14:15:47
Сумма по нескольким условиям с диапазоном суммирования из нескольких строк
 
как формулу массива вводите в E29
В кратце в столбце А ищем вхождение где присутствует РЖД
НАЙТИ(A29;$A$19:$A$26)
(если присутствует то получаем массив чисел с номерами первого вхождения слова, при отсутствии получаем Знач.)
=НАЙТИ(A29;$A$19:$A$26)>0 какие позиции больше нуля - возвращает массив Истина или Знач
=ЕСЛИОШИБКА(НАЙТИ(A29;$A$19:$A$26)>0;0) - убираем знач. вместо него 0
=--ЕСЛИОШИБКА(НАЙТИ(A29;$A$19:$A$26)>0;0) - Вместо Истина делает 1
=$E$19:$S$26 - массив с числами которые будем складывать
=--ЕСЛИОШИБКА(МЕСЯЦ(ДАТАЗНАЧ(1&$E$18:$S$18&2021))<=МЕСЯЦ(ДАТАЗНАЧ(1&$A$31&2021));0) массив 1 или 0 по условию месяц меньше или равен 9 (МЕСЯЦ(ДАТАЗНАЧ(1&$A$31&2021)) - это 9)
Перемножение этих трех массивов даст массив с нужными цифрами для сумм
Изменено: Тимофеев - 08.10.2021 14:17:39
Зачем Excel'21 вставляет в формулы "@" ?, Справка молчит.
 
Динамические - FILTER, SORT, SORTBY, UNIQUE, SEQUENCEи RANDARRAY.
XLOOKUP
LET
ПОИСКПОЗX
Новые возможности Excel 2021 для Windows (microsoft.com)
Изменено: Тимофеев - 07.10.2021 17:51:24
Сумма по нескольким условиям с диапазоном суммирования из нескольких строк
 
Код
=СУММ(--ЕСЛИОШИБКА(НАЙТИ(D13;$D$3:$D$10)>0;0)*($H$3:$V$10)*(--ЕСЛИОШИБКА(МЕСЯЦ(ДАТАЗНАЧ(1&$H$2:$V$2&2021))<=МЕСЯЦ(ДАТАЗНАЧ(1&$D$15&2021));0)))
Сумма по нескольким условиям с диапазоном суммирования из нескольких строк
 
Код
=СУММ(--ЕСЛИОШИБКА(НАЙТИ(D13;$D$3:$D$10)>0;0)*($H$3:$S$10)*(МЕСЯЦ(ДАТАЗНАЧ(1&$H$2:$S$2&2021))<=МЕСЯЦ(ДАТАЗНАЧ(1&$D$15&2021))))
Подстановка значений из предыдущей строки
 
Добавка к МатросНаЗебре,
в С2 формулу:
Код
=ЕСЛИ(A2="";C1;A2)
Ctrl+Shift+End
Отпускаем Shift+End и нажимаем D (Ctrl продолжаем удерживать)
Альтернатива протяжки при длинном списке
Изменено: Тимофеев - 07.10.2021 15:29:05
Сумма по нескольким условиям с диапазоном суммирования из нескольких строк
 
Код
=СУММ(--ЕСЛИОШИБКА(НАЙТИ(D13;$D$3:$D$10)>0;0)*($H$3:$S$10)*($H$2:$S$2=$D$15))
Повторное выделение ячейки с зажатым ctrl.
 
Jack Famous, не темнеет ничего 365
Изменено: Тимофеев - 07.10.2021 13:03:13
Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 23 След.
Наверх