Выбрать дату в календареВыбрать дату в календаре

Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 26 След.
Оптимизация запросов в Power Query
 
Цитата
creept написал:
должна получиться книга без привязки к запросам в виде плоских таблиц

ну так не бывает, даже ваши таблицы ссылаются на запросы, а DAX использует модель данных. в любом случае, я считаю, что такое ТЗ для платной ветки
Power Query фильтрация запроса по дате, веденной пользователем
 
таблица с ограничением дат, ее впихиваете в основной код

Код
let
    Источник = Excel.CurrentWorkbook(){[Name="Таблица1"]}[Content],
    #"Измененный тип" = Table.TransformColumnTypes(Источник,{{"с", type date}, {"по", type date}}),
    с= #"Измененный тип"{0}[с],
    по = #"Измененный тип"{0}[по]
in
    по


дате в ваш код по ограничению: ... [Date] >= с and [Date] <= по)
Оптимизация запросов в Power Query
 
вариант перехода на DAX не рассматриваете?
Сравнение сумм по двум временным шкалам в сводной таблице
 
Добрый день, это можно реализовать только с помощью DAX
Порядок цифр, но с повторением.
 
в А2 и копируем вниз

Код
=ЕСЛИ(СЧЁТЕСЛИ(A$1:$A1;A1)=1;A1;A1+1)
Свой формат сокращения дней недели.
 
так?

Код
=ТЕКСТ(A2;"ДД.ММ.ГГГГ")&" "&ВЫБОР(ДЕНЬНЕД(A2);"Вс";"Пн";"Вт";"Сре";"Чт";"Пт";"Суб")
DAX действие между двумя таблицами
 
не оптимально

Код
=SUMX(ADDCOLUMNS('Дебиторы';"q";LOOKUPVALUE('Курсы валют'[Курс];'Курсы валют'[Валюта];'Дебиторы'[Валюта];'Курсы валют'[Месяц];'Дебиторы'[Месяц]));[q]*'Дебиторы'[Задолженность])
Умножение дробей, Умножение дробей
 
Код
=C2*--ЛЕВСИМВ(F2;ПОИСК("/";F2;1)-1)/--ПРАВСИМВ(F2;ДЛСТР(F2)-ПОИСК("/";F2;1))
ПРОСМОТРX: Суммирование по вхождению
 
Добрый. К чему такие издевательства?

Код
=СУММЕСЛИ(A5:A10;B1&"*";C5:C10)
Учет времени в отпуске
 
Код
=(СУММПРОИЗВ((ДЕНЬНЕД(день1;2)<6)*(E12:S12="от"))+СУММПРОИЗВ((ДЕНЬНЕД(день2;2)<6)*(W12:AL12="от")))*8
Получить предыдущее значение SELECTEDVALUE
 
оно?

Код
=IF(ISFILTERED('Лист1'[Регион]);SUM('Лист1'[Сумма]);CALCULATE(SUM('Лист1'[Сумма]);FILTER('Лист1';'Лист1'[Главный регион]='Лист1'[Регион])))
Как получить расшифровку значений в формулах в соседней ячейке, Как получить расшифровку значений в формулах в соседней ячейке
 
если excel поддерживает, то обычная Ф.ТЕКСТ()
PQ: Расчет остатка запасов нарастающим итогом по месяцам
 
моя тема в помощь
тыц
7 последних (некалендарных) дат в сводной таблице
 
вариант с доп. столбцами
PQ: Конвертация столбцов с датами и суммами с разными форматами в один общий
 
Framed, и сколько таких файлов всего? если порядка сотни (можно и больше), то я бы заморочился и отработал бы каждый под нужный формат и пересохранил в csv
Power query игнорировать отсутствие листа
Поиск значения в массиве по нескольким условиям
 
вариант
Код
=ИНДЕКС(C3:K6;СУММПРОИЗВ((F9>=A3:A6)*(F9<B3:B6)*СТРОКА(A3:A6))-2;ПОИСКПОЗ(F8;C2:K2;0))
Power query игнорировать отсутствие листа
 
нужно смотреть тогда сами файлы
Формула для свода данных в разрезе статей затрат и периода, Формула для свода данных в разрезе статей затрат и периода
 
в С3 и копируем
Код
=СУММПРОИЗВ((ТЕКСТ(Заполнить!$A$2:$A$5;"ММММ")='Свод '!C$2)*(Заполнить!$E$2:$E$5='Свод '!$A3)*Заполнить!$C$2:$C$5)
Power Query аналог ВПР или ПОИСК из этой же таблицы, Можно ли осуществлять поиск значения по условию из этой же таблицы?
 
У Сидорова тип средний, а не пусто. Проверьте свой пример еще раз
Формула плана продаж в день, с учетом уже выполненных продаж за предыдущие дни
 
а может так?
Power query игнорировать отсутствие листа
 
удалите перед "на следующем шаге появляется ошибка:" строки с ошибками
Формула плана продаж в день, с учетом уже выполненных продаж за предыдущие дни
 
что такое "актуальный" план?
Сравнение числа с предыдущими в заданом диапазоне
 
так?
Формула не считается, Формула считается только после двойного щелчка по ней
 
выделить столбец и как на скрине, потом нажать готово
Формула не считается, Формула считается только после двойного щелчка по ней
 
изначально был установлен текстовый формат ячейки, затем его изменили на общий, но для того, чтобы формат применился и формула заработала нужно либо проклацивать либо сделать текст по столбцам
Получить таблицу из последных введеных даных Power Pivot по уникальности, dax formula
 
Чем обычная сводная таблица не устраивает?
powerBi. функция IF и область ее действия
 
п 2.3

тыц
Изменено: mechanix 85 - 10.06.2022 16:02:48
Power Query. Вложенная группировка
 
Цитата
deffocus написал:
Если требуется дописать условие в категории, то это будет выглядеть так?

так и все работает
Power Query. Вложенная группировка
 
Код
let
    Источник = Excel.CurrentWorkbook(){[Name="Таблица1"]}[Content],
    #"Измененный тип" = Table.TransformColumnTypes(Источник,{{"Категория 1", type text}, {"Категория 2", type text}, {"Категория 3", type text}, {"Сумма", Int64.Type}}),
    #"Сгруппированные строки" = Table.Group(#"Измененный тип", {"Категория 1", "Категория 2"}, {{"Сумма по критерию Дрмб3", each List.Sum(Table.SelectRows(_, each [Категория 3] = "Дрмб3")[Сумма])},{"Общая сумма", each List.Sum([Сумма]), type number}})
in
    #"Сгруппированные строки"
Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 26 След.
Наверх