Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Выбрать дату в календареВыбрать дату в календаре

Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 319 След.
Анекдот дня, Постим сюда понравившиеся:)
 
Регулярно употребляю чеснок и лук. Поэтому о сексе и ангине знаю только понаслышке...

Подружка сказала, что в постели надо быть непредсказуемой...
И вот во время секса я достала БУБЕН!!!

Вечер... Спальня... Злой голос мужа:
— Да у тебя на этой неделе только брови не болели!
Анекдот дня, Постим сюда понравившиеся:)
 
Бесконечное количество математиков заходит в бар.
Первый говорит: — Мне — поллитра пива, пожалуйста.
Второй говорит: — А мне — четверть литра.
Третий: — А мне — одну восьмую.
Четвертый: — А мне — одну шестнадцатую.
Бармен: — Эй, эй, эй, стоп! Вот вам один литр на всех, не полоскайте мне мозг!
anekdotov.net
Отменить автозамену на дату числа с точкой
 
Первая формула подходит только для ювелирных колец, там бывают размеры 17; 17.15; 18; 18.5 и т. д. и не бывает 17.4 или 17.6.
Вторая = более общий случай, когда десятичная часть числа может менятся от 0.1 до 0.9
Изменено: Михаил С. - 29 Ноя 2018 14:57:30
На что перейти с Excel ?, Финансово-политический вопрос. И досужие домыслы, обусловленные поверхстным взглядом на ситуацию.
 
Цитата
Neufazendnik написал:
Вроде и купил, вроде и твое
Купил, лицензия есть, значит не украл - счас полно возможностей активировать и без участия Майкрософта.
Отменить автозамену на дату числа с точкой
 
Начиная с А2:
Кольцо золотое |Т130613887| 18,5 |Т130613887
Кольцо серебряное| 64891# |с фианитом |17,5 |64891#
Кольцо серебряное| 64891# |с фианитом |18 |64891#
Изменено: Михаил С. - 29 Ноя 2018 00:05:25
Как якорить столбец из умной таблицы?
 
Уберите галку в "Параметры"-"Формулы"-"Работа с формулами" - "Показывать имена таблиц в формулах" и будет вам счастье.
Отменить автозамену на дату числа с точкой
 
Цитата
Мотя написал:
Как должен выглядеть последний вариант Формулы?
в каком смысле - последний?
Конкретно для этого файла, если там везде кольца, то можно
=ЕСЛИ(ЯЧЕЙКА("формат";AB2)="D2";ДЕНЬ(AB2)+0,5;AB2)

если же там не только кольца, и размеры могут быть 0т 18.1 до 18.9 - то
=ЕСЛИ(ЯЧЕЙКА("формат";AB2)="D2";ДЕНЬ(AB2)+МЕСЯЦ(AB2)/10;AB2)
а если возможны варианты 18.05 и 18.5 то решения нет, так оба значения автозаменой дадут 18 мая.
Отменить автозамену на дату числа с точкой
 
Цитата
rafa_el написал:
не заполнен в 4 строке и по умолчанию берется  его значение 1
немного не так; по умолчанию - пустая ячейка=нулю; ноль в формате "дата"  =00.01.1900 г; отсюда:
ДЕНЬ(00.01.1900)=0;МЕСЯЦ(00.01.1900)=1; РЕЗУЛЬТАТ_ПО_ФОРМУЛЕ - 0,1
Отменить автозамену на дату числа с точкой
 
Для файла "замена числа с точкой на дату.csv (1.13 КБ)" можно применить такую формулу:
=ДЕНЬ(AB2)+МЕСЯЦ(AB2)/10
Отменить автозамену на дату числа с точкой
 
Когда разбиваете текст csv по столбцам, указывайте проблемному столбцу текстовый формат.
VBA. Телефонная книга предприятия. Название отдела подтянуть к номеру телефона
 
Код
=ВПР(D2;$B$2:$C$7;2)
Анекдот дня, Постим сюда понравившиеся:)
 
Преподаватель литературы спрашивает студентку:
- Если бы вы могли встретиться и поговорить с любым писателем, живым или мертвым, кого бы вы выбрали?
- Живого...
График проведения ТО с привязкой к моточасам
 
если уйти от требования делать ТО до наступления срока, а делать при наработке, скажем, 150 +- средняя, то должно сработать так:
=ЕСЛИ(ОСТАТ(F70;1500)<$E70;"ТО-1500";
ЕСЛИ(ОСТАТ(F70;750)<$E70;"ТО-750";
ЕСЛИ(ОСТАТ(F70;250)<$E70;"ТО-250";
"")))
Подставлять знак + кроме слов меньше 3 символов
 
до кучи:
Код
Function ПРИСТАВИТЬ_ПЛЮС(Str$) As String
    Dim a, i&
    a = Split(Str)
    For i = 0 To UBound(a)
        If Len(a(i)) > 2 Then a(i) = "+" & a(i)
    Next
    ПРИСТАВИТЬ_ПЛЮС = Join(a)
End Function
Как рассчитать % премии при условии применяя форму РАЗНДАТА (для расчета выслуги лет)
 
Как-то так (см. файл)
=ПРОСМОТР(F2+1/24;$A$7:$A$10;$B$7:$B$10)*D2

зы.
В вашем случае некорректно пишется слитно (некорректно - ошибочно).
Изменено: Михаил С. - 26 Ноя 2018 21:46:38
Макрос сортировка, написать макрос сортировка
 
Почти за сутки заказчик на связь не вышел - я с такими не работаю.
Заказ свободен.
Наглядное суммирование значений кодом VBA, чтобы в результате в ячейке оставалась формула
 
Макрос счас написать не могу; формула выглядит так:
Код
СУММЕСЛИ($A$1:$A24;"Всего")
Изменено: Михаил С. - 26 Ноя 2018 15:27:11
Ошибка при присвоении значения переменной Range после вставки гиперссылки
 
Попробуйте Do Events применить, перед строкой, где останавливается.
Среднее арифметическое значение топ-5 максимальных видимых чисел
 
Счас с андроида решение дать не могу, возможно вечером, если раньше никто не решит.
Среднее арифметическое значение топ-5 максимальных видимых чисел
 
timur_kassymov, название темы нужно сменить, примерно так:
среднее арифметическое топ-5 видимых ячеек.
Попросите модераторов.
Ошибка при присвоении значения переменной Range после вставки гиперссылки
 
Встречалась такая проблема несколько раз - пошагово работает, автоматически - нет. Причину не знаю.
Среднее арифметическое значение топ-5 максимальных видимых чисел
 
Цитата
timur_kassymov написал:
я поэтому хочу через subtotal
subtotal работает с диапазоном ячеек, а у вас массив.
Проверка одного массива на наличие в нем значений другого массива, Проверка одного массива на наличие в нем значений другого массива
 
& - тоже самое, что СЦЕПИТЬ
Т.е. s&d=sd
Изменено: Михаил С. - 26 Ноя 2018 09:40:43
Макрос производит поиск фраз в точном соответствии только от 2 слов и больше.
 
Цитата
JayBhagavan написал:
говорят, что LIKE "тормознутая" - не проверял.
Like - одна из самых быстрых функций.
Проверка одного массива на наличие в нем значений другого массива, Проверка одного массива на наличие в нем значений другого массива
 
как-так, наверное:
=ЕСЛИ(СУММПРОИЗВ(СЧЁТЕСЛИ(B2;"*"&$A$2:$A$29&"*"));"содержит";"не содержит")
Проверка одного массива на наличие в нем значений другого массива, Проверка одного массива на наличие в нем значений другого массива
 
Цитата
Hammerside написал:
xlsx оказался больше 100кб,
Выложите в xlsx, сейчас пропускает до 300 кб
Макрос сортировка, написать макрос сортировка
 
Пишу в личку
Сравнение каждой строки одного диапазона с другим
 
формула массива:
=ЕСЛИОШИБКА(ИНДЕКС($B$1:$B$114;НАИМЕНЬШИЙ(ЕСЛИ(ЕЧИСЛО(ПОИСК(ИНДЕКС($A$1:$A$143;СТОЛБЕЦ(A1));$B$1:$B$114));СТРОКА($B$1:$B$114));СТРОКА(A1)));"")
вводите в С1 и растягиваете по строкам и столбцам
VBA. Запустить макрос из другой книги., Книга содана программно, ножно ее сохранить по кнопке в этой книге.
 
StoTisteg, я привык кнопкой в левом нижнем углу :)
VBA. Запустить макрос из другой книги., Книга содана программно, ножно ее сохранить по кнопке в этой книге.
 
StoTisteg, Пробовал, но что-то он мне ничего не записал :(
Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 319 След.
Наверх