Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Выбрать дату в календареВыбрать дату в календаре

Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 120 След.
Формула =ИЛИ, (нужно презентацию сделать в пойнт)
 
Функция ЛОГИЧЕСКАЯ. Проверяет ИЛИ(сдал зачет; не сдал) все равно какое-то из утверждений будет ИСТИНА. Но в принципе возможен вариант зависнуть в воздухе, тогда результат будет ЛОЖЬ.
Нарастающее число в ячейке
 
Смотрите вариант с кнопкой.

Мне кажется что у Вас несколько не правильный подход;) Вы пытаетесь считать в ОТЧЕТЕ. У вас уже есть куча листов с данными, добавьте еще один с таблицей в которую вы будете заносить исходные данные в табличной форме с данными по неделям и итогом, и уже оттуда тянуть данные в отчет.
                 Автобус  Трамвай
Итого
Текущая

Неделя1
Неделя 2
При этом у Вас сохранятся промежуточные данные, простая СУММ() будет считать нарастающий итог, а скопировать Текущую строку данных (или столбец) в низ таблицы макросом легче и не надо изгаляться считая строки и столбцы для внесения данных. Да и проверку даты внесения легко организовать и удалять повторы. Мой макрос это не делает и Вы легко можете нажать пару раз мышом. Можете в конце макроса вставить MsgBox с сообщением об окончании работы макроса.
Высчитать определенную сумму из процентов
 
Или ВПР с неточным соответствием =ВПР($E$18;$A$23:$C$28;3;1) Таблица данной формулы
Баллы проверкиПризовые
00% - 49,99% -1000
5050% - 74,99%-500
7575% - 79.99%0
8080% - 94,99%500
9595% - 100%1000
1001000
Сдвиг таблицы на ячейку с сегодняшним числом при открытии
 
Код
Private Sub Workbook_Open()
    Dim n As Long, FoundRng As Range
    
    Set FoundRng = Cells.Find(What:=Date, LookIn:=xlFormulas, LookAt:=xlWhole)
    If Not FoundRng Is Nothing Then
        n = FoundRng.Column - 7
        Cells(1, 6).Select
        ActiveWindow.SmallScroll ToRight:=n
    End If

End Sub


Попробуйте вставить этот код в модуль ЭтаКнига
Получение и присвоение значения ячейки с другого листа в VBA
 
И еще, а зачем Вам цикл? Присваиваем сразу значение диапазона.
Код
Dim i As long
i = Worksheets("Лист1").Range("K2").value

    Worksheets("Лист2").range(Cells(3, 19),Cells(i, 19)).Value = Worksheets("Лист1").range(Cells(3, 1),Cells(i, 1)).Value
Изменено: Igor67 - 23 Дек 2016 23:09:43
Получение и присвоение значения ячейки с другого листа в VBA
 
 У Вас объявлена 1 переменная i, цикл определен для переменной j, а номер строки в Cells(n
Определить последнею строку после фильтра,
 
2 vikttur, а не факт:) Вдруг надо не на листе, а именно последнюю видимую.
тогда вероятно так:
.Cells(.Rows.Count, 6).End(xlUp).SpecialCells(xlCellTypeVisible).Row
По ссылке коллекция вариантов по определению последней строки.
'ZVI:2009-01-11 Last cell/row/col with constant / formula / comment
'Also refer to: http://www.planetaexcel.ru/forum.php?thread_id=8203
Макрос даты по календарю.
 
По Вашим данным в модуль ЭтаКнига
Код
Private Sub Workbook_Open()
Dim strMonth As String, lDay As Long, rngDate As Range
strMonth = LCase(Format(Date, "mmmm"))
lDay = Day(Date)

Range(Range("A2"), Range("A2").SpecialCells(xlLastCell)).Interior.Pattern = xlNone
    
Cells.Find(What:=strMonth).Select
Set rngDate = Range(Cells(ActiveCell.Row, ActiveCell.Column - 2), Cells(ActiveCell.Row + 7, ActiveCell.Column + 4))
    rngDate.Find(What:=lDay).Interior.Color = 65535

End Sub
Функция "Если" с текстовым параметром в вычисляемых полях
 
Так похоже?
Код
=ЕСЛИ(ИЛИ(ЛЕВСИМВ(C3;1)="Д";ЛЕВСИМВ(C3;1)="Р");B3;0)
Создание итогового листа
 
А зачем нам знать количество листов? Вставляем итоговый лист,  Вводим формулу СУММ, выделяем первый лист,  SHIFT+последний лист с данными. А если потом если вставлять листы с данными МЕЖДУ первым и последним листом в формуле - они попадут в диапазон расчета.
Создание итогового листа
 
Ну и пример у Вас  :(   Может так?
Код
=СУММ(Иванов:Сидоров!B6)
 
Темп прироста, если есть пустые ячейки
 
Не понятно, но если нужно просто считать по отношению к предыдущим данным, то формула в столбец В
Код
=ЕСЛИОШИБКА(B2/ИНДЕКС($A$2:B2;1;ПОИСКПОЗ(3E+307;$A$2:A2;1))*100;"") 
выбор крайних значений в матрице
 
Можно и на ВБА, а формула не подойдет? Вставьте ее в N2 и протяните на весь диапазон.
Код
=ИНДЕКС($B$2:$L$12;СТРОКА($A1);ПОИСКПОЗ(9E+307;$B2:$L2;1)) 
Изменение порядка строк в сводной таблице
 
Из недр форума  :)  
Цитата
Можно еще так:
1. Заходим Сервис-Параметры-Списки, создаем список с нужной нам последовательностью.
2. Выделяем в сводной таблице диапазон который надо отсортировать.
3. Заходим Данные-Сортировка-Параметры. В поле Сортировка по первому ключу, выбираем созданный нами список и все.
Макрос: Значения из ячеек перенести по строчкам
 
Скрытый текст
Как вариант
Средняя за последние 5 дней.
 
Без контроля что заполненных столбцов может быть и меньше 5.
Код
=СУММ(СМЕЩ($A$7;;ПОИСКПОЗ(9E+307;7:7;1)-5;1;5))/5 
Макрос на определенных листах для определенного диапазона одновременно.
 
bekzus, в ВБА можно сразу так при активации или инициализации формы с ТекстБоксом (хотя не понял зачем 2 раза повторять месяц?)
Код
CurrentDate.Value =  format(date(),"d MMM MMM")
Найти строки с текстом по маске и составить таблицу, найти последнее значение по маске
 
1. Автофильтр с содержит?
2. Меняйте буквы и должно искать, если у Вас как в примере все отсортировано.
Код
=ИНДЕКС($C$4:$C$80;ПОИСКПОЗ("A???";$C$4:$C$80;0)+СЧЁТЕСЛИ($C$4:$C$80;"A???")-1) 
Как перенести макросы обработки события листа в другой файл?
 
Цитата
BretHard120 пишет:
файл "Проба..." тоже создается программно с помощью другого макроса
Честно говоря и сам не силен в копировании макросов программно, но если создать новую книгу и потом в нее скопировать лист из старой, то и макрос листа тоже переносится:)
Как перенести макросы обработки события листа в другой файл?
 
А попробуйте проще, событие на уровне книги код в ЭТАКНИГА, если контроль нужен на определенных листах, то проверяем через если ...

Скрытый текст
дублирование ячеек
 
Цитата
clop71 пишет: к чайникам здесь отношение не очень
Это Вы к чему? На Ваш общий вопрос - общий ответ. После напримера - сразу правильный ответ в части сбора не повторяющихся данных. А все остальное что Вам требуется знаете только Вы. Можем подсказать где описано что и как надо делать. Вкладка приемы на форуме и там как извлекать уникальные, что такое макросы и пр. и пр...
Скрыть/отобразить диаграммы, код работает неправильно при увеличении числа диаграмм
 
Можно заменить скрытие каждой сразу на все.
Код
ActiveSheet.ChartObjects.Visible = False 
Если используется ComboBox (ActiveX control), то где он берет данные? Может по той же ВПР вставлять имя диаграммы в ячейку и сразу без переборов ее отображать.
Как то так
Код
strCh$ = range("c10").value
ActiveSheet.ChartObjects(strCh).Visible = True
или в коде переписывать и там обрабатывать
arrD = Array("Nov - 13", "Dec - 13", "Jan - 14")
strCh = "Chart " & WorksheetFunction.Match(Trim(Right(ComboBox10.Value, 8)), arrD, 0)+1
ActiveSheet.ChartObjects(strCh).Visible = True
дублирование ячеек
 
Через расширенный фильтр (или еще как) оставляете уникальные данные (индивидуальные), а потом смотрите в копилку и прикручиваете решение себе тема в копилке сцепить по условию
Суммирование значений в диапазонах различного размера в одном столбце
 
Для меня нет. И еще ссылка на обсуждение подобной задачи с вариантами решений здесь
Суммирование значений в диапазонах различного размера в одном столбце
 
К сожалению формулы не могут быть в одном столбце с данными, просто теряется смысл и писать всякий раз ее заново... Решение для расположения над блоком разделенным пустой строкой
Код
=ЕСЛИ( И(A2="";ЕЧИСЛО(A3)); СУММПРОИЗВ(СМЕЩ(A3;0;0;ПОИСКПОЗ("";A3:A103&"";0);1)); "") 
формула описана в теме  Сумма между блоками цифр
Можно проще (подсмотрено у vikttur) , тогда сумма после блока цифр.
Код
=ЕСЛИ(И(A2="";A1<>"");СУММ($A$1:A1)-СУММ($B$1:B1);"") 
Все формулы для ячейки В2.
И еще были решения на форуме.
ПыСы а на желтенькое формула не реагирует:(
Сравнивать столбцы програмно
 
Цитата
Hugo пишет: "Ростов", и есть "Ростов-на-Дону"
А есть еще любители которые пишут просто Ростов, а на все вопросы отвечают что работают только с Ростов-на-Дону и смысла писать дальше нет :)
Адрес пустого столбца
 
Я не понял само условие, но если нужно найти разрыв в данных можно просто [a1].End(xlToRight).Column+1 Выбор решения зависит от конкретной задачи.
Адрес пустого столбца
 
А такие варианты определения границ данных не подходят?
Взято с сайта Павла Юрьевича Климова
Код
определение номера строки и столбца последней заполненной ячейки.

iRow = Cells(Rows.Count, 3).End(xlUp).Row
iRow = Cells(Rows.Count, "C").End(xlUp).Row
iClm = Cells(10, Columns.Count).End(xlToLeft).Column

With ActiveSheet.UsedRange
     iRow = .Row + .Rows.Count - 1
     iClm = .Column + .Columns.Count - 1
End With

iAddress = Range("A1").SpecialCells(xlLastCell).Address
iRow = Range("A1").SpecialCells(xlLastCell).Row
iClm = Range("A1").SpecialCells(xlLastCell).Column

On Error Resume Next
iRow = Cells.Find(What:="*", LookIn:=xlValues, SearchDirection:=xlPrevious, SearchOrder:=xlByRows).Row
iClm = Cells.Find(What:="*", LookIn:=xlValues, SearchDirection:=xlPrevious, SearchOrder:=xlByColumns).Column  
вывод номера ячейки при совпадении значения одного столбца к другому
 
Предлагаю использовать =ЯЧЕЙКА("адрес";ИНДЕКС(ПОИСКПОЗ...)))
Поиск различий по столбцам
 
А почему не использовать функции Ехс при проверке нахождения данных в диапазоне?
Скрытый текст
Изменено: Igor67 - 8 Июл 2014 17:36:02
Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 120 След.
Наверх