Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Выбрать дату в календареВыбрать дату в календаре

Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 174 След.
Продолжение макроса после выполнения действия с Листом Книги
 
или немодальную форму  с циклом ожидания
или два макроса - в первом устанавливается флаг - второй выполняется по событию (нажатия клавиши или экранной кнопки или..) только если поднят флаг
Изменено: Слэн - 31 Авг 2016 13:10:53
Живи и дай жить..
VBA: Изменить границы именованного диапазона программно
 
например:
ActiveWorkbook.Names("имя").RefersTo = "=" & Range("b2").Address
Изменено: Слэн - 31 Авг 2016 13:05:06
Живи и дай жить..
VBA: Изменить границы именованного диапазона программно
 
приоединюсь к предыдущему, но попробую прорицание: может     помочь свойство currentregion
Живи и дай жить..
Удобный поиск по выпадающему списку, Как быстро найти необходимое значение из списка данных
 
то, что чаще требуется - в начало поставить..
а так.. откуда нам известно как оптимизировать? мы этого списка в глаза не видели.
ели вы точно знаете название нужного, можно организовать поик по первым буквам.. но это частный случай
Живи и дай жить..
Please help. При протягивании ячейки все ячейки которые внутри фильтра скрыты тоже изменяются, где в настройке это изменить?
 
https://support.microsoft.com/ru-ru/contactus?ws=mscom&forceorigin=esmc
напишите свои пожелания - вполне возможно, что исполнят
Живи и дай жить..
Нужно подправить код на вставку со смещением по строкам
 
ну сдругой стороны от запятой будет
точнее убрать первую запятую
Изменено: Слэн - 30 Авг 2016 00:51:24
Живи и дай жить..
Нужно подправить код на вставку со смещением по строкам
 
Код
with selection
  .offset(,.offset(,-1))=.value
end with
ели перед выполнением была активной ячейка  фамилией
Живи и дай жить..
Как задать массив с помощью выделения в конкретном случае, Не получается взять данные со страницы через Selection
 
не знаю что вы делаете, вот так ве работает:
Код
Set x = Selection
MsgBox x.Rows.Count & " " & x.Columns.Count
Живи и дай жить..
макрос для вставки курсора в позицию и поиск свободной ячейки, замена F2 и поиск свободной ячейки
 
вот, чтобы точнее было в вашем файле сделал
Живи и дай жить..
макрос для вставки курсора в позицию и поиск свободной ячейки, замена F2 и поиск свободной ячейки
 
это уже 1й макрос. он ам следит за изменением данных

просто копируйте его код в свой (такой же) вместо строки call Макрос1
Изменено: Слэн - 28 Июл 2016 15:20:43
Живи и дай жить..
Интеграция надстройки
 
так это не 2й, а 3й пункт :)
и там совем другая поледовательность
Живи и дай жить..
Интеграция надстройки
 
а зачем убираете? и зачем сохраняете в xlsm
Изменено: Слэн - 28 Июл 2016 14:27:52
Живи и дай жить..
макрос для вставки курсора в позицию и поиск свободной ячейки, замена F2 и поиск свободной ячейки
 
Код
Private Sub Worksheet_Change(ByVal Target As Range)
If Target.Column = 1 Then
    Target.Offset(, 1).Select
    Application.SendKeys "{F2}"
End If
If Target.Column = 2 Then
    Target.Offset(, -1).End(xlDown).End(xlUp).Offset(1).Select
End If
End Sub
Живи и дай жить..
Интеграция надстройки
 
не из редактора(хотя и там в tools можно), но вот так, например
Живи и дай жить..
Интеграция надстройки
 
1 положите надстройку в какую-то определенную папку, кот укажите как автозагрузочную
2 подключите надстройку на постоянной основе из редактора vbу
3 создайте объединенный файл xlsm где будут и данные из xlsx и макросы из xla
Живи и дай жить..
Простой алгоритм создания новых листов в Excel
 
можно просто:
Код
On Error Resume Next
If Sheets("лист").Index = 0 Then Sheets.Add().Name = "лист"
Живи и дай жить..
Автозаполнение из имеющихся на листе данных
 
полно тем на список с контекстным поиском - это именно что вам надо
Живи и дай жить..
Посчитать количество слов, в которых искомая буква встречается N-ое количество раз., Можно ли укоротить формулу?
 
по крайней мере одни скобки лищние
Живи и дай жить..
формула ЕСЛИ, смысл отрицательного значения в формуле
 
чтобы с 1 начиналось
Живи и дай жить..
Макрос для скрытия строки, в которой опред. ячейка = 0,00
 
тогда чуть исправьте:
Код
   ActiveSheet.Range("$A$1:$L$63").AutoFilter Field:=10, Criteria1:="<>0", _
        Operator:=xlAnd

Изменено: Слэн - 25 Июл 2016 15:15:38
Живи и дай жить..
ВПР отрабатывает выборочно, часть данных находит, часть нет
 
н  мой взгляд логика проста - точное оответствие
например, хино и hino - никакого соответствия
Живи и дай жить..
Макрос для скрытия строки, в которой опред. ячейка = 0,00
 
или
Код
   ActiveSheet.Range("$A$1:$L$63").AutoFilter Field:=10, Criteria1:="<>0,00", _
        Operator:=xlAnd
Живи и дай жить..
Ошибка Compile error: Expected: end of statement. при попытке вывести формулу в ячейку
 
внутри кавычек кавычки нужно удваивать
Живи и дай жить..
Скрытие пользовательской формы по значению в текстбоксе, С кнопки скрывается, по изменению текстбокса ﹘ нет
 
Код
Private Sub txbTransferConfirm_KeyPress(ByVal KeyAscii As MSForms.ReturnInteger)
If txbTransferConfirm.Text & Chr(KeyAscii) = "999" Then
        txbTransferConfirm.Value = ""
        txbTransferConfirm.SetFocus
        usfmSystemTransferAlert.Hide
End If

End Sub
так работает
Живи и дай жить..
Скрытие пользовательской формы по значению в текстбоксе, С кнопки скрывается, по изменению текстбокса ﹘ нет
 
так у вас там написано не скрыть а показать:
Код
 Private Sub txbLSSEnter_Change()
    If txbLSSEnter.Text = "999" Then
        txbLSSEnter.Value = ""
        usfmSystemTransferAlert.Show
    End If
End Sub
Живи и дай жить..
Исключить определённое число в генераторе случайных чисел
 
или разрешить итерации:
a2=ЕСЛИ(A2=0;СЛУЧМЕЖДУ(-12;34);СЛУЧМЕЖДУ(-12;34))

нет, такая формула не гарантирует отсутствие нуля..  
Изменено: Слэн - 20 Июл 2016 15:11:44
Живи и дай жить..
Исключить определённое число в генераторе случайных чисел
 
=ЕСЛИ(СЛЧИС()>0,5;СЛУЧМЕЖДУ(-12;-1);СЛУЧМЕЖДУ(1;34))
Живи и дай жить..
Исключить определённое число в генераторе случайных чисел
 
по любому - разбить на два интервала
Живи и дай жить..
Исключить определённое число в генераторе случайных чисел
 
числа целые хотите получать? или любые?
Живи и дай жить..
Открытие книг в отдельных процессах
 
или установить свойство ignoreremoterequests=true
Живи и дай жить..
Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 174 След.
Наверх