Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Выбрать дату в календареВыбрать дату в календаре

Страницы: 1 2 3 4 5 6 7 8 9 След.
Диаграмма со "сложными" столбцами!
 
Цитата
В принципе, это решается наложением двух диаграмм друг на друга и заданием нужной прозрачности.
Можно и "костылями" решить.
Век живи, век учись - два века проживешь!
Объединение формул из нескольких ячеек в одну
 
Задача решена на соседнем форуме. Ссылка в первом сообщении.
Век живи, век учись - два века проживешь!
Автосмещение подписей данных на графике
 
См. мой кривой макрос  :D
Век живи, век учись - два века проживешь!
вычисляемое поле в сводной таблице, написание формулы
 
Еще как вариант - с модификацией исходной таблицы
Век живи, век учись - два века проживешь!
вычисляемое поле в сводной таблице, написание формулы
 
Вычисляемым полем в данном случае ИМХО никак, только допстолбцом рядом со сводной.
Век живи, век учись - два века проживешь!
Объединение формул из нескольких ячеек в одну
 
Цитата
Полезной составляющей в задумке нет, только если кто-то захочет сделать чисто из спортивного интереса.
Ок, спасибо!

Я наивный думал, что все так на части разбивают сложные формулы  :D
Век живи, век учись - два века проживешь!
Как Выцепить определенный текст из общего, Нужны значения которые стоят между символами
 
Код
=--ПСТР(A1;НАЙТИ("№ ";A1)+2;НАЙТИ(" от";A1;НАЙТИ("№ ";A1))-НАЙТИ("№ ";A1)-2)
 
Век живи, век учись - два века проживешь!
Объединение формул из нескольких ячеек в одну
 
[QUOTE]По Вашему варианту составляем алгоритмы для промежуточных вычислений, потом все лепим в одно?[/QUOTE] Не совсем понял, что Вы имеете в виду. И совсем не разбираюсь в макросах, поэтому все что написано ниже может быть абсолютным бредом   :)
Как на мой взгляд должен работать макрос:
1. Выделяем ячейки, участвующие в получении результата (в приложенном примере диапазон B7:B10);
2. Макрос пробегает по всем формулам и ищет ячейку, на которую не ссылается ни одна другая (В10);
3. Макрос просматривает формулу в найденной ячейке, и подменяет ссылки на ячейки из первоначального диапазона их содержимым (естественно, без "=");
4. п.3 повторяется несколько раз (число ячеек в первоначальном диапазоне);
5. Получившуюся в результате формулу макрос записывает в какую-нибудь ячейку, например В11.
Изменено: Руслан А. - 11 Мар 2014 09:00:19
Век живи, век учись - два века проживешь!
Объединение формул из нескольких ячеек в одну
 
Добрый день!

В этот солнечный нерабочий день пришла мне в голову одна мысль, которую я постараюсь сейчас изложить.
Часто, при решении поставленной задачи, большие многоэтажные формулы сложно написать сходу, поэтому я прописываю формулы поэтапно в несколько ячеек. После получения результата, все формулы "ручками" объединяю в одной ячейке (см. наглядный пример).
Вопрос в следующем: существует ли какой нибудь автоматизированный (надстройка, макрос, что-то еще) способ объединения формул в одну "многоэтажную"?

Кросс
Век живи, век учись - два века проживешь!
Формулы расчета площади вентиляционных изделий
 
[QUOTE]ber$erk пишет:
А сечения обычно круглые и/или овальные? или еще есть в виде звездочки?
[/QUOTE]Воздуховоды обычно круглые или прямоугольные.


Автору:
Площадь круга:

Код
=(A1/2)^2*ПИ()
, где в А1 диаметр.
Площадь прямоугольника (квадрата):

Код
=A1*B1
 
, где в А1 и В1 - ширина и высота.

Ваш КО.
Изменено: Руслан А. - 6 Мар 2014 08:22:18
Век живи, век учись - два века проживешь!
вопрос по импорту данных с сайта ЦБ в Excel,
 
Цитата
ber$erk пишет:
Докрутил в общем загрузку курсов валют за любой период
Супер!
Век живи, век учись - два века проживешь!
вопрос по импорту данных с сайта ЦБ в Excel,
 
Тоже заинтересован в таблице курсов.
В настоящее время имеется большая таблица вида:
Дата             Курс USD             Курс EURO             EURO/USD
Нужно, чтобы макрос подтягивал вниз все недостающие данные (даты и курсы).
Изменено: Руслан А. - 4 Мар 2014 12:58:34
Век живи, век учись - два века проживешь!
[ Закрыто] Объединение одинаковых значений, и получение суммы
 
Сводная таблица
Век живи, век учись - два века проживешь!
Перевёрнутый текст, Коды перевёрнутых символов
 
Как вариант   8)
Век живи, век учись - два века проживешь!
Оптимизация дохода по таблице
 
Явно не хватает ограничений на количество зданий каждого типа.
В представленной таблице по прибыльности человечко-часа, с огромным отрывом лидирует лавка сладостей за 250, соответственно на все ресурсы нужно строить ее.
Век живи, век учись - два века проживешь!
Подставить рисунки /объекты в подписи диаграммы, возможно ли?
 
Вставка -> Рисунок
Вставка -> Фигуры -> Надпись
Век живи, век учись - два века проживешь!
Смещение по среднему и построение диаграммы
 
Цитата
Эта формула, как и многие, даёт смещение на одну строку вниз, а надо на 4
Правда? А у меня все нормально, на 4 строки...
Вы хотя бы пробовали?
Формула для 17й строки.
Век живи, век учись - два века проживешь!
Смещение по среднему и построение диаграммы
 
Код
=СРЗНАЧ(СМЕЩ($A$17:$A$20;(СТРОКА()-17)*4;0))
Прикладывайте файл!!!
Век живи, век учись - два века проживешь!
Сводные таблицы. Остаток и приход материалов, Как добавлять формулы в сводные таблицы
 
Так?
Век живи, век учись - два века проживешь!
Просчет итого из одного столбца, рубли и доллары
 
То же самое, что у Матроса, только без макроса.
Без допстолбца можно формулами массива.
Век живи, век учись - два века проживешь!
год начала и окончания работ
 
Скрытый текст
Век живи, век учись - два века проживешь!
год начала и окончания работ
 
Код
=ЕСЛИ(И(C2>0;D2="";E2="");2014;ЕСЛИ(И(C2="";D2>0;E2="");2015;ЕСЛИ(И(C2="";D2="";E2>0);2016;"???")))
Поторопился.
Вот, для начала и окончания:

Код
=ЕСЛИ(C2>0;2014;ЕСЛИ(D2>0;2015;ЕСЛИ(E2>0;2016;"")))
=ЕСЛИ(E2>0;2016;ЕСЛИ(D2>0;2015;ЕСЛИ(C2>0;2014;"")))
Изменено: Руслан А. - 20 Фев 2014 14:42:24
Век живи, век учись - два века проживешь!
Отсортировать значения
 
Код
=ЕСЛИ(--ЕНД(ПОИСКПОЗ(B3;$A$3:$A$1766;0))=0;"";B3)
 
Век живи, век учись - два века проживешь!
Найти повторяющиеся 7 раз значения
 
Столбец G - счётчик:
Код
=ЕСЛИ(A3=A2;G2+1;1)
УФ на строки, где счетчик = 7.

Владимир, Ваша формула не везде правильно считает.
Изменено: Руслан А. - 19 Фев 2014 13:26:32
Век живи, век учись - два века проживешь!
Шахматный порядок
 
Цитата
Да братка!!!
Ташкентский университет финишт? ;-)
Век живи, век учись - два века проживешь!
Разделение текста по заглавным буквам
 
Брутфорс-метод. Для последней ячейки используем текст по столбцам.
Век живи, век учись - два века проживешь!
Диаграмма. Как формулой сформировать пустое значение?
 
Вместо "" в формуле поставьте нд()
Век живи, век учись - два века проживешь!
Суммирование диапазона ячеек в строке
 
Код
=СУММ(СМЕЩ($A$2:$C$2;0;ПОИСКПОЗ(A4;$A$1:$I$1;0)-1))
 
Век живи, век учись - два века проживешь!
Копирование одной строки в две макросом
 
Вариант формулами.
Формулы в четных и нечетных разные, поэтому растягивать нужно две строки сразу.
Век живи, век учись - два века проживешь!
Преобразовать ### в дату
 
Столбец попробуйте пошире сделать.
Если не поможет - файл в студию!
Век живи, век учись - два века проживешь!
Страницы: 1 2 3 4 5 6 7 8 9 След.
Наверх