Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Выбрать дату в календареВыбрать дату в календаре

Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 61 След.
Разбивка данных по разделителю
 
Здравствуйте! В примере - много таблиц и нет ни одного ";"
Преобразовать текс в дату через DAX
 
2/13/2018 - это 13 фев. 2018. А 2/12/2018 - это 12 фев. 2018 или 2 дек. 2018 ?
Преобразовать текс в дату через DAX
 
Помогите себе сами, почитайте правила форума
Форматирование изменяемого значения
 
Цитата
violettki написал:
Цитата
То есть вчерашнее значение физически не отражается нигде
... значит, скорее всего, имеем дело с оборотнем...
присоединяюсь к идее Сергея
Цитата
Сергей написал:
...вокруг костра попрыгаем с бубнами попросим высшие силы вас защитить...
ГИПЕРССЫЛКА - на место в документе, Нужн работчая формула, а в помощи майкрософт ошибка в подсказках
 
У Вас кавычек - нечетное число. Либо одной не хватает, либо одна лишняя. И скобок - 2 открывающих и 1 закрывающая.
Перенос данных из столбцов с разных листов в один столбец
 
У Вас данные организованы очень нехорошо, по моему мнению. Вам проще будет сделать лист Уведомление в виде шаблона с кол-вом строк 12 х 6, чтобы в эти строки с листов "Данные..." подтягивалась формулами нужная информация. А пустые строки - просто скрывать автофильтром. Выложенный Вами пример - слишком мало информации содержит для понимания задачию
Изменено: Михаил Лебедев - 3 Апр 2018 12:08:14
Суммирование диапазона со смещением
 
Добрый день!
Не совсем понятно, что Вы хотите. М.б. Вам просто нужно посчитать сумму значений в столбце К2 при условии, что даты в К1 напротив этих значений попадают в заданный ПЕРИОД?
Тогда можно формулой =СУММПРОИЗВ(($A$3:$A$59>=D3)*($A$3:$A$59<=E3)*($B$3:$B$59))   (для яч. Н3)
Но можно и с функцией =СМЕЩ():  =СУММ(СМЕЩ($B$2;ПОИСКПОЗ(D4;$A$3:$A$59;0);0;7;1)) (для яч. Н4)

А даты ПЕРИОДА лучше оставить в отдельных столбцах, а столбцы - скрыть.  
Макрос для создания итоговой таблицы, Макрос для создания итоговой таблицы в Excel 2016
 
Здравствуйте.
Боюсь предположить, что Вам не сюда, а в раздел "Работа".
Как при выборе продукта из списка продуктов, настроить в соседней ячейке выбор свойств этого продукта?
 
Цитата
Bovtenok написал:
Почему-то работает неправильно.
Добрый день. А Ваш файл-пример работает?
Изменено: Михаил Лебедев - 26 Фев 2018 12:43:50 (файл не захотел грузиться)
Формула для поиска в эксель, Никак не могу найти или составить формулу
 
...
Автоматический перенос значения
 
Привет!
Произвольное значение появится только с помощью макроса.
Не понятно, что Вы подразумеваете под "создаю новую строку в таблице". У Вас "Умная таблица" или простая? В Excel нет события "новая строка", как в access,, например.
Открытие сроки защищенного листа для редактирования по условию.
 
Цитата
Серёжа написал:
активировалась ячейка следующая за заполненной(то есть первая пустая)?
Так всё-таки, следующая или первая пустая?
Если следующая, то
Код
ActiveCell.Offset(1, 0).Select
Запрет редактирования документа одним пользователям, но разрешение пользоваться другим
 
Цитата
БМВ написал:
При сохранении указать пароль для записи и не разглашать его остальным.
И еще чтобы другие не могли сохранить у себя копию файла, стереть файл-оригинал, а потом на его место положить файл-копию :) .
Формирование заказа на основе выделенных позиций в прайсе
 
Цитата
kehrypy написал:
Михаил, дополнительных столбцов уже не надо в этом документе
Ну, скройте лишний столбец. Или итог можно еще сделать сверху (как на листе Прайс), Тогда можно без лишнего столбца.
А по другому (с перламутровыми пуговицами или без крыльев) с пом. Сводной - не получится.
Формирование заказа на основе выделенных позиций в прайсе
 
Цитата
kehrypy написал:
С помощью сводной таблицы у Вас сумма по цене не сходится
тогда с пом. доп. столбца на листе Прайс
Формирование заказа на основе выделенных позиций в прайсе
 
Добрый день!

С помощью обычной Сводной таблицы (PivotTable) и 2-ч мааааленьких макросов.
Изменено: Михаил Лебедев - 13 Фев 2018 09:56:07
Ноль не равен нулю!
 
да, бред какой-то... :(  ну, напишите просто =ЕСЛИ(A3=A9;"ok")   :)
Расчет значения исходя из наличия в тексте символа
 
Oops...
Открытие сроки защищенного листа для редактирования по условию.
 
1. Если у Вас в в ячейке записано жен. имя, то формулы сотрутся. А если после этого снова муж.?
Изменено: Михаил Лебедев - 12 Фев 2018 09:59:49 (добавил файл-пример)
Автоматическая перенумерация строк при добавлении новой строки в середину таблицы
 
Для В25 формула и протянуть: =ЕСЛИ(C25<>"";ПРОМЕЖУТОЧНЫЕ.ИТОГИ(3;$C$24:C25)-1;"")
Расчет значения исходя из наличия в тексте символа
 
Цитата
TUSHI написал:
я использовал вот такую формулу =ЕСЛИ(ЕЧИСЛО(ПОИСК("№1";A2));"B2-C2";"C2-B2")
попробуйте использовать ещё вот такую формулу: =ЕСЛИ(ЕЧИСЛО(ПОИСК("№1";A2));B2-C2;C2-B2)
Выборка данных из масива по условиям
 
Цитата
zhan1981 написал:
20 К строк как аргумент,
Извините, но непонятный аргумент. Я бы даже сказал, что спорный...
Изменено: Михаил Лебедев - 7 Фев 2018 09:08:13
VBA: манипуляции с переменными по условию If.
 
Код
Sub a()
If Selection.Row > 10 Then
a = Selection.Offset(0, 1)
Else
a = Selection.Offset(0, -1)
End If
' a.Formula = Selection - лишняя строка, закомментировал
' a.Replace What:=",", Replacement:="" - заменил на другую
a = VBA.Replace(a, ",", "")
End Sub

Что дальше с а хотите делать?
Проверка правильности заполнения формы, Форма ввода данных и как проверить правильность ее заполнения
 
Цитата
Kor написал:
Михаил Лебедев ,Прошу прощения за свой резкий коммпентарий
Не прошло и полгода :) ОК, я не в обиде.
Выборка данных из масива по условиям
 
Цитата
zhan1981 написал:
ошибка: "Недопустимое имя сводной таблицы и т.д.") т.к. таблица почти в 20 000 строк то переделывать анриал
Недопустимое имя - это скорее всего шапка исх. таблицы - многоуровневая и с объединенными ячейками. В этом случае Сводная не будет работать, т.к. появляются в шапке пустые ячейки. А 20000 строк для сводной - это "плёвое дело". Формулы будут на порядок медленнее работать.
Выборка данных из масива по условиям
 
м.б. так? ("Сводная таблица")
Подсчет количества за месяц
 
Добрый день!
Фот формула: =СУММПРОИЗВ(--(ТЕКСТ($A$4:$A$9;"ММММ")=F4))
Подсчет количества дней в месяце по дням недели, Подсчет количества дней в месяце по дням недели
 
Добрый день, м.б. так устроит?
Автозаполнение Даты при изменении в ячейке
 
Здравствуйте. Попробуйте так:
Код
Dim val

Private Sub Worksheet_Change(ByVal Target As Range)
For Each Cell In Target
 If Not Intersect(Cell, Range("C4:C1000")) Is Nothing Then
    If val = Target Then Exit Sub
  With Range("E" & Cell.Row)
     .Value = Now
     .EntireColumn.AutoFit
     End With
    End If
   Next Cell
End Sub

Private Sub Worksheet_SelectionChange(ByVal Target As Range)
    val = Target
End Sub
Поиск пары для смешанного списка из двухмерного массива
 
Цитата
nine_oleg написал:
вместо 12FV02639 получаю
поясните (у Вас в ячейках записано как раз 12, а буквы - это не содержание ячейки, а ее формат. Функции работают с содержанием, но не с форматом.
Изменено: Михаил Лебедев - 25 Дек 2017 17:52:48
Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 61 След.