Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Выбрать дату в календареВыбрать дату в календаре

Страницы: 1
Дата следующей поверки (для метрологов)
 
Нашел решение
Код
 =ДАТАМЕС(A1;A2*12)-1
где А1 - дата поверки, А2 - МПИ, лет.
Дата следующей поверки (для метрологов)
 
Здравствуйте!
Задача такова. В метрологии существуют МПИ (межповерочные интервалы): 1 год, 1,5 года и далее до 5 лет через каждые 6 месяцев.
Допустим, что сегодня 08.11.19 и мне нужно выписать свидетельство о поверке, то следующая поверка при МПИ = 1 год должна быть проведена не позже 07.11.20. При МПИ = 1,5 года - свидетельство выписывается до 07.05.22 и т.д.
Главная проблема при расчете ячейки "дата следующей поверки" возникает когда встречается високосный год с его 29 февраля.
Буду признателен, если сможете решить задачку. Желательно, чтобы ячейка с датой была прописана именно в формате ДАТА.
Выборка ячеек по заданным условиям
 
Спасибо, Сергей!
С основной задачей макрос справился. Будет время, поковыряюсь поглубже - остались некоторые "недоделки".
Выборка ячеек по заданным условиям
 

Спасибо за совет! Познал некоторые интересные моменты для будущих задач, но так и не смог применить их к данной задаче. Потратил 4 часа рабочего времени и еще столько же - дома... С такими темпами за полгода, авось, и добьюсь какого-нибудь результата ))
Пожалуйста, подкиньте формулку! С динамичными столбцами в этой таблице - прям-таки бяада (столбец C добавляется и списки в строках расширяются).

Выборка ячеек по заданным условиям
 
Здравствуйте! Помогите сделать выборку ячеек 1-ой строки (СЦЕПИТЬ) по заданным значениям из 2-ой и 3-ей строк. В приложенном файле ожидается увидеть результат вычислений в столбце B (напротив фамилий) по значениям пустых ячеек соответствующих строк . Столбцы C, D, E,… и последующие добавляются и убираются.
Изменено: Владислав Акимов - 5 апр 2017 12:51:43
Сортировка в таблице
 
блин, вы с такой скоростью формулы пишете... быстрее, чем у меня открываются листы в чате :)) класс!
Сортировка в таблице
 
ой, Михаил, не разглядел, что уже формулу написал... ))  
еще раз спасибки!
Сортировка в таблице
 
{quote}{login=vikttur}{date=04.02.2010 02:58}{thema=Re: }{post}{quote}{login= yanao}{date=04.02.2010 01:58}{thema=}{post}  
=ЕСЛИ(K4=1;0;ЕСЛИ(K4=0,5;0,5;1))  
как заставить ячейку I5 не отображать "1", если ячейка К4 пустая (т.е. не внесено "0")?{/post}{/quote}  
=ЕСЛИ(K4=1;0;ЕСЛИ(K4=0,5;0,5;""))  
А если в ячейку внесен ноль или другое значение, отличное от 0,5 или 1?{/post}{/quote}  
если К4 пустая, то I5 - пустая  
если К4=0, то I5 =1  
если К4=1/2, то I5 =1/2  
если К4=1, то I5 =0
Сортировка в таблице
 
{quote}{login=Михаил}{date=04.02.2010 03:01}{thema=}{post}=ЕСЛИ(K4="";"";ЕСЛИ(K4=1;0;ЕСЛИ(K4=0,5;0,5;1)))  
vikttur, по идее том не может быть других зачений: 1; 1/2; 0 или пусто... Это либо шашки либо шахматы...{/post}{/quote}  
верно, шахматы :)
Сортировка в таблице
 
Заработало! Довольно симпатичная табличка получается :) Всем большое спасибо!  
 
А по второму вопросу не подскажете (команда ЕСЛИ)?
Сортировка в таблице
 
Михаил, а что это за волшебные фигурные скобки  {=ИНДЕКС(B$3:B$12;ПОИСКПОЗ(НАИБОЛЬШИЙ(($C$3:$C$12)-СТРОКА($C$3:$C$12)/10000;СТРОКА(1:1));$C$3:$C$12-СТРОКА($C$3:$C$12)/10000;0))} в формуле для ников (столбец "Z")? ...это единственная формула, которую не могу скопировать, а если вписываю ручками эти скобки, то в значении ячейки именно эта запись и отображается.  
На всякий случай прикрепляю файл (с почти полной таблицей)  
 
И еще вопрос (он важен для другой более объёмной таблицы)...    
ячейка I5    =ЕСЛИ(K4=1;0;ЕСЛИ(K4=0,5;0,5;1))  
как заставить ячейку I5 не отображать "1", если ячейка К4 пустая (т.е. не внесено "0")?  
 

<EM><STRONG>Файл удален</STRONG> - велик размер - [<STRONG>МОДЕРАТОРЫ</STRONG>]</EM>

Сортировка в таблице
 
{quote}{login=Михаил}{date=31.01.2010 02:06}{thema=}{post}Примерно так{/post}{/quote}  
Очень даже неплохо, спасибо! ...а без дополнительной таблицы никак не получится (заносить данные в таблицу и её же сортировать)?    
 
Приношу извенения за 2007 Excel (обычно я в 2003 работаю), промахнулся малость.. Сейчас прикрепил файлы в общедоступном виде :)
Сортировка в таблице
 
Имена столбцов зависят от имен строк (т.е. меняются после сортировки)...  
Как закрепить значения в столбце за его именем?
Правильная расстановка игроков по доскам
 
О, уже частично работает! Сапасибки, The_Prist! А ПОИСКПОЗ ищет какие-либо значения - только так? Очень важным является решение задачи в том случае, когда ячейки еще пустые. И еще не работает список при перемещении ячеек по горизонтали(диагонали)...
Правильная расстановка игроков по доскам
 
хмм.. придется прикрепить файл
Правильная расстановка игроков по доскам
 
Спасибо, Angelina, что показала этот симпатичный сайт!.. :)  
Хочу продолжить её вопрос по перетаскиванию ячейки в таблице:  
 
Страницы: 1
Наверх