Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Выбрать дату в календареВыбрать дату в календаре

Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 49 След.
Сложить ячейки, Одна ячейка плюс другая
 
Может так?
Код
=A1+B1/100000
найти время предоперационной подготовки, как превратить разницу в часы и минуты?
 
В Вашем приложении переведите данные в числовой формат.
Вывести все значения в интервале между заданными датами, на одном из сайтов нашел формулу которая описывает данное решение, но формула не работает!!!
 
В формуле должна быть СТРОКА($1:$203)
Вывести все значения в интервале между заданными датами, на одном из сайтов нашел формулу которая описывает данное решение, но формула не работает!!!
 
Формула без масссивного ввода.
Код
=ЕСЛИОШИБКА(ИНДЕКС(C$2:C$200;АГРЕГАТ(15;6;СТРОКА($1:$200)/(A$2:A$200<=F$2)/(B$2:B$200>=F$2);ЧСТРОК($6:6)));"")
Как раскидать по 15 минут данные по часу.
 
Наверное так
Код
=I1+15/1440
Сведение исходных данных из одной таблицы в таблицу с ненулевыми значениями
 
Смотрите пример с формулой
Код
=ЕСЛИОШИБКА(ЕСЛИОШИБКА(ИНДЕКС('1'!A$4:A$20;АГРЕГАТ(15;6;СТРОКА($1:$20)/('1'!$B$4:$B$20<>0);ЧСТРОК($4:4)));ИНДЕКС('3'!A$4:A$20;АГРЕГАТ(15;6;СТРОКА($1:$20)/('3'!$B$4:$B$20<>0);ЧСТРОК($4:4)-СЧЁТЗ('1'!$B$4:$B$20))));"")
Сведение исходных данных из одной таблицы в таблицу с ненулевыми значениями
 
Ещё один вариант с формулой
Код
=ЕСЛИОШИБКА(ИНДЕКС('1'!A$4:A$20;АГРЕГАТ(15;6;СТРОКА($1:$20)/('1'!B$4:B$20<>0);ЧСТРОК($4:4)));"")
Сгруппировать все данные по каждой торговой точке в одну строку
 
вначале транспонируйте столбец Е по формуле
Код
=ЕСЛИОШИБКА(ИНДЕКС('Исходные данные'!$E$2:$E$200;АГРЕГАТ(15;6;СТРОКА($1:$200)/('Исходные данные'!$D$2:$D$200=D$1);ЧСТРОК($2:2)));"")
а потом другие столбцы по формуле
Код
=ЕСЛИОШИБКА(ИНДЕКС('Исходные данные'!A$2:A$200;ПОИСКПОЗ($D2;'Исходные данные'!$E$2:$E$200;0));"")
Изменено: jakim - 21 Мар 2019 16:35:43
Построение графика работы 2 /2
 
Формулы
для сотрудника 1
Код
=ЕСЛИ(ИЛИ(ОСТАТ(E5;4)=2;ОСТАТ(E5;4)=3);"8-20";"")
для сотрудника 2
Код
=ЕСЛИ(ИЛИ(ОСТАТ(E5;4)=0;ОСТАТ(E5;4)=1);"8-20";"")
Изменено: jakim - 14 Фев 2019 18:07:05
Формула для поиска наибольшей позиции и возврата значения заголовка
 
Формула
Код
=INDEX(B$1:E$1;;MATCH(MAX(B2:E2);B2:E2;0))
Выбор максимального значения по трем параметрам, Выбор максимального значения по трем параметрам
 
Формула без массивного ввода
Код
=MAX(INDEX('Форма для заполнения'!F$2:F$146*('Форма для заполнения'!A$2:A$146=A2)*('Форма для заполнения'!D$2:D$146=B2)*('Форма для заполнения'!E$2:E$146=C2);0))
Отбор различающихся строк двух таблиц
 
Формулой
Код
=IFERROR(INDEX(F$2:F$100;AGGREGATE(15;6;ROW(A$1:A$100)/(COUNTIFS($A$2:$A$25;$F$2:$F$25;$B$2:$B$25;$G$2:$G$25;$C$2:$C$25;$H$2:$H$25;$D$2:$D$25;$I$2:$I$25)=0);ROW(A1)));"")

Поиск ближайшего большего времени относительно выбранной ячейки
 
Ещё одна формула
Код
=AGGREGATE(15;6;C3:G3/(C3:G3>=C2);1)
для того чтобы формула выбирала время по Вашему примеру поста 3 необходимо к времени добавить дату.
Выделение цветом отличного от предыдущего значения
 
Вначале проформатируйте дубликаты, а потом начиная со второй строки по формуле
Код
=NOT(AND(A1=A2))
Транспонировать, отсортировать и удалить дубликаты формулой
 
Вариант с нижним примером
Код
=IFERROR(AGGREGATE(15;6;$A$15:$B$23/($A$15:$B$23>0/(COUNTIF($F15:F15;$A$15:$B$23)=0));1);"")
Транспонировать, отсортировать и удалить дубликаты формулой
 
Если с функцией АГРЕГАТ, то такая формула
Код
=IFERROR(INDEX($A$2:$A$30;AGGREGATE(15;6;ROW($1:$30)/($A$2:$A$30<>"")/(COUNTIF($C1:C1;$A$2:$A$30)=0);1));"")
Транспонировать данные, соответствующие своим id, в горизонтальные ячейки
 
Вариант для 2007 офиса на Лист3 формулами
Транспонировать данные, соответствующие своим id, в горизонтальные ячейки
 
Функцция АГРЕГАТ есть начиная с 2010 офиса.
Транспонировать данные, соответствующие своим id, в горизонтальные ячейки
 
Ещё один вариант без пустых строк.
Транспонировать данные, соответствующие своим id, в горизонтальные ячейки
 
Если для Excel2010+, то такой вариант.
Код
=IFERROR(INDEX($A2:$A300;AGGREGATE(15;6;ROW($1:$300)/($B2:$B300<>"");COLUMNS($F:F)));"'")
Составить формулу, которая возле чисел убирает букву
 
воспользуйтесь Ctrl+h (найти и заменить), без формул.
Транспонирование данных - помогите с массивом
 
Ещё один вариант формулами
Преобразовать горизонтальную таблицу в вертикальную
 
Вариант формулами
Как переобразовать вертикальный масив данных в горизонтальный?
 
Ещё вариант с формулами
для уникальных значений первого столбца
Код
=IFERROR(AGGREGATE(15;6;A$1:A$3500/(A$1:A$3500<>0)/(COUNTIF(D$1:D1;A$1:A$3500)=0);1);"")
для транспонирования второго столбца
Код
=IFERROR(INDEX($B$1:$B$5935;AGGREGATE(15;6;ROW($1:$6635)/($A$1:$A$5935=$D2)/($B$1:$B$5935<>"");COLUMNS($E:E)));"")
Поиск данных по нескольким признакам, Нужно найти данные по нескольким признакам среди повторяющихся значений
 
Ещё две формулы
1. обычная
Код
=IFERROR(INDEX(Факт!B$2:B$34;MATCH(1;INDEX((Факт!A$2:A$34=A2)*(Факт!B$2:B$34=B2);0);0));"")
2.массивная
Код
=IFERROR(INDEX(Факт!B$2:B$34;MATCH(1;(Факт!A$2:A$34=A2)*(Факт!B$2:B$34=B2);0));"")
Автоматическое транспонирование для сводной, Необходимо транспонировать часть данных таблицы для построения сводной
 
Вариант формулами
Скопировать строку таблицы из одного листа на другой
 
Смотрите приложенние с вариантом решения.
Изменено: jakim - 9 Дек 2018 18:30:20
Вывод с сортировкой необходимых данных из одной таблицы в другую
 
Даю поправку в приложенный файл (извините за ошибку).
Вывод с сортировкой необходимых данных из одной таблицы в другую
 
Предлагаю формульный вариант, но в отдельных столбцах.
Как сделать чтобы за 7 дней например 21 октября не зависимо от года подсвечивалась клетка.
 
Формула УФ
Код
=AND(MONTH(A1)-MONTH(TODAY())<=1;DAY(A1)-TODAY()<=7)
Изменено: jakim - 4 Дек 2018 19:05:03
Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 49 След.
Наверх