Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Выбрать дату в календареВыбрать дату в календаре

Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 49 След.
Поиск ближайшего минимального значения из определённого массива
 
Формула
Код
=AGGREGATE(14;6;H$2:H$12/(H$2:H$12<A1)/(G$2:G$12=B1);1)
Определение места (1,2,3) по количеству с одинаковыми результатами
 
Для ячейки F2 примените формулу
Код
=AGGREGATE(14;6;$A$1:$C$4/(E2>$A$1:$C$4);1)
и протяните её вправо
Изменено: jakim - 17 Июн 2019 22:24:33
Вытащить ФИО из адреса почты имя.фамилия@домен.рф
 
Формула
Код
=PROPER(SUBSTITUTE(LEFT(A2;SEARCH("@";A2)-1);".";" "))
Соединить строки в один диапазон, не учитывая пустые ячейки
 
Для первых двух столбцов формула
Код
=IFERROR(MAX(INDEX(C$2:C$34;MATCH(ROWS($2:2);$B$2:$B$34;0)):INDEX(C$2:C$34;MATCH(ROWS($2:2)+1;$B$2:$B$34;0)-1));"")
Найти позицию с минимальным количеством за промежуток времени
 
смотрите вариант с функцией АГРЕГАТ.
Создание градуировочных таблиц резервуаров в Excel, Помогите с формулой
 
Для упрощения расчёта сделайте градуировку в двух столбцах и примените формулу
Код
=INDEX(град.е4!$C$3:$C$188;MATCH(AK10;град.е4!B$3:B$188;0))
Список ФИО с группами и сортировка по столбцам по группам с помощью формул
 
Вариант с формулой
Код
=IFERROR(INDEX($B$3:$B$300;AGGREGATE(15;6;ROW($1:$300)/($C$3:$C$300=E$2);ROWS($3:3)));"")
Поиск максимума по двум условиям
 
Вариант с формулами без массивного ввода.
Удалить пробел между цифрами (преобразить текст в число)
 
Прикладываю файл.
Удалить пробел между цифрами (преобразить текст в число)
 
Формула вроде работающая и покороче
Код
=--SUBSTITUTE(A1;CHAR(160);"")
Автоматический перенос данных из одного листа в другой согласно определенным критериям
 
Смотрите вариант с формулой
Код
=IFERROR(INDEX(Исходные!A$4:A$200;AGGREGATE(15;6;ROW($1:$200)/(Исходные!$C$4:$C$200>100)/(YEAR(Исходные!$D$4:$D$200)=2019)/(MONTH(Исходные!$D$4:$D$200)=2);ROWS($3:3)));"")
из чисел вида 20160102 сделать дату.
 
Без формул (Data-->Next-->Next-->Date-->YMD-->Finish) и установите требуемый формат даты.
максимальное значение по четырем известным, найти максимальное значение по четырем известным
 
Ещё один вариант с функцией АГРЕГАТ.
Код
=IFERROR(AGGREGATE(14;6;Лист2!$F$2:$F$8/($A2=Лист2!$A$2:$A$8)/($B2=Лист2!$B$2:$B$8)/($C2=Лист2!$C$2:$C$8)/($D2=Лист2!$D$2:$D$8)/(E$1=Лист2!$E$2:$E$8);1);"")
Сложить ячейки, Одна ячейка плюс другая
 
Может так?
Код
=A1+B1/100000
найти время предоперационной подготовки, как превратить разницу в часы и минуты?
 
В Вашем приложении переведите данные в числовой формат.
Вывести все значения в интервале между заданными датами, на одном из сайтов нашел формулу которая описывает данное решение, но формула не работает!!!
 
В формуле должна быть СТРОКА($1:$203)
Вывести все значения в интервале между заданными датами, на одном из сайтов нашел формулу которая описывает данное решение, но формула не работает!!!
 
Формула без масссивного ввода.
Код
=ЕСЛИОШИБКА(ИНДЕКС(C$2:C$200;АГРЕГАТ(15;6;СТРОКА($1:$200)/(A$2:A$200<=F$2)/(B$2:B$200>=F$2);ЧСТРОК($6:6)));"")
Как раскидать по 15 минут данные по часу.
 
Наверное так
Код
=I1+15/1440
Сведение исходных данных из одной таблицы в таблицу с ненулевыми значениями
 
Смотрите пример с формулой
Код
=ЕСЛИОШИБКА(ЕСЛИОШИБКА(ИНДЕКС('1'!A$4:A$20;АГРЕГАТ(15;6;СТРОКА($1:$20)/('1'!$B$4:$B$20<>0);ЧСТРОК($4:4)));ИНДЕКС('3'!A$4:A$20;АГРЕГАТ(15;6;СТРОКА($1:$20)/('3'!$B$4:$B$20<>0);ЧСТРОК($4:4)-СЧЁТЗ('1'!$B$4:$B$20))));"")
Сведение исходных данных из одной таблицы в таблицу с ненулевыми значениями
 
Ещё один вариант с формулой
Код
=ЕСЛИОШИБКА(ИНДЕКС('1'!A$4:A$20;АГРЕГАТ(15;6;СТРОКА($1:$20)/('1'!B$4:B$20<>0);ЧСТРОК($4:4)));"")
Сгруппировать все данные по каждой торговой точке в одну строку
 
вначале транспонируйте столбец Е по формуле
Код
=ЕСЛИОШИБКА(ИНДЕКС('Исходные данные'!$E$2:$E$200;АГРЕГАТ(15;6;СТРОКА($1:$200)/('Исходные данные'!$D$2:$D$200=D$1);ЧСТРОК($2:2)));"")
а потом другие столбцы по формуле
Код
=ЕСЛИОШИБКА(ИНДЕКС('Исходные данные'!A$2:A$200;ПОИСКПОЗ($D2;'Исходные данные'!$E$2:$E$200;0));"")
Изменено: jakim - 21 Мар 2019 16:35:43
Построение графика работы 2 /2
 
Формулы
для сотрудника 1
Код
=ЕСЛИ(ИЛИ(ОСТАТ(E5;4)=2;ОСТАТ(E5;4)=3);"8-20";"")
для сотрудника 2
Код
=ЕСЛИ(ИЛИ(ОСТАТ(E5;4)=0;ОСТАТ(E5;4)=1);"8-20";"")
Изменено: jakim - 14 Фев 2019 18:07:05
Формула для поиска наибольшей позиции и возврата значения заголовка
 
Формула
Код
=INDEX(B$1:E$1;;MATCH(MAX(B2:E2);B2:E2;0))
Выбор максимального значения по трем параметрам, Выбор максимального значения по трем параметрам
 
Формула без массивного ввода
Код
=MAX(INDEX('Форма для заполнения'!F$2:F$146*('Форма для заполнения'!A$2:A$146=A2)*('Форма для заполнения'!D$2:D$146=B2)*('Форма для заполнения'!E$2:E$146=C2);0))
Отбор различающихся строк двух таблиц
 
Формулой
Код
=IFERROR(INDEX(F$2:F$100;AGGREGATE(15;6;ROW(A$1:A$100)/(COUNTIFS($A$2:$A$25;$F$2:$F$25;$B$2:$B$25;$G$2:$G$25;$C$2:$C$25;$H$2:$H$25;$D$2:$D$25;$I$2:$I$25)=0);ROW(A1)));"")

Поиск ближайшего большего времени относительно выбранной ячейки
 
Ещё одна формула
Код
=AGGREGATE(15;6;C3:G3/(C3:G3>=C2);1)
для того чтобы формула выбирала время по Вашему примеру поста 3 необходимо к времени добавить дату.
Выделение цветом отличного от предыдущего значения
 
Вначале проформатируйте дубликаты, а потом начиная со второй строки по формуле
Код
=NOT(AND(A1=A2))
Транспонировать, отсортировать и удалить дубликаты формулой
 
Вариант с нижним примером
Код
=IFERROR(AGGREGATE(15;6;$A$15:$B$23/($A$15:$B$23>0/(COUNTIF($F15:F15;$A$15:$B$23)=0));1);"")
Транспонировать, отсортировать и удалить дубликаты формулой
 
Если с функцией АГРЕГАТ, то такая формула
Код
=IFERROR(INDEX($A$2:$A$30;AGGREGATE(15;6;ROW($1:$30)/($A$2:$A$30<>"")/(COUNTIF($C1:C1;$A$2:$A$30)=0);1));"")
Транспонировать данные, соответствующие своим id, в горизонтальные ячейки
 
Вариант для 2007 офиса на Лист3 формулами
Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 49 След.
Наверх