Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Выбрать дату в календареВыбрать дату в календаре

Страницы: 1 2 3 4 5 След.
Как сгруппировать дубликаты по ячейке транспонированием
 
Цитата
rustf написал: до массивов не дошел
примеры
прямо сейчас можно дойти
составление номера договора, учитывая условия.
 
Mershik, может сразу и год "автоматизировать" :)
Код
=ТЕКСТ(СТРОКА()-3;"0000")&"-"&C4&"-"&ТЕКСТ(СЧЁТЕСЛИ($C$2:C3;C4)+1;"0000")&"/"&ГОД(B4)
составление номера договора, учитывая условия.
 
нумерация "с накоплением" ... если начинать с "нуля", то в формуле поставить "-1"
Изменено: kalmar - 18 Янв 2019 13:27:50
Разделение текста на название и размер
 
горящее решение :)
выборка данных с листов по наименовании листа
 
функции СТРОКА() и СТОЛБЕЦ() про них посмотрите, пожалуйста, в справке
Изменено: kalmar - 17 Янв 2019 12:29:59
выборка данных с листов по наименовании листа
 
Код
=ДВССЫЛ(АДРЕС(СТРОКА();СТОЛБЕЦ();4;1;$B$1))

вроде работало :)
Изменено: kalmar - 17 Янв 2019 11:02:43
Удаление строк со значением нумерации
 
если разово, то фильтр по столбцу А и найти "," (запятая). отфильтруются строки с "запятыми" и разом их удалить
Изменено: kalmar - 17 Янв 2019 10:55:50
Формула расчета плана по заданным полям
 
ВПР без аргумента "интервальный просмотр" считает тоже
Групповая замена и вставка символов в значениях ячеек таблицы экселя
 
Код
=ЕСЛИ(ДЛСТР(B1)=7;ЛЕВСИМВ(B1;2)+ПСТР(B1;4;2)/60+ПРАВСИМВ(B1;2)/3600;ПСТР(B1;2;2)+ПСТР(B1;5;2)/60+ПСТР(B1;2;2)/3600)

в зависимости от длинны текста. правильно?
Сложная фильтрация с множественным выбором
 
Добрый день! может расширенный фильтр и по первому столбцу с множеством выбора
расширенный фильтр
Посчитать бонус 4 сотрудникам использая табличку условий
 
и вот так получилось
Код
=ВПР(A10;A3:F6;ПОИСКПОЗ(ГПР(B10;$A$2:$F$2;1);$A$2:$F$2);ЛОЖЬ)
Создание таблицы, управляемой макросами с несколькими условиями
 
без макросов
а может и макросов не надо будет?
Поиск в тексте хХ (рядом строчная и заглавная) и вставка между ними символа
 
может вот это поможет? поиск заглавной буквы
коды заглавных букв в латинице от 65 до 90.
Изменено: kalmar - 29 Ноя 2018 12:59:00
Копирование данных из одной умной таблицы и вставка в другую на новом листе.
 
а макрос точно нужен? Вам никто сейчас процедуры писать не будет через заполнения :)
если они у Вас полностью совпадать будут, то пишите во второй таблице формулы
Код
=specifikaciya[@[Дата заполнения]]

или просто (без умной таблицы)
Код
='1'!A2

можете "посидеть" и защитить себя от ошибки "ССЫЛКА" (удаления строк) через функцию ДВВСЫЛ прописать формулы со ссылками на ячейки другого листа книги.

тема: формирование (дублирование) данных на основе другого листа книги (может так)?
Изменено: kalmar - 27 Ноя 2018 15:41:41
Разделение ячейки на несколько строк по нескольким колонкам одновременно
 
если без макросов, то быстро можно вот так (если не огромный массив):
- скопировать в Word
- обратно скопировать и снять объединение ячеек (появятся пустые строки)
- а потом  заполнение пустот
Вычисление при наличии фрагмента текста в значении ячейки
 
Код
=ЕСЛИ(ЕЧИСЛО(ПОИСК("*50*";B6));C6*50%;C6*30%)

если вдруг у Вас разные значения там могут быть, то как вариант получения значения
Код
=ЗНАЧЕН(ЛЕВСИМВ(B6;НАЙТИ(" ";B6)))
опять же если прописаны через пробел
Изменено: kalmar - 27 Ноя 2018 15:08:19
Сложить записи по сотрудникам для подсчета количества отработанных часов, консолидация времени по дате и по сотрудникам
 
с двумя дополнительными столбцами, если устроит? :) и если правильно понял
объединить
 
правила читать конечно же сложно. но вбить в строку поиска "объединить", а потом добавить "текст" ну и контрольный выстрел "excel"
и первая же ссылка на примеры с Планеты... но ведь не интересно, нужна уже готовая формула (решение)
объединение текста из разных ячеек excel
Изменено: kalmar - 22 Окт 2018 14:37:33
К числам одного столбца добавляется .0 в конце
 
в третьем шаге мастера текстов есть кнопка "Подробнее", там можно разделитель групп разрядов поменять
Выбор таблицы по наименованию
 
a.i.mershik, ну и вместо "умной таблицы" и фильтра сделать выпадающий список. правильно понял?
Изменено: kalmar - 18 Окт 2018 10:43:25
Динамический списка уникальных значений
 
может как вариант: сначала подсчитать количество уникальных уникальные с пустотами
а ниже поставить нумерацию с учетом количества уникальных и в соответствии с нумерацией НАИМЕНЬШИЙ, где вторым аргументов ссылка на нумерацию

хотя потом избавляться от дубликатов  :oops:

пока писал уже кучу решений предложили.
Изменено: kalmar - 18 Окт 2018 09:06:50
Определить продавца с самым стабильным годовым доходом
 
а вообще наверное
Код
=СТАНДОТКЛОН.В(B2:J2)

и у кого меньше тот стабильней?  :qstn:
статистика
Изменено: kalmar - 17 Окт 2018 15:59:49
Определить продавца с самым стабильным годовым доходом
 
в выручку по месяцам можно вот так поставить
Код
=ГПР(B18;$B$1:$J$9;ПОИСКПОЗ(A18;$A$1:$A$9;0);ЛОЖЬ)

и Вам получить значение по оптимальному?
Код
=ИНДЕКС($G$14:$G$21;ПОИСКПОЗ(J16;$H$14:$H$21;0))
Изменено: kalmar - 17 Окт 2018 15:46:30
Выборка данных по дате
 
можно и вот так
формулы можно под названия столбцов умной таблицы "доделать".
Изменено: kalmar - 17 Окт 2018 10:33:26
Выборка данных по дате
 
для расчета за последние сутки можно вот так
Код
=СУММЕСЛИМН(реестр!$C$104:$C$131;реестр!$F$104:$F$131;Отчет!B8;реестр!$E$104:$E$131;Отчет!$C$2)

а за последние 5 дней.
если удобно, то можно дополнительный столбец, посчитать разницу в датах. потом дополнительное условие в СУММЕСЛИ

тема: суммирование по двум и более условиям / критериям
Маленький плюсик при скрытых строках - что это?
 
:)  жду Медведя с трубкой! в части "где-то и у кого-то"
а пока можно самостоятельно почитать тему "группировка данных"
группировка
Выдернуть число из массива чисел разделенных символом !
 
мне кажется изначально можно загрузить уже по столбцам без разбивки.
сейчас через "блокнот" загрузились данные.
Выдернуть число из массива чисел разделенных символом !
 
БМВ, скорей всего один символ в ТЗ не дали, поэтому попал один символ "лишний"
на втором листе разбил текст по столбцам
Выдернуть число из массива чисел разделенных символом !
 
загрузка текстовых файлов
а может вот так. просто открывать / загружать уже  через символ-разделитель.
или уже как вариант: разбивка текста по столбцам через символ-разделитель
Как в зависмимости от величины значения получить 1 из 3-х вариантов?
 
вроде и задача легкая была и все готовы были без примера помочь... а тут "упс"... 8)
Страницы: 1 2 3 4 5 След.
Наверх