Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Выбрать дату в календареВыбрать дату в календаре

Страницы: 1 2 3 4 След.
"Обрезанное" контекстное меню в Excel 2016
 
Добрый день.

Попробуйте сбросить командой
Код
Application.CommandBars("Cell").Reset
Подстановка картинок по условиям
 
Добрый день.
Удалите 3-ю сверху и 3-ю снизу строчки кода:
Код
...
If Not Intersect(Target, Sheets("Sheet1").Range("C3")) Is Nothing Then
...
End If
...
Разделить название книги и автора
 
Добрый день.

Вариант во вложении.
Сравнение значений на разных листах Excel
 
Добрый день.

Можно формулой ВПР
Функция ЕСЛИ одновременно с тремя условиями
 
Можно так:
Код
=СУММЕСЛИМН($D:$D;$A:$A;"t";$B:$B;"b2";$C:$C;"*")
Автозаполнение пустых ячеек столбца данными в группированной таблице, ...и применение цветовой заливки по условию
 
Sanja, _Igor_61, огромное спасибо! Все варианты отлично работают!
Автозаполнение пустых ячеек столбца данными в группированной таблице, ...и применение цветовой заливки по условию
 
Добрый день, уважаемые форумчане.

Помогите, пожалуйста, в формировании макроса, который заполнял бы в столбце до конца таблицы пустые ячейки в зависимости от того, есть ли группировка или её нет (если есть группировка и ячейка в столбце пустая, то ячейка = ячейке ниже неё; если группировки нет, то ячейка остаётся пустой).
+ Если внутри группировки в этом же столбце есть различные данные, то ячейки слева красились бы в любой цвет.

В приложении есть пример - два листа Как есть и как хотелось бы получить.
Всё вышеописанное смог сделать формулами и условным форматированием (на листе "Хотелось бы получить") - записал манипуляции макрорекордером и попытался разобраться, но не увенчалось успехом.

Заранее благодарен за содействие.  
Срабатывание фильтра при изменении данных в ячейке
 
Добрый день.

Попробуйте воспользоваться данным приемом - ССЫЛКА
Агрегирование данных с нескольких листов на один
 
Добрый день.

Если принципиально хранить данные именно на разных листах,
но не принципиально добавить в них столбец с месяцами и использовать макросы, то как вариант решения можно сделать так (см.вложение).

ИСТОЧНИК
Изменено: Гаубица - 14 Ноя 2017 13:06:45
Как можно сокращать длинные формулы?
 
Добрый день.

Как вариант можно через Диспетчер имен (см.вложение).
Оценка упражнений по определенному алгоритму
 
Цитата
GrayBrother написал:
а как сделать чтоб оценка появлялась только после трех введенных данных

Подправил формулу (см.вложение)
Скрытый текст
Формула, вытягивающая курс валют из таблицы
 
Добрый день.

Попробуйте формулой:
=СУММЕСЛИМН($D$10:$D$69;$E$10:$E$69;$D$3;$C$10:$C$69;$D$4)
Изменено: Гаубица - 9 Ноя 2017 13:38:55
Подсчитать кол-во дубликатов
 
Добрый день.

Возможно так (см.вложение)
Оценка упражнений по определенному алгоритму
 
Добрый день.

Сделал безумной формулой, но вроде работает  :)
Скрытый текст
Фильтрация дат день-ночь (например 01-02.01.2017)
 
Добрый день.

Тут придется разбивать по каждой дате (см.прикрепленный пример)
Выделить повторяющие значения в столбце друг за другом
 
Должен подойти вот этот прием - ССЫЛКА
Поиск и выделение цветом только в разных столбцах
 
либо ВПР
Деление числа на равные части
 
Добрый день.

Приложите файл-пример (что есть, что надо)
Найти предпоследнюю заполненную ячейку.
 
Добрый день.

Посмотрите вариант во вложении
Формирование базы В ТАБЛИЦЕ
 
Добрый день.

Вставил код nilem в файл во вложении.
Макрос назначил на кнопку.

P.S.: подробнее об этом тут
Добавление в строку данных по условиям
 
Добрый день.

Сделал огромнейшей формулой..но вроде работает (см. вложение)
Изменено: Гаубица - 30 Окт 2017 16:06:57
Переместить столбцы один под другой, начало следующего под конец предыдущего
 
Geineh, Вам решать.
Можете использовать код Nordheim, либо код, который в моём файле:
Код
Sub test()
n = 1
Range("A1").Select
For c = 1 To 8
    For r = 1 To Range(Selection, Selection.End(xlDown)).Count
        Cells(n, 4) = Cells(r, c): n = n + 1
    Next r
Next c
Range("A:C,E:H").Select
    Selection.Delete Shift:=xlToLeft
    Range("A1").Select
End Sub
cвязать текст из excel и power point, автоматическое обновление связаных документов
 
Добрый день.
  1. Скопируйте ячейку Excel
  2. Вставьте специальной вставкой в Powerpoint (Ctrl+Alt+V)
  3. В меню специальной вставки выберите буллет "Связать", Как: "Объект Лист Excel" (см.картинку ниже)
  4. Нажмите "Ок"
Переместить столбцы один под другой, начало следующего под конец предыдущего
 
Добрый день.

Как вариант в прикрепленном файле.
Окрашивание ячейки из примечания
 
Добрый день.

А в каком формате указан цвет в примечаниях?
Приложите файл пример (см. п. 2.3 правил форума)
Узнать сумму в залитых строках, Выборка по условию выделенной ячейки
 
Попробуйте воспользоваться следующей функцией:
Код
Public Function SumColor(myRange As Range) As Variant
Dim rngCell As Range
Dim summa As Variant

For Each rngCell In myRange.Cells
    If rngCell.Interior.Color = vbRed Then
    summa = summa + rngCell.Offset(0, -1).Value
    End If
Next rngCell
SumColor = summa

End Function
+ приложил сам файл
Разрешить вводить только русские буквы/ кириллицу, Запрет ввода данных
 
Добрый день.
Посмотрите вариант в прикрепленном файле (при помощи "Проверки данных" на вкладке "Данные").
Источник: ССЫЛКА
Узнать сумму в залитых строках, Выборка по условию выделенной ячейки
 
Добрый день.

Попробуйте воспользоваться данным решением
http://www.planetaexcel.ru/techniques/9/162/
Транспонирование таблицы со связями, Нужно, чтобы в уже транспонированной таблице были формулы из исходной
 
см. п.2.3 правил форума.
Сокращение ФИО до Фамилии с инициалами.
 
Добрый день.

Посмотрите вариант во вложении.
Страницы: 1 2 3 4 След.
Наверх