Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Выбрать дату в календареВыбрать дату в календаре

Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 16 След.
Функция листа - аналог like для поиска по шаблону
 
Хороший вопрос, но плохой файл-пример
В примере нужно 4 Вами заполненных столбца -

Где_ищем
Что_ищем
Требуемый_результат
Пояснение_к_результату

И побольше вариантов, не три, два из которых по сути одинаковы, а штук 20 хотя бы
Скажи мне, кудесник, любимец ба’гов...

Отделить текст до первого встретившегося числа
 
кросс
http://www.excelworld.ru/forum/2-41201-1#273341
Скажи мне, кудесник, любимец ба’гов...

Подтверждение почтового адреса на сайте excelworld.ru
 
Я модератор того форума. Под каким ником Вы там зарегистрировались?
Изменено: _Boroda_ - 26 Фев 2019 11:30:32
Скажи мне, кудесник, любимец ба’гов...

Форматирование символов текста в зависимости от их цвета
 
У меня с первым символом очень похожая фигня в 2010 Excel. В 2013 все нормально. Это похоже мой первый вариант http://www.excelworld.ru/forum/2-40806-270434-16-1550238568 что-то попортил

А код в модуле листа - да просто мне так больше нравится писать (при отсутствии каких-либо предпочтений для местонахождения кода, конечно). Быстрее добраться до него - ПКМ на ярлык, исходный текст
Скажи мне, кудесник, любимец ба’гов...

Форматирование символов текста в зависимости от их цвета
 
Андрей VG, я тоже думал, что долго будет, а потом смотрю - не, вроде довольно-таки приемлимо
На моей машине, которую собирали 6 лет назад, 10 000 ячеек обрабатывает 28 секунд. Для работы с форматами - вполне

С твоим макросом, конечно же, по скорости не сравнить, но видишь, ограничение. У меня, кстати, ругается не на 1000 ячеек, а почему-то на немногим больше 100. Все ячейки с текстом "Иван Иванов (сын Ивана Ивановича)". Причем ругается на плавающее количество ячеек - примерно от 106 до 120, на каждый запуск макроса пропускает разное количество
Скажи мне, кудесник, любимец ба’гов...

Как подсчитать количество строк содержащих определенное значение
 
Так нужно?
=СЧЁТЕСЛИ(A$2:A$86;"*"&J2&"*")
Скажи мне, кудесник, любимец ба’гов...

Рассчет ежедневной нормы.
 
lahesis333, в следующий раз на всех форумах сообщайте о кроссах. Это есть в Правилах форума, как этого, так и того

И на другом форуме отписаться тоже не помешало бы
Изменено: _Boroda_ - 6 Ноя 2018 17:18:38
Скажи мне, кудесник, любимец ба’гов...

Протягивание формулы с определённым сдвигом диапазона
 
Можно и сдвигать
=СРЗНАЧ(ИНДЕКС($B3:$U3;1+5*(V1-1)):ИНДЕКС($B3:$U3;5*V1))
Скажи мне, кудесник, любимец ба’гов...

Протягивание формулы с определённым сдвигом диапазона
 
Так нужно?
=ЕСЛИОШИБКА(СРЗНАЧЕСЛИ($B1:$U1;V1;$B3:$U3);)
Изменено: _Boroda_ - 1 Ноя 2018 14:14:47
Скажи мне, кудесник, любимец ба’гов...

Поиск во всем диапазоне столбца
 
Читайте справку по СУММЕСЛИМН
"Важно: Каждый дополнительный диапазон должен состоять из такого же количества строк и столбцов, что и аргумент диапазон_условия1. Эти диапазоны могут не находиться рядом друг с другом".

Всю кучу в одну формулу можно так
=СУММПРОИЗВ(СЧЁТЕСЛИМН(Проверка!$D$2:$D$1692;"3";Проверка!$G$2:$G$1692;{"Изолятор":"заземление"}))
Вовнутрь фигурных скобок напишите всё то, что нужно. Или в ячейки напишите, тогда формула
=СУММПРОИЗВ(СЧЁТЕСЛИМН(Проверка!$D$2:$D$1692;"3";Проверка!$G$2:$G$1692;A40:A99))
в A40:A99 написаны условия (можно с пустыми ячейками)
Изменено: _Boroda_ - 1 Ноя 2018 23:23:02
Скажи мне, кудесник, любимец ба’гов...

счет количества букв с цифрами, нужно посчитать сколько будет сумма букв и цифр
 
Так?
=СУММ(--ТЕКСТ(ПРАВБ(ПОДСТАВИТЬ(A2:O2;"\";"000");4);"0;;;\0"))&ТЕКСТ(СУММ(--ТЕКСТ(ПСТР(ПОДСТАВИТЬ(Т(+A2:O2);"\";"   ");2;4);"0;;;\0"));"\Н0;;")
Скажи мне, кудесник, любимец ба’гов...

счет количества букв с цифрами, нужно посчитать сколько будет сумма букв и цифр
 
А могут быть значения типа 555, Н342, Н117\565?
Варианты еще
Массивные
=СУММ(--ТЕКСТ(ПРАВБ(ПОДСТАВИТЬ(A2:O2;"\";"000");4);"0;;;\0"))&"\Н"&СУММ(--ТЕКСТ(ПСТР(ПОДСТАВИТЬ(Т(+A2:O2);"\";"   ");2;4);"0;;;\0"))
=СУММ(ЕСЛИОШИБКА(--ПРАВБ(ПОДСТАВИТЬ(A2:O2;"\";"000");4);))&"\Н"&СУММ(ЕСЛИОШИБКА(--ПСТР(ПОДСТАВИТЬ(Т(+A2:O2);"\";"   ");2;4);))
Немассивный
=СУММпроизв(--ТЕКСТ(ПРАВБ(ПОДСТАВИТЬ(A2:O2;"\";"000");4);"0;;;\0"))&"\Н"&СУММпроизв(--ТЕКСТ(ПСТР(ПОДСТАВИТЬ(Т(+A2:O2);"\";"   ");2;4);"0;;;\0"))
Скажи мне, кудесник, любимец ба’гов...

Для каждого столбца найти максимальную длину строки
 
Цитата
БМВ написал:
Александр, вы это пошто людей путаете?
Никто никого не путает. Внимательно читаем цитату, речь идет именно о формуле массива:
Цитата
StoTisteg написал:
без формулы массива
*****
Кстати, что понимается под
Цитата
БМВ написал:
без масcивности
? Что такое "массивность"? Определение в студию.  
Скажи мне, кудесник, любимец ба’гов...

Для каждого столбца найти максимальную длину строки
 
Цитата
StoTisteg написал:
А как Вы предполагаете находить максимум в массиве без формулы массива?
Элементарно
=МАКС(ИНДЕКС(ДЛСТР(A1:A11);))
Скажи мне, кудесник, любимец ба’гов...

Ссылка в формуле относительно активной ячейки
 
Напишите формулу, поставьте в Excel стиль формул R1С1 и посмотрите как формула изменится. Думаю, так понятнее будет. Обратите внимание на то, как изменится ссылка вида RC, если Вы напишете $A$3, $A3, A$3, A3
Стиль меняется Файл - Параметры - Формулы
Изменено: _Boroda_ - 26 Окт 2018 15:34:05
Скажи мне, кудесник, любимец ба’гов...

Суммирование значений по данным, выбранным в выпадающих списках
 
Так нужно?
=СУММ(ИНДЕКС(C6:C12;ПОИСКПОЗ(D2;B6:B12;)):ИНДЕКС(C6:C12;ПОИСКПОЗ(D3;B6:B12;)))
Скажи мне, кудесник, любимец ба’гов...

Условное форматирование на основании значения в другой ячейке
 
Переделал Вам шапку таблицы. В А1 вводите первое число нужного месяца. Строки 2 и 3 заполняются автоматически. Раскраска суббот и воскресений тоже автоматически
В УФ формула такая
=МЕДИАНА(4+ИЛИ(ДЕНЬНЕД(B$2;2)=1;ДЕНЬНЕД(B$2;2)=5);5+ИЛИ(ДЕНЬНЕД(B$2;2)=1;ДЕНЬНЕД(B$2;2)=5);B4)=B4
Для 2013 и 2016 Excel можно покороче формулу написать
Скажи мне, кудесник, любимец ба’гов...

Как подсчитать количество строк содержащих определенное значение
 
Все правильно. У Вас там числовые значения. То, что Вы поставили им текстовый формат, ничего не меняет - это числа в ячейках, которые в текстовом формате (смотрите голубые ячейки с формулами ЕЧИСЛО и ЕТЕКСТ)
А вот если в соседнем столбце написать
=A1&""
, то это будет уже текст (несмотря на то, что формат в ячейках не текстовый)
Тогда формулу можно написать так
=СЧЁТЕСЛИ(B:B;7&ЛЕВБ(C3;4)&"*")
или так
=СЧЁТЕСЛИ(B:B;"*"&ЛЕВБ(C3;4)&"*")
Изменено: _Boroda_ - 26 Окт 2018 11:46:11
Скажи мне, кудесник, любимец ба’гов...

Как подсчитать количество строк содержащих определенное значение
 
Звездочка подразумевает текстовые значения в массиве для поиска
У Вас можно написать
=СЧЁТЕСЛИМН(H:H;">=781420000";H:H;"<=781429999")
А вообще Вам нужно было бы приложить свой файл
Изменено: _Boroda_ - 26 Окт 2018 11:25:33
Скажи мне, кудесник, любимец ба’гов...

Пользовательский формат с условиями
 
va-grom, рисовать самому с нуля лень. Вот Вы сделайте диаграмму "почти как нужно" и опишите, что там доделать надо, тогда да, можно попробовать
Скажи мне, кудесник, любимец ба’гов...

Изменения адреса ячейки в строке формулы
 
KILOJOUL, а зачем Вы делаете ссылку на строку 10? Может, проще выделить ячейки С12:AF12, ввести в первую ячейку формулу
=ТРАНСП(A1:A31)
и нажать Контрл Шифт Ентер?
Скажи мне, кудесник, любимец ба’гов...

Пользовательский формат с условиями
 
Так нужно?
[=3]"B+";[=2]"B";"B-"
Скажи мне, кудесник, любимец ба’гов...

Суммирование отрицательных и положительных числа в диапозоне при наличии текстовых значений
 
Еще пара немассивных вариантов
=СУММПРОИЗВ((ABS(Ч(+A3:AD3))>8)*(ABS(Ч(+A3:AD3))-8))
=СУММПРОИЗВ(ТЕКСТ(A3:AD3;"[>8]0;[<-8]0;\8;\8")-8)
Скажи мне, кудесник, любимец ба’гов...

Ошибка при создании временнОй шкалы в сводной таблице
 
blizardo,Вы бы посмотрели что там у Вас на остальных трех листах
Изменено: _Boroda_ - 9 Окт 2018 15:44:40
Скажи мне, кудесник, любимец ба’гов...

Итоговый отчёт: суммировать итог на выбранный период.
 
Цитата
Anton555 написал:
формула "суммесли" может суммировать именно массив, а "суммеслимн" нет
Не совсем так, СУММЕСЛИМН тоже берет двумерные массивы, только нужно следить, чтобы у всех аргументов "диапазон ..." были одинаковые размерности
А формулу предлагаю такую (ничего в файле не меняя)
=СУММЕСЛИМН(D3:JE3;$L$1:$JM$1;">="&$B$16;$L$1:$JM$1;"<="&$B$17)
Изменено: _Boroda_ - 9 Окт 2018 15:41:47
Скажи мне, кудесник, любимец ба’гов...

Ошибка при копирвании данных в другой диапазон
 
Range у Вас относится к wrkBook.Worksheets(1)
А Cells к чему относится?
Намек понятен?
Скажи мне, кудесник, любимец ба’гов...

Нумерация с учётом использования иерархии групп
 
А нужно сделать как в каком столбце?
И вообще - что дано и что нужно получить?
Изменено: _Boroda_ - 3 Окт 2018 13:24:00
Скажи мне, кудесник, любимец ба’гов...

Определение ФИО по предпоследнему посещению с уникальным кодом
 
Цитата
БМВ написал:
ни я ни Александр не знали, что у вас там будет текст а не числа со временем.
Я знал. Иначе бы не поставил два минуса здесь =--B$2:B$99
Это действительно косяк. Вот тк нужно
=ЕСЛИОШИБКА(ПРОСМОТР(;-1/(МАКС((A2=A$2:A$9)*(B$2:B$9-B2<0)*B$2:B$9)=--B$2:B$9);C$2:C$9);"--")
С самого начала хотел так написать, потом почему-то (типа короче и вроде работает) написал так, как написал в посте выше
Скажи мне, кудесник, любимец ба’гов...

Определение ФИО по предпоследнему посещению с уникальным кодом
 
Цитата
БМВ написал:
что будет при одинаковом времени у разных карт?
Я исходил из того, что поскольку время в секундах, то это явно считыватель (или человечий ввод с автопроставкой времени) на проходной. Два человека с одной картой одновременно пройти не могут.
Цитата
БМВ написал:
странно , формулы идентичны
Действительно, что-то здесь автор явно недоговаривает. На ExcelWorld я то же самое написал:
"Вообще-то это одинаковые формулы. Если у Вас они дали разные результаты, то покажите в файле"

В общем, Алексей Максимович когда файл приложит, то посмотрим
Скажи мне, кудесник, любимец ба’гов...

Определение ФИО по предпоследнему посещению с уникальным кодом
 
Из кросса
=ПРОСМОТР(;-1/(МАКС((A2=A$2:A$99)*(B$2:B$99<B2)*B$2:B$99)=--B$2:B$99);C$2:C$99)&""
Изменено: _Boroda_ - 29 Сен 2018 13:37:58
Скажи мне, кудесник, любимец ба’гов...

Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 16 След.
Наверх