Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Выбрать дату в календареВыбрать дату в календаре

Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 17 След.
Как произвести автозаполнение пустых значений?
 
Тогда формула
=ЕСЛИОШИБКА(ЕСЛИОШИБКА(ВПР(B4;B$3:E3;4;);ВПР(B4;B5:E$10;4;));)
Скажи мне, кудесник, любимец ба’гов...

Присваивание значений, Присваивание значений, но не формул
 
А чем принципиально это отличается от формулы =А1 в А2?
Скажи мне, кудесник, любимец ба’гов...

Присваивание значений, Присваивание значений, но не формул
 
Ага :)
На чьем файле будем макрос писать?
Скажи мне, кудесник, любимец ба’гов...

Как произвести автозаполнение пустых значений?
 
Потребители по порядку или произвольно расположены?

=Е5 может не прокатить - внизу может быть уже другая организация

В п.3 предыдущего поста я что-то в этом роде так написал
=ЕСЛИ(B4=B3;E3;ЕСЛИ(B4=B5;E5;))
Но это только в том случае, если значения упорядочены по потребителю
Изменено: _Boroda_ - 21 Май 2019 10:40:21
Скажи мне, кудесник, любимец ба’гов...

Условное форматирование по определенному условию, Форматирование текстовых значений
 
Так хотели?

=ЕСЛИ(F$1="Факт";-ПРОСМОТР(;-F3:N3/("Факт"=F$1:N$1))+ПРОСМОТР(;-C3:K3/("Факт"=F$1:N$1));"")
Скажи мне, кудесник, любимец ба’гов...

Присваивание значений, Присваивание значений, но не формул
 
Эээ, несколько вопросов
Цитата
Вагиз написал:
в присваивание вида А2=А1, из ячейки А1 забрать не формулу, а значение?
Формула А2=А1, из ячейки А1 забирает как раз значение. Вы же в А2 видите не СЕГОДНЯ(), а дату, которая в А1, правильно?
Цитата
Вагиз написал:
в ячейке А2 будет всегда текущая дата. А там нужна дата на текущий момент.
Чем отличается текущая дата от даты на текущий момент?

Возможно,Вы имеете в виду, что
1. В А1 СЕГОДНЯ(), а Вы хотите, чтобы в А2 была фиксированная дата на момент пересчета файла. И чтобы завтра в А1 была завтрашняя дата, но в А2 осталась бы сегодняшняя. Тогда формулы Вам не помогут, разве что с ручным пересчетом, но все равно не то. Простенький макрос решит вопрос
2. Или наоборот - у Вас стоит ручной пересчет и завтра дата в А2 самостоятельно не меняется (впрочем, тогда и в А1 не меняется). В этом случае достаточно поставить автопересчет
3. Или что-то иное?
Скажи мне, кудесник, любимец ба’гов...

Как сгенерировать ряд чисел
 
В А1 - это будет результат
=ЛЕВБ(A2;ДЛСТР(A2)-ДЛСТР(", "))
В А2 и ниже на сколько нужно
=СТРОКА()&", "&A3
Изменено: _Boroda_ - 13 Май 2019 17:59:30
Скажи мне, кудесник, любимец ба’гов...

Сумма по нескольким условиям, ссылка на массив, находящийся на пересечении нужных строк и столбцов, работает некорректно.
 
Цитата
turbidgirl написал:
Формула работает
Вы хотите сказать, что моя не работает?
Цитата
turbidgirl написал:
Изначально его и надо было бы выложить...
Конечно. Получили бы ответ на 2 часа раньше
Такой вариант
=СУММ(ЕСЛИОШИБКА(СУММЕСЛИ(PriceOsoby[Код];$A2:$A8;ИНДЕКС(PriceOsoby;;ПОИСКПОЗ(D1;PriceOsoby[#Заголовки];)));$B2:$B8)*D2:D8)
А вот так
Цитата
turbidgirl написал:
[[Саша]:[Маша]];
лучше не пишите. Завтра перед Сашей или после Маши добавится столбец - и формулу придется переписывать

Да, и не совсем ясно про 1620. Должно получиться 1500. В файле проверка
Изменено: _Boroda_ - 23 Апр 2019 20:11:31
Скажи мне, кудесник, любимец ба’гов...

Сумма по нескольким условиям, ссылка на массив, находящийся на пересечении нужных строк и столбцов, работает некорректно.
 
Если у Вас расположение артикулов параллельно (как в примере), то можно
=СУММ(D2:D6*ЕСЛИОШИБКА(ИНДЕКС(PriceOsoby;;ПОИСКПОЗ(D1;PriceOsoby[#Заголовки];));$B2:$B6))

Не посмотрел на название темы.
Может что-то типа "сумма по нескольким условиям"?

Изменено: _Boroda_ - 23 Апр 2019 17:55:00
Скажи мне, кудесник, любимец ба’гов...

Как сделать автоматический прайс если много цифр.значений
 
Ответил здесь http://www.excelworld.ru/forum/2-41564-1#275863
Скажи мне, кудесник, любимец ба’гов...

Извлечь из массива наиболее часто встречающееся название города
 
Цитата
Akropochev написал:
_Boroda_, спасибо Вам
За что?
Скажи мне, кудесник, любимец ба’гов...

Извлечь из массива наиболее часто встречающееся название города
 
Цитата
Akropochev написал:
с модой 255 строчек всего
Что это вдруг? Там же массив, а не перечисление

* А формула классная
Скажи мне, кудесник, любимец ба’гов...

Медленная работа штатного цикла Do WHILE при копировании строк
 
Цитата
Джек Восмеркин написал:
копируется построчно на Лист2
зачем? Почему именно построчно? Почему не все сразу?
Скажи мне, кудесник, любимец ба’гов...

Медленная работа штатного цикла Do WHILE при копировании строк
 
При работе с листом нужно отключать обновление экрана и пересчет.
И что-то странно - на Вашем файле Ваш цикл отрабатывает за 0,35 сек, никак не  18 сек. А с отключениями - 0,38 сек

Вот такой код у меня отрабатывает примерно за 0,009 сек
Код
Sub tthh()
    t_ = Timer
    Sheets("Лист1").UsedRange.Copy Sheets("Лист2").Cells(1)
    MsgBox Timer - t_
End Sub
Скажи мне, кудесник, любимец ба’гов...

[ Закрыто] Ускорение. Перестройка..., Ускорение. Перестройка...Цикл копирование строк из Лист1 в Лист2
 
Причины конечно видны, но есть несколько вариантов горбачевизации
А самому данные рисовать лень
 
Скажи мне, кудесник, любимец ба’гов...

Извлечь из массива наиболее часто встречающееся название города
 
Цитата
БМВ написал:
что-то две последние не всегда корректно работают.
А они вообще неправильные, стормозил я
Вот с твоей МОДой правильно
=ГПР(D4;D4:D40;МОДА(ЕСЛИ(D4:D40<>0;ПОИСКПОЗ(D4:D40;D4:D40;)));)
Изменено: _Boroda_ - 11 Апр 2019 12:32:32
Скажи мне, кудесник, любимец ба’гов...

[ Закрыто] Ускорение. Перестройка..., Ускорение. Перестройка...Цикл копирование строк из Лист1 в Лист2
 
И файлик поиграться
Скажи мне, кудесник, любимец ба’гов...

Извлечь из массива наиболее часто встречающееся название города
 
Еще вариант
Код
=ПРОСМОТР(;-1/(МАКС(СЧЁТЕСЛИМН(D3:D40;Т(+D3:D40)))=СЧЁТЕСЛИМН(D3:D40;D3:D40));D3:D40)
И Ваш вариант
Код
=ИНДЕКС(D4:D40;ПОИСКПОЗ(МАКС(СЧЁТЕСЛИ(D4:D40;Т(+D4:D40)));СЧЁТЕСЛИ(D4:D40;D4:D40))
И еще
Код
=ГПР(D4;D4:D40;МАКС(СЧЁТЕСЛИ(D4:D40;Т(+D4:D40)));)
И немассивный
Код
=ГПР(D4;D4:D40;МАКС(ИНДЕКС(СЧЁТЕСЛИ(D4:D40;Т(+D4:D40)));)
Скажи мне, кудесник, любимец ба’гов...

Разнести значение одной ячейки по другим, учитывая разделители
 
Если итог нужен тот, что голубенький, то
Код
=СЖПРОБЕЛЫ(ПСТР(ПОДСТАВИТЬ(ПОДСТАВИТЬ($A5;"(";";");";";ПОВТОР(" ";99));198*СТОЛБЕЦ(A5)-197;99))
Код
=СЖПРОБЕЛЫ(ПСТР(ПОДСТАВИТЬ(ПОДСТАВИТЬ($A5;"(";")");")";ПОВТОР(" ";99));198*СТОЛБЕЦ(A5)-99;99))
Скажи мне, кудесник, любимец ба’гов...

Написать формулы для файла Excel (задание)
 
Цитата
iMrTidy написал:
_Boroda_ , Вы и тут лезете с нравоучениями
iMrTidy, Вы и тут попытаетесь поучить меня жизни? Что, не живется спокойно, заняться больше нечем, обязательно прицепиться нужно? Да, я понимаю, Вам не понравились мои комментарии в этой теме http://www.excelworld.ru/forum/2-39176-1 , но попробуйте как-то уже это пережить или, по крайней мере, не переносить в совершенно непричастные темы.

И в личку мне тоже цитаты из Правил форума, которые Вы сами же и нарушаете, присылать не нужно. Вот уж что-то, а Правила я наизусть знаю - это первое, что я читаю на любом форуме

И да, это не нравоучения, а прямая забота о потенциальном исполнителе - информирование о возможном скрытом тендере, что довольно часто встречается
Скажи мне, кудесник, любимец ба’гов...

Написать формулы для файла Excel (задание)
 
А пофиг, сообщать все равно нужно. Тем более в платной ветке
Скажи мне, кудесник, любимец ба’гов...

Написать формулы для файла Excel (задание)
 
http://forum.msexcel.ru/index.php?topic=11992.new#new
http://www.excelworld.ru/forum/6-41431-1

Где еще раскидали вопрос?
Скажи мне, кудесник, любимец ба’гов...

Закрасить ячейки за несколько дней до указанной даты
 
Неадекватный Борода с такого же форума исключительно ради заботы о вашем, Darvel, зрении, вас на том форуме заблокировал
http://www.excelworld.ru/forum/2-41339-274253-16-1553964573
Скажи мне, кудесник, любимец ба’гов...

Функция листа - аналог like для поиска по шаблону
 
Хороший вопрос, но плохой файл-пример
В примере нужно 4 Вами заполненных столбца -

Где_ищем
Что_ищем
Требуемый_результат
Пояснение_к_результату

И побольше вариантов, не три, два из которых по сути одинаковы, а штук 20 хотя бы
Скажи мне, кудесник, любимец ба’гов...

Отделить текст до первого встретившегося числа
 
кросс
http://www.excelworld.ru/forum/2-41201-1#273341
Скажи мне, кудесник, любимец ба’гов...

Подтверждение почтового адреса на сайте excelworld.ru
 
Я модератор того форума. Под каким ником Вы там зарегистрировались?
Изменено: _Boroda_ - 26 Фев 2019 11:30:32
Скажи мне, кудесник, любимец ба’гов...

Форматирование символов текста в зависимости от их цвета
 
У меня с первым символом очень похожая фигня в 2010 Excel. В 2013 все нормально. Это похоже мой первый вариант http://www.excelworld.ru/forum/2-40806-270434-16-1550238568 что-то попортил

А код в модуле листа - да просто мне так больше нравится писать (при отсутствии каких-либо предпочтений для местонахождения кода, конечно). Быстрее добраться до него - ПКМ на ярлык, исходный текст
Скажи мне, кудесник, любимец ба’гов...

Форматирование символов текста в зависимости от их цвета
 
Андрей VG, я тоже думал, что долго будет, а потом смотрю - не, вроде довольно-таки приемлимо
На моей машине, которую собирали 6 лет назад, 10 000 ячеек обрабатывает 28 секунд. Для работы с форматами - вполне

С твоим макросом, конечно же, по скорости не сравнить, но видишь, ограничение. У меня, кстати, ругается не на 1000 ячеек, а почему-то на немногим больше 100. Все ячейки с текстом "Иван Иванов (сын Ивана Ивановича)". Причем ругается на плавающее количество ячеек - примерно от 106 до 120, на каждый запуск макроса пропускает разное количество
Скажи мне, кудесник, любимец ба’гов...

Как подсчитать количество строк содержащих определенное значение
 
Так нужно?
=СЧЁТЕСЛИ(A$2:A$86;"*"&J2&"*")
Скажи мне, кудесник, любимец ба’гов...

Рассчет ежедневной нормы.
 
lahesis333, в следующий раз на всех форумах сообщайте о кроссах. Это есть в Правилах форума, как этого, так и того

И на другом форуме отписаться тоже не помешало бы
Изменено: _Boroda_ - 6 Ноя 2018 17:18:38
Скажи мне, кудесник, любимец ба’гов...

Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 17 След.
Наверх