Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Выбрать дату в календареВыбрать дату в календаре

Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 143 След.
Как для перетаскивания кружков мышкой (на которых макросы) - обходится всего одним щелчком
 
тогда как вариант удерживайте Alt. или это тоже 2 щелчка считается?
Как для перетаскивания кружков мышкой (на которых макросы) - обходится всего одним щелчком
 
нажимаете ПКМ и переносите.
не понимаю как работает цикл, Do while ...Loop
 
Цитата
Homa_8999 написал: Что это означает?
:) обычное сравнение.
Код
j1 = 1
j1k = 100

соответственно 1<100    будет ИСТИНА
на следующем шаге j1 = j1 + 1=1+1=2
2<100 ИСТИНА и так далее пока не дойдет до 100<100 ЛОЖЬ.
не понимаю как работает цикл, Do while ...Loop
 
перед входом в цикл вы проверяете условие  j1 < j1k если ИСТИНА то идете дальше по циклу, если ЛОЖЬ то пропускаете цикл. Как то так.
не понимаю как работает цикл, Do while ...Loop
 
оформляйте код тегом, ищите кнопку <...>
Помогите поставить число (сумму) прописью, Формула суммапрописью
 
Цитата
mEGEVOVA написал:
Пробовала, у меня не получается
на будущее, утверждение "не получилось" подтверждайте файлом с вашей попыткой.
Как из одного списка , удалить дубли другого?
 
вот ваш новый файл с формулами и сортировкой.

сотрируем так.
1. Выделяем полностью столбцы А и В.
2. Вкладка "Главная" - Сортировка и фильтр - Настраиваемая сортировка. Сортировать по столбцу В - по возрастанию.
Как из одного списка , удалить дубли другого?
 
открываете оба файла. в новом в столбец В вписываете формулу
Код
=ПОИСКПОЗ(A1;'старый файл.csv'!$A:$A;)

сортируете по столбцу В и удаляете строки с числами, оставляете только Н/Д
Как снять фокус с TextBox из формы при активной форме
 
поставить фокус на кнопку не вариант?
Не отображается результат вычислений формулы
 
MergeIfs висит в персональной книге. на каждом компе своя персональная книга. перекиньте ф-цию из персональной  в обычный модуль файла и откорректируйте формулу.
Изменено: V - 15 Май 2018 15:28:14
Не отображается результат вычислений формулы
 
MergeIfs отсутствует в файле.
В сумме одно и́з значений подставляется в кавычках., Проблема с кавычками
 
данные вводите вручную или это выгрузки из некой проги?
Изменение цвета формы на основе значения ячейки, код VBA по изменению цвета формы на основе значения ячейки
 
Код
If IsNumeric(Target.Value) Then
         rg = Choose(Target.Value, vbRed, vbYellow, vbGreen, vbBlack)
        ActiveSheet.Shapes("Oval 1").Fill.ForeColor.RGB = rg
        ActiveSheet.Shapes("Oval 2").Fill.ForeColor.RGB = rg
    End If
Какое значение ячейки если удалить содержимое кнопкой Delete ?
 
Цитата
ttp8 написал:
При удалении содержимое ячейки В1 кнопкой Delete, значение А1 не меняется.
в этом виновато Target.Count > 1. при внесении данных Target.Count =1, а при удалении Target.Count =(количеству объединенных ячеек) 3.
Сообщение о циклической ссылке
 
можно, но учтите что формулы действительно могут считаться не правильно. Это вам нужно?
Параметры - формулы - Включить итеративные вычисления.
Изменено: V - 11 Май 2018 16:11:42
Поиск в матрице определённого значения и определение его адреса, Поиск в матрице при заданных условиях
 
вариант для строк
Код
=СУММПРОИЗВ(($A$1:$A$9=$I$4)*($B$1:$B$9=$I$3)*($C$1:$F$9=$I$2)*СТРОКА($A$1:$A$9))

для столбца
Код
=ПОИСКПОЗ(I2;ИНДЕКС(C1:F9;I12;);)

вариант от ежика не смотрел. :)
Подсчитать количество ответов "верно" по определенным номерам билетов
 
файл прикладываем. и над правильным названием думаем.
Как присвоить имена таблицам из цифр и минуса, Не могу присвоить таблице имя из цифр и минуса.
 
Подозреваю вы хотите сделать зависимый список, тогда формула для имени (имя например "модель").
Код
=ИНДЕКС(Лист1!$J$7:$U$44;;ПОИСКПОЗ(Лист1!$C$6;Лист1!$J$6:$U$6;))
Условия в Select Case
 
от select-ов старайтесь уходить.
Код
Select Case Sheets("Protocol").Range("JA12").Value
Макрос: замена первой буквы первого слова в ячейке на заглавную
 
вариант
Код
Sub vvv()
If Selection.Count > 1 Then
   m = Selection.Value
   For i = 1 To UBound(m)
       m(i, 1) = UCase(Left(m(i, 1), 1)) & Mid(m(i, 1), 2, Len(m(i, 1)) - 1)
   Next
   Selection.Value = m
Else
   ActiveCell = UCase(Left(ActiveCell, 1)) & Mid(ActiveCell, 2, Len(ActiveCell) - 1)
End If

End Sub

как повесить макрос на кнопки спросите у гугла или этого форума.
Условия в Select Case
 
посмотрите
select_case
Выпадающий список с выбором нескольких значений
 
более мудрено :)
Код
Union(Range("B6"), Range("D6"))
Условное форматирование для строки
 
читать научитесь.
Цитата
vikttur написал:
Модераторы заменят.
С помощью формул определить топ-3 значений в таблице (не используя сортировку)
 
Учтите если максимальные значения одинаковые, то формула выдаст только первого в списке.
Как присвоить имена таблицам из цифр и минуса, Не могу присвоить таблице имя из цифр и минуса.
 
имя не может начинаться с цифры и содержать символ "-"
С помощью формул определить топ-3 значений в таблице (не используя сортировку)
 
для данного примера это подойдет.
Код
=ИНДЕКС($B$2:$B$11;ПОИСКПОЗ(НАИБОЛЬШИЙ($C$2:$C$11;E2);$C$2:$C$11;))
Автоматическое формирование календаря на указанный месяц с заполнением ячеек формулами
 
файл показываем.
Перенос части текста из одной ячейки в другую, Перенос части текста из одной ячейки в другую
 
Код
=СЖПРОБЕЛЫ(ПСТР(ПОДСТАВИТЬ(ПСТР(E1;ПОИСК("Ф.И.О.";E1)+6;99);" ";ПОВТОР(" ";50));50;2*50))
Изменено: V - 21 Апр 2018 11:33:04
Перенос части текста из одной ячейки в другую, Перенос части текста из одной ячейки в другую
 
файл-пример приложите.
Как подвязать шаблон таблицы к выплывающим окнам
 
как вариант листы обозвать как месяцы и тогда формула для ячейки F5 листа График
Код
=ЕСЛИ(ДВССЫЛ($M$2&"!" &ЯЧЕЙКА("адрес";F5))=0;"";ДВССЫЛ($M$2&"!" &ЯЧЕЙКА("адрес";F5)))
Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 143 След.