Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Выбрать дату в календареВыбрать дату в календаре

Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 151 След.
Определение названия той фигуры, по которой щелкнули
 
Код
Sub Name_Shape()
Dim sShName As String
sShName = Application.Caller
MsgBox sShName
End Sub
Разбить текст из одной ячейки на несколько по условию
 
для ИНН
Код
=ЛЕВСИМВ(ПСТР(A1;ПОИСК("ИНН: ";A1)+5;99);ПОИСК(",";ПСТР(A1;ПОИСК("ИНН: ";A1)+5;99))-1)
если длинна всегда 10 символов то можно так
=ЛЕВСИМВ(ПСТР(A1;ПОИСК("ИНН: ";A1)+5;99);10)

для огрн, кпп по аналогии
Обработчик текста в выделенных ячейках
 
на много проще через регулярные выражения сделать (цикла не будет), но я с ними на ВЫ. :)
Изменено: V - 19 Мар 2019 11:24:23
Обработчик текста в выделенных ячейках
 
по второму вопросу, вариант
Код
If UserForm1.symbols And InStr(1, "[*/,.~!@#$%^&(){}\¹;:?-=+']", s) Then s = ""
Обработчик текста в выделенных ячейках
 
Цитата
borro написал:
почему при выбранной во всплывающей форме галке "Удалить буквы..." удаляются и пробелы
ексель воспринимает значение как число, а у числа нет пробелов.
поставте формат ячеек текстовый и пробелы останутся.
Изменено: V - 19 Мар 2019 11:10:24
Разбить текст на строки указанной длины без разрыва слов
 
подправил
Код
=СЖПРОБЕЛЫ(ПСТР($A$1;СУММПРОИЗВ(ДЛСТР($A$6:A6))+СТРОКА(A1);ЕСЛИ(ДЛСТР($A$1)-СУММПРОИЗВ(ДЛСТР($A$6:A6))-СТРОКА(A1)<=69;69;ПРОСМОТР(999;ПОИСК(" ";ПСТР($A$1;СУММПРОИЗВ(ДЛСТР($A$6:A6))+СТРОКА(A1);70);СТРОКА($1:$999))))))
Разбить текст на строки указанной длины без разрыва слов
 
Код
=ПСТР($A$1;СУММПРОИЗВ(ДЛСТР($A$6:A6))+1;ПРОСМОТР(999;ПОИСК(" ";ПСТР($A$1;СУММПРОИЗВ(ДЛСТР($A$6:A6))+1;69);СТРОКА($1:$999)))-1)

не до конца работает, в последней косяк. :(
Изменено: V - 19 Мар 2019 08:20:40
Максимальное в диапозоне с несколькими условиями
 
Апельсины  - Январь почему не стоит ничего?
Atan. Поиск угла между (0;х) и гипотенузой треугольника
 
интересно при х=40, y=40 какой должен быть ответ. 45 или 315
Изменено: V - 16 Мар 2019 11:08:27
добавление к дате одной цифры, добавление к дате одной цифры
 
вместо K1;".";L1;".";M1 пропишите ТЕКСТ(расход!C4;"ДД.ММ.ГГГГ"). если вы об этом.
Суммирование текстовых ячеек до определенного момента, повторение цикла
 
Цитата
Skachko написал:
Правила форума я читал.
про файл пример xls по ходу не прочли.
Подсчет количества элементов по параметру
 
Код
=ЕСЛИ(E8>=9;МАКС($B$7:B7)+1;"")
Изменено: V - 13 Мар 2019 10:30:34
Суммирование текстовых ячеек до определенного момента, повторение цикла
 
для полного ответа прочитайте ПРАВИЛА форума.
[ Закрыто] Нужна помощь в оптимизации кода
 
12 сообщений, а правила так и не прочитали?
как обойти ошибку #Н/Д
 
Цитата
Aprelskaya написал:
не прошел файл не знаю почему.
как вариант размер большой.
ЕСЛИОШИБКА работает в 2007 и выше, если что.
Изменено: V - 12 Мар 2019 15:46:54
как обойти ошибку #Н/Д
 
файла не вижу.
=ЕСЛИОШИБКА(формула;"") подойдет?
Перенос строки по определенному условию
 
например так - разнести данные ячейки по строкам
естественно полного совпадения наврятли найдете, придется подпиливать под себя.
Изменено: V - 12 Мар 2019 10:59:10
Перенос строки по определенному условию
 
можно. макросом. поищите по форуму, было уже.
Переход в макросе на строку ниже
 
скорее так
Код
Set d = Cells.Find(What:=Date, After:=ActiveCell, LookIn:=xlFormulas, _
       LookAt:=xlWhole, SearchOrder:=xlByRows, SearchDirection:=xlNext, _
       MatchCase:=False, SearchFormat:=False)
 If Not d Is Nothing Then d.Offset (1).Paste
Как задать массив в ИНДЕКС начиная с ячейки, определяемой формулой ?, Как задать массив через формулу?
 
вариант
п.с. смотрим диспетчер имен (ctrl+F3)
Изменено: V - 11 Мар 2019 15:34:37
Подсчитать количество работаюших на полную ставку
 
Dark1589, так про *1 и не понял.
Условное форматирование., Столбцы с данными в разных книгах
 
правила изучаем.
Формула ВПР в VBA - где ошибка в коде?
 
а почему она должна работать? VBA формула так не пишется. Для VBA fStr = WorksheetFunction.VLookup(тут разбирайтесь)
Как остаток от деления округлить до целого в большую сторону?
 
Цитата
Жирный Тони написал:
Не подходит. На значении 10 выдаёт ноль.
странно, у меня 1 выдало
Изменено: V - 4 Мар 2019 11:17:19
Макрос для монтекарло симуляции
 
Код
 Range("MC_EURJPY").Select

у вас нет такого.

П.С. Select-ы почистите.
Код
Sheets("Rates").Select
    Range("USDRUB_Link").Select
    Selection.Copy
можно записать так
Sheets("Rates").Range("USDRUB_Link").Copy
Изменено: V - 28 Фев 2019 09:45:10
Суммирование по нескольким условиям в разных диапазонах
 
добавим универсальности для растягивания формулы и по столбцам.. :)
Код
=СУММПРОИЗВ((ИНДЕКС($D$11:$J$14;ПОИСКПОЗ($B27;$B$11:$B$14;);)>0)*ИНДЕКС($D$6:$J$9;ПОИСКПОЗ(D$26;$B$6:$B$9;);))
Изменено: V - 28 Фев 2019 09:33:43
Макрос для монтекарло симуляции
 
Код
Call Calculation
???
Скрыть строки, чтобы числа меньше нуля остались на листе
 
Фильтр не подходит?
Выбор значений из списка
 
Код
=ВПР(D2&"*";$A$2:$B$4;2;)
Чередование цвета заливки, Чередование цвета заливки строк в зависимости от изменения значения в первом столбце.
 
Это смотрели?
Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 151 След.
Наверх