Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Выбрать дату в календареВыбрать дату в календаре

Страницы: 1
Не корректная работа функции ВПР
 
Однако так как сказал DV вроде работает) буду тестировать )
PS: Данные кстати на лист заходят из БД... скорее всего трабл где-то тут(
Код
=ЕСЛИОШИБКА(ВПР(ОКРУГЛТ(I2*24;1)/24;rate!$A$5:$F$1404;4;ЛОЖЬ);0)
Изменено: bito - 27 июл 2015 14:23:16
Не корректная работа функции ВПР
 
Вот и я сижу и не могу догнать в чем подвох ))
Не корректная работа функции ВПР
 
Да я был прав, ищет, но не точное вхождение ((
Не корректная работа функции ВПР
 
Цитата
Sanja написал: ВПР(I2;rate!$A$5:$F$1404;4;1)
Извините, я так понимаю 1 - это Истина, и будет искать не точные вхождения ? Хотя щас попробовал вроде-бы работает

Цитата
alexthegreat написал: А что именно не корректно?
Не во всех ячейках формула отрабатывает (
Не корректная работа функции ВПР
 
Добрый день, столкнулся с такой проблемой не корректно отрабатывает функция ВПР...Файлик прицепил, сама функция находится в столбце J...Подскажите куда копать...
Макрос на сумму, при неизвестном количестве строк
 
Код
Sub selct()
Dim lLastRow As Long
    lLastRow = Cells(Rows.Count, 3).End(xlUp).Row
    Cells(lLastRow + 1, 3) = WorksheetFunction.Sum(lLastRow, C2)
End Sub
Вот такой вариант... вот только не правильно он сумму считает...слишком маленькое число выдает..Такое ощущение что он считает не сумму, а среднее значение..
Изменено: bito - 1 дек 2013 17:47:15
Макрос на сумму, при неизвестном количестве строк
 
Я попросил глянуть что не так... во втором сообщение...
Макрос на сумму, при неизвестном количестве строк
 
Код
Sub selct()
Dim lLastRow As Long
lLastRow = Cells(Rows.Count, 3).End(xlUp).Row
    Cells(3, lLastRow + 1) = WorksheetFunction.Sum(C2, lLastRo)
End Sub
Написил вот такое.... но что-то он не работает...
Макрос на сумму, при неизвестном количестве строк
 
Такая ситуация, нужен макрос, который будет считать сумму столбца, при неизвестном кол-ве строк... т.е. в разных ситуациях оно будет разным... и в последующюю строку вставляет эту сумму...
Страницы: 1
Наверх