Выбрать дату в календареВыбрать дату в календаре

Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 384 След.
Функция ТЕКСТ и дата в родительном падеже
 
Подобное было уже на форуме. Поиск рулит.

Формула массива (ФМ) вводится Ctrl+Shift+Enter
Memento mori
Чему быть в отчетах для директора, маркетолога, регионального менеджера по продажам товаров
 
Михаил Л, XYZ-анализ

Формула массива (ФМ) вводится Ctrl+Shift+Enter
Memento mori
Не запускается макрос excel из планировщика заданий Windows
 
tosvr, почитайте.

Формула массива (ФМ) вводится Ctrl+Shift+Enter
Memento mori
Поиск слова в списке по клику по ячейке с этим словом
 
в модуль листа А, срабатывает по двойному клику

Формула массива (ФМ) вводится Ctrl+Shift+Enter
Memento mori
Согласно условию скопировать текстовой значение в ячейке и вставить в конец строки
 
Цитата
yarlo написал: какой-то сайт с простым и очень подробным синтаксисом по VBA
Поиск. Выбирайте что Вам по-душе.

Формула массива (ФМ) вводится Ctrl+Shift+Enter
Memento mori
Значение второй ячейки в зависимости от первой, База соответствия
 
Цитата
Sotofa написал: чтобы она брала артикул с другого файла?
Можно.Приложите файл-пример откуда брать.

Формула массива (ФМ) вводится Ctrl+Shift+Enter
Memento mori
Значение второй ячейки в зависимости от первой, База соответствия
 
Sotofa, возможное решение на ВБА не будет работать для гугл-таблиц. Вам придётся генерировать ссылку по ID, а после парсить содержимое страницы при помощи JS.

Формула массива (ФМ) вводится Ctrl+Shift+Enter
Memento mori
Расчет зарплаты для сотрудников по условиям
 
evgeniygeo, это не платная ветка.

Формула массива (ФМ) вводится Ctrl+Shift+Enter
Memento mori
Добавление элементов в xml с помощью VBA
 
Михаил Пуш, "Идентиф" и "Значен" - это атрибуты "ТекстИнф". Поиск в помощь.

Формула массива (ФМ) вводится Ctrl+Shift+Enter
Memento mori
Значение второй ячейки в зависимости от первой, База соответствия
 
Цитата
Sotofa написал: ключевые слова
Правила, файл-пример.

Формула массива (ФМ) вводится Ctrl+Shift+Enter
Memento mori
Добавление элементов в xml с помощью VBA
 
Было.

Формула массива (ФМ) вводится Ctrl+Shift+Enter
Memento mori
Как сравнить цену только между одинаковыми товарами
 
СЧЁТЕСЛИМН()

Формула массива (ФМ) вводится Ctrl+Shift+Enter
Memento mori
Макрос работает правильно при ручном запуске и неправильно при запуске кнопкой
 
Legos, ошибки не наблюдаю. Комп пробовали перезагрузить?

Формула массива (ФМ) вводится Ctrl+Shift+Enter
Memento mori
Каким образом настроить работу макросов в режиме общего доступа?
 
Цитата
Дмитрий(The_Prist) Щербаков написал: как Вы решите проблему того, что макросы в версии он-лайн не реализованы?
Прошу прощения, что вставляю свои 5ть копеек. Думаю, что, возможно, подойдёт переход на гугл таблицы и замена макросов VBA на google apps scripts, с учётом всех нюансов и ограничений.

Формула массива (ФМ) вводится Ctrl+Shift+Enter
Memento mori
Посчитать ячейки в диапазоне, если значения из них отсутствуют в другом диапазоне
 
Формула массива:
=СУММ(--(ЧАСТОТА(ЕСЛИ(ЕНД(ПОИСКПОЗ($B$3:$D$7;$E$3:$E$7;0));$B$3:$D$7;"");$B$3:$D$7)>0))

Формула массива (ФМ) вводится Ctrl+Shift+Enter
Memento mori
Поиск даты и остатка долга
 
Добавил столбцы (один - отсрочка дней, два - формулы с соотв. заголовками)

Формула массива (ФМ) вводится Ctrl+Shift+Enter
Memento mori
Поиск даты и остатка долга
 
Зачем дата я не понял. Сумма долга считается легко (ввести в H2 и протянуть вниз):
=СУММЕСЛИМН($D$1:$D$16;$A$1:$A$16;$F2;$C$1:$C$16;"ЗАЙМ")-СУММЕСЛИМН($D$1:$D$16;$A$1:$A$16;$F2;$C$1:$C$16;"ПЛАТЕЖ")

Формула массива (ФМ) вводится Ctrl+Shift+Enter
Memento mori
Посчитать ячейки в диапазоне, если значения из них отсутствуют в другом диапазоне
 
=СУММПРОИЗВ(--ЕНД(ПОИСКПОЗ($B$3:$D$7;$E$3:$E$7;0)))

Формула массива (ФМ) вводится Ctrl+Shift+Enter
Memento mori
Посчитать ячейки в диапазоне, если значения из них отсутствуют в другом диапазоне
 
Анастасия Коноваленко, файл-пример в состоянии приложить? Или будем скринами обмениваться?

Формула массива (ФМ) вводится Ctrl+Shift+Enter
Memento mori
Не срабатывает макрос на определённом компьютере
 
yal, у Вас в коде используется буфер обмена (копипаст), а буфер обмена может использовать сторонняя программа. Советую НЕ использовать копипаст, а использовать запись типа:
Код
ThisWorkbook.Sheets("Combi").Range("AU" & lRow).Value=DB.Range("V" & x).Value

Формула массива (ФМ) вводится Ctrl+Shift+Enter
Memento mori
Не срабатывает макрос на определённом компьютере
 
yal, от Вас мало конкретики. То есть Вы по-шагам прошли весь код и все шаги выполнились, а результата нет? Не видя Вашего макроса, не зная какой офис на злополучном ПК - мне сказать больше нечего.

Формула массива (ФМ) вводится Ctrl+Shift+Enter
Memento mori
Не срабатывает макрос на определённом компьютере
 
yal, по-шагам выполните макрос и выясните, где происходит сбой.

Формула массива (ФМ) вводится Ctrl+Shift+Enter
Memento mori
А не пора ли пересмотреть требование к названию темы?
 
Цитата
Неопытный_Экселист написал: ведь это в ходит в круг их обязанностей!..
Мягко говоря, я обескуражен. Кому лень думать над формулировкой задачи - милости просим в раздел "работа". Остальное читать не намерен.
Есть правила - соблюдаем. "Оступились" - получили замечание от модератора(ов) и/или форумчан - исправили.

Формула массива (ФМ) вводится Ctrl+Shift+Enter
Memento mori
Количество уникальных значений если включен фильтр
 
Андрей Капитунян, данная формула не годится под представленные Вами последние данные. Используйте УДФ от Msi2102.
Update...
Нашёл на просторах тырнета формулу массива:
=СУММ(ЕСЛИ(ЧАСТОТА(ЕСЛИ(ПРОМЕЖУТОЧНЫЕ.ИТОГИ(3;СМЕЩ(A2;СТРОКА(A2:A1000)-СТРОКА(A2);;1)); ЕСЛИ(A2:A1000<>"";ПОИСКПОЗ("~"&A2:A1000;A2:A1000&"";0)));СТРОКА(A2:A1000)-СТРОКА(A2)+1);1))
Источник. Поиск.
Изменено: JayBhagavan - 06.09.2021 03:58:17

Формула массива (ФМ) вводится Ctrl+Shift+Enter
Memento mori
Получить список выбранных позиций товара с расчётом суммы
 
Steel Smith, все имеющиеся в экселе столбцы заняты и никак выделить под формулу где-нибудь (не обязательно в колонке D) столбец нельзя?
Ну, тогда надо свою УДФ (UDF) писать, которая будет принимать три диапазона: наименование, цена и кол-во. В цикле проходить по кол-ву и если оно является числом, то делать кумулятивную (с нарастающим итогом) сцепку, которую после цикла вернуть.
Изменено: JayBhagavan - 05.09.2021 17:30:14

Формула массива (ФМ) вводится Ctrl+Shift+Enter
Memento mori
Количество уникальных значений если включен фильтр
 
Андрей Капитунян, массивная:
=СУММПРОИЗВ(--ЕСЛИОШИБКА(ПРОМЕЖУТОЧНЫЕ.ИТОГИ(3;СМЕЩ($A$2:$A$31;СТРОКА($2:$31)-СТРОКА($1:$1)-1;0;1))*(СТРОКА($2:$31)=ПОИСКПОЗ($A$2:$A$31;$A:$A;0));0))
Изменено: JayBhagavan - 05.09.2021 13:39:57

Формула массива (ФМ) вводится Ctrl+Shift+Enter
Memento mori
Получить список выбранных позиций товара с расчётом суммы
 
Цитата
Steel Smith написал: скидывать клиенту перечень того что он накидал
А нельзя просто отфильтровать записи, где кол-во не пустое?
Если нужно получить сцепку, как в примере, то ввести в D4:
=ЕСЛИ(ЕЧИСЛО($C4);$A4&" "&$C4&" * "&$B4&"грн = "&$B4*$C4&"грн";"")&ЕСЛИ(ЕЧИСЛО(ИНДЕКС(C:C;СТРОКА()+1));СИМВОЛ(13);"")&ИНДЕКС(D:D;СТРОКА()+1)
протянуть вниз таблицы, результат получите в D4.
Изменено: JayBhagavan - 05.09.2021 13:31:10

Формула массива (ФМ) вводится Ctrl+Shift+Enter
Memento mori
Количество уникальных значений если включен фильтр
 
Цитата
Андрей Капитунян написал: чтобы при наличии пустых ячеек, она работала
Покажите в файле-примере, какой должен быть результат работы формулы "при наличии пустых ячеек".

Формула массива (ФМ) вводится Ctrl+Shift+Enter
Memento mori
Проблема с объединением строк и использованием фильтра
 
aleks_belora, просьба не писать мне в телегу по вопросам из этой ветки. Что не понятно - пишите здесь.

Формула массива (ФМ) вводится Ctrl+Shift+Enter
Memento mori
Как создать условие применения УФ при необходимости градиентной раскраски (в зависимости от значений ячеек).
 
Сергей Евдокимов, здравия. ИМХО, макросом применить УФ ко всем столбцам, в цикле перебрать столбцы, где в заголовке "нет" и убрать в них УФ. Такое реализовать только через УФ мной не представляется возможным.

Формула массива (ФМ) вводится Ctrl+Shift+Enter
Memento mori
Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 384 След.
Наверх