Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Выбрать дату в календареВыбрать дату в календаре

Страницы: 1
Отметка во 2-ой книге, если в 1-ой книге есть, VBA
 
Тема закрыта
Отметка во 2-ой книге, если в 1-ой книге есть, VBA
 
В принципе сделал, но пришлось добавить еще пару формул
Код
=ЕЧИСЛО(RC[-1])
 
и
Код
=ЕСЛИ(RC[-1];1;0)
 

Итого получилось так. Пошел конечно через тяжелый путь, но самое главное сделано
Скрытый текст
Отметка во 2-ой книге, если в 1-ой книге есть, VBA
 
legionercheg, попробовал Ваш способ, тоже не получилось  :(
Отметка во 2-ой книге, если в 1-ой книге есть, VBA
 
Hugo,
1. Я думал, что он будет копировать эти единички во второй файл, но он их не копирует. Попробовал решение с сайта office.microsoft.com примера 3, но не получилось
2. В принципе, ВПР помогает, он просто возвращает значение, которое и искал (штрихкод), а мне нужно вернуть единичку, если нашел
3. Да, только один
Отметка во 2-ой книге, если в 1-ой книге есть, VBA
 
Теперь сделал так:
Код
=ВПР(RC[-3];'файл 1.csv'!C2;'файл 1.csv'!C6;1)
и в ячейку возвращает значение столбца 2 файла1.csv, а мне надо столбец 6 файла1.csv. Т.е. должен возвращать значение 1
Отметка во 2-ой книге, если в 1-ой книге есть, VBA
 
Сделал так.
Код
=ВПР(RC[-3];'файл 1.csv'!C2;2;)
 
Теперь если встречается значение, то пишется #ССЫЛКА, если нет #Н/Д.
А как сделать так, чтобы писалось значение 1 при удачном поиске
Изменено: blackdron - 8 Авг 2014 11:24:10
Отметка во 2-ой книге, если в 1-ой книге есть, VBA
 
Так написал, но что-то не помогает.
Код
=ВПР(C[-4];'[файл 2.xlsx]TDSheet'!C1:C6;C[-4];ИСТИНА)
Отметка во 2-ой книге, если в 1-ой книге есть, VBA
 
Уважаемые форумчане, помогите, пожалуйста.

У меня есть 2 файла. В первом и во втором файле находятся список товара. Мне необходимо сделать так, чтобы товар, который есть в файле 1.csv (поиск можно делать по штрихкоду - столбец 2),  отмечался в файле 2.xlsx (отмечать можно так, например в 9 (пустом) столбце ставить цифру 1), поиск также можно делать по штрихкоду (столбец 6). Файлы прилагаю. Если что-то не понятно объяснил, спрашивайте.

Заранее спасибо!
Как выделить жирным текст часть ячейки
 
Kuzmich,большое спасибо. Все работает, Вы очень помогли.
Как выделить жирным текст часть ячейки
 
Уважаемые Форумчане, подскажите пожалуйста,
Необходимо выделить жирными именно только первую ячейку при присоединении, а именно Cells(i, 1) в строке после "="
Код
Cells(i, 1) = Cells(i, 1) + vbNewLine + a + vbNewLine + b + " руб."
Просто если изначально первую строку делать жирный, то при слиянии он весь текст желает жирным, а мне нужно только изначальную первую ячейку

Весь код прилагаю.
Код
For i = 1 To 1315
Dim a As String
Dim b As String
a = Cells(i, 2)
b = Cells(i, 3)
Cells(i, 1) = Cells(i, 1) + vbNewLine + a + vbNewLine + b + " руб."
Cells(i, 1).Select
 With Selection
        .HorizontalAlignment = xlCenter
        .VerticalAlignment = xlCenter
 End With
Next


Заранее спасибо.
Копирование строки (.Paste), ошибка
 
Юрий М, большое спасибо! Всего доброго!
Копирование строки (.Paste), ошибка
 
Уважаемые форумчане, помогите пожалуйста,
Смысл задачи:
Есть большой список товара (около 2 тыс.), выделяем ячейку товара и он копирует всю строку в другой лист в 1-ую строку. Потом находим еще один товар, выделяем ячейку и он копирует всю строку в другой листа в следующую пустую строку. И так далее.
Выше смысл задачи был похож, только там заменяла строку в другой листе постоянно, а мне нужно чтобы вставляла в новую строку (примерный код высылаю, но не могу оформить условие пустой строки).
Код
Dim a As Integer
a = 1
Cells(ActiveCell.Row, "A").Select
If Cell.Text = "" Then
    ActiveCell.EntireRow.Copy Sheets("Лист2").Rows(a)
    Else
    a = a + 1
    ActiveCell.EntireRow.Copy Sheets("Лист2").Rows(a)
End If
 
Заранее спасибо!
Страницы: 1
Наверх