Выбрать дату в календареВыбрать дату в календаре

Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 29 След.
Объединить в одну базу через PowerQuery или PowerPivot десятки файлов (более миллиона строк)
 
Артем Иванов, добрый день. Здесь посмотрите https://www.planetaexcel.ru/techniques/12/2152/
Power Query разбить данные на три столбца
 
Марина Пасічник, посмотрите, может быть полезным https://www.youtube.com/watch?v=pV8Rw5gSjFI
Как работать с многоуровневыми шапками таблицы
Изменено: Stics - 26.04.2021 17:09:27
Power Query разбить данные на три столбца
 
Марина Пасічник, вот кнопочками в PQ натыкал для 2016.
До пакетного преобразования файлов не добрался. Честно говоря, лень было уже. Может гуру подтянутся и помогут
Как найти 5 наилучших результатов , при условии что KPI4>0 ?
 
посмотрите
Расчёт повышения премии при уменьшении % премии, при увеличении выручки процент премии снижается, но сама премия растёт
 
Цитата
Sergey F написал:
Необходимо в ячейку А8 вводить размер выручки, а в ячейке B8 рассчитывать какой процент премии получится и соответственно в С8 посчитается сумма премии.
По условию "Х" - это выручка, "Y" - % премии. У Вас рассчитывается сумма премии, а потом процент. А нужно сначала рассчитать процент, а потом сумму премии. Почему так, может быть ответит автор темы.
Расчёт повышения премии при уменьшении % премии, при увеличении выручки процент премии снижается, но сама премия растёт
 
Sergey F, отлично!)
ссылка на расчет уравнения по двум точкам в #2. там же все формулы для расчётов. Вместо выручки используйте её логарифм. Я брал двоичный.
Расчёт повышения премии при уменьшении % премии, при увеличении выручки процент премии снижается, но сама премия растёт
 
потому, что связь между премией в деньгах и выручкой нелинейная получается.
посмотрите другой вариант (в файле желтым цветом). Возможно подойдет
Изменено: Stics - 25.02.2021 19:25:35
Расчёт повышения премии при уменьшении % премии, при увеличении выручки процент премии снижается, но сама премия растёт
 
как вариант, используя линейную интерполяцию
уравнение прямой можно рассчитать по формулам [уравнение прямой по двум точкам], или, например, здесь
Склеивание текста ячеек, если в соседнем столбце одинаковое имя
 
вариант на PQ
подробнее в приёмах
Код
let
    Источник = Excel.CurrentWorkbook(){[Name="Таблица1"]}[Content],
    result = Table.Group(Источник, {"name"}, {"grp", each Text.Combine([kvedcode], " ")})
in
    result


название темы предлагаю такое же, как в приемах: "Склеивание текста по условию"
Сумма определённых столбцов по условиям
 
Добрый день! Вы файл с примером не прикрепили
Анализ данных двумерного массива с формированием одномерного массива результатов построчного анализа
 
так?
Код
=И(B3:D3>0)

тема: "Определение статуса менеджера по выполнению плана продаж"
Определение факта наступления события из календаря
 
inicman1991, для понимания можно посмотреть здесь
ключевой момент по фразе "Умножение трех диапазонов различного размера с последующим суммированием результатов"
Определение факта наступления события из календаря
 
как вариант
Код
=ЕСЛИ(СУММПРОИЗВ(($C$22:$C$34=$C13)*($D$21:$AG$21=D$12)*($D$22:$AG$34))<>0;1;"")

Тема: "Определение факта наступления события из календаря"
Изменено: Stics - 15.09.2020 21:54:39
Разнести данные из ячейки по разделителю
 
в PQ можно кнопками
Код
let
    Источник = Excel.CurrentWorkbook(){[Name="Таблица1"]}[Content],
    #"Разделить столбец по разделителю" = Table.ExpandListColumn(Table.TransformColumns(Источник, {{"Страна прозводства", Splitter.SplitTextByDelimiter("/", QuoteStyle.Csv), let itemType = (type nullable text) meta [Serialized.Text = true] in type {itemType}}}), "Страна прозводства"),
    #"Измененный тип" = Table.TransformColumnTypes(#"Разделить столбец по разделителю",{{"Страна прозводства", type text}}),
    #"Сортированные строки" = Table.Sort(#"Измененный тип",{{"Страна прозводства", Order.Ascending}})
in
    #"Сортированные строки"
Суммировать даные, если с одним ID больше трех строк
 
в PQ

Код
let
    Источник = Excel.CurrentWorkbook(){[Name="Table14"]}[Content],
    grp = Table.Group(Источник, "ID", {"tmp", each Table.AddIndexColumn(_, "index", 1, 1)}),
    tableCombine = Table.Combine(grp[tmp]),
    selectRows = Table.SelectRows(tableCombine, each [index] > 3),
    out = List.Sum(selectRows[Значение])
in
    out
Поиск нескольких максимальных значений
 
ещё вариант
Код
=АГРЕГАТ(15;6;СТОЛБЕЦ($A$1:$H$1)/($A$2:$H$2=МАКС($A$2:$H$2));СТОЛБЕЦ(A1))
остаток по нескольким критериям на ближайшую дату из прошлого к заданной
 
Добрый день!
вариант
Код
=ИНДЕКС($G$4:$G$11;АГРЕГАТ(14;6;(СТРОКА($G$4:$G$11)-3)/($D$4:$D$11=K9)/($E$4:$E$11=L9)/($F$4:$F$11<=$L$3);1))

Даты должны быть в порядке хронологии внутри категорий (связка подразделение + бренд)

и на PQ
Код
let
    Источник = Excel.CurrentWorkbook(){[Name="data"]}[Content],
    transform = Table.TransformColumnTypes(Источник,{{"дата", type date}}),
    filter = Table.SelectRows(transform, each [дата] <= filter),
    group = Table.Group(filter, {"подразделение", "бренд"}, {"grp", each Table.Max(_, "дата", 1)}),
    fromrecords = Table.FromRecords(group[grp]),
    res = Table.TransformColumnTypes(fromrecords,{{"дата", type date}})
in
    res
Изменено: Stics - 21.07.2020 11:10:29 (добавлен вариант на PQ)
Сверка цены поставки товара с прайсом
 
Courage, добрый день! Поясните, почему, например, для товара 1 присутствует разная цена в одних и тех же пересекающихся временных интервалах?
Подсчет времени пересекающихся событий
 
Роман Миланов, посмотрите вариант.
"Подсчет времени пересекающихся событий" можно такое название.
Найти все значения, удовлетворяющие условию
 
начните с материала в Приемах
Найти все значения, удовлетворяющие условию
 
RamRiz, мой вариант смотрели?
Найти все значения, удовлетворяющие условию
 
Добрый день! Как вариант.
Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист4!$B$3:$B$27;АГРЕГАТ(15;6;(СТРОКА(Лист4!$C$3:$C$27)-2)/(Лист4!$C$3:$C$27=Лист1!C2);СЧЁТЕСЛИ($C$2:C2;C2)));"Нет")


и в приемах можно посмотреть
Изменено: Stics - 17.07.2020 21:12:10
Как поделить число на двузначное число каковым являются последние две цифры этого числа .
 
solnce60, так можно
Код
=A1/ОСТАТ(A1;100)
Подсчитать поступления денежных средств за месяц, имея ряд дат.
 
как понял
Код
=СУММПРОИЗВ((МЕСЯЦ(E4:E23)=МЕСЯЦ(СЕГОДНЯ()))*($D$4:$D$23))
Удаление дубликатов одновременно в строках и колонках Excel таблицы
 
вариант на PQ
P.S. кривовато, но думаю, если спецы подтянутся, то оптимальный вариант предложат
Посчитать даты по годам, кроме повторяющихся
 
покажите, пожалуйста, как это должно выглядеть
Посчитать даты по годам, кроме повторяющихся
 
сводной сделайте, в файле добавил вариант
Посчитать даты по годам, кроме повторяющихся
 
как вариант
Код
=СУММПРОИЗВ(--(ГОД($A$1:$A$19)=C2))
Изменено: Stics - 30.06.2020 11:30:24
Вычисление медианы по нескольким условиям
 
Брям, у Вас же формулы есть, что не получается?
Power Query. Сравнение диапазона на наличие значений из справочника., Сравнение диапазона со справочниками при помощи PQ
 
Денис Веселов, Вас просят привести пример в файле. Желательно в виде "что есть" -> "как нужно". Облегчайте жизнь помогающим, это же не сложно.
Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 29 След.
Наверх