Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Выбрать дату в календареВыбрать дату в календаре

Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 23 След.
Power Query - удаление дубликатов по условиям
 
buchlotnik, спасибо, взял приём в работу)
Power Query - удаление дубликатов по условиям
 
Добрый день! Так?
Код
let
    Источник = Excel.CurrentWorkbook(){[Name="Звіт_по_заведеним_заявкам_в_КФ"]}[Content],
    tmp = Table.Group(Источник, "ФИО Клиента", {{"tmp", each Table.Max(_, "Дата создания Заявки")}, {"amount", each List.Count([Тип])}}),
    result = Table.FromRecords(tmp[tmp]),
    join = Table.NestedJoin(result, {"ФИО Клиента"}, tmp, {"ФИО Клиента"}, "tmp", JoinKind.LeftOuter),
    expand = Table.ExpandTableColumn(join, "tmp", {"amount"}, {"amount"}),
    #"Измененный тип" = Table.TransformColumnTypes(expand,{{"Дата создания Заявки", type datetime}, {"Дата отправки", type datetime}})
in
    #"Измененный тип"
Изменено: Stics - 10 Окт 2019 17:43:34
Как посчитать количество уникальных слов в документе для переводчика
 
День добрый! Небольшой пример в файле покажите "что есть" -> "как надо"
Группировка строк по условию в PowerQuery
 
или так
Код
let
    Источник = Excel.CurrentWorkbook(){[Name="Таблица1"]}[Content],
    fill_fio = Table.FillDown(Источник, {"ФИО"}),
    result = Table.Group(fill_fio, {"Номер", "ФИО"}, {"tmp", each Text.Combine([Данные], ", ")})
in
    result
Группировка строк по условию в PowerQuery
 
Добрый день!
В приёмах посмотрите

Код
let
    Источник = Excel.CurrentWorkbook(){[Name="Таблица1"]}[Content],
    result = Table.Group(Источник, {"Номер"}, {"tmp", each Text.Combine([Данные], ", ")})
in
    result
Изменено: Stics - 9 Окт 2019 12:09:40
Прогнозирование продаж на основании предшествующих периодов с учетом ошибки
 
Kentavrik7,
тема давняя и проблемная в плане точности построения прогноза. В открытых источникам много информации как раз с Вашей спецификой.
И вопросов достаточно
- это потребление юридических/физических лиц
- календарные эффекты нужно учитывать/или без них можно
- какая точность прогнозирования считается отличной/приемлемой/недопустимой

Из общих рекомендаций. Excel тут вряд ли хороший помощник. Если только в сторону сезонного экспоненциального сглаживания смотреть (ПРЕДСКАЗ.ETS.СЕЗОННОСТЬ) и связанные функции.

А так я бы в сторону или специализированного софта смотрел, или в R/Питон.
Из бесплатного Demetra можно рекомендовать, но программа уж очень специфическая
Уникальное текстовое значение с наибольшим количеством повторений, Нужна формула для гугл таблицы
 
День добрый! Небольшой файл с примером упростит и ускорит помощь.
Проверки массива по 2м условиям и вывод в отдельной закладке
 
Код
=ИНДЕКС(Офис!$A$2:$E$12;АГРЕГАТ(15;6;(СТРОКА(Офис!$A$2:$A$13)-1)/(Офис!$B$2:$B$13=$B$1)/(Офис!$D$2:$D$13=$D$1);СТРОКА(A1));СТОЛБЕЦ(A1))
Изменено: Stics - 29 Сен 2019 20:59:46
все значения до первой запятой (если нет запятой, то значение ячейки)
 
Код
=ЕСЛИОШИБКА(ПСТР(B2;1;ПОИСК(",";B2)-1);B2)

так?
Построение плоской таблицы, содержащей все возможные сочетания значений из двух исходных столбцов
 
Power Query
Мышкой в меню кнопками "натыкал"
Построение плоской таблицы, содержащей все возможные сочетания значений из двух исходных столбцов
 
кнопками в PQ , как вариант
Вывести список всех значений соответствующим 2 условиям
 
Код
=ЕСЛИОШИБКА(ИНДЕКС($B$3:$B$17;АГРЕГАТ(15;6;(СТРОКА($B$3:$B$17)-2)/($A$3:$A$17=$F$2)/($C$3:$C$17="Нарушение");СТРОКА()-5));"")

так?
Изменено: Stics - 24 Сен 2019 14:12:02
Power Query. Трансформация структуры отчета из 1С в плоскую таблицу.
Поиск минимального значения в зависимости от соседнего столбца
 
Добрый день
Код
=АГРЕГАТ(15;6;B2:B6/(A2:A6<>"");1)

так попробуйте
и файл с примером, конечно, не помешает
Распределить товар по магазинам, Распределить товар по магазинам. Каждый магазин имеет один из 4-х форматов, товар часто может находиться не во всех форматах.
 
Добрый вечер. ela98, поясните, почему для магазина 1 (формат 1) план 40, если количество товара на формат 1 равно 24?
Первое и последнее число платежа
 
ещё вариант
Код
=АГРЕГАТ(15;6;$A$4:$A$42/(ЕЧИСЛО(B4:B42));1)

Код
=АГРЕГАТ(14;6;$A$4:$A$42/(ЕЧИСЛО(B4:B42));1)

обычные
Изменено: Stics - 12 Сен 2019 14:04:40
[ Закрыто] Сортировка значений в зависимости от ячейки
 
Код
=СУММПРОИЗВ(ЕСЛИОШИБКА(($C$21:$H$27=J20)*($C$20:$H$26);0))

массивная
для модератора: "Суммирование значений по условию"
Изменено: Stics - 11 Сен 2019 22:51:15
[ Закрыто] Сортировка значений в зависимости от ячейки
 
И Вам добрый день! Файл с примером приложите. Это ускорит и упростит помощь.
Подстановка всех значений согласно искомому значению в столбец по порядку
 
Добрый день!
ну и АГРЕГАТОМ до заодно. Обычная.
Код
=ЕСЛИОШИБКА(ИНДЕКС($B$4:$B$12;АГРЕГАТ(15;6;(СТРОКА($C$4:$C$12)-3)/($C$4:$C$12=$E$3);СТРОКА(A1)));"")
Наиболее распространенное слово в столбце
 
Начните с файла с примером. Вы поставьте себя на место помогающего, посмотрите на Вашу формулу и определите желание разобраться и помочь.
Среднее значение между двумя столбцами если есть еще один критерий
 
Добрый день!
Цитата
joda1307 написал:
есть еще один критерий
что за критерий?
Приложите файл с примером. "Что есть" -> "как надо". Это упрощает и ускоряет помощь.
а так как понял
Код
=ЕСЛИ(СЧЁТЗ(A1:B1)=2;СРЗНАЧ(A1:B1);"")
Изменено: Stics - 11 Сен 2019 21:26:12
Расскидать случайным образом число в диапазоне
 
Цитата
franchesko написал:
каждое из 13 чисел должно быть больше 90
Цитата
franchesko написал:
примерно в радиусе 100 (+-50)
два условия противоречат друг другу
150 * 13 = 1950 < 2148
нужно какое-то условие скорректировать
а так СЛУЧМЕЖДУ попробуйте для генерации 12 чисел, а 13-е = 2148 - [сумма первых 12-и сгенерированных чисел]
Формирование групп из массива данных
 
Цитата
Inexsu написал:
Рюкзак тут и рядом не валялся :-)
Значит показалось, что похожая формулировка). Для общего развития подскажите тогда кто "валялся"?)
Изменено: Stics - 5 Сен 2019 12:16:51
Формирование групп из массива данных
 
Ras174, поищите "задачу о рюкзаке". На форуме, кажется тоже встречались похожие задачи
линейный тренд с помощью ПРЕДСКАЗ()
 
Цитата
futurama3000 написал:
предположим, что я не знаю, что тренда нет. Есть просто набор конечных данных. Как быть?
1. Проверить наличие тренда.
2. Если тренд есть использовать модель Y = b*x + a
3. Если тренда нет, использовать модель Y = a
Изменено: Stics - 3 Сен 2019 12:25:34
линейный тренд с помощью ПРЕДСКАЗ()
 
Добрый день! Не очень понятно, зачем вы тренд оцениваете, если знаете, что его изначально нет.
Модель, которую вы оцениваете: Y = b*x + a. И коэффициент "b" в любом случае будет оценен, как отличный от 0, поэтому Y = 100 не получается.
Если тренда нет, то оцените модель Y = a (a=Yсреднее), тогда и получите Y = 100.
Почему exel не считает корректную формулу?, Exel перестал считать формулы
 
alenasever, сравните то, что Вам написали,
Код
=СУММПРОИЗВ((B2:B18)*1)

и что у Вас
Как выбрать самую позднюю дату, Есть отчет, в котором у одного пользователя может стоять несколько дат. Нужно выбрать самую позднюю дату
 
PQ
Поиск соответствия условию в таблице
 
Цитата
Mershik написал:
никак не подружусь с агрегатом)
А я уже от НАИМЕНЬШИЙ/НАИБОЛЬШИЙ отвык)
Основной момент в том, что деление "/" выполняет роль фильтра.
т.е. в СТРОКА($A$1:$A$5)/(C$3:C$7="ТО") мы делим либо на 0, либо на 1.
Если делим на 0, то получаем #ДЕЛ/0! и игнорируем его, а с оставшимися значениями работаем дальше
В целом принцип такой же как и в вашей формуле.
Поиск соответствия условию в таблице
 
Цитата
ATPZT написал:
То, что я выбрал вручную, и то, что выводит формула, - совершенно разные вещи
исправил. Ссылки абсолютные в одном месте забыл открепить
Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 23 След.
Наверх