Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Выбрать дату в календареВыбрать дату в календаре

Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 28 След.
Анализ данных двумерного массива с формированием одномерного массива результатов построчного анализа
 
так?
Код
=И(B3:D3>0)

тема: "Определение статуса менеджера по выполнению плана продаж"
Определение факта наступления события из календаря
 
inicman1991, для понимания можно посмотреть здесь
ключевой момент по фразе "Умножение трех диапазонов различного размера с последующим суммированием результатов"
Определение факта наступления события из календаря
 
как вариант
Код
=ЕСЛИ(СУММПРОИЗВ(($C$22:$C$34=$C13)*($D$21:$AG$21=D$12)*($D$22:$AG$34))<>0;1;"")

Тема: "Определение факта наступления события из календаря"
Изменено: Stics - 15 сен 2020 21:54:39
Разнести данные из ячейки по разделителю
 
в PQ можно кнопками
Код
let
    Источник = Excel.CurrentWorkbook(){[Name="Таблица1"]}[Content],
    #"Разделить столбец по разделителю" = Table.ExpandListColumn(Table.TransformColumns(Источник, {{"Страна прозводства", Splitter.SplitTextByDelimiter("/", QuoteStyle.Csv), let itemType = (type nullable text) meta [Serialized.Text = true] in type {itemType}}}), "Страна прозводства"),
    #"Измененный тип" = Table.TransformColumnTypes(#"Разделить столбец по разделителю",{{"Страна прозводства", type text}}),
    #"Сортированные строки" = Table.Sort(#"Измененный тип",{{"Страна прозводства", Order.Ascending}})
in
    #"Сортированные строки"
Суммировать даные, если с одним ID больше трех строк
 
в PQ

Код
let
    Источник = Excel.CurrentWorkbook(){[Name="Table14"]}[Content],
    grp = Table.Group(Источник, "ID", {"tmp", each Table.AddIndexColumn(_, "index", 1, 1)}),
    tableCombine = Table.Combine(grp[tmp]),
    selectRows = Table.SelectRows(tableCombine, each [index] > 3),
    out = List.Sum(selectRows[Значение])
in
    out
Поиск нескольких максимальных значений
 
ещё вариант
Код
=АГРЕГАТ(15;6;СТОЛБЕЦ($A$1:$H$1)/($A$2:$H$2=МАКС($A$2:$H$2));СТОЛБЕЦ(A1))
остаток по нескольким критериям на ближайшую дату из прошлого к заданной
 
Добрый день!
вариант
Код
=ИНДЕКС($G$4:$G$11;АГРЕГАТ(14;6;(СТРОКА($G$4:$G$11)-3)/($D$4:$D$11=K9)/($E$4:$E$11=L9)/($F$4:$F$11<=$L$3);1))

Даты должны быть в порядке хронологии внутри категорий (связка подразделение + бренд)

и на PQ
Код
let
    Источник = Excel.CurrentWorkbook(){[Name="data"]}[Content],
    transform = Table.TransformColumnTypes(Источник,{{"дата", type date}}),
    filter = Table.SelectRows(transform, each [дата] <= filter),
    group = Table.Group(filter, {"подразделение", "бренд"}, {"grp", each Table.Max(_, "дата", 1)}),
    fromrecords = Table.FromRecords(group[grp]),
    res = Table.TransformColumnTypes(fromrecords,{{"дата", type date}})
in
    res
Изменено: Stics - 21 июл 2020 11:10:29 (добавлен вариант на PQ)
Сверка цены поставки товара с прайсом
 
Courage, добрый день! Поясните, почему, например, для товара 1 присутствует разная цена в одних и тех же пересекающихся временных интервалах?
Подсчет времени пересекающихся событий
 
Роман Миланов, посмотрите вариант.
"Подсчет времени пересекающихся событий" можно такое название.
Найти все значения, удовлетворяющие условию
 
начните с материала в Приемах
Найти все значения, удовлетворяющие условию
 
RamRiz, мой вариант смотрели?
Найти все значения, удовлетворяющие условию
 
Добрый день! Как вариант.
Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист4!$B$3:$B$27;АГРЕГАТ(15;6;(СТРОКА(Лист4!$C$3:$C$27)-2)/(Лист4!$C$3:$C$27=Лист1!C2);СЧЁТЕСЛИ($C$2:C2;C2)));"Нет")


и в приемах можно посмотреть
Изменено: Stics - 17 июл 2020 21:12:10
Как поделить число на двузначное число каковым являются последние две цифры этого числа .
 
solnce60, так можно
Код
=A1/ОСТАТ(A1;100)
Подсчитать поступления денежных средств за месяц, имея ряд дат.
 
как понял
Код
=СУММПРОИЗВ((МЕСЯЦ(E4:E23)=МЕСЯЦ(СЕГОДНЯ()))*($D$4:$D$23))
Удаление дубликатов одновременно в строках и колонках Excel таблицы
 
вариант на PQ
P.S. кривовато, но думаю, если спецы подтянутся, то оптимальный вариант предложат
Посчитать даты по годам, кроме повторяющихся
 
покажите, пожалуйста, как это должно выглядеть
Посчитать даты по годам, кроме повторяющихся
 
сводной сделайте, в файле добавил вариант
Посчитать даты по годам, кроме повторяющихся
 
как вариант
Код
=СУММПРОИЗВ(--(ГОД($A$1:$A$19)=C2))
Изменено: Stics - 30 июн 2020 11:30:24
Вычисление медианы по нескольким условиям
 
Брям, у Вас же формулы есть, что не получается?
Power Query. Сравнение диапазона на наличие значений из справочника., Сравнение диапазона со справочниками при помощи PQ
 
Денис Веселов, Вас просят привести пример в файле. Желательно в виде "что есть" -> "как нужно". Облегчайте жизнь помогающим, это же не сложно.
Суммировать значение по двум условиям, одно из которых представлено в виде списка соответствий, без вспомгательного столбца, с использованием только vlookup index match sum, if
 
ещё вариант
Код
=СУММ(ЕСЛИ(ИНДЕКС($H$2:$H$4;ПОИСКПОЗ($A$2:$A$29;$G$2:$G$4;0))=$H$9;$C$2:$C$29;0)*(ГОД($B$2:$B$29)=G10))
Группировка данных в таблице по нескольким условиям
 
Владислав Крупин, файл не загружен
Как посчитать количество Да за указанный период времени
 
Роман,
вводите дополнительный множитель с условием
Код
=СУММПРОИЗВ((C2:C5594="Да")*(I2:I5594>=K1)*(I2:I5594<=M1)*(A2:A5594="Ипотека"))
PQ. Table.Group - параметризация аргументов
 
del
Изменено: Stics - 2 июн 2020 19:20:13
Преобразовать СЛОЖНУЮ вертикальную таблицу в горизонтальный формат, Преобразовать СЛОЖНУЮ вертикальную таблицу в горизонтальный формат
 
как вариант на PQ
Код
let
    Источник = Excel.CurrentWorkbook(){[Name="Таблица1"]}[Content],
    group = Table.Group(Источник, {"Соответствие", "Данные"}, {"tmp", each Table.AddIndexColumn(_, "index", 1, 1)}),
    Пользовательский1 = Table.Combine(group[tmp]),
    #"Измененный тип" = Table.TransformColumnTypes(Пользовательский1,{{"index", type text}}),
    #"Добавлен пользовательский объект" = Table.AddColumn(#"Измененный тип", "out", each [Данные] & [index]),
    #"Удаленные столбцы" = Table.RemoveColumns(#"Добавлен пользовательский объект",{"Данные", "index"}),
    #"Сведенный столбец" = Table.Pivot(#"Удаленные столбцы", List.Distinct(#"Удаленные столбцы"[out]), "out", "Клиент(фио+др)"),
    #"Переупорядоченные столбцы" = Table.ReorderColumns(#"Сведенный столбец",{"Соответствие", "mobile_phone1", "name11", "name21", "name22", "name31", "name32"})
in
    #"Переупорядоченные столбцы"
На основании порядкого номера найти цену с самой поздней датой
 
Код
=ИНДЕКС($B$2:$B$22;ПОИСКПОЗ(F3&АГРЕГАТ(14;6;($C$2:$C$22)/($A$2:$A$22=F3);1);$A$2:$A$22&$C$2:$C$22;0))
Расшифровка формулы c функцией ПРЕДСКАЗ
 
Сергей А, добрый день!
Возможно Вы ищите функцию ЛИНЕЙН. Формулы из справки выше приведены.
Посмотрите материал на тему парной линейной регрессии, может часть вопросов снимется.
Изменено: Stics - 1 июн 2020 12:45:25
Выбор диапазона суммирования в зависимости от найденного условия, диапазон суммирования в зависимости от условия
 
как-то так по п.1
Код
=ЕСЛИ(ВПР(--ЛЕВСИМВ(B8;2);$A$27:$B$30;2;1)=0;"";СУММ(ИНДЕКС(D8:F8;;ВПР(--ЛЕВСИМВ(B8;2);$A$27:$B$30;2;1)):F8))
Изменено: Stics - 27 май 2020 19:38:17
min/max отклонение по ряду позиций
 
или так
минимум
Код
=АГРЕГАТ(15;6;($H$4:$H$20)/($B$4:$B$20=B4)/($D$4:$D$20=D4);1)

максимум
Код
=АГРЕГАТ(14;6;($H$4:$H$20)/($B$4:$B$20=B4)/($D$4:$D$20=D4);1)
Изменено: Stics - 27 май 2020 12:59:15
Расчет периодов пустых ячеек между значечниями в строке
 
vsergey35, попробуйте поискать по ключевым словам "подсчет числа серий excel". Периодически встречается такая задача
Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 28 След.
Наверх