Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Выбрать дату в календареВыбрать дату в календаре

Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 20 След.
Транспонировать один столбец по условию
 
как вариант PQ
Изменено: Stics - 13 Апр 2019 12:45:17
Сформировать список из большого списка по нескольким значениям
 
в приёмах есть
Изменено: Stics - 8 Апр 2019 14:12:21
Подсчет числа одинаковых цен
 
chdv142, Вы файл с примером приложите. Обычно это существенно упрощает и ускоряет помощь. Мало кому интересно с картинок данные перерисовывать в таблицу.
[ Закрыто] Прошу помочь., Поиск значений и извлечение информации из строки по столбцу 2 в другой столбец.
 
Benicio Del Toro, поищите примеры использования функции ВПР
Счёт по условию для текущего месяца
 
ещё вариант
Код
=СУММПРОИЗВ((МЕСЯЦ($A$5:$A$19)=МЕСЯЦ(СЕГОДНЯ()))*($B$5:$B$19=F16))

P.S. для текущего года
Изменено: Stics - 1 Апр 2019 11:50:32
Проблема при разделении столбца в Power Query, Если в ячейке разделителей больше, чем было при создании запроса, дополнительные столбцы не создаются.
 
ещё вариант предложу
Код
let
    Источник = Excel.CurrentWorkbook(){[Name="Таблица2"]}[Content],
    РазделениеНаСлова = Table.AddColumn(Источник, "data", each Splitter.SplitTextByDelimiter(" ")([Столбец1])),
    РазделениеСловНаСтроки = Table.FromColumns(РазделениеНаСлова[data]),
    Итог = Table.Transpose(РазделениеСловНаСтроки)
in
    Итог
Изменено: Stics - 29 Мар 2019 17:40:36
Распределение Фишера, По какой формуле рассчитывается P-значение
 
Код
=F.РАСП.ПХ(F17;D17;D18)

и
Код
=F.ОБР.ПХ(0,05;D17;D18)
Изменено: Stics - 29 Мар 2019 11:46:35
Вычисление Верхнего Квартиля и Моды диапазона данных без учета нулей
 
qwertylola,
Цитата
Stics написал:
массивные
вводите как формулу массива
1. нажмите F2
2. Нажмите клавиши CTRL+SHIFT+ВВОД
Подсчёт количества значений не учитывая повторы
 
Код
=СУММПРОИЗВ((A8:A22=A8)/СЧЁТЕСЛИМН(A8:A22;A8:A22;D8:D22;D8:D22))
Вычисление Верхнего Квартиля и Моды диапазона данных без учета нулей
 
qwertylola, не нужно
Подсчет количества номеров писем на одного адресата посредством PQ
 
naa700, посмотрите в приемах
Вычисление Верхнего Квартиля и Моды диапазона данных без учета нулей
 
Код
=МОДА(ЕСЛИ(B3:P3=0;"";B3:P3))

Код
=КВАРТИЛЬ(ЕСЛИ(B3:P3=0;"";B3:P3);3)

массивные
Поиск последнего значения массива
 
Код
=АГРЕГАТ(14;6;СТРОКА(A1:A10)*(A1:A10=A7);1)
Подсчет количества номеров писем на одного адресата посредством PQ
 
вариант формулой (массивная)
Код
=СУММ(ДЛСТР(E4:E7)-ДЛСТР(ПОДСТАВИТЬ(E4:E7;",";"")))+СЧЁТЗ(E4:E7)
Подсчёт кол-ва месяцев с нулевыми продажами, считать с первого месяца продаж, у разных товаров он разный
 
Добрый день!
как вариант
Код
=СЧЁТЗ(ИНДЕКС(B3:O3;;ПОИСКПОЗ(1;B3:O3;0)):O3)-СУММ(ИНДЕКС(B3:O3;;ПОИСКПОЗ(1;B3:O3;0)):O3)
Выбор первого положительного значения, расчет периода окупаемости
 
ещё вариант
Код
=АГРЕГАТ(15;6;B6:V6/(B6:V6>0);1)
Поиск необходимых данных в огромном массиве и отображение результата в виде таблицы
 
Alexey_Spb, по 10 млн строк?
Сбор данных из нескольких таблиц по заданным параметрам
 
Torb, например, приёмы можно поизучать
Сгруппировать все данные по каждой торговой точке в одну строку
 
Добрый день.
В PowerQuery одной кнопкой делается ("Столбец сведения")
Изменено: Stics - 21 Мар 2019 15:58:04
Экспорт чисел из текстового файла, когда десятичным разделителем является точка
 
скрин
Экспорт чисел из текстового файла, когда десятичным разделителем является точка
 
Добрый день!
при экспорте в excel в качестве разделителя целой и дробной части укажите точку (.)
Или в файле эксель змените точку на запятую
Выбор приоритетной валюты по условию
 
Как вариант. С дополнительным столбцом.
для модератора: выбор приоритетной валюты по условию
Добавить условный столбец в power query Excel 2016
 
Gevo, вот про это речь
Добавить условный столбец в power query Excel 2016
 
а версия какая?
Вычисление в смещающемся диапазоне, Необходим шаблон формулы, которая находит количество заполненных ячеек в диапазоне от текущей даты до этой же даты в прошлом году.
 
ещё вариант
Код
=СУММПРОИЗВ((B3:B16<=СЕГОДНЯ())*(B3:B16>=ДАТАМЕС(СЕГОДНЯ();-12))*(C3:C16=C3))

Allekss, у вас хронология в примере нарушена. После апреля март идет.
Пересечение диапазонов дат в пределах строки, Пересечение дат в строке
 
ещё вариант
Код
=СУММПРОИЗВ((D2:L2<=C2)*(D2:L2>=B2))>0
Добавить условный столбец в power query Excel 2016
 
вот
Посчитать сколько сотрудников выполнили план по нескольким продуктам
 
Цитата
belogorskayata написал:
зачем знак  --  в первой формуле?
"превращает" ИСТИНА в 1, а ЛОЖЬ в 0
Разделить данные по разделителю и удалить дубликаты
 
mgkmgk, покажите в файле с примером "что есть" -> "как надо"
Суммирование по условию для текущего месяца
 
Добрый день
Код
=СУММПРОИЗВ(($C$5:$C$19)*($B$5:$B$19=F16)*(МЕСЯЦ(СЕГОДНЯ())=МЕСЯЦ($A$5:$A$19)))
Изменено: Stics - 18 Мар 2019 17:53:25
Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 20 След.
Наверх