Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Выбрать дату в календареВыбрать дату в календаре

Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 28 След.
Удаление дубликатов одновременно в строках и колонках Excel таблицы
 
вариант на PQ
P.S. кривовато, но думаю, если спецы подтянутся, то оптимальный вариант предложат
Посчитать даты по годам, кроме повторяющихся
 
покажите, пожалуйста, как это должно выглядеть
Посчитать даты по годам, кроме повторяющихся
 
сводной сделайте, в файле добавил вариант
Посчитать даты по годам, кроме повторяющихся
 
как вариант
Код
=СУММПРОИЗВ(--(ГОД($A$1:$A$19)=C2))
Изменено: Stics - 30 Июн 2020 11:30:24
Вычисление медианы по нескольким условиям
 
Брям, у Вас же формулы есть, что не получается?
Power Query. Сравнение диапазона на наличие значений из справочника., Сравнение диапазона со справочниками при помощи PQ
 
Денис Веселов, Вас просят привести пример в файле. Желательно в виде "что есть" -> "как нужно". Облегчайте жизнь помогающим, это же не сложно.
Суммировать значение по двум условиям, одно из которых представлено в виде списка соответствий, без вспомгательного столбца, с использованием только vlookup index match sum, if
 
ещё вариант
Код
=СУММ(ЕСЛИ(ИНДЕКС($H$2:$H$4;ПОИСКПОЗ($A$2:$A$29;$G$2:$G$4;0))=$H$9;$C$2:$C$29;0)*(ГОД($B$2:$B$29)=G10))
Группировка данных в таблице по нескольким условиям
 
Владислав Крупин, файл не загружен
Как посчитать количество Да за указанный период времени
 
Роман,
вводите дополнительный множитель с условием
Код
=СУММПРОИЗВ((C2:C5594="Да")*(I2:I5594>=K1)*(I2:I5594<=M1)*(A2:A5594="Ипотека"))
PQ. Table.Group - параметризация аргументов
 
del
Изменено: Stics - 2 Июн 2020 19:20:13
Преобразовать СЛОЖНУЮ вертикальную таблицу в горизонтальный формат, Преобразовать СЛОЖНУЮ вертикальную таблицу в горизонтальный формат
 
как вариант на PQ
Код
let
    Источник = Excel.CurrentWorkbook(){[Name="Таблица1"]}[Content],
    group = Table.Group(Источник, {"Соответствие", "Данные"}, {"tmp", each Table.AddIndexColumn(_, "index", 1, 1)}),
    Пользовательский1 = Table.Combine(group[tmp]),
    #"Измененный тип" = Table.TransformColumnTypes(Пользовательский1,{{"index", type text}}),
    #"Добавлен пользовательский объект" = Table.AddColumn(#"Измененный тип", "out", each [Данные] & [index]),
    #"Удаленные столбцы" = Table.RemoveColumns(#"Добавлен пользовательский объект",{"Данные", "index"}),
    #"Сведенный столбец" = Table.Pivot(#"Удаленные столбцы", List.Distinct(#"Удаленные столбцы"[out]), "out", "Клиент(фио+др)"),
    #"Переупорядоченные столбцы" = Table.ReorderColumns(#"Сведенный столбец",{"Соответствие", "mobile_phone1", "name11", "name21", "name22", "name31", "name32"})
in
    #"Переупорядоченные столбцы"
На основании порядкого номера найти цену с самой поздней датой
 
Код
=ИНДЕКС($B$2:$B$22;ПОИСКПОЗ(F3&АГРЕГАТ(14;6;($C$2:$C$22)/($A$2:$A$22=F3);1);$A$2:$A$22&$C$2:$C$22;0))
Расшифровка формулы c функцией ПРЕДСКАЗ
 
Сергей А, добрый день!
Возможно Вы ищите функцию ЛИНЕЙН. Формулы из справки выше приведены.
Посмотрите материал на тему парной линейной регрессии, может часть вопросов снимется.
Изменено: Stics - 1 Июн 2020 12:45:25
Выбор диапазона суммирования в зависимости от найденного условия, диапазон суммирования в зависимости от условия
 
как-то так по п.1
Код
=ЕСЛИ(ВПР(--ЛЕВСИМВ(B8;2);$A$27:$B$30;2;1)=0;"";СУММ(ИНДЕКС(D8:F8;;ВПР(--ЛЕВСИМВ(B8;2);$A$27:$B$30;2;1)):F8))
Изменено: Stics - 27 Май 2020 19:38:17
min/max отклонение по ряду позиций
 
или так
минимум
Код
=АГРЕГАТ(15;6;($H$4:$H$20)/($B$4:$B$20=B4)/($D$4:$D$20=D4);1)

максимум
Код
=АГРЕГАТ(14;6;($H$4:$H$20)/($B$4:$B$20=B4)/($D$4:$D$20=D4);1)
Изменено: Stics - 27 Май 2020 12:59:15
Расчет периодов пустых ячеек между значечниями в строке
 
vsergey35, попробуйте поискать по ключевым словам "подсчет числа серий excel". Периодически встречается такая задача
Поиск минимального/максимального значения по нескольким условиям
 
Здравствуйте.
Извлечение первого слова из строки
 
ioruslan88, файл приложите, где ошибка появляется
Переставить числа из начала в конец текста
 
realmen80, может быть еще мгновенное заполнение поможет
Поиск и замена по номеру серии (макрос)
 
без причесывания используя формулу Mershik,
Код
=ПРОСМОТР(2;1/(($A$2:$A$29=$A6)*(ЕЧИСЛО(--($B$2:$B$29))=ИСТИНА));$B$2:$B$29)
найти количество новых клиентов при сложных условиях, найти количество новых клиентов при сложных условиях
 
Seitkassym, в excel пример показывайте. Облегчайте жизнь помогающим.
Power Query - Преобразовать несколько диапазонов в таблицу
 
вариант
Код
let
    Источник = Excel.CurrentWorkbook(){[Name="Таблица2"]}[Content],
    type_date = Table.TransformColumnTypes(Источник,{{"Дата начала", type date}, {"Дата окончания", type date}}),
    add_column = Table.AddColumn(type_date, "date", each {Number.From([Дата начала])..Number.From([Дата окончания])}),
    expand = Table.ExpandListColumn(add_column, "date"),
    out = Table.TransformColumnTypes(expand,{{"date", type date}})
in
    out
Найти сумму объема потребленного ресурса за каждый месяц по каждому дому
 
Цитата
thet1mka написал: дать направление на какие функции стоит обратить внимание
СУММЕСЛИ, СУММЕСЛИМН, сводные таблицы.

Формулируйте небольшие вопросы.
Например, как вариант темы: "Найти сумму объема потребленного ресурса за каждый месяц по каждому дому"
Изменено: Stics - 6 Апр 2020 17:30:52
Сортировка огромной таблицы и добавление + удаление лишних строк, Необходимо удалить и добавить новые строки в таблицу
 
PQ
но без пустых строк
Код
let
    Источник = Excel.CurrentWorkbook(){[Name="Таблица1"]}[Content],
    date = Table.TransformColumnTypes(Источник,{{"Дата накладной", type date}}),
    min_max = Table.Group(date, "Наименование товар", {{"min", each Table.Min(_, "Дата накладной")},{"max", each Table.Max(_, "Дата накладной")}}),
    unpivot = Table.UnpivotOtherColumns(min_max, {"Наименование товар"}, "Атрибут", "Значение"),
    out = Table.FromRecords(unpivot[Значение]),
    type_date = Table.TransformColumnTypes(out,{{"Дата накладной", type date}})
in
    type_date
Сортировка огромной таблицы и добавление + удаление лишних строк, Необходимо удалить и добавить новые строки в таблицу
 
Leto123, Добрый день!
Файл с примером приложите "что есть" -> "как надо".
Вывод цены по приоритетности по заданным данным
 
вариант
Код
=ИНДЕКС(B5:E5;;АГРЕГАТ(15;6;(СТОЛБЕЦ(B$2:$E3)-1)/НЕ(ЕПУСТО(B5:E5));1))

в G4
Изменено: Stics - 31 Мар 2020 21:09:11
Поиск текстового словосочетания из одного массива в другом массиве.
 
ещё вариант
Код
=ЕСЛИ(ЕЧИСЛО(ПРОСМОТР(2;1/ПОИСК($G$8:$G$12;A24)));"Да";"Нет")

массивная
Большой диапазон данных нужно сгруппировать в доступном виде.
 
вкладке "Просмотр" есть "Расширенный редактор".
Изменено: Stics - 26 Мар 2020 15:50:31
Большой диапазон данных нужно сгруппировать в доступном виде.
 
ДЭНЧИК147, код выше это не макрос, а скрипт Power Query.
С макросом не смогу помочь
Большой диапазон данных нужно сгруппировать в доступном виде.
 
ДЭНЧИК147, обновил #2.
Изменено: Stics - 26 Мар 2020 14:07:10
Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 28 След.
Наверх