Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Выбрать дату в календареВыбрать дату в календаре

Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 124 След.
Формула для определения последнего месяца поставки товара
 
Здравствуйте.
Попробуйте так
Код
=ЕСЛИ(--ТЕКСТ(Таблица1[@[Дата потребности]];"ММ.ГГГГ")>=--ТЕКСТ(Таблица1[@[Дата поступления]];"ММ.ГГГГ");"В срок";"Не в срок")
Как определить количество дней работы в месяце, имея несколько интервалов работы транспортного средства
 
И Вам не хворать.
Вариант в файле.
Код
=ЕСЛИ(СЧЁТЕСЛИМН(Лист1!$E:$E;"проверен";Лист1!$C:$C;"<="&Лист2!B$1+1;Лист1!$D:$D;">="&Лист2!B$1;Лист1!$B:$B;Лист2!$A7);"х";"")
Подставить время по части наименования операции
 
Формула массива
Код
=СУММПРОИЗВ(ЕСЛИ(ЕЧИСЛО(НАЙТИ($E$2:$E$4;A2));$F$2:$F$4;""))
Ошибка 400 при обращении к Range
 
Цитата
Ігор Гончаренко написал:
не возможно обратиться к диапазону одного листа, задавая его двумя ячейками другого листа
Alex K, Вам же уже написали, невозможно.....
Вы запускаете макрос с листа ws2. Ячейки (Cells(1, 1), Cells(3, 1)) на каком листе находятся? Если не указать конкретный лист, то макрос эти ячейки воспринимает как активного листа, т.е ws2. Но вы указываете что диапазон копирования на листе ws1. ws1.Range(, а теперь ячейки ограничивающие этот диапазон находятся на ws2. Что вам должен сказать Excel? Вот он и выдаёт вам 400.
Запишите так
Код
    With ws1
    .Range(.Cells(1, 1), .Cells(3, 1)).Copy
    End With

Или так

Код
ws1.Range(ws1.Cells(1, 1), ws1.Cells(3, 1)).Copy
Изменено: gling - 16 дек 2020 22:44:21
Как просуммировать баллы при попадании определенного значения в диапазон с критериями
 
Вариант в файле.
Расчет среднего балла и средней оценки за контрольную работу в зависимости от работы
 
Здравствуйте.
Не знаю это хотели или нет.
СЧЁТЕСЛИ выдает 0, хотя должна быть точно 1, пук пук
 
И Вам здравствовать!
А в вашем файле это увидеть можно?
как рассчитать процент при двух фильтрах
 
Здравствуйте.
А сводная не подходит?
Сортировка групп данных по наименьшему значению в группе
 
Здравствуйте.
Вариант темы: Сортировка групп данных по наименьшему значению в группе.
Вариант с формулой в доп столбце в файле.

Упс! Наверно я не так понял, группы должны стыковаться одинаковыми значениями?
Изменено: gling - 6 дек 2020 23:17:48
Как связать клик по ячейке с автофильтром
 
Без количества мастей работало правильно, а с выбором количества мастей не всё правильно. Может хоть идея пригодится.
Как связать клик по ячейке с автофильтром
 
Здравствуйте.
Еще один вариант.
Перенос с нескольких строк в одну
 
Вариант формулами. На больших объёмах наверно повиснет.
Из набора цифр составить дату рождения
 
Цитата
IRINA SAVITSKAJA написал:
Дата , при дате рождения,
В А1 это странное число; первая формула возвращает Дату; вторая первый знак в ячейке.
Код
=ДАТА(ПСТР(A1;2;2);ПСТР(A1;4;2);ПСТР(A1;6;2))
=ПСТР(A1;1;1)
Перетянуть плоскую таблицу в календарный формат
 
Здравствуйте.
Тоже формула массива, без ДопСтолбцов А;В;С.
Код
=ЕСЛИ(СУММ(($G$8:$G$10=$N23)*($H$8:$H$10=$O23)*($K$8:$K$10<=P$19)*($L$8:$L$10>=P$19));$J$8:$J$10&"%;"&$I$8:$I$10;"")
Прошу поддержки администрации planetaexcel
 
Вы находитесь на форуме где задают вопросы по работе с файлами и возможностями Excel, где в Вашем вопросе про Excel?  Это Вам и пытался объяснить  _Igor_61. Ваш вопрос
Цитата
как работать в Power BI PRO облачном сервисе
не по теме форума, попробуйте его задать на специализированном форуме если он есть.
Цитата
В первую очередь хочу уточнить, что Power BI это не часть Excel, а самостоятельная программа для бизнесс-анализа, которую надо будет установить на ПК отдельно.
Подсчитать количество ячеек в столбце в разрезе диапазонов значений (от и до)
 
Цитата
Lillimasha написал:
может есть какая встроенная функция
Здравствуйте.
Сводная таблица, с группировкой с шагом =200. Можно и формулами.
Изменено: gling - 24 ноя 2020 22:58:18 (Заменил файл)
Распределение ящиков по заданному числу машин с минимальным перемешиванием товаров
 
Цитата
Volounteer написал:
к сожалению, не знаю
Вариант на листе бумаги нарисовал. Варианта формулами в Excel нет.
Возврат последнего значения из пополняемого списка при нескольких аргументах
 
Здравствуйте. Попробуйте такую формулу.
Код
=ИНДЕКС($A$3:$O$3;СУММПРОИЗВ(МАКС(($A$5:$O$5=$B8)*СТОЛБЕЦ($A$5:$O$5))))
количество звонков по каждой дате
 
Цитата
Иван Зарубин написал:
должно быть так:
Вы бы в своём файле показали как должно быть.В вашем примере только 17.08.2017 есть звонки у ID 10499 их 2418. И как результат должн выглядеть в конечном варианте? А может лучше не формулами, а сводной таблицей?
Изменено: gling - 8 ноя 2020 22:50:52
Как внутри формулы ВПР изменять название листа протягиванием формулы?
 
Здравствуйте.
Может так?
Код
=ВПР("a";ДВССЫЛ("'2020_"&A2&"'!A14:F22");3;0)
или
=ВПР("a";ДВССЫЛ("'2020_"&СТОЛБЕЦ()&"'!A14:F22");3;0)
Сравнение содержимого 3 столбцов
 
Здравствуйте.
Не знаю правильно ли понял.
Код
=ЕСЛИОШИБКА(ЕСЛИ(СЧЁТЕСЛИ(A2;"*ТНВ*");"Цех производства ПФ";ВПР(D2;Лист2!D:E;2;));"")
Разнести по ячейкам числа, записанные в одной ячейке
 
Арсен Асатурян, Вам необходимо избавиться в ячейках от неразрывных пробелов (код символа 0160), для этого выполните следующее: Выделите диапазон с данными--Ctrl+H--установите курсор в Найти:--зажав Alt наберите на клавишах справа при нажатом NumLock число= 0160--Заменить все--Закрыть. После этого Текст по столбцам и всё будет считать как и хотели.
Выпадающий список с привязкой к группировке, При выборе определенного значения в выпадающем списке раскрывается нужная группировка
 
Цитата
Viktor1987 написал:
уже восемь уровней вложения
Цитата
Viktor1987 написал:
Хочется что бы лишнего не было!
Вы бы описали саму задачу, а не то как вы хотите её решить через группировку. У вас 8 уровней группировки, а в примере 1. Это значит, внутри каждой группы (обозначена плюсиком слева от данных) будет ещё 7 плюсиков (уровней) и какой уровень какой группы хотите открывать через выпадающий список? Опишите или покажите, что у вас есть (какая база данных) и что хотите увидеть (нажав на какую то кнопочку)? Может вообще группировка не нужна, а нужно вытаскивать данные на отдельный лист для просмотра? В этом случае лишнего на листе просмотра не будет. Мне не понятно как должен выглядеть конечный результат. Ведь при группировке всё равно одна строка группы остается видимой и если групп будет 100, то при выборе сотой группы в выпадающем списке она откроется внизу страницы или даже на другой странице. Даже нормально распечатать не получится.
Выпадающий список с привязкой к группировке, При выборе определенного значения в выпадающем списке раскрывается нужная группировка
 
А почему обязательно выпадающий список, просто группировка не устраивает? И видно какие вкладки нужно открыть. Посмотрите еще варианты на соседнем листе.
Пронумеровать пустые  ячейки в столбцах, ориентируясь на значения в других столбцах
 
С ДопСтолбцом
Код
=ИНДЕКС($W$5:$W$9;ПОИСКПОЗ(СУММПРОИЗВ((G11:G15="х")*{1:2:3:4:5});$AA$5:$AA$9;))
Изменено: gling - 17 окт 2020 16:57:36
Выпадающий список с привязкой к группировке, При выборе определенного значения в выпадающем списке раскрывается нужная группировка
 
Здравствуйте.
Цитата
Viktor1987 написал:
А нет способа поизящнее?
Без макросов Источник
Как заставить динамический график дружить с таблицей данных
 
Пусть формула выдаст не 0 или "", а пробел " " и ищите этот пробел.
При копировании листа со сводной таблицей источник данных остается на копируемый лист
 
Цитата
Антон Филиппов написал:
Как то можно поправить ?
Вкладка Работа со сводными таблицами -- Параметры -- Данные -- Источник данных - Измените имя листа
выбор значений из заданного диапазона
 
Здравствуйте.
Может так?
Код
=СУММЕСЛИМН(DATA!J:J;DATA!A:A;">="&Тест_0!B2;DATA!A:A;"<="&Тест_0!B3)/СЧЁТЕСЛИМН(DATA!A:A;">="&Тест_0!B2;DATA!A:A;"<="&Тест_0!B3)
=СУММЕСЛИМН(DATA!K:K;DATA!A:A;">="&Тест_0!B2;DATA!A:A;"<="&Тест_0!B3)/СЧЁТЕСЛИМН(DATA!A:A;">="&Тест_0!B2;DATA!A:A;"<="&Тест_0!B3) 

Или функция СРЗНАЧЕСЛИМН() если есть

Изменено: gling - 11 окт 2020 21:31:16
Копирование выделенной (динамической) строки с Лист1 на Лист2 этой же книги
 
Здравствуйте.
Смотрите в файле, так надо?
Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 124 След.
Наверх