Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Выбрать дату в календареВыбрать дату в календаре

Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 119 След.
возврат значений со смещением, видимо СМЕЩ и СТРОКА
 
Цитата
meidiland написал:
должно быть "Смещение"
Ежели так уж хотите.
Код
=ЕСЛИ(ОСТАТ(СТРОКА(A3);3);"";СМЕЩ($A$2;СТРОКА(A3)/3-1;;1;))
Подтянуть информацию из массива данных при соблюдении нескольких условий
 
Цитата
Светлана написал:
а вот даты уведомлений у них разные
Если это всегда так, можно проще
Код
=СУММЕСЛИМН(H:H;G:G;A2;I:I;B2)
Взять значения из одной ячейки и вставить их в другую после 4 символа
 
Ответ удалил. Сломал язык при обращении по Нику.
Изменено: gling - 13 Ноя 2019 22:18:51
Поменять формулы в фигурах
 
Вариант.
Цитата
С. Петров написал:
Даже направлению поиска
Поищите в файле, может что то и найдете.
как сделать активный выпадающий список с временем
 
Здравствуйте. Вариант в файле. Не совсем так как хотелось бы, но близко к этому. Время начала >= Времени окончания предыдущей работы. Новые листы нужно будет создавать из листа 13, в результате создадутся и именованные диапазоны на листах. Иначе придется для каждого листа писать свою формулу в проверке данных, так как нужно проверять ячейки на своём листе.
Изменено: gling - 13 Ноя 2019 11:15:11 (Заменил файл.)
Проверка данных - запрет на выполнение формулы по условию из другой ячейки
 
Цитата
если в столбце "Наличие" было "нет"
Вариант.
Код
=И(ОСТАТ(D3;C3)=0;B3<>"нет")
=И(ОСТАТ(D3;C3)=0;B3="есть")

Для столбца стоимость

Код
=ЕСЛИ(B2="есть";D2*E2;0)

Или я не так понял?
Изменено: gling - 12 Ноя 2019 11:57:10
Выбор дат и перестановка их в нужные ячейки
 
Здравствуйте. Вариант в файле.
Код
=ЕСЛИ(ЕЧИСЛО(--B3);B3;A2)
Поиск по 2 значениям в горизонтали
 
Здравствуйте. А может быть сводной таблицей попробовать?
Печать заданных строк
 
Цитата
nemo1975 написал:
можно реализовать?
Может быть так?
Удаление дубликатов строк по двум значениям в двух столбцах
 
И Вам здравствовать! Вариант в файле, то что не нужно скрыто фильтром.
Изменено: gling - 11 Ноя 2019 22:01:55
Печать заданных строк
 
Вариант, перед печатью столбец 1 скрыть.
сумма ячеек диапазона с условием
 
Цитата
Vik_tor написал:
как же не мешает
Точно, мой косяк, не проверил результат, можно в D2 поставить тире или убрать эту часть формулы.
сумма ячеек диапазона с условием
 
Цитата
Vik_tor написал:
уберите первую часть формулы
Это оставил на перспективу, а вдруг нужно будет суммировать по группе2 и группе3 вместе, или появится еще группа4. Эта часть не мешает конечному результату.
сумма ячеек диапазона с условием
 
Здравствуйте. Вариант в файле.
Код
=СУММЕСЛИМН(ИНДЕКС(план!$D$3:$M$7;ПОИСКПОЗ($B4;план!$B$3:$B$7;););план!$D$2:$M$2;рабочий!C$2&"*")+СУММЕСЛИМН(ИНДЕКС(план!$D$3:$M$7;ПОИСКПОЗ($B4;план!$B$3:$B$7;););план!$D$2:$M$2;рабочий!C$3&"*")
Как связать ячейку с другой книгой, в которой меняются расположения строк
 
Здравствуйте. Вариант в файле. Только нужно избавиться от объединенных ячеек. А если лист из ежемесячного файла переносить в Макет, то будет гораздо удобнее и всегда под рукой вся статистика за собранный в файле период.
А если еще немного поработать с файлом, можно будет выбирать периоды по месяцам и сравнивать их в разных годах.
Изменено: gling - 5 Ноя 2019 09:10:40 (Заменил файл.)
как связать несколько(более 3-4) ячеек со списками чтобы они зависели друг от друга
 
Здравствуйте. Покажите в примере, что нужно связать и с чем. У вас в файле на листах справочник Воздух и Лист3 не из чего выбирать, каждому наименованию соответствует одна строка. По этим данным нет необходимости организовывать несколько выпадающих списков, достаточно одного "Наименование", а остальные данные из таблиц подтянутся формулой =ВПР()
Автоматизация теста в excel (VBA)
 
Здравствуйте.
Цитата
bronzor написал:
затем в ячейки C6 создаётся
"Затем", за чем? После чего? Что должно произойти чтобы создался список? Если просто хотите создать много ячеек с выпадающими списками, каждый со своим диапазоном, то пропишите для выпадающего списка в С2 диапазон B2:B5. Копируйте эту ячейку в С6 и у вас выпадающий список с новым-своим диапазоном. Хотите скрипт, пишите цикл  вставки скопированной ячейки с шагом 4.
Как записать высчитанный макросом диапазон в формулу Excel?
 
Цитата
Griver написал:
получится очень громоздкой
Вы знаете эту формулу?
Формула последней заполненной строки в диапазоне
Код
=СУММПРОИЗВ(МАКС((A1:P21>0)*СТРОКА(A1:P21)))

Формула последней заполненной ячейки в столбце А

Код
=ПОИСКПОЗ(9^9;A:A;1)

Был бы файл пример, может что то и предложили, более близкое к решению вашей задачи, но не вами придуманным способом.

Как записать высчитанный макросом диапазон в формулу Excel?
 
А зачем макросом искать? Пропишите всё в формуле.
Гиперссылка на нужную таблицу
 
Цитата
Hops-c написал:
Как сделать чтобы при нажатии на ячейку, мне кидало нужный график?
В какой ячейке выберите, туда и прыгнет. Можно сделать и при нажатии на ячейку. Только что делать дальше с диаграммой, отправлять её на старое место обитания или нет?
Как убрать сдвиг слова в ячейке с формулой
 
=СЖПРОБЕЛЫ(СЦЕПИТЬ(A3;" "......
Создание листов по фильтру со сводной таблицы и их переименование, Макрос
 
Здравствуйте. А что обязательно нужно макросом, встроенные возможности Excel не устраивают?
Активируйте любую ячейку сводной таблицы-- далее по вкладкам: Работа со сводными таблицами -- Параметры --- на треугольничек рядом с кнопкой Параметры -- Отобразить страницы фильтра отчета -- Ок.
Макрорекордером получился такой макрос:
Код
Sub Макрос1()
    ActiveSheet.PivotTables("Сводная таблица2").ShowPages PageField:="Брик"
End Sub
Изменено: gling - 24 Сен 2019 20:09:36
Для каждого наименования из двух столбцов найти максимальный номер строки, где оно встречается, и значение третьего столбца этой строки, упростить индексацию в файле
 
Эта формула?
Код
=ИНДЕКС($C$1:$C$13;СУММПРОИЗВ(МАКС(($A$1:$B$13=D1)*СТРОКА($C$1:$C$13))))
Расчёт стоимости командировки, Массив работает непонятно
 
Цитата
VargIgor написал:
но интересно, что в массиве было не так:
Здравствуйте. У Вас в формуле ПОИСКПОЗ() без третьего аргумента, там должен быть 0 или ЛОЖЬ
Поиск минимального значения в зависимости от соседнего столбца
 
Цитата
Vovochka написал:
менее корректно, чем описано в примере
Покажите в примере.
Условное форматирование ячеек, адреса которых указаны в других ячейках
 
Вариант с УФ.
Залить ячейку цветом, номер которого вводиться в другую ячейку
 
Самый первый макрорекордером, а потом смотрел в приемах разные объяснения. Но писать макросы я пока не научился, то что я умею это "баловство", а не написание макросов, элементарные вещи, где то подсмотрел макрос, разобрался как он работает и приспособил под свои нужды. В основном обучаюсь на форумах, если могу помогаю, если не могу учусь на ответах которые выкладывают другие участники форума.
Залить ячейку цветом, номер которого вводиться в другую ячейку
 
Так?
Код
Private Sub Worksheet_Change(ByVal Target As Range)
    If Not Intersect(Target, Range("A1")) Is Nothing Then
    Cells(1, 1).Interior.ColorIndex = Cells(1, 1).Value
    End If
End Sub
Сортировать таблицы в порядке убывания не затрагивая 1 столбец таблицы
 
Цитата
Mag.emk написал: как нормально сформулировать тему.
Какова конечная цель? Выстроить данные по определенному порядку (шаблону)?
Цитата
vikttur написал: К первому сообщению прикрепите небольшой пример
Работа со сводной таблицей. Выделение строк цветом.
 
Цитата
fareng8 написал:
Цветов не сотни, их 4.
Для пары категорий пропишите ещё 2 условия с другими цветами в УФ. Для сотни не понятно, а в какие цвета вы их хотите красить? 50 одним и 50 другим?
Цитата
fareng8 написал:
И их статус каждые пару недель необходимо менять.
Каким образом вы меняете статус? Можно в первоначальной таблице создать доп столбец где будет прописываться статус, а по статусу будет определяться цвет закраски.
Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 119 След.
Наверх