Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Выбрать дату в календареВыбрать дату в календаре

Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 116 След.
Вставка или перенос с шагом с одного столбца в другой
 
Разве я такую формулу написал?
Код
=ЕСЛИ(ОСТАТ(СТРОКА(A2);7)=0;ИНДЕКС($A$3:$A$22;СТРОКА(A2)/7);"")

Вставьте формулу из сообщения #2 в ячейку С3 и протяните вниз. Возможно и нужно было уточнить ячейку в сообщении #2.

Изменено: gling - 22 Апр 2019 23:48:20
Расчёт суммы налога по нескольким условиям.
 
Здравствуйте. В Вашем примере не видно, что вы осилили, а что нет. Вам нужно решения по всем трем пунктам?
Вставка или перенос с шагом с одного столбца в другой
 
Здравствуйте. Попробуйте так
Код
=ЕСЛИ(ОСТАТ(СТРОКА(A7);7)=0;ИНДЕКС($A$3:$A$22;СТРОКА(A7)/7);"")
Вывод повторяющихся значений в отдельный список
 
Цитата
Бряk написал:
чтоб в итоге был список
Тема: Вывод повторяющихся значений в отдельный список
Перенос данных с помощью макроса из одного листа на другой по условиям
 
Научу плохому. Вставьте эти формулы макросом в нужные диапазоны--пересчитайте их и потом замените на значения. Всё это можно записать макрорекордером.
Перенос данных с помощью макроса из одного листа на другой по условиям
 
Цитата
Qwerty1122 написал:
Возможен ли такой маневр?
Конечно! А формулы не подойдут?
Определить период работы с клиентом
 
Здравствуйте. Вариант сводной таблицей.
ВПР возвращает "0" либо ""
 
Ячейка В2 не пустая,но её значение равно 0. Проверьте так
Код
=ТЕКСТ(B2;"@")=ТЕКСТ(B3;"@")

Какой символ в ней не знаю, но избавиться от ячеек с таим символом можно выделив столбец нажмите текст по столбцам -- Готово.

Раскраска строк макросом при совпадении данных из столбцов на другом листе
 
Здравствуйте.
Цитата
Romario940 написал:
Через условное форматирование
Столбец  А скрыт. От объединенных ячеек избавился.
суммеслимн , условия не все выполняются - результат 0, работа суммеслимн - что посоветуете?
 
Здравствуйте.  А так не подойдет?
Код
=СУММПРОИЗВ(СУММЕСЛИМН(Лист1!$K$2:$K$18;Лист1!$B$2:$B$18;Лист2!C3;Лист1!$J$2:$J$18;{160;171;172;351}))
Выпадающий список в одной ячейке с другого листа.
 
Здесь озвучен вопрос про Выпадающие списки, а по созданию перечня работ при выборе месяца - это другая тема, не связанная с выпадающим списком, которого у Вас нет.
Изменено: gling - 28 Мар 2019 00:22:08
Отметить / снять выбор всех пометок элементов списка, Пометки элементов списка. ОТМЕТИТЬ ВСЕ / СНЯТЬ ВСЕ ОТМЕТКИ
 
Попробуйте такой код, и кликните дважды в А1. Без файла не пробовал.
Код
Private Sub Worksheet_BeforeDoubleClick(ByVal Target As Range, Cancel As Boolean)
 
    If Not Intersect(Target, Range("A2:A300")) Is Nothing Then
        Cancel = True 'Prevent going into Edit Mode
        Target.Font.Name = "Marlett"
            If Target = vbNullString Then
                Target = "a"
            Else
                Target = vbNullString
            End If
    End If
    If Not Intersect(Target, Range("A1")) Is Nothing Then
        Cancel = True
            If Target = "Отметить Все" Then
                Range("A2:A300") = "a"
                Target = "Снять выделение"
            Else
                Range("A2:A300").ClearContents
                Target = "Отметить Все"
            End If
    End If
End Sub
Проверка таблицы с текстом по множественным ключам и заливка пересечений
 
Тоже в УФ
Код
=СУММПРОИЗВ(СЧЁТЕСЛИ(B3;"*"&$G$2:$G$8&"*"))
Выделить, если есть изменения
 
Вариант.
Фильтр с объединенными ячейками.
 
Попробуйте скопировать текст макроса и вставить его на лист, сохранить может что и получится.
Код
Private Sub Worksheet_Calculate()
    Dim r As Range, ar As Range, sRows As Range
    Dim dic As Object, adic, i&, fi&
    With ActiveSheet
        If .AutoFilterMode Then
        For i = 1 To .AutoFilter.Filters.Count
             If .AutoFilter.Filters(i).On Then fi = i
            Next
            If fi Then
                Application.ScreenUpdating = False
                Application.EnableEvents = False

                Set dic = CreateObject("Scripting.Dictionary")
                Set r = .AutoFilter.Range.SpecialCells(xlCellTypeVisible)
                For Each ar In r.Areas
                    For Each sRows In ar.Rows
                        dic.Item(sRows.Row) = 1
                    Next
                Next
                .AutoFilter.Range.AutoFilter Field:=fi, Criteria1:="@"
                adic = dic.keys
                For i = LBound(adic) To UBound(adic)
                    Range("A" & adic(i)).MergeArea.EntireRow.Hidden = False
                Next
                Application.EnableEvents = True
                Application.ScreenUpdating = True
            End If
        End If
    End With
End Sub
Изменено: gling - 12 Мар 2019 00:17:49
Фильтр с объединенными ячейками.
 
Недавно была тема тоже про такое, выяснилось что Офис не полный, наверно и у вас нужно установить нормальный офис. Попробуйте самостоятельно создать простейший макрос,получится?
Фильтр с объединенными ячейками.
 
Снова выгрузите файл с форума. Возможно вы его сохранили с расширением .xlsx и все макросы стерлись. Файл должен быть в формате .xlsm. Просмотреть макросы можно Alt+F11 на листе.
Сумма времени по группе на каждую дату
 
Цитата
elenalll написал:
"общее время" суммируется и делится на общее количество входящих звонков
А зачем делить, если можно сразу брать это время. Ведь общее состоит из Кол. звонков*на время.
Код
=СУММЕСЛИМН(ИНДЕКС(данные!$G$5:$EC$15;;ПОИСКПОЗ('Свод по группам'!H$1;данные!$G$2:$EC$2;)+2);данные!$D$5:$D$15;$A8)
Фильтр с объединенными ячейками.
 
Макросы включить--Сохранить документ --Закрыть документ--Вновь открыть и попробовать. Формула СЕГОДНЯ() должна быть. Комп перегружать не нужно. Документ с включенными макросами сохранить-закрыть и вновь открыть.
Изменено: gling - 11 Мар 2019 23:23:31
Фильтр с объединенными ячейками.
 
У меня работает. Макросы были включены или включили сейчас  в этом документе?
Изменено: gling - 11 Мар 2019 23:15:12
Фильтр с объединенными ячейками.
 
Попробуйте сортировать по дате или столбцы А:Е. Макросы должны быть включены.
Изменено: gling - 11 Мар 2019 22:50:51
Фильтр с объединенными ячейками.
 
Цитата
CORDOBA написал:
в каком ячейке
В любой, только чтобы её случайно не удалить. Сейчас она в U1.
Изменено: gling - 11 Мар 2019 22:41:32
Неправильная сортировка по дате
 
Здравствуйте. У Вас дата записана как текст,  Excel её так и видит текстом, поэтому такая сортировка неправильная. Попробуйте преобразовать столбец с датами в число. Выделите весь столбец--на вкладке Данные--Текст по столбцам--Готово. Попробуйте вновь сортировать. Если не получится выкладывайте файл с данными.
Выделить, если есть изменения
 
Здравствуйте. Вы бы прочитали правила этого форума.
1. Такое название темы ведет к её закрытию. Придумайте новое. Название темы сами изменить не сможете, нужно предложить в ответе, а модератор изменит.
2. В файле примере есть исходные данные, а как должен выглядеть конечный результат? Закрасьте вручную что должно быть в нужные цвета.
Итоги в сводной помесячно и итого
 
Почему не считает? Вы увеличьте разрядность в таблице Уд вес. Или я не понял, что вы хотите?
Изменено: gling - 11 Мар 2019 00:30:47
Итоги в сводной помесячно и итого
 
Здравствуйте. Может так нужно?
Ошибка #ССЫЛКА в формуле массива после выполнения макроса свода из разных листов в один
 
Здравствуйте. попробуйте в коде поменять
Код
sh.Range("A2:K" & iLastRow).EntireRow.Delete
на
sh.Range("A2:K" & iLastRow).ClearContents
Поиск значения в диапазоне по нескольким критериям, В не самом стандартном варианте
 
Самое основное в этой формуле эта часть ИНДЕКС($C$3:$I$18;;ПОИСКПОЗ($K3;$C$2:$I$2;)), здесь находится столбец по которому нужна сумма, а остальное всё описано в СУММЕСЛИМН()
Поиск значения в диапазоне по нескольким критериям, В не самом стандартном варианте
 
Здравствуйте. Посмотрите вариант
Код
=СУММЕСЛИМН(ИНДЕКС($C$3:$I$18;;ПОИСКПОЗ($K3;$C$2:$I$2;));$C$3:$C$18;L$2;$A$3:$A$18;L$1) 

Если нужно считать только ИТОГО, до добавьте еще условие

Код
=СУММЕСЛИМН(ИНДЕКС($C$3:$I$18;;ПОИСКПОЗ($K3;$C$2:$I$2;));$C$3:$C$18;L$2;$A$3:$A$18;L$1;$B$3:$B$18;"Итого")
Изменено: gling - 7 Мар 2019 18:17:56
Подсчитать количество работаюших на полную ставку
 
Не добиваю, может кто будет читать этого не знает. Сам недавно только узнал, вот и поделился.
Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 116 След.
Наверх