Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Выбрать дату в календареВыбрать дату в календаре

Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 119 След.
Найти первое и последнее значение соответствующее условию, Найти первое и последнее значение соответствующее условию
 
Здравствуйте.
Может так подойдет.
Код
=ИНДЕКС($D11:$N11;СУММПРОИЗВ(ПОИСКПОЗ(1;--($D11:$N11>$O$10);)))
=ИНДЕКС($D11:$N11;СУММПРОИЗВ(МАКС(($D11:$N11>$O$10)*СТОЛБЕЦ($D$11:$N$11)-3)))
Автоматизация группировки строк, Нужна помощь в автоматизации группировки большого количества строк
 
Вариант2
Код
Sub iGroup1()
Dim iLastRow As Long, i As Long
Application.ScreenUpdating = False
ActiveSheet.Outline.SummaryRow = xlAbove
  iLastRow = Cells(Rows.Count, 1).End(xlUp).Row
    For i = 1 To iLastRow
    If Cells(i, 1) <> "" Then
    Rows(i + 1).Group
    End If
    Next
Application.ScreenUpdating = True
End Sub
Как посчитать итоговую сумму по клиенту одной формулой на весь лист
 
Здравствуйте.
Вариант в файле и посмотрите здесь
Ссылка на лист левее
 
Вариант формулами, но макросы должны быть включены. Список листов в диспетчере имен.
Изменено: gling - 26 Ноя 2019 23:53:16
Как организовать три подчиненных выпадающих списка статей?.., Как организовать три подчиненных выпадающих списка статей?..
 
Здравствуйте. Посмотрите здесь, составьте базу трёх уровней в соответствии с примером. А в вашем файле ничего не нашел, даже выпадающего списка первого уровня.
Цитата
выделенные в диапазоне цветом, сформированы для визуального понимаия
В выделенном диапазоне всё разбросано, что к чему понять не смог. Наверно нужно знать ин. язык.
Изменено: gling - 26 Ноя 2019 22:40:36
Подсчёт продаж товара по месяцам
 
Я оправлял файл с другой формулой, в сообщении #9 написал как нужно сделать, вы даже не попробовали. Если хотите за 10 дней каждого месяца считать, то в формуле из сообщения #9 измените дату конца периода, обозначьте её как начало периода +10. Если создать ячейку в которой нужно будет заносить нужное количество дней, то конец периода будет "ячейка начала периода+ячейка с количеством дней".  
Изменено: gling - 15 Ноя 2019 12:41:45
Подсчёт продаж товара по месяцам
 
Цитата
Сергий написал:
А как сделать
А так и сделать, две ячейки начало периода- конец периода
Код
=СУММЕСЛИМН('Исходные данные'!$D$1:$D$146;'Исходные данные'!$C$1:$C$146;Результат!$B2;'Исходные данные'!$B$1:$B$146;">="&ячейка начала периода;'Исходные данные'!$B$1:$B$146;"<"&ячейка конец периода)

А что сводная не подходит? Если нажать на фильтр даты в сводной, можно выбирать любые периоды, поэксперементируйте.

Изменено: gling - 15 Ноя 2019 12:11:20
Определение текстового значения в ячейке с несколькими значениями
 
Здравствуйте. Попробуйте функцию СУММЕСЛИМН(), формула будет приблизительно такая
Код
=СУММЕСЛИМН($D$1:$D$14;$A$1:$A$14;">="&$N$1;$A$1:$A$14;"<="&$N$2;$E$1:$E$14;"*"&J1&"*")*24*60
Изменено: gling - 15 Ноя 2019 11:47:02
Подсчёт продаж товара по месяцам
 
А сводная таблица не подойдет? А формулами как считать 18 и 19 год по месяцам вместе?
Изменено: gling - 15 Ноя 2019 01:34:44
возврат значений со смещением
 
Цитата
meidiland написал:
должно быть "Смещение"
Ежели так уж хотите.
Код
=ЕСЛИ(ОСТАТ(СТРОКА(A3);3);"";СМЕЩ($A$2;СТРОКА(A3)/3-1;;1;))
Подтянуть информацию из массива данных при соблюдении нескольких условий
 
Цитата
Светлана написал:
а вот даты уведомлений у них разные
Если это всегда так, можно проще
Код
=СУММЕСЛИМН(H:H;G:G;A2;I:I;B2)
Взять значения из одной ячейки и вставить их в другую после 4 символа
 
Ответ удалил. Сломал язык при обращении по Нику.
Изменено: gling - 13 Ноя 2019 22:18:51
Поменять формулы в фигурах
 
Вариант.
Цитата
С. Петров написал:
Даже направлению поиска
Поищите в файле, может что то и найдете.
как сделать активный выпадающий список с временем
 
Здравствуйте. Вариант в файле. Не совсем так как хотелось бы, но близко к этому. Время начала >= Времени окончания предыдущей работы. Новые листы нужно будет создавать из листа 13, в результате создадутся и именованные диапазоны на листах. Иначе придется для каждого листа писать свою формулу в проверке данных, так как нужно проверять ячейки на своём листе.
Изменено: gling - 13 Ноя 2019 11:15:11 (Заменил файл.)
Проверка данных - запрет на выполнение формулы по условию из другой ячейки
 
Цитата
если в столбце "Наличие" было "нет"
Вариант.
Код
=И(ОСТАТ(D3;C3)=0;B3<>"нет")
=И(ОСТАТ(D3;C3)=0;B3="есть")

Для столбца стоимость

Код
=ЕСЛИ(B2="есть";D2*E2;0)

Или я не так понял?
Изменено: gling - 12 Ноя 2019 11:57:10
Выбор дат и перестановка их в нужные ячейки
 
Здравствуйте. Вариант в файле.
Код
=ЕСЛИ(ЕЧИСЛО(--B3);B3;A2)
Поиск по 2 значениям в горизонтали
 
Здравствуйте. А может быть сводной таблицей попробовать?
Печать заданных строк
 
Цитата
nemo1975 написал:
можно реализовать?
Может быть так?
Удаление дубликатов строк по двум значениям в двух столбцах
 
И Вам здравствовать! Вариант в файле, то что не нужно скрыто фильтром.
Изменено: gling - 11 Ноя 2019 22:01:55
Печать заданных строк
 
Вариант, перед печатью столбец 1 скрыть.
сумма ячеек диапазона с условием
 
Цитата
Vik_tor написал:
как же не мешает
Точно, мой косяк, не проверил результат, можно в D2 поставить тире или убрать эту часть формулы.
сумма ячеек диапазона с условием
 
Цитата
Vik_tor написал:
уберите первую часть формулы
Это оставил на перспективу, а вдруг нужно будет суммировать по группе2 и группе3 вместе, или появится еще группа4. Эта часть не мешает конечному результату.
сумма ячеек диапазона с условием
 
Здравствуйте. Вариант в файле.
Код
=СУММЕСЛИМН(ИНДЕКС(план!$D$3:$M$7;ПОИСКПОЗ($B4;план!$B$3:$B$7;););план!$D$2:$M$2;рабочий!C$2&"*")+СУММЕСЛИМН(ИНДЕКС(план!$D$3:$M$7;ПОИСКПОЗ($B4;план!$B$3:$B$7;););план!$D$2:$M$2;рабочий!C$3&"*")
Как связать ячейку с другой книгой, в которой меняются расположения строк
 
Здравствуйте. Вариант в файле. Только нужно избавиться от объединенных ячеек. А если лист из ежемесячного файла переносить в Макет, то будет гораздо удобнее и всегда под рукой вся статистика за собранный в файле период.
А если еще немного поработать с файлом, можно будет выбирать периоды по месяцам и сравнивать их в разных годах.
Изменено: gling - 5 Ноя 2019 09:10:40 (Заменил файл.)
как связать несколько(более 3-4) ячеек со списками чтобы они зависели друг от друга
 
Здравствуйте. Покажите в примере, что нужно связать и с чем. У вас в файле на листах справочник Воздух и Лист3 не из чего выбирать, каждому наименованию соответствует одна строка. По этим данным нет необходимости организовывать несколько выпадающих списков, достаточно одного "Наименование", а остальные данные из таблиц подтянутся формулой =ВПР()
Автоматизация теста в excel (VBA)
 
Здравствуйте.
Цитата
bronzor написал:
затем в ячейки C6 создаётся
"Затем", за чем? После чего? Что должно произойти чтобы создался список? Если просто хотите создать много ячеек с выпадающими списками, каждый со своим диапазоном, то пропишите для выпадающего списка в С2 диапазон B2:B5. Копируйте эту ячейку в С6 и у вас выпадающий список с новым-своим диапазоном. Хотите скрипт, пишите цикл  вставки скопированной ячейки с шагом 4.
Как записать высчитанный макросом диапазон в формулу Excel?
 
Цитата
Griver написал:
получится очень громоздкой
Вы знаете эту формулу?
Формула последней заполненной строки в диапазоне
Код
=СУММПРОИЗВ(МАКС((A1:P21>0)*СТРОКА(A1:P21)))

Формула последней заполненной ячейки в столбце А

Код
=ПОИСКПОЗ(9^9;A:A;1)

Был бы файл пример, может что то и предложили, более близкое к решению вашей задачи, но не вами придуманным способом.

Как записать высчитанный макросом диапазон в формулу Excel?
 
А зачем макросом искать? Пропишите всё в формуле.
Гиперссылка на нужную таблицу
 
Цитата
Hops-c написал:
Как сделать чтобы при нажатии на ячейку, мне кидало нужный график?
В какой ячейке выберите, туда и прыгнет. Можно сделать и при нажатии на ячейку. Только что делать дальше с диаграммой, отправлять её на старое место обитания или нет?
Как убрать сдвиг слова в ячейке с формулой
 
=СЖПРОБЕЛЫ(СЦЕПИТЬ(A3;" "......
Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 119 След.
Наверх