Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Выбрать дату в календареВыбрать дату в календаре

Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 123 След.
VBA. Удаление строк, в которых непустая ячейка в столбце
 
Цитата
Mershik написал:
все  Hugo ,  msi2102 ,  расходимся ваши предложения не помогли)
Да, нужно было решение, а не путь к нему.
Как просуммировать значения найденные по суммесли на всех листах, с учетом того что кол-во листов будет постоянно добавляться, никак не увязать суммессли и трехмерную ссылку
 
Здравствуйте. Вариант формулами
Код
=ЕСЛИОШИБКА(СУММПРОИЗВ(СУММЕСЛИМН(ДВССЫЛ("'"&$I$1&"'!G10:G1000");ДВССЫЛ("'"&$I$1&"'!B10:B1000");A2;ДВССЫЛ("'"&$I$1&"'!C10:C1000");B2;ДВССЫЛ("'"&$I$1&"'!E10:E1000");C2));"Листа "&$I$1&" нет в этой книге")
Автоматический отображение данных из ячеек в форму textbox
 
Здравствуйте.
Тыкните ячейку в столбце В дальше первой строки.
Ошибки пр обновлении сводных, построенных на основе таблицы БД
 
Здравствуйте.
Обычно такое пишет если в шапке базовой таблицы имеется пустая ячейка. Все ячейки шапки базовой таблицы должны быть заполнены именами, каждый столбец должен иметь своё название. Не допускается отсутствие названия столбца в базовой таблице, если этот столбец в ходит в диапазон построения Сводной таблицы. Возможно есть скрытые столбцы без названия. Проверьте внимательнее.
Объединить массив ячеек с данными в одну
 
Цитата
Valeriy Chuperka написал:
Есть какие нибудь другие варианты ?
Здравствуйте. Вариант в файле, UDF взята здесь. Макросы должны быть включены.
Изменено: gling - 17 сен 2020 22:12:04
Изменение формул в ячейках в зависимости от выбранного результата из выпадающего списка
 
Попробуйте как вам уже предложили, так:
Код
G9 =ИНДЕКС(Данные!B4:G109;ПОИСКПОЗ(G6;Данные!A4:A109;);ПОИСКПОЗ(G8;Данные!B2:G2;))
G10 =ИНДЕКС(Данные!B4:G109;ПОИСКПОЗ(G7;Данные!A4:A109;);ПОИСКПОЗ(G8;Данные!B2:G2;))
Изменено: gling - 17 сен 2020 10:50:13
Изменение формул в ячейках в зависимости от выбранного результата из выпадающего списка
 
Здравствуйте. Не понятно в каких ячейках формулы и что должно меняться.
Цитата
Macvaer написал:
есть две ячейки с формулами
Адреса у ячеек есть?
Цитата
Macvaer написал:
листе 1
Имя "Лист1" в файле отсутствует, возможно речь о листе "Расширительный бак". Но там много формул, а куда указывают стрелки, там формул нет. Так что надоть?
Расчет процента премии в зависимости от выполнения плана
 
Так наверно.
Код
=ПРОСМОТР($B2;$B$1:$E$1;$B$6:$E$6)
Расчет процента премии в зависимости от выполнения плана
 
Здравствуйте.
А может так? Формат ячейки %
Код
=ПРОСМОТР($B2;{0;0,95;1;1,01;1,02};{0;0,01;0,02;0,03;0,04})
=ПРОСМОТР($B2;{0;0,95;1;1,01;1,02};{0;0,2;0,5;0,6;0,8})
Изменено: gling - 17 сен 2020 09:20:55 (Изменил формулы, загрузил файл)
Из текстовой строки дата с временем получить только дату VBA
 
Здравствуйте. А может так?
Код
Sub Дата_из_текста()
    Dim r As Range
    With ActiveSheet
        Set r = Intersect(.UsedRange, .[a:a]).Offset(1)
        r.Replace What:=" *", Replacement:=""
        'r.FormulaLocal = r.FormulaLocal
        'r.NumberFormat = "dd.mm.yyyy"
    End With
End Sub

Копирование только значений (НЕПУСТЫХ ячеек) из одного массива в другой
 
Здравствуйте. Включаете запись макроса макрорекордером - Копируете Массив копирования - Активируете левую верхнею ячейку Массива вставки - открываете специальную вставку - ставите галку Пропускать пустые ячейки - ОК - Выключаете запись макроса. Всё макрос готов, можно пользоваться, при необходимости можно подправить и изменить ячейки. Но зачем это надо, если и без макроса можно быстренько всё сделать.
Хотите закрасить ячейки с числами, тоже не сложно. Выделяете диапазон--жмете F5 - Выделить - константы - оставляете галку на числа - ОК - Выбираете нужный цвет заливки ячеек.
Изменено: gling - 29 авг 2020 02:12:32
Как указать в СУММEСЛИ(МН) условия для интервала дат?
 
Здравствуйте! У вас в файле вторая дата записана так "'<01.01.1970" уберите ненужный апостроф , будет считать.
Внесение данных в определенный столбец относительно даты.
 
Здравствуйте.
Вариант
Код
=ЕСЛИ(E$1>=МЕСЯЦ($C2);"";ЕСЛИ(E$1>=МЕСЯЦ($B2);$D2;""))
Специальная вставка фрагмента в Word из Excel
 
Цитата
buchlotnik написал:
нет в ворде
А Word обзывает так кнопку
Подсчет повторяющихся событий в табеле, Подсчет повторяющихся событий в табеле за всё время и по месяцам
 
Цитата
Андрей Андреев написал:
что значит разделить
Разделил, смотрите столбец В.
Подсчет повторяющихся событий в табеле, Подсчет повторяющихся событий в табеле за всё время и по месяцам
 
А как бы вы хотели? Если отпуск в конце мая весь июнь и заканчивается в июле, сколько отпусков должно посчитать, 3 в каждом месяце по одному?  Чтобы так считало, разделите конец месяца и начало другого пустой строкой, тогда считать будет в каждом месяце отдельно.
Изменено: gling - 9 авг 2020 19:52:06
Три диаграммы(Линейная, Линейная, Столбиковая) собрать вместе
 
Здравствуйте.
Так надо?
Подсчет повторяющихся событий в табеле, Подсчет повторяющихся событий в табеле за всё время и по месяцам
 
Может добавить ещё условие?
Код
=СУММПРОИЗВ((C$4:C$369="к")*(C$5:C$370<>"к")*($B$4:$B$369>=$K4)*($B$4:$B$369<=КОНМЕСЯЦА($K4;0)))
=СУММПРОИЗВ((C$4:C$369="о")*(C$5:C$370<>"о")*($B$4:$B$369>=$K4)*($B$4:$B$369<=КОНМЕСЯЦА($K4;0)))
Выпадающий список по условию.
 
Здравствуйте.
Подправил формулу, чтобы не ругалась.
Код
=СМЕЩ('1'!$A$2;;ПОИСКПОЗ('2'!$A2;'1'!$A$1:$C$1;)-1;СЧЁТЗ(ИНДЕКС('1'!$A$2:$C$8;;ПОИСКПОЗ('2'!$A2;'1'!$A$1:$C$1;))))
Удаление текста между "(" и ")", как удалить любое значение между скобками
 
А такой вариант не подойдёт?
Ctrl+H -- Найти:  (*) -- Заменить на: ничего не пишем -- Заменить все
Выбор оператора для решения задачи (Поиск, Индекс, Неравенство), Работа с массивом
 
Для точного совпадения формула, какой выдаст результат столько совпадений.
Код
=СЧЁТЕСЛИ(H:H;D2)
Выбор оператора для решения задачи (Поиск, Индекс, Неравенство), Работа с массивом
 
У вас на картинке адреса с индексами и формулой вы ищите точное совпадение. Вашу формулу может заменить СЧЁТЕСЛИ().
В файле в столбце H нет индексов и формула СЧЁТЕСЛИ() без дополнительных преобразований данных не справится.
Так что вы хотите, определить наличие адреса в столбце H по неточному совпадению, так как адрес в столбце D с индексом? Или же вы хотите определить точное совпадение адреса в столбце H?
Изменено: gling - 4 авг 2020 23:26:25
Не работает макрос для создания выпадающего списка, Макрос не работает при копировании на другие листы в файле
 
Цитата
Energo73 написал:
Когда это повторил для другого, то вообще непонятное началось
Здравствуйте.
Цитата
Energo73 написал:
Вставил этот код в лист23
Зачем вставлять? Копируете лист с работающими списками ПКМ по ярлычку - Переместить или скопировать - Создать копию =галка - Показываете куда копировать - ОК. Переименовываете этот новый лист, в нём всё должно работать так-же как и в оригинале. Стирайте не нужные данные и вводите новые.
Как в сводной таблице сделать, чтобы столбец не учитывался при отборе?
 
Кросс
Раскрытие диапазона при фильтрации
 
Можно и без макроса. Раз вы всё равно объединяете ячейки вручную, то объединяйте их таким образом:
1. Первоначально в таблице все ячейки не объединены и вы в столбце В в ячейках которые будите объединять пишите нужное название объекта, например "Футбольное поле"
2. Объединяете ячейки столбца D и в объединенной ячейке пишите формулу (это вы делаете при формировании таблицы).
3. Копируете эту объединенную ячейку и вставляете "Специальной вставкой" - Форматы - ОК в ячейку В2.
После этого фильтроваться должно так как вам и нужно.
Сравнение значения со списком и подставление значения из списка, работа со списками
 
И вам здравствовать, уважаемый Maxim -!
Попробуйте ВПР()
Формула для нахождения суммы цифр в столбце до пустой строки.
 
Здравствуйте.
Ещё вариант, тоже формула массива.
Код
=ЕСЛИ(ЕТЕКСТ(B1);СУММ(ИНДЕКС($C$1:C1;ПОИСКПОЗ("яя";$A$1:A1)):ИНДЕКС(C1:C190;ПОИСКПОЗ(;ДЛСТР(B1:B190);)));"")
Раскрытие диапазона при фильтрации
 
Здравствуйте.
Вариант в файле.
Изменение номера строки в ссылках в значениях нескольких ячеек
 
Цитата
oleg9911 написал:
как это редактировать?
ПКМ по кнопкам - Формат объекта - Элемент управления
Изменение номера строки в ссылках в значениях нескольких ячеек
 
Здравствуйте.
Вариант без макросов.
Изменено: gling - 2 авг 2020 10:28:01 (Заменил файл. Счётчик начинается с 1.)
Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 123 След.
Наверх