Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Выбрать дату в календареВыбрать дату в календаре

Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 127 След.
Склейка большого количества ячеек по условию
 
Может статья поможет или эта.
Изменено: gling - 21 апр 2021 00:35:04
Выборка данных среди множества занчений
 
Здравствуйте.
Попробуйте функцию СРЗНАЧЕСЛИ() или СРЗНАЧЕСЛИМН() если у вас такие есть.
Изменено: gling - 19 апр 2021 19:50:58
Посчитать прерываемый стаж с нескольких листов
 
Здравствуйте.
Вариант со списком листов в именованном диапазоне. Для правильной работы формул макросы должны быть включены.
Код
=СУММПРОИЗВ(СУММЕСЛИ(ДВССЫЛ("'"&Листы&"'!C1:C10");D8;ДВССЫЛ("'"&Листы&"'!F1:F10")))
Печать колонтитулов через VBA
 
Здравствуйте.
У меня нет принтера, но когда я отправляю на печать и сохраняю в формате .XPS сохраняется правильно. Можно попробовать перед отправкой на печать задавать область печати листа отправляемого на печать. Тогда на принтер всегда будет отправляться только один лист с колонтитулами которые туда вставятся для этого листа. Или попробовать складывать эти файлы в формате .XPS в определенную папку с номерами файлов, отправлять все файлы на печать, а после удалить эту папку. Других идей пока нет. Может кто знает какой вариант и подскажет как это сделать.
Наверно лучше выводить на печать только диапазон нужного листа и так последовательно по каждому листу отдельно.
У меня получилось так:
Код
Private Sub CommandButton2_Click()
    Dim HPB As HPageBreak, rngHPB As Range, sum_page As Double, i As Long, j As Long, nl As Long, kl As Long
    Application.ScreenUpdating = False
        If ActiveSheet.Name = "Остатки на складе" Then 'обязательно условие - указание имени листа, иначе VBA пытается выполнить код на др. листах
            With Sheets("Остатки на складе")
'                If .HPageBreaks.Count > 0 Then
                    Set rngHPB = .HPageBreaks(.HPageBreaks.Count).Location
                    i = 8
                    For Each HPB In ActiveSheet.HPageBreaks
                        j = j + 1
                        Set rngHPB = HPB.Location
                        sum_page = Application.Sum(.Range(.Cells(i, 9), .Cells(HPB.Location.Row - 1, 9)))
                        If sum_page > 0 Then
                            If j = 1 Then
                                nl = 1
                            Else
                                nl = i
                            End If
                            i = HPB.Location.Row
                            kl = i - 1
                            .PageSetup.RightFooter = Join(Array("Итого по стр. ", j, Space(1), Format(sum_page, "0.00")))
                            .Range("A" & nl & ":J" & kl).PrintOut Copies:=1
                        Else: Exit Sub
                        End If
                    Next HPB
'                End If
            End With
        End If
    Application.ScreenUpdating = True
End Sub


Изменено: gling - 8 апр 2021 22:21:18
Удалить размноженное условное форматирование и воссоздать по новой
 
Цитата
Артур Рахматуллин написал:
Можно ли макросом их удалить и воссоздать по новой?
Да.
Выбрать строки по нескольким условиям
 
Здравствуйте.
Цитата
iAlex написал:
как вывести все строки во вкладку Result
Введите  формулу из сообщения #3 как формулу массива, а потом протягивайте.
Изменено: gling - 3 апр 2021 23:35:27
Подстановка значений в таблицу по диапозону дат
 
Цитата
Дмитрий Шульгин написал:
именно формулой
С доп столбцом
Код
=ИНДЕКС('Part 2 DATA'!A:A;ПОИСКПОЗ(СТРОКА()-8;'Part 2 DATA'!$K:$K;))
Подстановка значений в таблицу по диапозону дат
 
Здравствуйте.
А сводная таблица не вариант?
Подстановка значений в 3 ячейки по одному условию
 
Вариант Ігор Гончаренко, но не массивная. Нули скрыл в параметрах.
Код
=СМЕЩ($B$3;СТРОКА(B1);ПОИСКПОЗ($B$10;$B$3:$E$3;)-1)
Закрашивание планируемой даты платежа
 
Здравствуйте. Вариант в файле. УФ
Код
=И(D2>0;СЧЁТ($D$2:$I$2)=1)
Поиск до определенной ячейки
 
Код
=СЧЁТЕСЛИ(A1:ИНДЕКС(A1:F1;ПОИСКПОЗ("груши";A1:F1;));"яблоки")
Получить необходимое условие, удовлетворяющее интвервалу
 
Здравствуйте. А что не получается?
Код
=ЕСЛИ(И(A2>E2;A2<F2);J2;"Условие ???")
Перенос данных суммированием из одной таблицы в другую
 
Ещё вариант
Код
=СУММЕСЛИ(исходная!$A$3:$A$10;$B$1;ИНДЕКС(исходная!$B$3:$K$10;;ПОИСКПОЗ($A5;исходная!$B$2:$T$2;0)))
Условное форматирование на основе совпадения части текста в столбце
 
Вариант УФ столбца А.
Код
=ЕСЛИ(A2<>"";СЧЁТЕСЛИ(B:B;ЛЕВБ(A2;24)&"*");0)
Поиск по двум критериям в таблице, относящейся к выбранному городу
 
Цитата
buchlotnik написал:
как бы спасибо
Как бы и не за что, просто уточнил немного. Разъяснение это для ТС.
Вписать дату в нужный столбец в зависимости от вводимого значения
 
Пропишите это вначале кода
Код
If Target.Cells.Count > 1 Then Exit Sub
Поиск по двум критериям в таблице, относящейся к выбранному городу
 
Цитата
buchlotnik написал:
ДВССЫЛ(имя_таблицы)
Имя таблицы можно указать и без ДВССЫЛ, а если имя таблица будет прописано в ячейке, тогда надо ДВССЫЛ(ячейка с именем таблицы)
Как в сводной таблице поставить фильтр по месяцам?
 
Посмотрите здесь
Можете в гугле забить"группировка в сводной таблице excel" и вам будет видео на выбор.
Изменено: gling - 24 мар 2021 22:14:48
Как в сводной таблице поставить фильтр по месяцам?
 
Поставьте дату в название строк--ПКМ (правой кнопкой мыши) по столбцу с датами-- выбрать группировать--выбрать месяц и год--переместить эти столбцы в фильтр в списке полей. Можно воспользоваться поиском. чтобы посмотреть видео как это делается.
Изменено: gling - 24 мар 2021 22:08:14
Как в сводной таблице поставить фильтр по месяцам?
 
Цитата
Андрей написал:
нужно по фильтру выбрать любой из месяцев,
Группируйте и выбирайте.
Сохранение шага ссылки на ячейку при автозаполнении
 
И Вам здравствовать!
Не понятно как это хотите использовать, но пробуйте
Код
=ЕСЛИ(ОСТАТ(СТРОКА(A3);3);"";ИНДЕКС($A$1:$A$8;СТРОКА(A3)/3))
добавить в перекодирование латиница-кириллица количество замен символов
 
ixet, Если у вас в одной ячейке несколько одинаковых символов на английском, то после использования замены вы их все меняете на русский шрифт, по этому они уже второй раз в слове не заменяются. Подправьте немного код и будет считать правильно
Код
            'cell = Replace(cell, c, Mid(Rus, p, 1))
            cell.Value = Application.Substitute(cell, c, Mid(Rus, p, 1), 1)
Изменено: gling - 24 мар 2021 23:10:20
Преобразование формулы суммы по нескольким листам
 
Цитата
БМВ написал:
Ctrl+H и заменить это на то
Заменить: =МСК*Д!
На: =СУММ(МСК:РНД!
Изменено: gling - 21 мар 2021 22:48:53
Составная ссылка из нескольких значений в функции
 
Здравствуйте.
При сцепке у вас получился просто текст а не ссылка на диапазон. Чтобы текст преобразовать в диапазон нужно использовать ДВССЫЛ, например так ДВССЫЛ(СЦЕПИТЬ("'F:\DOC\Наташа\проба\[";B1;".xlsx]Лист1'!B:B")). Но ДВССЫЛ вроде с закрытыми книгами не работает и получится ли у вас не знаю, попробуйте при закрытой книге и при открытой. Сам я такого не пробовал.
Сводная данных относительно диапазона дат и доп. ячейки
 
Ещё вариант. Sbor2 с доработкой от Mershik, с выбором листов по номеру недели, в файле.
Код
Sub Sbor()
Dim LastRow As Long, j As Long, jj As Long, i As Long, a As Long, ii As Long
Application.ScreenUpdating = False
'Application.EnableEvents = False
Sheets("Счёт").Range("A7:F1000").Clear
a = 7
    For i = 1 To ThisWorkbook.Sheets.Count
    If Sheets(i).Name > 0 Then
        LastRow = Sheets(i).Cells(Rows.Count, 2).End(xlUp).Row
           With Sheets(i)
                For j = 2 To LastRow
                If .Cells(j, 1) >= Sheets("Счёт").Range("A2").Value And .Cells(j, 1) <= Sheets("Счёт").Range("B2").Value Then
                    For jj = j To j + 50
                        If .Cells(jj, 1) = "" Then Exit For
                    Next
                    For ii = j + 1 To jj - 1
                        If .Cells(ii, 1) = Sheets("Счёт").Range("C2").Value Then
                            .Cells(j, 1).Copy
                            Sheets("Счёт").Cells(a, 1).PasteSpecial Paste:=xlPasteFormats
                            Sheets("Счёт").Cells(a, 1).PasteSpecial Paste:=xlPasteValues
                            .Range(.Cells(ii, 2), .Cells(ii, 6)).Copy Sheets("Счёт").Cells(a, 2)
                            Sheets("Счёт").Range("A" & a & ":F" & a).Borders.LineStyle = xlContinuous
                            Sheets("Счёт").Range("A" & a & ":F" & a).Borders.Weight = xlThin
                            a = a + 1
                        End If
                    Next
                End If
                Next
            End With
    End If
    Next
Application.ScreenUpdating = True
'Application.EnableEvents = True
End Sub
Контекстно зависимый список в заданном диапазоне
 
Цитата
Georg7490 написал:
если задать группу Овощи и границу от 30 до 30, то в список попадает всего одно название
Тогда можно "Спис" заменить на
Код
=ИНДЕКС(Наз;ПОИСКПОЗ(форула!$B$3;АртГруп;0)):ИНДЕКС(Наз;ПОИСКПОЗ(форула!$B$4+0,1;АртГруп;1))
Контекстно зависимый список в заданном диапазоне
 
Здравствуйте.
Если в выпадающем списке пустые строки не мешают, то вариант в файле. Артикулы можно вписывать только существующие, иначе работать не будет. Можно попробовать не точный поискпоз если это надо.
Изменено: gling - 19 мар 2021 14:36:04
Копирование с одного листа в другой с изменением
 
Цитата
Алекс Семенов написал:
Из подходящего было обращение к ячейкам напрямую
В ячейке В6 впишите формулу
Код
='Лист О1'!A6&" еще одно слово"
Изменено: gling - 18 мар 2021 10:24:15
Извлечь текстовое значение первой отфильтрованной строки
 
Цитата
diman27 написал:
его надо просто копировать
Формулы не копируют значения, они вычисляют и на основе произведенных вычислений в ячейке отображается результат. Копирование можно выполнить вручную или макросом.
Извлечь текстовое значение первой отфильтрованной строки
 
Здравствуйте. В формуле первый аргумент 9-это сумма, а как хотите просуммировать текст?
Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 127 След.
Наверх