Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Выбрать дату в календареВыбрать дату в календаре

Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 111 След.
Сгенерировать ячейки с произвольными цветами, Нужно быстро создать около 300 ячеек с неповторяющимися цветами
 
Здравствуйте. Условное форматирование--Цветные шкалы. Но как получится различить 300 оттенков цветов не знаю.
Суммирование в зависимости от значения столбца А
 
А если и А и Б и против них значения, тогда какой результат в J12? Кроме того значения  ячеек E13:G13 сложить не возможно. Вы показали бы какой должен быть ответ при разных вариантах написания, может быть понятнее было бы.
Изменения адреса ячейки в строке формулы
 
Цитата
_Igor_61 написал:
="A"&B10
Эта конструкция как формула конечно же работать не будет, т.е. результат из А10 не подтянется. Чтобы работала как формула и подтянула значение из ячейки А10 ещё нужно её записать как ДВССЫЛ
Код
=ДВССЫЛ("A"&B10)
=ДВССЫЛ("A"&СТОЛБЕЦ(A1))
Выборка в последовательности, указанной на другом листе
 
Здравствуйте. Может так надо?
Код
=ЕСЛИ(ЕПУСТО(Лист2!$B3);Лист2!A3&"";ЕСЛИОШИБКА(ИНДЕКС(Лист1!A:A;ПОИСКПОЗ(Лист2!$A3;Лист1!$A:$A;));""))
Поиск конкретного значения в общей ячейке и разнесение по столбцам
 
Здравствуйте. Попробуйте конструкцию
Код
=ПСТР(ПСТР($A4;ПОИСК(B$3;$A4)+ДЛСТР(B$3);20);ПОИСК(" ≡ ";ПСТР($A4;ПОИСК(B$3;$A4)+ДЛСТР(B$3);20))+3;ПОИСК(";";ПСТР($A4;ПОИСК(B$3;$A4)+ДЛСТР(B$3);20))-ПОИСК(" ≡ ";ПСТР($A4;ПОИСК(B$3;$A4)+ДЛСТР(B$3);20))-3)
только у Вас названия в заказе и в таблице немного разные. Нули скрыл в параметрах.
Корректное удаление выбранной строки на листе через listbox
 
Здравствуйте. А если так записать
Код
            'Rows(rng.Row).Delete
            Rows(i + 2).Delete
Подсчёт количества заполненных ячеек
 
Можно так попробовать
Код
=СЧЁТЕСЛИ(A1:B1;"<>0")
Изменено: gling - 6 Окт 2018 22:59:51
Макрос: заменить источник данных сразу в нескольких сводных таблицах
 
Цитата
leslip написал:
Мне нужен макрос для замены источника данных сразу в нескольких сводных таблицах.
Это ключевая фраза. Далее необходимо показать файл с этими несколькими таблицами и объяснить что, откуда и куда.  Переделывать макрос не зная, что, откуда  и куда =сами понимаете  что можно нагородить.
быстродействие СУММЕСЛИ, при использовании СУММЕСЛИ в диапазоне 60 т. срок на 60 столбцов пересчет происходит очень долго
 
Цитата
ДмСмирнов написал:
приложил файл
А макрос где? В формате .xlsx макросы не живут, выложите пример в формате .xls или .xlsm.
быстродействие СУММЕСЛИ, при использовании СУММЕСЛИ в диапазоне 60 т. срок на 60 столбцов пересчет происходит очень долго
 
Цитата
gling написал:
но лучше бы увидеть всё в файле строк этак 10-20,
Возможно тормозит не формула, а работа макроса. Прогоните его работу пошагово через F8, посмотрите на какой строке идет долго обработка. Сами понимаете, что участникам форума это проверить, без вашего файла-примера, не получится.
Изменено: gling - 1 Сен 2018 09:05:36
быстродействие СУММЕСЛИ, при использовании СУММЕСЛИ в диапазоне 60 т. срок на 60 столбцов пересчет происходит очень долго
 
Здравствуйте. Попробуйте ограничить диапазоны на 70тыс строк,и отключите проверку ошибок, но лучше бы увидеть всё в файле строк этак 10-20, возможно есть формулы на других листа и они тормозят расчеты. СУММЕСЛИ не должна так тормозить.
Подсветка видимых дубликатов.
 
Тоже  с доп столбцом.
Суммировать время, записанное текстом
 
Код
=СУММ(C2:F2)*"1:30"  

Формат ячеек [ч]:мм

Изменено: gling - 28 Авг 2018 00:33:54 (Изменил формулу)
Выпадающий список из первых букв категорий (без доп. столбца), проверка данных: динамический список и формулы массива
 
Хотите оптимизировать напишите макрос, который будет создавать диапазон начальных букв на скрытом листе.
Доп столбцы облегчают вычисление формул, нужно еще посмотреть, что за формулы. Массивные формулы затрудняют вычисления при больших объемах. Формулы спрятанные в диспетчер имен работают как массивные. Вы в диспетчере имен создали формулы с использованием всего столбца, лучше этого не делать. И для чего создавать слово из 255 букв Я, достаточно просто написать "ЯЯЯ". Возможно это мало влияет на работу файла, но лишний пересчет, это лишнее время работы.
Если у вас много выпадающих списков, то они очень грузят файл, лучше от них избавиться и сделать на базе ActiveX c подгрузкой уже обработанных данных макросом.
Изменено: gling - 26 Авг 2018 22:54:33
Выпадающий список из первых букв категорий (без доп. столбца), проверка данных: динамический список и формулы массива
 
Цитата
TBaranessa написал:
требует руководство.
Но сомневаюсь что они тоже знают
Цитата
TBaranessa написал:
Про скрытые и суперскрытые силы
Создайте суперскрытый дубликат листа и именованный диапазон столбца с левсимв.
Выпадающие списки работают только с диапазонами на листе.
Перенос строки на новый лист при выполнение условия, порядок формирования нового листа с верху вниз без пустых строк, исходная строка должна сохраниться .
 
Цитата
joni-V написал:
для другой единицы технике) формулы перестают работать
Попробуйте еще вариант. Создайте дубликат листа и выберите на нем нужную технику.
Условное форматирование таблицы по по вхождению значения столбца городов в один из списков другой таблицы, Особое правило для форматирования таблицы
 
Еще вариант УФ.
Перенос строки на новый лист при выполнение условия, порядок формирования нового листа с верху вниз без пустых строк, исходная строка должна сохраниться .
 
Цитата
joni-V написал:
Или в место " 1 " писать количество  ?
Пишите количество. И диапазон 'Выбираем на спис. '!$A$5:$O$451 во всех формулах листа замените на реальный.
Не работает формула при перетаскивании вниз
 
Для ячейки L2 и можно тянуть вниз
Код
=СУММ($J$2:J2)/A2
Перенос строки на новый лист при выполнение условия, порядок формирования нового листа с верху вниз без пустых строк, исходная строка должна сохраниться .
 
А может без макроса и лишних листов подойдет? На листе ЛЗК в ячейке С11 выбрать объект на который списывается. Выпадающий список с объектами можно сделать в любой другой ячейке листа.
В столбце из данных дата и числа, оставить только даты в PQ
 
Здравствуйте. Автофильтр--Снять галку с 2018--ОК. Выделить что осталось--Delete  или ПКМ--Удалить--Удалить строки
Удаление переднего пробела в ячейке, Удалить пробел с условием, есть он или нет.
 
Может так попробовать? Для первого имени
Код
=ЛЕВБ(C4;ПОИСК(" -";СЖПРОБЕЛЫ(ПОДСТАВИТЬ(C4;"-";" -"))&" -")-1)
MIN MAX в диапазонах разной размерности
 
Так надо?
Выпадающий список по условию без применения "двссыл"
 
Цитата
Kirill Gureev написал:
через "двссыл" писал страшную формулу,
Действительно это не удобно, но так же и не удобно вписывать нужные данные в формулу, а если этих диапазонов нужно 10 или еще >? Может лучше написать простую не страшную формулу, в диспетчер имен и не заморачиваться какой столбец выбирать. В предыдущей формуле нужно вбивать в формулу каждый диапазон, а в этой формула сама его находит.
Код
=ИНДЕКС(Таблица1;;ПОИСКПОЗ(""&$A$1;Таблица1[#Заголовки];0))
Выпадающий список по условию без применения "двссыл"
 
Согласен. Но тема то как называется? Может и подойдет.
Выпадающий список по условию без применения "двссыл"
 
А может без ДВССЫЛ попробовать? Хотя тема так и называется.
Код
=ИНДЕКС((Таблица1[1];Таблица1[2];Таблица1[3]);;;Лист1!$A$1)
Изменено: gling - 14 Авг 2018 11:08:02
Поиск минимального значения по условию
 
Здравствуйте. Попробуйте формулу массива. Вводится одновременным нажатием Shit+Ctrl+Enter.
Код
=МИН(ЕСЛИ(($A$3:$A$13=D3)*($B$3:$B$13>0);$B$3:$B$13))
Сортировка по датам
 
Здравствуйте. У меня по датам сортирует. Попробуйте выделить столбец F --Текст по столбцам--Готово. И вновь попробуйте сортировку. В столбце F  у вас даты в текстовом формате, возможно Excel их и не распознает.
Как разбить столбец с текстом по условию формулой (определенный фиксированный текст в один столбец, оставшуюся часть во второй)
 
Не идеальный результат. Далее копируем столбец Е в другое место как значение и Текст по столбцам -- разделитель пробел, результат в столбцах L и далее.
Изменено: gling - 14 Авг 2018 09:07:38 (Заменил файл.)
Разница в минутах между датами без учета определенных условий
 
Цитата
Юрий М написал:
Скажите ему кто-нибудь
БМВ, Наркотики ещё большее зло, чем объединённые ячейки ))
Изменено: gling - 13 Авг 2018 23:53:52
Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 111 След.
Наверх