Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Выбрать дату в календареВыбрать дату в календаре

Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 117 След.
Сумма по нескольким столбцам по одному критерию
 
Здравствуйте. Вариант
Код
=ЕСЛИ(СЧЁТЕСЛИ($A$3:A3;A3)=1;СУММПРОИЗВ(($B$3:$N$13)*($A$3:$A$13=A3));"")
Найти минимальную сумму для повторяющегося номера, присвоить значение
 
Цитата
IrinaVN написал:
без предварительной сортировки
Вариант
Код
=ЕСЛИ(И((СЧЁТЕСЛИ($B$2:$B$49;B2)-1)>0;СУММ(D2:G2)=0);"удалить из списка";"актуальные значения")
или так
=ЕСЛИ(И(СЧЁТЕСЛИ($B$2:$B$49;B2)>1;СУММ(D2:G2)=0);"удалить из списка";"актуальные значения")
Изменено: gling - 17 Июн 2019 00:41:47
Каталог с выпадающими списками
 
Покажите кусочек вашей базы данных, и вариант с выпадающими списками.
При слиянии с вордом дата "ломается", а график не меняется после повторного открытия файла Ворд
 
Цитата
БМВ написал:
Можно сколь угодно делать примеры
Согласен, и не факт что файл с ошибкой выдаст ошибку на моём компе. Но попробовать можно.
При слиянии с вордом дата "ломается", а график не меняется после повторного открытия файла Ворд
 
У Вас первый вопрос про дату, а второй про график? Или это один и тот же вопрос "Дата неправильно отображается в графике который вставлен из Exсel  в Word?
При слиянии с вордом дата "ломается", а график не меняется после повторного открытия файла Ворд
 
Цитата
pikabu написал:
"\@ "dd.MM.yyyy"
Может нужен пробел перед слешем?
При слиянии с вордом дата "ломается", а график не меняется после повторного открытия файла Ворд
 
Цитата
pikabu написал:
но ничего не меняется.
После изменения формата нужно обновить поле. Или попробуйте сохранить и открыть вновь, а может получится. Еще замечал, что при написании формата в Word, пробелы имеют значение, не правильно поставленный пробел или отсутствие его может повлиять на результат. А может это мне показалось.
Изменено: gling - 16 Июн 2019 19:17:20
При слиянии с вордом дата "ломается", а график не меняется после повторного открытия файла Ворд
 
А поискать?
Группировка данных под один шаблон
 
Вариант в файле, с использованием ИНДЕКС+ПОИСКПОЗ, два диапазона - две формулы.
Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист1!$B:$D;ПОИСКПОЗ($A2;Лист1!$A:$A;);ПОИСКПОЗ(B$1;Лист1!$B$1:$D$1;));"")
=ЕСЛИОШИБКА(ИНДЕКС(Лист1!$H:$J;ПОИСКПОЗ($A2;Лист1!$G:$G;);ПОИСКПОЗ(G$1;Лист1!$H$1:$J$1;));"")
Как избавиться от пробелов, образующихся при выгрузке из 1С?
 
Цитата
kolyale написал:
Проблема с ВПР
Цитата
kolyale написал:
Как удалить НЕНУЖНЫЕ пробелы?
Задача в чём, удалить пробелы, заставить работать ВПР, а может нужно посчитать определенны данные из выгрузки 1С? Так и нужно было назвать тему соответственно, при чем здесь ВПР? Предполагаю, что название "Подсчет значений при не полном совпадении наименований" более подходит.
Можно и с ВПР
Код
=ВПР(A2&"*";'из 1С'!A:B;2;0)

Но в выгрузке есть одинаковые наименования, строки 4-6, при ВПР подтянутся только данные строки 4, а как должно быть, вам виднее.

Изменено: gling - 14 Июн 2019 23:29:30
Какой Макрос сможет это сделать!, настройка макроса
 
Цитата
veter9191 написал:
которые способны переработать вес в указанный спок.
На заказ не претендую, просто интересно как определяется тот, кто способен переработать? Хочу попробовать организовать это на формулах.
Изменено: gling - 12 Июн 2019 15:31:01
Поиск, выбор и счёт значения текста по двум первым словам
 
Цитата
как на счёт столбца А Лист2
А может столбца В?  Можно сводной таблицей.
Но если всё же нужно заполнять столбец А, тогда чем?
Изменено: gling - 12 Июн 2019 14:06:45
Сравнение с предыдущим имеющимся значением, использовать нужно одну формулу (без промежуточных вычислений и макросов)
 
Цитата
lif написал:
пример с ответом
Здравствуйте.
Подогнал под ответ.
Код
=ЕСЛИОШИБКА(ЕСЛИ(ЕПУСТО(C4);"";C4-ИНДЕКС($C$3:C3;ПОИСКПОЗ(9^9;$C$3:C3;1)));ИНДЕКС($C$3:C3;ПОИСКПОЗ(9^9;$C$3:C3;1))-$C$3)
Изменено: gling - 23 Май 2019 18:14:11
Сбор данных по условию и сортировка по значению
 
Здравствуйте. Может сводная таблица подойдет? Только 4 числа есть 2 одинаковые строки с С, так специально сделано?
Разбить диапазон в ячейке на несколько значений
 
Цитата
LeonUa написал:
Спасибо, но я не знаю как применить данную формулу.
Не думал, что это сложно. Вариант в примере, такой как я себе надумал. Если не так,то покажите в Вашем примере, как должно быть.
Разбить диапазон в ячейке на несколько значений
 
Цитата
LeonUa написал:
а что бы каждый год был в отдельной ячейке.
Попробуйте формулу с протяжкой вправо по строке
Код
=ЕСЛИ((ЛЕВБ($K$2;4)+СТОЛБЕЦ(A2)-1)<=--ПРАВБ($K$2;4);ЛЕВБ($K$2;4)+СТОЛБЕЦ(A2)-1;"")
Смещение расчета формулы на заданное кол-во столбцов.
 
Может так попробовать?
Код
=ЕСЛИ(ИЛИ(C$8<$C$4;C$8>=$C$4+$C$3);0;1-1/($C$3+1)*(C$8-$C$4+1))
Выпадающий список с условием
 
Цитата
pojaho написал:
Проблема в том, что столбец С заполняется формулой, а не связанным выпадающим списком.
Нет, проблема в том, что диапазоны в диспетчере имен SM; SN; SS и SW ссылаются на пустые ячейки и прописана в проверке данных непонятная формула. Переделал, посмотрите что делали не так.
Вставка рисунка в зависимости от условия.
 
Может опять не так понял, ещё вариант.
При изменении ячейки, сцепить результат, и вернуть начальное значение.
 
Кросс
Макрос. Разбивка Excel файла на разные файлы в зависимости от менеджера.в
 
Цитата
Мария - написал:
Я его к себе на комп сохранила, ничего
Нужно включить макросы и нажать "Бымц", а после заглянуть в папку где сохранили этот файл и проверить не появились ли там файлы с фамилиями менеджеров.
Вставка рисунка в зависимости от условия.
 
Цитата
Rvictor написал:
подпихнуть в значение"Foto" именованный  диапазон
Вариант в файле. Под реальный файл нужно будет переделать формулу диапазона
Изменено: gling - 11 Май 2019 22:40:50
Скопировать формулу для связанных выпадающих списков
 
Цитата
gling написал:
Поправил формулу в диспетчере имен и добавил еще одну.
Сравните её с той которая была и создал формулу для динамического диапазона "Критерии"
Скопировать формулу для связанных выпадающих списков
 
Здравствуйте.
Поправил формулу в диспетчере имен и добавил еще одну. Пробуйте.
Поиск в ячейке по определенным условиям?
 
Цитата
Angarov написал:
можно ли откинуть все знаки, которые находятся до (или после) определенного знака
Да, можно, в ваше примере ластиком или корректором, а в файле Excel формулой или макросом.
Поиск значения из таблицы, где должны точно совпадать лишь первые 4 символа
 
Вам это надо?
Код
=ВПР(ЛЕВСИМВ(E2;4)&"*";$A$1:$B$99;2;0)
Минимизировать расходы при поставке продукции от поставщиков к потребителям
 
Здравствуйте.
Цитата
prosto login написал:
Решая вручную, получился верный ответ (120)
А почему не показали ручной расчет? Формула посчитала правильно=192.
Вывод: или используется не та формула которая необходима для решения этой задачи, или неправильно выполнен расчет вручную.
Изменено: gling - 7 Май 2019 23:56:26
Подставить значения строки другого листа, если номер совпадает
 
Здравствуйте. Файл надо было прикрепить к сообщению
Как вставлять скопированную ячейку без изменения ее границ.
 
Здравствуйте. Попробуйте ПКМ (правая кнопка мыши) - Специальная вставка - Значения - ОК.
Поиск и подстановка текста из ячейки по двум условиям
 
Код
=ИНДЕКС('Копируем с GDocs'!D:Лист1!D;ПОИСКПОЗ(Лист1!C1&Лист1!A1;'Копируем с GDocs'!D:D&'Копируем с GDocs'!B:B))

Разберем немного формулу:

1. 'Копируем с GDocs'!D:Лист1!D- это что за диапазон? Не понятно с какого листа, а точнее на каком листе этот диапазон.

2. ПОИСКОЗ() имеет три аргумента (что ищем;диапазон где ищем; точное совпадение или нет)

3. 'Копируем с GDocs'!D:D&'Копируем с GDocs'!B:B-сцепка двух массивов (столбцов), а формулу не вводите как формулу массива

Не понятно, а какой результат вы хотели бы получить в В1?
Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 117 След.
Наверх