Выбрать дату в календареВыбрать дату в календаре

Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 128 След.
Удаление значений в строках и удаление пустой ячейки со сдвигом влево.
 
Здравствуйте. Выполните действия прописанные далее: Выделяете диапазон -- жмите кнопки Ctrl+H -- в Найти пишите букву h -- жмите Заменить всё --  в Найти пишите букву c -- жмите заменить всё -- Закрыть -- клавиша F5 -- Выделить -- Пустые ячейки -- ОК -- на ленте находите Удалить -- треугольничек рядом с кнопкой -- Ячейки, со сдвигом влево -- ОК.
Изменено: gling - 24.11.2021 21:56:16
Выборка ТОЛЬКО основных сотрудники категорий ВиП и РСП
 
Цитата
написал: в строке К
По вашим данным можно так. Для столбца К, а точнее в К10 формулу и тянуть вниз
Код
=СЧЁТЕСЛИМН(X10;$F$2;W10;"01.1*";AC10;"*П")
Разделение таблицу на листы по фамилиям
 
Здравствуйте.
Если немного изменить вашу таблицу (Лист1) и создать из неё сводную таблицу (Лист2), то можно без макроса создать листы по фамилиям. Для этого надо зайти на вкладку ленты = Работа со сводными таблицами -- Параметры -- слева раздел Сводная таблица -- против надписи Параметры нажать треугольник -- далее нажать Отобразить страницы фильтра отчёта... Должны сформироваться все таблицы по фамилиям.
Разделить сотрудников по категориям возрастным
 
Цитата
Скажите, пожалуйста, что с формулой не так?
Разделите условия по мужчинам и по женщинам отдельно.
типа так
Код
=ЕСЛИ((T7<=59)*(D7="Мужской")*(T7>=18)*(D7="Мужской")+(T7<=54)*(D7="Женский")*(T7>=18)*(D7="Женский");1;0)
Рассортировка/группировка данных из строки
 
Вариант в файле.
Изменено: gling - 26.10.2021 20:29:57
Рассортировка/группировка данных из строки
 
Здравствуйте. Либо файл не тот, либо вы спрятали данные так, что я их не нашел.
По описанию похоже, что сводная таблица выдаст вам нужный результат.
Сводная таблица по заказам с разных листов
 
Вариант в файле. Про гугл докс не знаю, что там работает а что нет.
Изменено: gling - 22.10.2021 13:31:22
Умножить числа из желтых объединенных ячеек на красные ячейки
 
А может формулу руками вписать в одну ячейку и протянуть по остальным, скрыв фильтром желтые ячейки?
Код
=ИНДЕКС($D$8:D9;СУММПРОИЗВ(МАКС(($C$8:C9="$")*СТРОКА($C$8:C9)))-7)*I9
Выпадающий список. При вводе первых букв запроса выдавать пример поиска
 
Цитата
DNail написал:
как можно сделать
Посмотрите здесь
Какая причина долгих расчетов без предварительного сохранения или открытия параметров экселя, почему скорость расчетов зависит от просмотра параметров экселя
 
Вы хотите сказать что если выбрать UDF_1 - происходит пересчёт долго, выбрать UDF_2 - происходит пересчёт быстро, вновь выбрать UDF_1 - происходит пересчёт быстро. Так? Одна и таже UDF работает по разному в зависимости от очереди выбора? Медленно работают все UDFки которые запускаются первыми после открытия файла? Для меня такое тоже загадка. Возможно это связано со способностями "Умных таблиц", у них есть своя способность вставлять формулы во весь столбец при изменении в одной ячейке, а здесь ещё накладывается "вычислить". Не знаю, возможно кому и нравится, но я стараюсь не использовать "умные таблицы" с макросами, да и с формулами тоже. На мой взгляд с обычными таблицами работать проще и удобнее.
Какая причина долгих расчетов без предварительного сохранения или открытия параметров экселя, почему скорость расчетов зависит от просмотра параметров экселя
 
Цитата
andylu написал:
Почему тормоз только на первом
При первом расчёте вставляется формула UDF в первую ячейку-- происходит пересчёт одной UDF-- вставляется во вторую ячейку происходит пересчёт двух UDF.....-- вставляется предпоследняя формула происходит пересчёт на одну меньше чем все--вставляется последняя формула происходит пересчёт всех UDF. Это конечно дольше, ведь в последующих пересчётах UDF уже вставлены и выполняется только последний пересчёт из описанного выше.
Какая причина долгих расчетов без предварительного сохранения или открытия параметров экселя, почему скорость расчетов зависит от просмотра параметров экселя
 
Цитата
andylu написал:
на первом выборе затрагивающем UDF будут тормоза
"Вычислить" это макрофункция работает как UDF, кроме того она в диспетчере имен, а там обычные функции работают как формулы массива. Как она точно работает не скажу, но предполагаю что работа происходит так: сработала макрофункция "вычисляй" в одной ячейке - следом включилась в работу UDF пробежалось по всем ячейкам где есть эта UDF, далее изменение во второй ячейке и вновь UDF включилось в работу и так далее до последней ячейки. И чем больше ячеек в таблице, тем дольше пересчёт. На больших объёмах наверно даже видно последовательность изменений данных в ячейках. Предполагаю если вместо использования "вычисляй", выбранные формулы вставлять в таблицу макросом и после  этого производить расчёт, будет быстрее работать.
Изменено: gling - 19.10.2021 22:30:11
Не подтягивает ВПР по условию ячейки в которой формула, Помогите, уважаемые гуру экселя. Всю голову сломал..
 
Цитата
Владимир Афанасьев написал:
объясните
Здесь есть пояснения.
Вставка нечётных строк на другой лист., Вставка нечётных строк на другой лист.
 
Может так?
Код
Private Sub CommandButton1_Click()
For i = 3 To 12 Step 2
    With Sheets("Лист2")
        .Range(.Cells(i, 2), .Cells(i, 6)).Value = Range(Cells(i, 2), Cells(i, 6)).Value
    End With
Next
End Sub
Как из таблицы с данными перенести информацию на другой лист по нескольким параметрам
 
Здравствуйте.
Вариант в файле.
обновление рабочего файла без открытия дополнительных файлов, Помогите, пожа
 
Цитата
New написал:
всё равно должен открыть ваш файл
И если файл "тяжелый", то макрос может работать долго, затрачивая время на открытие файла, пусть даже в скрытом режиме.
обновление рабочего файла без открытия дополнительных файлов, Помогите, пожа
 
Цитата
Viktoria N написал:
У меня сейчас так и работает
У меня немного по другому. Изменяем ставки и закрываем файл со ставками. При открытии файла 1, Excel предлагает обновить связи, если соглашаемся на обновление связей данные подтягиваются новые, если не соглашаемся на обновление данные остаются старые. Если при открытии файла обновление не выполнялось, то можно зайти на вкладку Данные в Изменить связи обновить нужные связи. А вот если открыть файл ставки при открытом файле 1, то обновление данных произойдет без запроса.
обновление рабочего файла без открытия дополнительных файлов, Помогите, пожа
 
Здравствуйте.
Попробуйте СУММПРОИЗВ(). Конечно-же адрес расположения файла будет ваш.
Код
=СУММПРОИЗВ('C:\Users\User\Downloads\[файл 2 ставки.xlsx]Лист1'!$D$3:$D$50*('C:\Users\User\Downloads\[файл 2 ставки.xlsx]Лист1'!$A$3:$A$50>=КОНМЕСЯЦА(F3;-1)+1)*('C:\Users\User\Downloads\[файл 2 ставки.xlsx]Лист1'!$A$3:$A$50<=КОНМЕСЯЦА(F3;0))*('C:\Users\User\Downloads\[файл 2 ставки.xlsx]Лист1'!$B$3:$B$50=B3))
Суммировать в ОТФИЛЬТРОВАННОМ списке только уникальные значения
 
Попробуйте функцию ПРОМЕЖУТОЧНЫЕ.ИТОГИ()
Как обойти округление и отображать сотые значения без округления?
 
Здравствуйте.
Вариант
Код
=--ЕСЛИОШИБКА(ПСТР(D4*1,2;1;НАЙТИ(",";D4*1,2)+2);D4*1,2)
Изменено: gling - 12.08.2021 21:32:19
Развернуть таблицу из горизонтальной в вертикальную
 
Может на одном листе так надо?
Код
=ИНДЕКС(S3:AW3;ПОИСКПОЗ(МАКС(S3:AW3);S3:AW3;))
Развернуть таблицу из горизонтальной в вертикальную
 
Здравствуйте. Формула для подтягивания даты
Код
=ИНДЕКС('Форма от руководителя'!$Q$2:$BS$2;ПОИСКПОЗ(P3;ИНДЕКС('Форма от руководителя'!$Q$3:$BS$130;СУММПРОИЗВ(('Форма от руководителя'!$F$3:$F$130='То, что должно получиться'!F3)*('Форма от руководителя'!$I$3:$I$130='То, что должно получиться'!I3)*('Форма от руководителя'!$E$3:$E$130='То, что должно получиться'!E3)*('Форма от руководителя'!$K$3:$K$130='То, что должно получиться'!K3)*('Форма от руководителя'!$N$3:$N$130='То, что должно получиться'!M3)*СТРОКА('Форма от руководителя'!$A$1:$A$128)););))
Суммирование данных с начала года до указанного последнего месяца
 
Если не хотите ничего менять, попробуйте так:
Код
=СУММ($C$8:ИНДЕКС($C$8:$C$19;ПОИСКПОЗ(G4;$B$8:$B$19;)))
Об организации и представлении план-факт(-ных) данных
 
Цитата
Kirill Gureev написал:
Спасибо.
Не пришлось долго ждать, даже три года не прошло.
ВПР по нескольким условиям со счетом значений из другого списка
 
Цитата
snatg написал:
всем раздает по 13 очков
Согласен. Не совсем разобрался в логике расчёта ваших формул. Попытаюсь разобраться.
Возможно это не просто ВПР, а расчёт предварительных параметров внутри функции ВПР()
Может формула массива подойдет?
Код
=ЕСЛИ(СЧЁТЕСЛИ(Spisok!E:E;B2);ВПР(СУММ(($B$2:B2=ТРАНСП(Spisok!$E$2:$E$8))*($G$2:G2=G2));S:T;2;);"")
Изменено: gling - 27.06.2021 21:52:30
ВПР по нескольким условиям со счетом значений из другого списка
 
Здравствуйте!
Цитата
snatg написал:
как избавиться от формул в столбцах O и  P на листе Data
Так не пишите их туда и всё. Запишите их в последнею с ВПР.
Код
=ВПР(ЕСЛИ(СЧЁТЕСЛИМН(Spisok!E:E;Data!B2);СЧЁТЕСЛИМН(Data!B:B;Data!B2;Data!G:G;Data!G2);"");S:T;2;)

Только у вас в списке Список Д+ фамилии должны совпадать с фамилиями на листе Дата. Сидоров не равен Сидоров В.

Суммировать с условием заполняемости ячеек из другой части таблицы
 
Здравствуйте.
Попробуйте такую формулу
Код
=СУММ(B10:ИНДЕКС(B10:M10;ПОИСКПОЗ(9^9;B5:M5;1)))
Суммирование цифр в одной ячейке.
 
Здравствуйте.
Возможно есть вариант проще, но я его не знаю. Попробуйте формулу массива
Код
=СУММ(ЕСЛИОШИБКА(--ПСТР(A1;СТОЛБЕЦ(A3:G3);1);0))
Добавить в макрос условие повтора
 
Здравствуйте.

Ответ выше.

Изменено: gling - 05.06.2021 17:28:08
Взять данные из таблицы, из верхней и нижней ячеек относительно ячейки с 0
 
И Вам не хворать!
Ничего не понятно. От куда вытащить, куда, почему рядом с 660, а не с 680 или 640?  
Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 128 След.
Наверх