Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Выбрать дату в календареВыбрать дату в календаре

Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 55 След.
Скрыть строчки по условию
 
Код
....= "test"
Показать диапазон дат в формате месяца в зависимости от попадания в срез.
 
Цитата
pumasky2 написал:
Сейчас перезалью файл
у Вас ошибки в каждом фрукте
Изменено: Catboyun - 24 Дек 2018 14:06:48
Показать диапазон дат в формате месяца в зависимости от попадания в срез.
 
вопрос снимается по апельсинам.
вообще не понял.
почему начальные даты (т.е первый месяц продаж) не совпадают, а конечные при этом совпадают?
короче говоря описание не соот с файлом.
Изменено: Catboyun - 24 Дек 2018 13:55:01
Показать диапазон дат в формате месяца в зависимости от попадания в срез.
 
с Апельсинами что-то не так...
Поиск и удаление ячеек по значению
 
Цитата
Anton555 написал:
только надо на к примеру "+++", потом
зачем?
фильтр и пустоту понимает.
Поиск и удаление ячеек по значению
 
Цитата
Mershik написал:
удалит то что ищете
Цитата
random_object написал:
okno были удалены
да все правильно.
так и хотел ответить (вошел увидел Ваш ответ)
Цитата
Mershik написал:
CTRL+H
*okno* на ничего
Изменено: Catboyun - 24 Дек 2018 13:30:25
Подсчет по листам и результаты на отдельном листе с названиями листов
 
Цитата
prog_excel написал:
Первый вариант работает
не совсем, если убрать пробел в ячейке.
лучше используйте последнюю из #11
Подсчет по листам и результаты на отдельном листе с названиями листов
 
формулу в сооб. выше изменил (апнул на случай скачивания файла, до редактирования)
а лучше так
Код
=ЕСЛИОШИБКА(ЕСЛИОШИБКА(СРЗНАЧ(ДВССЫЛ("'"&B3&"'!B2:B11"));СРЗНАЧ(ДВССЫЛ("'"&ПОДСТАВИТЬ(B3;" ";)&"'!B2:B11")));"")
на случай отрицательных,
а еще лучше все же имена листов в ячейке писать в точном соответствии
Изменено: Catboyun - 22 Дек 2018 22:25:17
Подсчет по листам и результаты на отдельном листе с названиями листов
 
Код
=МАКС(ЕСЛИОШИБКА(СРЗНАЧ(ДВССЫЛ("'"&B3&"'!B2:B11")););ЕСЛИОШИБКА(СРЗНАЧ(ДВССЫЛ("'"&ПОДСТАВИТЬ(B3;" ";)&"'!B2:B11"));))
Цитата
artyrH написал:
у меня тоже не видит
все дело в '
Изменено: Catboyun - 22 Дек 2018 22:16:26 (формула была не доработана, изменил)
Столбец с названиями листов, копирование значения из соответствующего листа.
 
как-то так
=ЕСЛИОШИБКА(ДВССЫЛ("'"&I3&"'!B2");"")
Как сделать так чтобы свечи были на весь график , а не только вверху
 
так устроит?
Код
Private Sub Worksheet_Calculate()
    ChartObjects("bbb_").Chart.Axes(xlValue).MinimumScale = Application.Min(Range("K2:O15"))
End Sub
Проверка открытости/закрытости открываемой книги
 
Не понимаю Ваших действий конечно.
Код
    If IsBookOpen("Книга1.xls") Then
        'действия при открытой книге
    Else
        'действия при закрытой книге
    End If
Условное форматирование: после заполнения ячейки закрашивать расположенные слева
 
так нужно?
=И(СЧЁТЗ($A3:I3)=6;A3<>"")
Найти если в тексте содержится
 
=ПОИСК()
=НАЙТИ()
Как поставить одним действием знак равно в диапазоне ячеек
 
Цитата
otg666 написал:
что за функция
см. диспетчер имен (Ctrl + F3)
или вариант предложенный мной:
выделяйте A1:A5 и жмите кнопку
Изменено: Catboyun - 11 Дек 2018 19:54:17
Обновление и НЕобновление связей между книгами
 
Есть формулы, которые не работают с закрытыми книгами.
Запретить копи паст в определенные столбцы листа
 
Код
Private Sub Worksheet_SelectionChange(ByVal Target As Range)
    If Target.Column = 1 Then Application.CutCopyMode = False
End Sub
Target.Column = 1 or Target.Column = x
Как поставить одним действием знак равно в диапазоне ячеек
 
Код
    Selection.Replace What:=",", Replacement:="."
    Selection = Evaluate("""=""&" & Selection.Address)
Замена «0» на пустое значение
 
Цитата
Мотя написал: КОГДА ЖЕ?
Да простой пример:
На одном и том же листе где то нужно отображать, а где то нет.
'
Есть формат ячейки: 0;; и т.д.
'
Но Вам лучше знать какой самый лучший вариант.
Изменено: Catboyun - 4 Дек 2018 20:10:04
Замена «0» на пустое значение
 
Цитата
Мотя написал: Это - самый лучший вариант
не всегда.

еще варианты формул:
=ЕСЛИОШИБКА(ПОДСТАВИТЬ(СЧЁТЕСЛИМН(общее!$W:$W;A4;общее!$Y:$Y;B4;общее!$X:$X;C4)-1;-1;)+1;"")
=ЕСЛИОШИБКА(--ПСТР(-СЧЁТЕСЛИМН(общее!$W:$W;A4;общее!$Y:$Y;B4;общее!$X:$X;C4);2;15);"")
текст
=ПСТР(-СЧЁТЕСЛИМН(общее!$W:$W;A4;общее!$Y:$Y;B4;общее!$X:$X;C4);2;15)
Разделить по столбцам текст: до предпоследнего пробела и два последних слова
 
=ПСТР(A1;ПОИСК("\";ПОДСТАВИТЬ(A1;" ";"\";ДЛСТР(A1)-ДЛСТР(ПОДСТАВИТЬ(A1;" ";))-1))+1;99)
Изменено: Catboyun - 4 Дек 2018 01:35:08
На что перейти с Excel ?, Финансово-политический вопрос. И досужие домыслы, обусловленные поверхстным взглядом на ситуацию.
 
импортозамещение
https://myoffice.ru/products/
Определить время прибытия с учетом условия (не меньше указанного времени)
 
Цитата
Deagle3 написал: я даже теперь не знаю
массивная более универсальная.
Цитата
Deagle3 написал: для чего +1?
неточный ПОИСКПОЗ найдет число меньшее (наиболее близкое) или равное (если такое есть) к искомому,
а Вам надо число больше, значит следующее за найденным = +1.
если число не будет найдено формула выдаст ошибку, так вернее:
=ЕСЛИОШИБКА(ИНДЕКС(C4:C13;ПОИСКПОЗ(B15;C4:C13)+1);0)
но неточный поиск корректно работает только в упорядоченном диапазоне.
Определить время прибытия с учетом условия (не меньше указанного времени)
 
обычная
=ИНДЕКС(C4:C13;ПОИСКПОЗ(B15;C4:C13)+1)
для Вашей таблицы, где время упорядочено по возрастанию и <, а не <= подойдет.

файл из сооб.№4 смотрели?
Определить время прибытия с учетом условия (не меньше указанного времени)
 
=МИН(ЕСЛИ(B15<C4:C13;C4:C13))
Цитата
Mershik написал:
CTRL+SHIFT+ENTER
Подсчет стажа по дате приема
 
+1 добавьте не только в днях, но и в месяцах и годах.
фильтрация и очистка дубликатов без удаления ячеек ( и другого текста)
 
Код
Sub Filtr_chistka()

'
' чистка Макрос и построение
'

'
    'Columns("F:H").Select
    a = Cells(Rows.Count, "F").End(xlUp).Row
    ActiveWorkbook.Worksheets("итог").Sort.SortFields. _
        Clear
    ActiveWorkbook.Worksheets("итог").Sort.SortFields. _
        Add Key:=Range("F2:F" & a), SortOn:=xlSortOnValues, Order:=xlAscending, _
        DataOption:=xlSortNormal
    With ActiveWorkbook.Worksheets("итог").Sort
        .SetRange Range("F1:H" & a)
        .Header = xlYes
        .MatchCase = False
        .Orientation = xlTopToBottom
        .SortMethod = xlPinYin
        .Apply
    End With    
    
    For i = a To 2 Step -1    
        If Cells(i, 6) = Cells(i - 1, 6) Then
        Cells(i, 6).ClearContents
        End If
    Next i    
    
End Sub
Изменено: Catboyun - 28 Ноя 2018 12:52:15
фильтрация и очистка дубликатов без удаления ячеек ( и другого текста)
 
Сводная диаграмма должна справиться без макросов и т.п.
Подсчет стажа по дате приема
 
=РАЗНДАТ(A7;B7;"y")
и т.д.
Сборка заказа по непустым значениям
 
с весом не понял.
вариант доп.столбец +ВПР
Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 55 След.
Наверх