Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Выбрать дату в календареВыбрать дату в календаре

Страницы: 1
Выбор/Сумма значений из нескольких массивов данных
 
_Boroda_,о, значит урок пошел на пользу, осталось только "следить за руками" :)
Спасибо за помощь!
Выбор/Сумма значений из нескольких массивов данных
 
Экспериментирую,задал противоположные условия - выбрать оставшийся "статус исполнения", но по текущему месяцу....
Цитата
=СУММПРОИЗВ((C5:C14=C19)*МЕСЯЦ(СЕГОДНЯ()=A5:A14*ЕЧИСЛО(ПОИСК("Статус Исполнения";H4:S4))*H5:S14))

... получается бардак какой-то...

Поставил условие сразу же после проверки Товара - проверять еще и текущий месяц - видимо перемудрил ... Подскажите, что неправильно сделал?
Выбор/Сумма значений из нескольких массивов данных
 
Фух, Борода,  идеальное решение!!
Спасибо огромное всем за помощь!!!!
В качестве просьбы - где мне почитать "ликбез" именно в контексте написания вот этой формулы? чтобы восполнить пробелы :)
Выбор/Сумма значений из нескольких массивов данных
 
Формула ищет по "Товар". Т.е. если там будут другие названия, например "Запас Поставщика" "Груз в дороге" - нужно приводить к к общему маркеру...
Правильно прочитал формулу?
Выбор/Сумма значений из нескольких массивов данных
 
Да, работает!!! Спасибо!!!!

Теперь  буду разбираться в самой формуле.... И в одном и в другом решении, при нажатии значка"формула" все прописывается в одной строке.... "если число" так же ясно... а вот как формула ищет по всему диапазону - почему не залазит в "статус исполнения"?
Выбор/Сумма значений из нескольких массивов данных
 
Сейчас попробую
Выбор/Сумма значений из нескольких массивов данных
 
А без маркера (1) - никак не обойтись? :) (сорри)
Изменено: Yarrrolu - 12 Май 2015 17:28:14
Выбор/Сумма значений из нескольких массивов данных
 
ОНО!!!!!! ;)  Благодарю!!!!!

А где можно почитать о логике формулы массива? понять как самому прописывать
Выбор/Сумма значений из нескольких массивов данных
 
Я уже и базу данных и множественное суммирование приплетал..... не получается ( у меня), призабыл
Выбор/Сумма значений из нескольких массивов данных
 
The Best
Я так его тоже обманул :)

Ищу вариант формулы именно в ячейке, без доп колонок.
Выбор/Сумма значений из нескольких массивов данных
 
Здравствуйте,
Пытаюсь написАть формулу, которая без создания дополнительных промежуточных колонок сможет суммировать данные в нескольких диапазонах.  (т.к. если просуммировать, создав доп колонку значения в (G+H+I+K+L+M+O+P+Q) и воспользоваться СУММЕСЛИ, то искомые данные получаю)
Через сводную таблицу делать не хочу, интересно прописать именно формулу, без каких-либо дополнительных шагов.

Комментарий: в файле - упрощенная идея таблицы, где выбирая из списка наименование товара 1-3 (снизу), необходимо посчитать ВЕСЬ товар N, по всем Покупателям в колонках (G+H+I+K+L+M+O+P+Q).
Соответственно, выбрав из списка Товар 2 - должен быть автоматический пересчет по данному товару и по всем покупателям.

Прошу помочь с написанием формулы именно в ячейке D19.
Заранее благодарен
Ярослав
Изменено: Yarrrolu - 12 Май 2015 17:11:40
Страницы: 1
Наверх