Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Выбрать дату в календареВыбрать дату в календаре

Страницы: 1
перекодировка даты по условию, кодирование начального и конечного значения даты в интервал по условию
 
Забыли вложение
Вот только не надо умничать!
Защита ячейки с выпадающим списком от вставки (Copy/Paste)
 
Вроде верно, проверьте на данных.
Если вам помогло такое решение, советую разобраться с условным форматированием с применением формул.
Вот только не надо умничать!
Защита ячейки с выпадающим списком от вставки (Copy/Paste)
 
Цитата
Gabi написал:
Объясните пож-та, не совсем поняла про вставку значения?
1. Копируете нужные данные
2. Выбираете ячейку, куда нужно вставить -> правая кнопка мыши -> Специальная вставка -> Значения -> ок

Поясню. Подсветку сделал через условное форматирование. Если вы делаете обычную вставку, то условное форматирование с ячейки слетает и подсветки не будет. Чтобы этого избежать, используйте Специальную вставку -> Значения.  
Вот только не надо умничать!
Защита ячейки с выпадающим списком от вставки (Copy/Paste)
 
Попробовал сделать, чтобы при вставке значения не из списка подсвечивалась ячейка.
Но! Вставка должна быть только вставкой значения (иначе условное форматирование слетает).
Формула для условного форматирования: =ЕСЛИ(И(E2<>"";СЧЁТЕСЛИ('Период Активности'!A:A;E2)=0);1;0). форматирование установлено на ячейки E2:E100.
p.s. в моем примере ваш макрос удален.  
Вот только не надо умничать!
Заполнить по условиям готовый шаблон данными из источника
 
Для Вашей задачи подойдет стандартный функционал сводных таблиц.
Прикрепляю пример.
Форматирование сводной таблицы можно сделать собственное (заливку, границы и т.д.)
Вот только не надо умничать!
Форматировать определенные ячейки в зависимости от значения других
 
Вроде понял идею. Посмотрите.
Вот только не надо умничать!
Самопроставляющиеся гиперссылки
 
Если это делать с помощью стандартных формул - можно добавить столбец с критерием (например, значения 1 и 2), и при заполнении столбца с номенклатурами проставлять это критерий, по которому можно будет понять, где файл находиться. Но это может быть удобно, только в том случае, если количество номенклатур разумное. Если больше, то тут на помощь приходит макрос, тогда никаких "ограничений", даже по количеству мест поиска.
 
Изменено: СеменСеменыч - 21 окт 2015 18:51:14
Вот только не надо умничать!
Форматировать определенные ячейки в зависимости от значения других
 
 м
Изменено: СеменСеменыч - 21 окт 2015 18:41:36
Вот только не надо умничать!
Самопроставляющиеся гиперссылки
 
Можно, нужен конкретный пример.
Если есть критерий сортировки рецептур по разным папкам и этот критерий в самом названии, то это совсем просто.
Вот только не надо умничать!
Самопроставляющиеся гиперссылки
 
Попробуйте формулу =ЕСЛИ(B2="";"";ГИПЕРССЫЛКА("C:\Users\Documents\"&D2&".xlsx";D2))  
Вот только не надо умничать!
Форматировать определенные ячейки в зависимости от значения других
 
Цитата
aleks2015 написал:
если в таблице2 какой-то ячейки стоит число плюс еще прибавить это число к ячейке таблица1. как это сделать?
Не понимаю, что еще нужно плюсовать? можете пояснить.
Вот только не надо умничать!
Форматировать определенные ячейки в зависимости от значения других
 
Если нужно просто сравнить две таблицы, то условным форматированием можно так
Изменено: СеменСеменыч - 21 окт 2015 18:12:06
Вот только не надо умничать!
Ошибка Method "Range" of object 'Global failed, Составлена форма, забиты все данные, но при выполнении массива НарастИтог выходит эта ошибка. Помогите :-(
 
Исправил. На почту отправил.
Ошибка была все та же - в диспетчере имен в формуле выдает #ССЫЛКА.
Исправил по аналогии с другим "рабочим" макросом FillMassiv и рабочим диапазоном в диспетчере «MassivRange».
Проверяйте!
Вот только не надо умничать!
Ошибка Method "Range" of object 'Global failed, Составлена форма, забиты все данные, но при выполнении массива НарастИтог выходит эта ошибка. Помогите :-(
 
Цитата
victoriamsu написал:
выслать свою почту
Советую все-таки поработать над файлом и выложить на форум.
Стоит удалить лишние данные и оставить пару записей для примера.
Если не получится, отправляю почту в личку.  
Вот только не надо умничать!
Ошибка Method "Range" of object 'Global failed, Составлена форма, забиты все данные, но при выполнении массива НарастИтог выходит эта ошибка. Помогите :-(
 
Цитата
victoriamsu написал:
Был прикреплен неверный файл.
Вы поменяли файл? Или вопрос уже снят?
Вот только не надо умничать!
Ошибка Method "Range" of object 'Global failed, Составлена форма, забиты все данные, но при выполнении массива НарастИтог выходит эта ошибка. Помогите :-(
 
В "диспетчере имен" три имени с ошибочной формулой. VBA не может найти нужный диапазон.
Вот только не надо умничать!
Страницы: 1
Наверх