Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Выбрать дату в календареВыбрать дату в календаре

Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 749 След.
Как перенести содержимое одних столбцов в другие по определённому правилу?
 
Ну в целом готово, работает.
Выполнять по Alt+F8, выбрать макрос ImportfromCSV().
Исходный csv будет в том же каталоге, туда же будет сохранён и результат.
Далее можно доработать детали, по желанию.
См. личку.

Тут была книга...
Как перенести содержимое одних столбцов в другие по определённому правилу?
 
Сколько примерно всего данных? Вдруг пара миллионов - в csv такое может быть, может быть и больше... А в xls только 65к с небольшим.
Как перенести содержимое одних столбцов в другие по определённому правилу?
 
Да на выходе можно xls сделать, без проблем, это даже проще чем если бы они захотели какой хитрый csv.
Сейчас сделаю рабочий вариант, завтра проверите.
Изменено: Hugo - 12 авг 2020 20:00:58
Как перенести содержимое одних столбцов в другие по определённому правилу?
 
Т.е. пока я понял так - есть пустая форма как на листе КУДА, в ней нужно заполнить 6 столбцов данными из этого csv/xlsx.
Пустую строку из исходника так и копировать?
И да, открылся у меня этот csv кодом корректно в Экселе, даже удивительно... :)
Изменено: Hugo - 12 авг 2020 19:58:15
Как перенести содержимое одних столбцов в другие по определённому правилу?
 
Мой эксель кодом такой csv корректно думаю не откроет, мне нужен xlsx.
А по процессу - есть большая разница между копированием и переносом. Если нужно копирование - нет вопросов, скопируем. В xlsx. Делать?
Изменено: Hugo - 12 авг 2020 19:50:47
Как перенести содержимое одних столбцов в другие по определённому правилу?
 
Не, я пас, с таким csv работать тяжело. Если разделитель другой поставите, и его точно не будет в адресах - тогда всё проще и дешевле. И я не ценю час моей работы меньше чем Вы :)
Тогда проще работать с xlsx.
Ну и так пока и не понятны детали, Вы бы показали в одном например xlsx в одной строке исходные данные, в другой уже результат всех переносов. На одних данных естественно.
Как перенести содержимое одних столбцов в другие по определённому правилу?
 
Цитата
Михаил Тиняков написал:
Если есть возможность работать сразу с cvs, то будет круто…
- если cvs это csv, то можно, если файл позволяет. А его никто не видел...
Но в csv нет никаких других листов, могу предложить создавать другой файл.
А если делать - то кроме отсутствия файла не хватает информации что делать с содержимым столбцов E, F, B, G, J, A.
И соотв. если переносим - на прежних местах оставляем пустые ведь ячейки?
Изменено: Hugo - 12 авг 2020 19:34:46
Разнести данные из ячейки по разделителю
 
Код
Option Explicit

Sub tt()
    Dim a, i&, x&, y&, el, elel, col As New Collection

    a = [a1].CurrentRegion.Value
    With CreateObject("Scripting.Dictionary")
        .comparemode = 1    'текстовое сравнение
        On Error Resume Next
        For i = 2 To UBound(a)
            For Each el In Split(a(i, 6), "/")
                col.Add el, el
                If Not .exists(el) Then .Add el, New Collection
                .Item(el).Add i
            Next
        Next
        On Error GoTo 0

        y = 1    'тут пишем номер первой строки результата!

        For Each el In col
            ReDim b(1 To UBound(a), 1 To UBound(a, 2))
            For x = 1 To UBound(a, 2)
                b(1, x) = a(1, x)
            Next
            i = 1
            For Each elel In .Item(el)
                i = i + 1
                For x = 1 To UBound(a, 2)
                    b(i, x) = a(elel, x)
                Next
                b(i, 6) = el
            Next

            Cells(y, 1).Resize(i, UBound(b, 2)) = b
            y = y + i + 1
        Next

    End With

End Sub


Можете пробовать выполнить при
Россия/Китай/Франция
Россия/Франция
Россия/Китай
Изменено: Hugo - 12 авг 2020 18:49:33
PQ.. Вызвать функцию через другую функцию
 
Просто в названии нужно упомянуть что это про PQ. Как все делают. Другие.
Как создать несколько сообщений в 1 макросе
 
Так вроде и раньше в коде не наблюдается
Код
.Send

только всюду .Display...
P.S. Вот тут вроде как должно быть всё исчерпывающе. Но я не нашёл как "создать несколько сообщений в 1 макросе" :( В смысле отправить одно письмо сразу по нескольким адресам, обычно это делали давая их как массив, но т.к. оутлука не имею, проверить не могу...
А как в одном макросе отправить хоть 100500 писем - там есть :)
Изменено: Hugo - 12 авг 2020 16:54:47
Синхронизация двух таблиц Excel, Синхронизация двух таблиц с артикулами товаров
 
Из закрытого csv ничего тянуться не будет, как я помню. Проверил - у меня работает и с закрытым! Но как-то подозрительно, лучше открыть.
Работает так:
Код
=ВПР(E2;'C:\Users\Igor\Downloads\[Т1.csv]Т1'!$D:$D;1;0) (это с закрытым csv)
=ВПР(E2;Т1.csv!$D:$D;1;0)
=ВПР(D2;[Т2.xlsx]Таблица!$E:$E;1;0)
Изменено: Hugo - 12 авг 2020 13:08:40
Синхронизация двух таблиц Excel, Синхронизация двух таблиц с артикулами товаров
 
И это не получится никак... Не, вообще возможно, но с большим трудом.
Да и зачем, если просто можно использовать ВПР прямо вот так по месту, ничего никуда не выстраивая.
Синхронизация двух таблиц Excel, Синхронизация двух таблиц с артикулами товаров
 
Вообще задача какая-то странная - зачем синхронизировать таким образом? В чём тайный смысл?
И ВПР такой заказанной синхронизации по факту не даёт.
И ещё учтите - формулы в csv работают, но не живут! Что и видно в последнем файле.
Изменено: Hugo - 11 авг 2020 20:34:19
Макрос для скрытия пустых столбцов
 
Думаю что ВПР работает по категории, которую заполняет юзер.
Можно и по товару делать звёздочки и категории, но Вы реально предусмотрели все товары и все варианты из написания юзером?
Соотв. можно сделать выбор этих категорий из выпадающего списка, ну а далее и товар можно выбрать из списка, ну или вписать новый.
При выборе категории - сразу меняется состав видимых столбцов, и это просто. И дажде не нужно звёздочки делать, достаточно где-то иметь список соответствий.
Но свой пример делать я отказываюсь! :)
Вообще тут на форуме было много примеров файлов где по паре первых (или содержащихся) символов предлагался список наименований, вполне тоже можно прикрутить для ускорения безошибочного заполнения базы.
Как сделать макрос, который ищет, как впр, похожие данные
 
Код
Sub Макросик()
    Dim a, i&, t$

    With CreateObject("Scripting.Dictionary")
        a = Sheets("Таблица 2").ListObjects(1).DataBodyRange.Value
        For i = 1 To UBound(a)
            .Item(a(i, 1)) = a(i, 2)
        Next
        a = Sheets("Таблица 1").ListObjects(1).DataBodyRange.Value
        For i = 1 To UBound(a)
            t = Left(a(i, 1), 8)
            If .exists(t) Then a(i, 1) = .Item(t) Else a(i, 1) = Empty
        Next
        Sheets("Таблица 1").[c2].Resize(UBound(a), 1) = a
    End With
End Sub
Дата из Textbox переноситься как текст в диапазоне ячеек
 
Цитата
Voltz написал:
Получается, это не возможно?
- Вы читаете что Вам пишут? Где кто сказал что это невозможно? Даже больше - я написал как это возможно :)
Дата из Textbox переноситься как текст в диапазоне ячеек
 
Я исходя из описания посмотревших файл не смотрел, но обычно делают так - выбирают из текста год, месяц и день и формируют из этого дату.
Дата из Textbox переноситься как текст в диапазоне ячеек
 
А как Вы ухитрились в текстбокс поместить дату? Это же ТЕКСТбокс!
Вытащить значение по условию из одного листа в другой
 
Код
=ИНДЕКС(KiumCells!E2:E300; ПОИСКПОЗ(C6;KiumCells!A2:A300))

Но ВПР() ведь проще :)
Код
=ВПР(C6;KiumCells!A:E;5;0)

а чтоб очищалось - ну ЕСЛИ навесьте...
Изменено: Hugo - 6 авг 2020 22:06:34
Вытащить значение по условию из одного листа в другой
 
Есть задача - есть ВПР()
Удалить слова из ячеек по списку
 
New, там ещё application.trim() нужно навесить на результат.
Как получить список строк(записей) таблицы по критерию используя VBA?
 
Чуть производительнее собирать в коллекцию только номера строк исходного массива, он ведь ещё живой.
И затем перебирая for each эти номера можно брать данные сразу из исходного объекта.
Возможно ли наименованию столбца прописать префикс, если наименование похоже на 'ABC' (или содержит 'ABC'), Power Query M
 
Судя по примерам - если в названиях оставить только цифры и "кв" то этого должно быть достаточно. Как сделать в PQ - не знаю.
Изменено: Hugo - 5 авг 2020 16:46:49
Как убрать формулу round по всему документу Excel, Можно ли автоматически убрать формулу Round по всему документу.
 
По данному примеру можно макросом. А как там в рабочем файле - кто знает...
Цикл по ячейкам, читаем формулу - если в начале "=ОКРУГЛ(", то меняем ";2)" на ничего,  "=ОКРУГЛ(" на "="
Изменено: Hugo - 5 авг 2020 14:48:17
Счетчик печати документа, Изменять номер заказа после его печати
 
Так берите любой из показанных (они все у Вас есть в Вставка->Фигуры), пишите на нём что хотите.
Изменено: Hugo - 5 авг 2020 12:22:21
Счетчик печати документа, Изменять номер заказа после его печати
 
smalljohn,  можно я помогу? Выбирайте любую: http://prntscr.com/tuctjp
Суммирование чисел из ячеек с заливкой и со смешанными данными
 
Т.к. и так уже xlsm, то я бы не мудрил и взял любую UDF, извлекающую цифры, тем более что они только в начале.
Например вот, берите любую:
Код
Function GetNumeric(t As String)
    Dim j As Integer, l As String
    For j = 1 To Len(t)
        If IsNumeric(Mid(t, j, 1)) Then l = l & Mid(t, j, 1)
    Next j
    GetNumeric = Val(l)
End Function

Public Function ExtractNumber(s As String)
    Dim i As Integer, str As String, a$
    For i = 1 To Len(s)
        a = Mid(s, i, 1)
        If InStr(1, "1234567890,", a) Then str = str & a
    Next
    ExtractNumber = str
End Function
Изменено: Hugo - 5 авг 2020 11:00:18
сумма произведений по дате и условию
 
А почему 9, карл?
Не добавили такую мелочь как ФОРМУЛА МАССИВА!
Изменено: Hugo - 5 авг 2020 10:06:04
[ Закрыто] Связать два макроса, Задача связать два макроса со счётчиком
 
Код
Sub tt()

    With ActiveSheet.Shapes("Scroll Bar 7").OLEFormat.Object
'        .Value = 2
        .Min = 5 ' <====================
        .Max = 99
        .SmallChange = 5
        .LargeChange = 10
        .LinkedCell = "$C$2"
        .Display3DShading = True
    End With
End Sub
Перенести данные из нескольких файлов в один файл
 
Цитата
realmen80 написал:
Также не могу понять почему вместо русских букв - знаки вопросов стали...
- нужно копировать код при русской раскладке.
Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 749 След.
Наверх