Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Выбрать дату в календареВыбрать дату в календаре

Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 213 След.
Объединение строк по вертикали и фильтрация
 
Алексе Егоров, как уже ответили выше, нужно писать макрос.
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Объединение строк по вертикали и фильтрация
 
Нужно оббъеденить- объеденяйте. В чем вопрос?
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Контроль заполнения расчета по единой модели, при наличии сторонних моделей или записей отобразить рекомендацию
 
Добрый и Вам. Пример бы глянуть. Что есть, что хотите получить.
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Объединение строк по вертикали и фильтрация
 
Снимите объединение строк, а затем воспользуйтесь этой статьёй из Приемов Заполнение пустых ячеек значениями из соседних ячеек
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Объединение строк по вертикали и фильтрация
 
Добрый и Вам. Что мешает избавиться от объеденённых ячеек?
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
[ Закрыто] Помощь с таблицами, Из двух таблиц сделать одну
 
Вы же вчера такую же тему создали и там даже есть ответы.
И название вместо Вам предложили нормальное а не "Помощь с таблицами".
Изменено: Максим В. - 13 янв 2021 11:52:49
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Определить для частоты ее диапазон (НЧ, ВЧ...)
 
Цитата
mazersw написал:
Да, там пример сделал просто
Т.е. вы обращаетесь за помощью, но даже не удосужились указать правильный результат. От фонаря накидали. Ну что ж, круто.
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Присвоить верный номер лота по диапазону дат
 
Добрый и Вам. Ну в рамках первой группы понятно и мой результат совпал с Вашим. А дальше как происходит присвоение номеров?
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Определить для частоты ее диапазон (НЧ, ВЧ...)
 
А в столбце В что? Нужный результат?
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Найти дубликат и определить первую дату вхождения в список
 
Цитата
Алекс Пол написал:
очень хотелось бы без массива
Сортируйте даты от старых к новым. В столбце H формула
Код
=ЕСЛИ(СЧЁТЕСЛИ(G$4:G4;G4)=1;"Новый";"Старый")

Как видите результаты совпадают.

Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Найти дубликат и определить первую дату вхождения в список
 
Алекс Пол, Вам не кажется, что задача решится проще, если даты отсортировать от старых к новым?
Попытка №2. Формула массива:
=ЕСЛИ(СТРОКА()=МИН(ЕСЛИ(МИН(ЕСЛИ(G$4:G$105=G4;D$4:D$105*1))=ЕСЛИ(G$4:G$105=G4;D$4:D$105*1);СТРОКА(G$4:G$105)));"Новый";"Старый")
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Найти дубликат и определить первую дату вхождения в список
 
И Вам добрый. Так?
=ЕСЛИ(СЧЁТЕСЛИ(G$4:G4;G4)=1;"Новый";"Старый")
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Выборка из массива чисел месяца с соответствующим значением
 
Решение в файле
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Макрос на выборку данных из таблицы с дальнейшей подстановкой в столбцы
 
С такой задачей и формула справится. Массивная:
Код
=ИНДЕКС(Лист1!$C$2:$C$139;НАИМЕНЬШИЙ(ЕСЛИ(A$2=Лист1!$B$2:$B$139;СТРОКА(Лист1!$B$2:$B$139)-1);СТРОКА(A1)))
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Выборка из массива чисел месяца с соответствующим значением
 
Файл Эксель покажите. ЧТо есть, что нужно получить.
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Задать диапазон в формуле другой формулой
 
Добрый и Вам. Динамический диапазон с автоподстройкой размеров
Может не совсет то, но в качестве идеи.
Изменено: Максим В. - 5 янв 2021 12:06:23
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Поиск обратных пар дубликатов пунктов отправления и прибытия
 
Формула массива. Вводить следует сочетанием клавиш CTRL+SHIFT+ENTER.
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Поиск обратных пар дубликатов пунктов отправления и прибытия
 
А у меня ИСТИНА
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Поиск обратных пар дубликатов пунктов отправления и прибытия
 
И Вам здравствовать. В соседний столбец формула массива:
=ИЛИ(B$2:B2&A$2:A2=A2&B2)
Отфильтровать по ИСТИНА и удалить.
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Дата понедельника прошлой недели
 
Может так?
=B1-ДЕНЬНЕД(B1;2)-6
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Неправильно отображаются числа
 
У меня сумашествие не воспроизводится.
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Неправильно отображаются числа
 
А можно на это посмотреть?
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Переставить значения из сстолбца в строку с заданным шагом
 
Пробуйте:
Код
=ЕСЛИ(ОСТАТ(СТОЛБЕЦ()-6;3)=1;ИНДЕКС($D$7:$D$15;ОКРВВЕРХ((СТОЛБЕЦ()-6)/3;1));"")
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Переставить значения из сстолбца в строку с заданным шагом
 
И Вам с наступающим. Исходные действительно числа или это только для примера?
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
VBA. Сделать числа отрицательными (в зависимости от условия в соседнем столбце)
 
Как вариант:
1) Отфильтровали что нужно
2) Спецвставкой умонжили на -1
3) Сняли фильтр
У меня заняло 13 секунд
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
VBA. Сделать числа отрицательными (в зависимости от условия в соседнем столбце)
 
Цитата
Starik19 написал:
от условия в той же строка но в столбце A
И что это за условие?
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Подтянуть данные в таблицу, используя часть значения в ячейке
 
1) Где в файле из сообщения 10 предложенная мною формула?
2) Что по должна вернуть вот эта Ваша формула?
Код
 =ВПР("*" & A2 & "*";'Лист с данными'!$A$1:$E$16;1;ЛОЖЬ)
3) Попробуйте такой вариант:
Код
=ЕСЛИОШИБКА(ВПР("*"&$A2&",*";'Лист с данными'!$A$1:$E$16;СТОЛБЕЦ();ЛОЖЬ);ВПР("*" &$A2&"*";'Лист с данными'!$A$1:$E$16;СТОЛБЕЦ();ЛОЖЬ))
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Найти значение DOF/ и REG/ и показать их в отдельный ячейках
 
Это вы о чём? Совет (если вам действительно нужно решение задчи)
1) Предложите название темы отражающее задачу. К нынешнему названию у модераторов будут претензии.
2) Приложите нормальные пример на десяток строк, с различными вариантами исходных данных и желаемым результатом.
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Подтянуть данные в таблицу, используя часть значения в ячейке
 
Александр Шиллер, покажите файл в котором не работает.
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Подтянуть данные в таблицу, используя часть значения в ячейке
 
А если так?
=ВПР("*"&$A2&",*";'Лист с данными'!$A$2:$E$4;СТОЛБЕЦ();)
Изменено: Максим В. - 30 дек 2020 10:55:02
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 213 След.
Наверх