Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Выбрать дату в календареВыбрать дату в календаре

Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 158 След.
Анекдот дня, Постим сюда понравившиеся:)
 
Цитата
БМВ написал:
— Звучит заманчиво! А на хрена им программист?
:D  
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Количество дней от сегодня до необходимой даты
 
Добрый и Вам.
=C2-СЕГОДНЯ()
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Создать список сортировки по наличию числа
 
Формула для доп. столбца:
=--ПРАВСИМВ([@Столбец1];2)
Далее сортируйте по этому столбцу.
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Создать список сортировки по наличию числа
 
Привет. А в старой теме не хотите отписаться?
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Ошибка при поиске тильды с помощью ПОИСКПОЗ
 
Вот так работает:
=ИНДЕКС($A$3:$B$12;ПОИСКПОЗ(ПОДСТАВИТЬ($D3;"~";"~~");$A$3:$A$12;0);2)
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Ошибка при поиске тильды с помощью ПОИСКПОЗ
 
Доброе. А если искать 2 тильды?
=ПОИСКПОЗ("~~";A:A;0)
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Объединить данные по нескольким столбцам
 
Проверяйте:
=СУММЕСЛИМН(I:I;H:H;A2;G:G;B2)
Если вместо нулей хотите видеть -, примените к ячейкам формат:
# ##0,00;-# ##0,00;-
Изменено: Bema - 8 Ноя 2018 17:42:45
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Заполнение строки данными из столбца
 
Цитата
a.i.mershik написал:
СТОЛБЕЦ()-5
Цитата
a.i.mershik написал:
место которое удобно ...было в столбце G))))
Какой Вы коварный ;)  
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Посчитать сумму только в строках, удовлетворяющих заданным критериям и временному интервалу
 
Цитата
vangerful написал:
но все они почему-то не работают с временными интервалами.
Думаю причина в том, что в столбце А у Вас действительно даты, а в критериях текст.
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Цикл с автозаполнением по условию (макрос)
 
Еще варианты.
Формула массива:
=ЕСЛИ(ИЛИ(ЕСЛИ(G2=$B$2:$B$12;$A$2:$A$12)="$");"$";"")
обычная
=ЕСЛИ(СЧЁТЕСЛИМН($B$2:$B$12;G2;$A$2:$A$12;"$")>0;"$";"")
Не увидел, что нужно макросом.
Изменено: Bema - 7 Ноя 2018 17:08:21
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Значение ячейки по нескольким условиям и по диапазону дат
 
Здрасьте.
=СУММПРОИЗВ((B6=поставщики!$A$6:$A$9)*(A6>=поставщики!$C$6:$C$9)*(A6<=поставщики!$D$6:$D$9)*поставщики!$E$6:$E$9)
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
текст между знаком "\" и первым пробелом после этого знака
 
Цитата
Luslav написал:
Уточнение
Нужен файл в формате Эксель строк на 10, с разными вариантами исходных данных.
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Рассчитать среднее значение для столбца с учётом двух условий
 
Цитата
Clubline написал:
что больше "20" и меньше "-5"
И или ИЛИ
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Рассчитать среднее значение для столбца с учётом двух условий
 
Добрый и Вам.
А функцию СРЗНАЧЕСЛИМН Ваш Эксель знает?
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Вывод списка уникальных цифровых значений по критерию
 
Еще вариант:
=НАИМЕНЬШИЙ(ЕСЛИ($B$2:$B$90=$D$2;$A$2:$A$90);СУММПРОИЗВ(СЧЁТЕСЛИ($E$1:E1;ЕСЛИ($B$2:$B$90=$D$2;$A$2:$A$90)))+1)
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
отбор уникальных значений из таблицы с пустыми ячейками
 
А может для начала вы пример покажите?
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Выцепление числа по условию через VBA.
 
Привет. Судя по описанию, можно и формулами попробовать. Но, в любом случае необходим файл-пример.
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Поиск номера строки по части текста.
 
Пробуйте:
Код
=ПОИСКПОЗ("*"&C1&"*";A1:A3;0)
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Одно значение по 3-м условиям (текст и числа)
 
Такой вариант проверьте. Формулу можно тянуть вниз, при это закрепление столбцов знаком $ не нужно:
=СУММПРОИЗВ((МЕСЯЦ(Сводка!D$9:D$46)=C$2)*(Сводка!E$9:E$46=B$2)*(Сводка!F$9:F$46=ЕСЛИ(A3="гарантия";"да";"нет")))
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Одно значение по 3-м условиям (текст и числа)
 
Так?
=СУММПРОИЗВ((МЕСЯЦ(Сводка!$D$9:$D$46)=$C$2)*(Сводка!$E$9:$E$46=$B$2)*(Сводка!$F$9:$F$46="да"))
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Подтянуть нужное значение из диапазона
 
Еще
=ВПР(F2;$A$2:$C$32;3;1)
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Поиск повторяющихся значений
 
Balrog2014, добрый и Вам. В каком виде нужен результат?
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Как сравнить время, которое больше 24 часов?, Например, как сравнить 54:32 с 48:00
 
Цитата
vmokuq написал:
почему 2 обозначает 2 дня?
1 это 24 часа, 2 это 48 часов. Введите в ячейку цифру 2 и примените формат [h]:mm:ss
Изменено: Bema - 25 Окт 2018 10:13:46
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Как сравнить время, которое больше 24 часов?, Например, как сравнить 54:32 с 48:00
 
Или так?
=ЕСЛИ(1*A2>2;"вне времени";"ок")
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Среднее значение по датам отгрузки исходя из территории
 
Вариант:
=СРЗНАЧЕСЛИМН(ИНДЕКС(Лист2!$C$4:$Z$6;ПОИСКПОЗ(B4;Лист2!$B$4:$B$6;0);0);Лист2!$C$3:$Z$3;">="&C4;Лист2!$C$3:$Z$3;"<="&D4)
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Фильтр и суммы значений между промежуточными итогами
 
Цитата
backbeat написал:
в умной таблице у меня не активна эта кнопка
Если преобразовать в диапазон, то заработает.
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Фильтр и суммы значений между промежуточными итогами
 
Может это поможет Вставка промежуточных итогов
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Массивы – поиск показ или ВПР
 
Цитата
Сергей написал:
тему можно закрывать
Рано еще. Медведь может еще заглянет в тему ;)  
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Массивы – поиск показ или ВПР
 
Сергей, 18$?
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Получение коэффициентов линии тренда для неполного ряда
 
Цитата
JayBhagavan написал:
Фантастика!
Здравствуйте, JayBhagavan, А в чем фантастика?
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 158 След.
Наверх