Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Выбрать дату в календареВыбрать дату в календаре

Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 207 След.
Выбор столбца и "счётесли" в нем
 
Цитата
poceluev написал:
Привет!
ЗдАрова.
И зачем эта картинка с формулой?
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Поиск первой заполненной ячейки, ПОИСК ПОЗ выдает ошибку
 
Формула массива:
=ПОИСКПОЗ(1=1;B6:B8<>"";)
Изменено: Максим В. - 18 сен 2020 10:08:03
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Не менять ссылку при копировании формул
 
Цитата
DJMC написал:
или это не то?
А сами-то как думаете?
Типы ссылок на ячейки в формулах Excel
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Не менять ссылку при копировании формул
 
Почитайте про типы ссылок в Эксель.
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Вывод данных в другую ячейку если есть значение
 
frimen, заверните формулу в функцию ЕСЛИОШИБКА()
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Вывод данных в другую ячейку если есть значение
 
Формулы массива:
=НАИМЕНЬШИЙ(ЕСЛИ(B$3:B$106=1;A$3:A$106);СТРОКА(F1))
=НАИМЕНЬШИЙ(ЕСЛИ(B$3:B$106="";A$3:A$106);СТРОКА(F1))
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Поиск ближайшего отрицательного значения с дополнительным критерием
 
Для первого отрицательного формула массива:
=ИНДЕКС(B4:Q4;ПОИСКПОЗ(1=1;ЕСЛИ(B3:Q3=D3;B4:Q4<>ABS(B4:Q4));))
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Сопоставление столбцов на наличие нечетких совпадений
 
Цитата
александр солнцев написал:
с ним часто случатся какие-то странности.
Многие функции себя странно ведут. Самая любимая их странность- возвращать не тот результат, который ожидает пользователь.
Цитата
александр солнцев написал:
можете сказать, пожалуйста, что не так?
ВПР всегда находит первое значение соответствующее искомому. В Вашем случае ВР находит I19 и возвращает число 523,44
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Сопоставление столбцов на наличие нечетких совпадений
 
Mershik, и это тоже. Или пример составлен абы було или логика уж больно заумная. Я склоняюсь к первому.
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Сопоставление столбцов на наличие нечетких совпадений
 
Объясните почему ИСТИНА?
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Объединение одинаковых столбцов, Найти столбцы с одинаковыми значениями
 
Добрый и Вам. Каким должен быть результат? Как Вы его видите?
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Формулой вытянуть показатель (типа =впр) из списка минимальных значений
 
Здравствуйте. Посмотрите здесь Левый ВПР
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Автоматический сортировка по итогам в таблице
 
Чем мой вариант не устроил?
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Автоматический сортировка по итогам в таблице
 
Формула массива:
=ВПР(НАИМЕНЬШИЙ(СУММЕСЛИ(A$20:A$88;A$20:A$27;B$20:B$88);СТРОКА(A1));ЕСЛИ({0;1};A$20:A$27;СУММЕСЛИ(A$20:A$88;A$20:A$27;B$20:B$88));2;)
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Найти по условиям текст, соответствующий максимальному значению из столбца
 
Ну и до кучи формула массива:
=ГПР(МАКС(C3:F3);ЕСЛИ({1:0};C3:F3;C$2:F$2);2;)
Если максимумов несколько, вернет первой соответствующее значение.
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Сравнить два столбца на разных листах, вывести совпавшие значения
 
Цитата
kolkntva написал:
Нужно из листа 2 взять столбец A (ордер айди), сравнить с листом 1 столбец C, если ордер совпал
Зачем их сравнивать, если в Вашем примере они и так совпадают и по значению и по позициям?
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Найти по условиям текст, соответствующий максимальному значению из столбца
 
Так что ли:
=МАКС(C3:F3)
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Как растянуть формулу горизонтально, беря вертикальные данные
 
Вариант:
=ЕСЛИОШИБКА(СРЗНАЧЕСЛИ($B$2:$B$94;H2;$D$2:$D$94);"")
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Поиск и выделение строк по ключевому значению столбца
 
Частичная реализация Вашей хотелки в файле
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Собрать заказы при ограничении количества
 
А почему заказ 2 из 6 единиц? Прибавили 4 за первый январь?
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Заменить в нескольких ячейках номер строки на указанный
 
Цитата
oleg9911 написал:
Сейчас номер колонки не указан.
Третий аргумент функции ИНДЕКС это номер столбца.
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
СУММПРОИЗВ - при расчете исключает текстовые значения и учитывает только цифровые значения
 
Ралиф Ишмухаметов, а не пробовали воспользоваться функцией СУММЕСЛИ?
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
сцепить ячейки по условию, Формулами счепить несоклько ячеек, при этом в некоторых случаях либо оставлять имеющееся значение, либо удалять его
 
=ПОДСТАВИТЬ(ПОДСТАВИТЬ(СЖПРОБЕЛЫ(СЦЕПИТЬ(ЕСЛИ(ДЛСТР(A2)>1;ПОДСТАВИТЬ(A2;" ";"@");ПОДСТАВИТЬ(A2;"-";" "));" ";ЕСЛИ(ДЛСТР(E2)>1;ПОДСТАВИТЬ(E2;" ";"@");ПОДСТАВИТЬ(E2;"-";" "));" ";ЕСЛИ(ДЛСТР(G2)>1;ПОДСТАВИТЬ(G2;" ";"@");ПОДСТАВИТЬ(G2;"-";" "))));" ";";");"@";" ")
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
сцепить ячейки по условию, Формулами счепить несоклько ячеек, при этом в некоторых случаях либо оставлять имеющееся значение, либо удалять его
 
Проверяйте на реальных данных:
=ПОДСТАВИТЬ(ПОДСТАВИТЬ(СЖПРОБЕЛЫ(СЦЕПИТЬ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(A2;" ";"@");"-";" ");" ";ПОДСТАВИТЬ(ПОДСТАВИТЬ(E2;" ";"@");"-";" ");" ";ПОДСТАВИТЬ(ПОДСТАВИТЬ(G2;" ";"@");"-";" ")));" ";";");"@";" ")
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
сцепить ячейки по условию, Формулами счепить несоклько ячеек, при этом в некоторых случаях либо оставлять имеющееся значение, либо удалять его
 
Добрый и Вам. А что за текст в ячейках? Одно слово?
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Раскидать каждую строку колонки по столбцам в новой таблице
 
Еще:
=ИНДЕКС($A$2:$A$1101;СТОЛБЕЦ(A2)+(СТРОКА(D1)-1)*5)
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Сравнение массивов числовых данных на степень похожести, найти ряд данных, наиболее близкий к расчётным
 
Как понял. Массивная:
=ИНДЕКС(B4:F4;ПОИСКПОЗ(МАКС(МУМНОЖ(ТРАНСП(--(A5:A114=B5:F114));СТРОКА(A5:A114)^0));МУМНОЖ(ТРАНСП(--(A5:A114=B5:F114));СТРОКА(A5:A114)^0);))
или так:
=ИНДЕКС(МУМНОЖ(ТРАНСП(--($A5:$A114=$B5:$F114));СТРОКА(A5:A114)^0)/ЧСТРОК(A5:A114);СТОЛБЕЦ(A5))
Изменено: Максим В. - 5 авг 2020 08:46:58
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Фильтры в ячейке и расчет суммы оценок
 
Еще вариант:
=СУММПРОИЗВ(ЕСЛИОШИБКА(ИНДЕКС(D5:H5;Ч(ИНДЕКС(--ПСТР($L$2;{1:3:5:7:9};1);0)));0))
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Вставить название бренда в пустую ячейку
 
=ПРОСМОТР(1;1/ПОИСК($G$2:$G$4;B2);$G$2:$G$4)
В диапазоне $G$2:$G$4 список брендов.
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Управление диапазоном ссылки при помощи формулы ПОИСКПОЗ
 
Юрий М, из этого
Цитата
ZakZak написал:
Дальше я при помощи формулы ПОИСКПОЗ определяю, что поиск надо начинать с 1000 строки.
что автор уже получил 1000 строку с помощью ПОИСКПОЗ.
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 207 След.
Наверх