Выбрать дату в календареВыбрать дату в календаре

Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 37 След.
Почему дата больше явно большей даты?
 
, От того что вы меняете Формат ячейки, текст в ней не превратится в число(дату) воспользуйтесь предложенными вариантами из сообщения #2
Заполнение таблицы с простоями в зависимости от даты
 
, Что не получилось, надо писать в теме а не в личку
Смотрите на вашем же примере работу формулы
Заполнение таблицы с простоями в зависимости от даты
 
,, Вариант
Код
=СУММПРОИЗВ(($B$1=ЦЕЛОЕ(Table1[[Начало простоя]:[Начало простоя]]))*(C$2=Table1[[Причина]:[Причина]])*($B3=Table1[[Актив]:[Актив]])*Table1[[Время, ч]:[Время, ч]])
Вставьте в С3 и протяните вправо и вниз. Дату сравнивает с столбцом "Начало простоя"
Формирование отчетов с помощью расширенного фильтра
 
New, Здравствуйте коллега, задание "Г" решается так, посмотрите по ссылке Задача 6 (Условия отбора, созданные в результате применения формулы)
Задать номер строки через ссылку на ячейку
 
Анастасия Горбенко, 2 варианта, либо вы неправильно сформулировали свой вопрос, либо вы не применили предложенную вам формулу, так как формула
Код
=МИН(AB3;ИНДЕКС(AB:AB;C27)) 
при равенстве ячейки С27 значению 45, выдаст такой же результат как формула
Код
=МИН(AB3;AB45)

можете наглядно убедится в этом в файле примере
Исключить из диапазона скрытые столбцы
 
sashgera, Здравствуйте, вариант
Код
Range("CH:EC").SpecialCells(xlCellTypeVisible).ColumnWidth = 6
Подтянуть показания счетчика по его номеру и типу шкалы
 
Mst Touch, Приведите в соответствие данные в файле "Ведомость..." Столбец "P" с файлом "Текущ..." Столбец "AC" С помощью инструмента Найти и заменить (ctrl + H), далее вставьте формулу в ячейку V8 файла "Текущ..."
Код
=ИНДЕКС('[Ведомость отпуска энергии по населению город.xlsx]Все дома'!$T$11:$T$117;ПОИСКПОЗ($T8&$AC8;'[Ведомость отпуска энергии по населению город.xlsx]Все дома'!$O$11:$O$117&'[Ведомость отпуска энергии по населению город.xlsx]Все дома'!$P$11:$P$117;0))
и потяните вниз.
Формула массива, вводится нажатием клавиш Ctrl + Shift + Enter
Оба файла должны быть открыты

P.S. предлагаю название темы: Подтянуть данные по двум условиям
Или Подтянуть показания счетчика по его номеру и типу шкалы
Изменено: Александр П. - 30.09.2021 04:36:39
Как разделить и выбрать данные одной ячейки в другие ячейки
 
irina2, Статья из приемов вам вполне поможет.
Либо просто используйте имеющийся инструмент - Данные - Текст по столбцам
Вставить строки между диапазонами строк с одинаковыми датами
 
Цитата
Гарик Айвазян написал:
Скорее всего есть такая формула, которая вставляет строчки
Формулы не добавляют (вставляют) строки
Сохранение листа в отдельную книгу без формул VBA, Нужно сохранить лист в отдельную книгу без формул
 
Максим, Например перед сохранением добавить
Код
With ActiveWorkbook.ActiveSheet.UsedRange
    .Value = .Value
End With
Формирование матрицы в соответствии со значениями ячеек таблицы
 
Адрей стрельцов, Вариант
Код
=ЕСЛИ(СЧЁТЕСЛИ(B$1:B$7;СТРОКА())=0;"";СЧЁТЕСЛИ(B$1:B$7;СТРОКА()))
Объединить в одну ячейку данные по одинаковому значению с других столбцов
 
allalone, Здравствуйте, в приемах есть то, что вам поможет склеивание текста по условию, обратите внимание на Способ 1. Макрофункция склейки по одному условию
Счет слов в строке
 
BodyDeBuilder, Вариант
Сортировка дробных чисел, Автозаполнение и сортировка данных
 
Илья Кропотов, копируете данные в соседний столбец, далее Вкладка Данные=> Текст по столбцам, разделитель указываете "/", далее выделяете получившийся диапазон (вместе с исходным столбцом) , вкладка Главная => Настраиваемая сортировка
Сгруппировать ненулевіе значения из двух столбцов в один с подтягиванием данных из третьего столбца
 
oleg9911, Вариант, при условии, что в диапазоне А:B, в 1ой строке может быть только одно значение неравное 0 (как в примере)

для столбца F
Код
=ЕСЛИОШИБКА(СУММ(ИНДЕКС($A$1:$B$26;НАИМЕНЬШИЙ(ЕСЛИ($A$2:$B$26<>0;СТРОКА($A$2:$A$26));СТРОКА(A1));;1));"")
Для столбца G
Код
=ЕСЛИОШИБКА(ИНДЕКС($A$1:$C$26;НАИМЕНЬШИЙ(ЕСЛИ($A$2:$B$26<>0;СТРОКА($A$2:$A$26));СТРОКА(A1));3);"")
Формулы массива (вводим через ctrl + shift + enter)
Изменено: Александр П. - 18.08.2021 09:38:28
ВПР. Ссылка на ячейку со сдвигом строки.
 
Сергей Евдокимов, Как вариант - использовать ДВССЫЛ
Код
=ВПР(ДВССЫЛ("A2");$A$1:$B$7;2;0)
Тему предлагаю переименовать - Как избежать ошибки #ССЫЛКА! при удалении строк
Подсчёт одинаковых значений за определённый период
 
Владимир, Вариант
Код
=СУММПРОИЗВ((ЕОШ(ПОИСК(F$14;$A$2:$A$40))=ЛОЖЬ)*(ДАТА(ГОД($B$2:$B$40);МЕСЯЦ($B$2:$B$40);ДЕНЬ($B$2:$B$40))=$E15))
Только будет работать если приведете данные к 1му виду, если у вас в данных "Пакет 4,5 часа" пишется 4,5 через "," (Запятую) то и в шапке таблицы для подсчёта нужно писать так же через запятую.  
Формат даты в функции ТЕКСТ для компьютеров с разной локацией
 
manat78, Здравствуйте, тема с ответом на ваш вопрос ССЫЛКА
Форматирование текста внутри ячейки/формулы, Хочется сделать таблицу более аккуратной, но понимаю что не знаю ни одного способа.
 
Цитата
Dobshikov написал: Как вывести результат на разных строчках.
Код
="Да"&СИМВОЛ(10)&"Нет"
Цитата
Dobshikov написал: есть ли вообще способы изменять то что выводит формула, шрифты, размер текста
Нет
Количество каждой цифры в последовательности чисел от 1 до указанного числа (шаг 1)
 
Цитата
fourSTEP написал:
Но в ячейках выдает - #ИМЯ?
В формуле предложенной Игорем используется функция которая появилась начиная с MS Office 2019, ну или в офис 365. Возможно вы используете более раннюю версию.
Количество каждой цифры в последовательности чисел от 1 до указанного числа (шаг 1)
 
fourSTEP, Формула массива означает, что при вводе функции нажать не Enter, а комбинацию клавиш - Ctrl+Shift+Enter.
Объединение числа с текстом с отображением разрядности
 
Василька,  Вариант под ваш пример
Код
=ТЕКСТ(A1;"# ##0")&" "&A2

Предлагаю название темы: Сцепить число с текстом сохранив разделители групп разрядов
Выделенный текст в ячейке не окрашивается
 
Это происходит только если в ячейке число, причин не знаю, но если в ячейке текстовое значение, то хоть весь текст выделяйте, хоть часть, будет работать нормально
Изменено: Александр П. - 06.05.2021 09:23:44
Условное форматирование. Формула для сравнения производного без помещения производного в отдельную колонку.
 
Elena Tr, Вариант
Код
=СУММПРОИЗВ(($A$2:$A$64=A2)*($D$2:$D$64=D2)*$N$2:$N$64;$P$2:$P$64)>15000
Условное форматирование. Формула для сравнения производного без помещения производного в отдельную колонку.
 
Elena Tr, Вариант
Изменено: Александр П. - 30.04.2021 02:29:26
Выводить каждую четвертую строчку из столбца
 
Валентина Коршикова, Вариант
Код
=ИНДЕКС('Результаты поиска'!B:B;4*СТРОКА(A1))
Макрос блокирует возможность отмены действий, В развитие ранее заданного вопроса
 
Цитата
Эльбрус написал:
почему он блокирует (делает неактивными) кнопки отмены и возврата действий
Это нормально, после действий макроса пропадает возможность отмены действий совершенных до запуска макроса
Изменено: Александр П. - 23.04.2021 07:13:16
Заполнение данных по совпадению кадастрового номера, Требуется вставить значения в соответствии с кадастровым номером.
 
dr.loginoff, Вам поможет функция ВПР()
Вставка данных в несколько ячеек одной строки
 
Цитата
Bublee написал:
вставка данных из столбца А активной строки в столбцы с 3 по 5 этой же активной строки.
Вариант
Код
Range("C" & ActiveCell.Row & ":E" & ActiveCell.Row).Value = ActiveCell.Value
При выборе фильтрующего значения среза скрыть столбцы без значений, vba
 
Цитата
evgeniygeo написал:
так костылей никто не отменял вроде
Спасибо за пример. Никогда не сталкивался с подобной проблемой, так что ссылки в копилку  :)  
Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 37 След.
Наверх