Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Выбрать дату в календареВыбрать дату в календаре

Страницы: 1 2 След.
Настройка динамической диаграммы с последующими днями =Сегодня()
 
NV.Telegin, через именованные динамические диапазоны получилось.
Обращение к ячейкам объединенных диапазонов
 
Sceptic, Спасибо, то что нужно!
Обращение к ячейкам объединенных диапазонов
 
Доброго времени суток, форумчане!

Столкнулся с проблемой обращения к ячейкам в объединенных диапазонах. Ниже кусок кода:
Код
Dim rr As Range
Set rr = Union(Range("A1:A3"), Range("B1:D1"))

Debug.Print rr.Cells.Count          'значение 6 - всё верно
Debug.Print rr.Cells(1).Address     'значение $A$1 - всё верно
Debug.Print rr.Cells(2).Address     'значение $A$2 - всё верно
Debug.Print rr.Cells(4).Address     'значение $A$4 - хотелось бы получить значение $B$1 - четвертой ячейки объединенного диапазона rr

Имеется диапазон ячеек, объединенных из двух диапазонов "A1:A3" и "B1:D1".
Хотел обращаться к ячейкам по их индексу в объединенном диапазоне "rr" , то есть всего ячеек 6, первая - это А1, вторая А2 ... шестая D1
Не понимаю логику обращения. До А3 идет как мне представляется, далее просто вниз продолжается.

Кто-нибудь сталкивался с такой проблемой? Можете подсказать пути решения? или лучше в словарь/массив нужные ячейки загонять?
Изменяемая длинна выпадающего списка
 
Такое решение могу предложить.
Ошибка Ошибка при загрузке сайта с помощью объекта InternetExplorer.Application, работа с InternetExplorer.Application
 
Игорь, у Вас оба сайта открываются без ошибок? настройки безопасности поменять или какие?
Как такое может быть, что с одними и теми же настройками один сайт открывается, а другой нет? Может быть, что это особенности сайтов?

Потестил еще несколько сайтов. Открываются без ошибок:
http://www.planetaexcel.ru
https://ruads.org/

Возникает такая же ошибка:
https://rosreestr.ru/

Прикрепил файл с макросом. Если у кого есть возможность, прошу проверить.
Ошибка Ошибка при загрузке сайта с помощью объекта InternetExplorer.Application, работа с InternetExplorer.Application
 
Добрый день, форумчане!

Не могу разобраться с проблемой возникновения ошибки.
Код следующий:
Код
Sub check()
Set objIE = CreateObject("InternetExplorer.Application")
'objIE.Navigate "https://ya.ru/"
objIE.Navigate "https://www.reestr-zalogov.ru/search/index"

While objIE.Busy Or (objIE.ReadyState <> 4)
DoEvents
Wend

objIE.Visible = 1
MsgBox objIE.LocationURL
objIE.Quit
Set objIE = Nothing
End Sub
При выполнении кода возникают разные ошибки на строке
Код
While objIE.Busy Or (objIE.ReadyState <> 4)
Ошибка:
Run-time error -2147023179 (800706b5)
Automation error
the interface is unknown

Ошибка:
Run-time error -2147467259
Automation error
Unspecified error

Ошибка:
Method "Busy" of object 'IWebBrowser2" failed

Причем на строке
Код
objIE.Navigate "https://www.reestr-zalogov.ru/search/index"
объект "objIE" принимает значение Visible (хотя до этой строки код еще не дошел)

Этот же код при замене URL адреса на "https://ya.ru/" отрабатывает без проблем.
В чем может быть причина ошибок? Сам сайт блокирует корректное выполнение макроса?
Поиск части фразы, расположенной на листе, ошибка при использовании функции Application.WorksheetFunction.Match
 
kuklp, Юрий М,хоть и результат typename(arr) является string. Функция InStr не хочет работать с моей переменной arr. Выдает ошибку 13 (Type mismatch).
Код
instr(1,arr,"искомое значение",vbTextCompare)

Возможно дело в том, как эта переменная образуется:
Код
arr = Split(xmlHttpRequest.responseText, vbLf)
Поиск части фразы, расположенной на листе, ошибка при использовании функции Application.WorksheetFunction.Match
 
kuklp, Спасибо большое!
По поводу логики: эта строка является частью достаточно большого кода, в котором загружается информация с сайта. Загружаю ее так:
Код
Set xmlHttpRequest = CreateObject("MSXML2.XMLHTTP")
xmlHttpRequest.Open "GET", myUrl, False
xmlHttpRequest.send Null
arr = Split(Trim(xmlHttpRequest.responseText), vbLf)

Далее функцией Application.WorksheetFunction.Match искал местоположение искомых значений в переменной "arr" и "выдергивал" содержание всей строки, в котором содержались искомые значения. Вот так:
Код
txt = arr(Application.WorksheetFunction.Match("*искомое значение*", arr, 0))

Можно ли с помощью ".find" искать в переменной "arr" и "выдергивать" необходимые значения?

Пробовал arr.find( ), выдает ошибку.

Изменено: AlbertSF - 31 Май 2017 15:04:39
Поиск части фразы, расположенной на листе, ошибка при использовании функции Application.WorksheetFunction.Match
 
Добрый день, Форумчане!

При попытке найти часть фразы, расположенной на листе, некоторые фразы ищутся без проблем, а на некоторых выдает ошибку. Пожалуйста, помогите разобраться. Файл пример прикладываю.
Статистика использования (запуска) макроса, Получение информации о пользователях, запускающих макрос.
 
Hugo, The_Prist,спасибо, буду пробовать.
Статистика использования (запуска) макроса, Получение информации о пользователях, запускающих макрос.
 
Добрый день, форумчане!

В ходе работы приходится пользоваться макросами, значительно упрощающими выполнение поставленных задач. Некоторые из подобных макросов написаны мною и используются коллегами в разных городах и субъектах РФ. Поэтому, любопытно (а может иногда и полезно) было бы получать информацию об использовании макросов: кем запускался (имя пользователя Excel, учетная запись Windows, ip-адрес), когда запускался (дата).

Может кто уже сталкивался с подобными задачами? Какими способами можно получать такую статистику? Единственное до чего пока додумался, при каждом использовании макроса отсылать письмо со статистикой на мой электронный адрес. Или можно проще всё сделать? Подскажите пожалуйста в каком направлении работать.  
Пустая ячейка воспринимается Excel'ем как 0. Как исправить?, Функция СУММ(A1<5;A3<5; и т.д.)
 
Eugen_excel, ваша формула в файле примере посчитала все верно.
Код
=СУММ(A1<5;C1<5;E1<5;G1<5;I1<5;K1<5;L1<5;N1<5)

Условие у вас "Нужно посчитать количество ячеек...", а формулу пишете "Сумм".

Например, у меня формула

Код
=СЧЁТЕСЛИ(A1:N1;"<5")

дает результат 3. Что верно. Пустые ячейки не считает. Если добавить в этот диапазон 0. то результат станет 4.

Какой результат хотите получить в итоге?

[ Закрыто] Формулы, Связи в формуле
 
Добрый день!
Есть встроенная функция в Excel "Вычислить формулу". Вкладка Формулы - Раздел Зависимости Формул - Вычислить формулу.
Поиграйтесь с  кнопками "Шаг с заходом" и "Вычислить". Может быть это то, что вам нужно?
Подтянуть ростовочные размеры одежды, Автоматическое подтягивание рамеров с выпадающимся списком
 
Пожалуйста!
Подтянуть ростовочные размеры одежды, Автоматическое подтягивание рамеров с выпадающимся списком
 
Цитата
ШАГ написал:
Показывает в ячейки ЛОЖЬ
Заполните на листе Примечание значение размеров, тогда будет отображать размер.
Или другой результат должен был получиться?
Подтянуть ростовочные размеры одежды, Автоматическое подтягивание рамеров с выпадающимся списком
 
ШАГ, На каком листе выбираете материал в Ячейке В2? Ощущение что всё смещено на 1 столбец.

Если правильно понимаю, то попробуйте так:
Код
=ЕСЛИОШИБКА(ИНДЕКС(Примечание!G2:G5;ПОИСКПОЗ(A2;Наименование_продукции;0));"")
Копирование данных из одного диапазона в другой по произвольному №.
 
al_geor,Как вариант можно ввести формулу:
Код
=СМЕЩ(C3;5*$A$3;0) 
в ячейку С3 и растянуть на всю закрашенную область.
Есть существенные требования для обеспечения работоспособности:
1. Номера вариантов располагать строго по порядку.
2. Должна строго соблюдаться структура данных (два столбца, четыре строки, каждый вариант должна разделять одна пустая строка).

Или нужно решение макросами?
Многоуровневая формула с условиями, ЕСЛИ для нескольких значений
 
Gena85, значение в желтой ячейке всегда целое число? Границы 17 и 18 включительно?
Подсчет количества значений поступивших в определенный интервал времени, Подсчет кол-ва клиентов поступивших в интервале 90 дней
 
Так удобно читается информация?
Подсчет количества значений поступивших в определенный интервал времени, Подсчет кол-ва клиентов поступивших в интервале 90 дней
 
Gena85, вставляете формулу в ячейку и протягиваете и получаете информацию ту, которую просили. Если изначально нужен был иной вид представляемой информации, то необходимо было оформить файл примера желаемым образом. И формула скорее всего короче была бы и помогающие время сэкономили бы!
Подсчет количества значений поступивших в определенный интервал времени, Подсчет кол-ва клиентов поступивших в интервале 90 дней
 
Формула в ячейку С2
Код
=СЧЁТЕСЛИМН(B:B;B2;A:A;">="&ДАТА(ГОД(A2);ИНДЕКС({1:4:7:10};ОКРВВЕРХ(МЕСЯЦ(A2)/3;1));1);A:A;"<"&ДАТА(ГОД(A2);ИНДЕКС({1:4:7:10};ОКРВВЕРХ(МЕСЯЦ(A2)/3;1))+3;1))
Поиск значения в прайс листе в зависимости от значения
 
Формула с учетом стоимости покупки при дробных значениях:
Код
=ИНДЕКС($B$2:$F$11;ПОИСКПОЗ($A17;$A$2:$A$11;0);ЕСЛИ(B17<1;1;ОКРВНИЗ(B17;1)))/ЕСЛИ(B17<1;1;ОКРВНИЗ(B17;1))*B17
Поиск значения в прайс листе в зависимости от значения
 
Цитата
=ИНДЕКС($B$2:$F$11;ПОИСКПОЗ($A17;$A$2:$A$11;0);ОКРУГЛ(B17;0))
Получается если взять 0,5 и 0,6 арахиса цена полуается 100 у.е. - т.е. одинаковая цена при разном весе.
Если ввести значение меньше 0,5, цена равна 190 у.е.
Изменено: AlbertSF - 6 Фев 2017 12:58:48
Поиск значения в прайс листе в зависимости от значения
 
в ячейку С17 формула =ВПР(A17;$A$1:$F$11;1+B17;0)
При другой структуре таблицы работать не будет.
Указать аванс, относительно даты и артикула
 
Сократил формулу до следующего (убрал лишние, на мой взгляд, проверки):
Код
=ЕСЛИОШИБКА(
СУММЕСЛИМН(производство!$F$4:$F$23;производство!$D$4:$D$23;B4;производство!$E$4:$E$23;B$1)+
СУММЕСЛИМН(производство!$H$4:$H$23;производство!$D$4:$D$23;B4;производство!$G$4:$G$23;B$1)+
СУММЕСЛИМН(производство!$J$4:$J$23;производство!$D$4:$D$23;B4;производство!$I$4:$I$23;B$1)+
СУММЕСЛИМН(производство!$L$4:$L$23;производство!$D$4:$D$23;B4;производство!$K$4:$K$23;B$1);"")

Проверил, все работает.
Указать аванс, относительно даты и артикула
 
Зачем вы используете функцию "И", если у вас проверяется только одно логическое значение? Поэтому на второй проверке получалось ИСТИНА (так как ЛОЖЬ > 0 = ИСТИНА), результат равен нулю и дальнейшая проверка не проводилась (т.е. 3 и 4 не рассматривались).
Как вариант, уберите все функции "И" и формула заработает.
Определение даты через заданное количество дней (с учётом выходных, но без учёта заданных праздников)
 
Если правильно понял суть задачи, то получается следующая формула:
Код
=ЕСЛИ(ДЕНЬНЕД(C3+D3;2)=6;C3+D3+2;ЕСЛИ(ДЕНЬНЕД(C3+D3;2)=7;C3+D3+1;C3+D3))+НЕ(ЕОШИБКА(ПОИСКПОЗ(ЕСЛИ(ДЕНЬНЕД(C3+D3;2)=6;C3+D3+2;ЕСЛИ(ДЕНЬНЕД(C3+D3;2)=7;C3+D3+1;C3+D3));Праздники!$A$2:$A$4;0)))
Немного длинно конечно, но может более опытные форумчане подскажут, как оптимизировать!
Возврат предыдущего значения ячейки по условию, можно ли хранить значение в памяти?
 
Цитата
bekzus написал: а какая разница с маленькой буквы или с большой
Это не большая буква I(ай), а маленькая L (эль) первая буква от типа Long
Расчет времени (суммирование) в интервале
 
Добрый день!

Вроде через формулы массивов получилось. Проверяйте!
Использование аргументов в методе Application.Dialogs(xlDialogInsertPicture)
 
Максим Зеленский, хорошая идея, спасибо!
Страницы: 1 2 След.
Наверх