Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Выбрать дату в календареВыбрать дату в календаре

Страницы: 1
Выбор варианта из таблицы вариантов по номеру зачетки
 
gling,блин гениально, малость ток добавить, ЕСЛИ на вариант, когда последние две цифры 00 (т.к. выдает 420).
Спасибо!
Выбор варианта из таблицы вариантов по номеру зачетки
 
vikttur, думал массивом будет проще сделать, чем вот так
Код
=ЕСЛИ(--ПСТР(C2;7;2)=0;10;ЕСЛИ(ОСТАТ(--ПСТР(C2;7;2);30)=0;30;ОСТАТ(--ПСТР(C2;7;2);30)))
Выбор варианта из таблицы вариантов по номеру зачетки
 
vikttur, спасибо, но вот вопрос, а через массив никак нельзя? Что бы искал номер последних двух цифр в таблице и возвращал значение варианта.
Изменено: Lex Backer - 17 Июл 2016 17:00:55
Выбор варианта из таблицы вариантов по номеру зачетки
 
Здравствуйте!
Помогите пожалуйста с данным вопросом, имеется таблица для выбора варианта по двум последним цифрам зачетки, но я не могу вернуть значение строки (номера варианта), если бы присутствовали значения столбцов, а не только строк, то реализовал бы через ВПР или ИНДЕКС, а тут только строки... - затрудняюсь.
Изменено: Lex Backer - 17 Июл 2016 16:49:37
Выбор варианта из последних цифр зачетки по таблице
 
vikttur,спасибо, такого применения ВПР еще не видел.
Выбор варианта из последних цифр зачетки по таблице
 
Sanja, gling, спасибо большое! Это как раз то, что я искал... думал про массив но не знал как именно выбирать из столбца и строки искомое... )  
Выбор варианта из последних цифр зачетки по таблице
 
Здравствуйте!
Помогите пожалуйста с таким вот вопросом.
Имеется таблица по которой необходимо выбрать вариант из последних цифр зачетки...
Как это реализовать? Массив? Или же все таки придется писать 24 условия ЕСЛИ ?

Файл таблицы есть ниже, там номера зачеток и таблица по которой выбирается вариант.
Страницы: 1
Наверх