Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Выбрать дату в календареВыбрать дату в календаре

Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 1298 След.
Заменить диапазон одним числом
 
"????"&"-" = "????-"
Извлечение частей текста, разделенных двумя символами
 
У меня Excel-2010, ошибок нет

Видимо, срабатывает ограничение по количеству знаков 32767. 30 фрагментов ---> 29*1000 = 29 000. И это только добавляемые пробелы. А еще длина текстовой строки...
Если решать такой формулой, следует разбить ее на две? каждая из которых обрабатывает по 15 столбцов.
Заменить диапазон одним числом
 
Заменить в  тексте или извлечь из текста?
Пример - небольшая демонстрация в файле Excel
Подсчет количества уникальных значений ID каждого наименования
 
Если не работает - нужно показывать.

Я на свои вопросы  ответов так и не получил. Больше не интересно. Автор общается сам с собой.
Подсчет количества уникальных значений ID каждого наименования
 
А если отвечать на задаваемые вопросы?
Подсчет количества уникальных значений ID каждого наименования
 
Цитата
На сообщение №6 ответа нет...
После этого Вы написали, что там ошибка. Далее следует просьба показать ошибку в файле. Вы выкладываете файл со своей старой формулой. ЗАЧЕМ?

И зачем Вы выложили пример второй раз?
Ускорение работы макроса, выставляющего значение в фильтре сликера
 
Проблема в Selected. Работа с объектами листа медленная
Цитата
VBA_beginner написал: Файл с персональными данными, поэтому скопировать дословно код или выложить всю таблицу не могу.
Сесть и нарисовать НЕБОЛЬШОЙ пример с отвлеченными данными некогда...
Извлечение частей текста, разделенных двумя символами
 
Где?
Извлечение частей текста, разделенных двумя символами
 
Из-за длинных текстов. Заменить в формуле 999 на 2000, например
Извлечение частей текста, разделенных двумя символами
 
А куда файл спрятали?
Подсчет количества уникальных значений ID каждого наименования
 
Пока не покажете в примере - и я не понимаю
Подсчет количества уникальных значений ID каждого наименования
 
На сообщение №6 ответа нет...
Удалить из текста часть от пробела перед символом до символа
 
Цитата
s.e.r.g_h написал: формула подходит, если перед знаком "/" только один символ, а если 2, или более
Как показали пример, так и получили
Цитата
 2.3. Приложите файл(ы) с примером...  в реальной структуре и форматах данных
Покажите нормальный пример с возможными вариантами, иначе получите формулу и опять вспомните о каком-нибудь условии.
Удалить первое слово в тексте, где формулой удаляется фрагмент
 
s.e.r.g_h, в 4-й раз за сегодня о правилах..
Название теме нужно давать ПО ЗАДАЧЕ, а не по выбраному пути решения.
Цитировать не запрещается, но цитировать, а не жать на кнопку бездумно!. Исправьте сообщение.
Удалить из текста часть от пробела перед символом до символа
 
=ЗАМЕНИТЬ(A2;ПОИСК("/";A2)-1;2;)
Подсчет количества уникальных значений ID каждого наименования
 
Вложить еще по одному условию в ЕСЛИ
ЕСЛИ($A$2:$A$10=A2;ЕСЛИ($C$2:$C$10<>"";$C$2:$C$10))
Подсчет количества уникальных значений ID каждого наименования
 
Формула массива
=СЧЁТ(1/ЧАСТОТА(ПОИСКПОЗ(ЕСЛИ($A$2:$A$10=A2;$C$2:$C$10);ЕСЛИ($A$2:$A$10=A2;$C$2:$C$10););СТРОКА($1:$99)))-1
Извлечение частей текста, разделенных двумя символами
 
Цитата
_DenA_ написал: перечисленных через запятую без пробелов
Запятая - невидимый символ? Где в она в данных?

Ага...
Цитата
Для работы формулы я заменил в оригинале разделитель запятую на пробел.
Теперь помогающим предлагаете менять обратно? Нет уж, сами формулу корректируйте.
=СЖПРОБЕЛЫ(ЛЕВБ(ПОДСТАВИТЬ(СЖПРОБЕЛЫ(ПСТР(ПОДСТАВИТЬ(" "&$A3;" ";ПОВТОР(" ";999));СТОЛБЕЦ(A1)*999;999));"_";ПОВТОР(" ";999));999))
Определить наличие кода в другой таблице, функция ЕСЛИ в масиве не работает
 
=СЧЁТЕСЛИ(Таблица1[Код];[@[Код кл,]])
Функция покажет наличие кода в другой таблице. Если >0, то "Yk".
То, что Вы пытались получить - массив, который нужно обрабатывать - суммировать количество "Yk".

Зачем выкладываете рабочий файл? Лишнее отвлекает. Достаточно 20 строк.
Поиск минимума, максимума, медианы по условию
 
Вот такой массив
=ЕСЛИ($D$4:$D$232=D4;$C$4:$C$232)
В нем находите нужные значения - МАКС, МИН, МЕДИАНА
Формула вводится как формула массива, тремя клавишами.

Для примера достаточно 20-30 строк.
Подсчет количества уникальных значений ID каждого наименования
 
=Сумм(СУММПРОИЗВ(...))
А вообще пора уже знать о файле-примере
Сравнить зарплату единицы персонала
 
Цитата
artyrH написал: срезал там для компактности
Это не компактность :)
bibika, Ну почему помогающие должны рыться в Вашем обрезанном рабочем файле с кучей МУСОРА! (для решеня вопроса все лишнее - мусор)? Вам жаль своих 15 минут на подготовку небольшого прмера? Пусть другие напрягаются?
Будьте добры, замените файл в первом сообщении. Тема еще может многим помочь.

По  формуле. Доп. столбец на исходном листе - зачем вычислять склад, если его название в столбце С? В этот же доп.столбец добавить  должность - и не нужна формула массива
Макрос удаления сток неправильно работает
 
Точно. Постоянно с массивами работаю, а тут не обратил внимания.
Макрос удаления сток неправильно работает
 
Код
Sub ACT()
    Dim rRng As Range
    Dim lr As Long, i As Long

    lr = Cells(Rows.Count, 1).End(xlUp).Row
    
    For i = 2 To lr
        If Cells(i, 7).Value <> "AC" And Cells(i, 7).Value <> "AS" And Cells(i, 7).Value <> "NV" And Cells(i, 7).Value <> "PA" Then
            If rRng Is Nothing Then
                Set rRng = Cells(i, 1)
            Else
                Set rRng = Union(rRng, Cells(i, 1))
            End If
        End If
    Next i
    
    If Not rRng Is Nothing Then
        With Application
            .ScreenUpdating = False
            .Calculation = xlCalculationManual
            .EnableEvents = False
        End With
        
        rRng.EntireRow.Delete
        Set rRng = Nothing
    
        With Application
            .ScreenUpdating = True
            .Calculation = xlCalculationAutomatic
            .EnableEvents = True
        End With
    End If
End Sub

Еще немного ускорить:
Код
        If Cells(i, 7).Value <> "AC" Then
            If Cells(i, 7).Value <> "AS" Then
                If Cells(i, 7).Value <> "NV" Then
                    If Cells(i, 7).Value <> "PA" Then
Суммирование цифр в ячейке
 
Еще одна немассивная
=СУММ(--ПРАВБ((ЦЕЛОЕ(A1/10^{0;1;2;3;4;5}))))
Если число с разделителем:
=СУММ(--ПРАВБ((ЦЕЛОЕ(ПОДСТАВИТЬ(A1;",";)/10^{0;1;2;3;4;5}))))
Последнее число в масиве констант должно быть равно или больше разрядности числа в ячейке
Сумма по нескольким столбцам по одному критерию
 
=ЕСЛИ(A2<>A3;СУММ(B3:$N$13)-СУММ(P4:$P$13);)
Суммы диапазонов, разделенных пустыми строками
 
Цитата
Jonsnow написал: этот метод тоже пробовал
Надо показывать, а не голословить

(и обратите внимание на файл - один лист, минимум данных для иллюстрации задачи)
Заменить функции, если в поиске более 500000 строк
 
Цитата
Алексей Башмаков написал: поископз или впр не подставляется т.к. excel ругается что поля таблицы более 64999 строк
Функции не виноваты.

Попробуйте реобразовать таблицы в данные.
Ускорить поиск ВПР или ПОИСКПОЗ можно, если искать в отсортированных данных - поиск по неточному совпадению.
Суммы диапазонов, разделенных пустыми строками
 
Сообщение №11 пропустили?
Ошибка при вставке объединенной ячейки из 1С Предприятие 8.3 в Excel строку после 65536, ошибки
 
В предыдущей своей теме ответить не хотите?
Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 1298 След.
Наверх