Выбрать дату в календареВыбрать дату в календаре

Страницы: 1 2 3 След.
удаление дубликатов макрос VBA, необходимо удалить дубликаты, если одинаковый текст в 12 столбцах
 
MikeVol, Ее код будет срабатывать на активном листе

Iгор все верно написал, чтобы срабатывало на листе Материалы (With Sheets("Материалы"))
Нужно добавить точку
При чем тут лист Детали сложно понять, любой активный лист должен срабатывать.
Но без файла тяжело понять, может автор вообще другой смысл закладывал
Написать формулу для подстановки значений по трем критериям, т.е. когда не просто необходимо подтянуть данные по двум критериям, но ещё и выбирать диапазон из которого тянуть.
 
Протяните формулу вправо и вниз
пропали макросы, пропали макросы как восстановить?
 
xlsb, xlsm, xls
Написать формулу для подстановки значений по трем критериям, т.е. когда не просто необходимо подтянуть данные по двум критериям, но ещё и выбирать диапазон из которого тянуть.
 
Поискпоз ищет в какой строке "Тамбов" = 5
далее ИНДЕКС - первый параметр где смотреть, второй какой номер элемента искать 5+1, но при протягивании 1 не меняется, поэтому номер элемента для поиска 5+Строка(A1)
Написать формулу для подстановки значений по трем критериям, т.е. когда не просто необходимо подтянуть данные по двум критериям, но ещё и выбирать диапазон из которого тянуть.
 
ИНДЕКС
ПОИСКПОЗ
СТРОКА
преобразование числа
 
Так формат ячейки у верхних другой
выделяешь ячейку, которая соответствует критериям, выбираешь формат по образцу, после чего выделяешь ячейки в которых нужно поменять формат
преобразование числа
 
Выделяешь весь список, с первой ячейки у которой есть зеленый уголок
Правой кнопкой преобразовать в число
(если я правильно понял)
Как убрать из формата ДАТА + ВРЕМЯ секунды
 
=ОКРУГЛ(A1*1440; 0)/1440
VBA | Как найти последнюю ячейку в столбце, в которой формулой выводится значение?
 
Через цикл
VBA | Как найти последнюю ячейку в столбце, в которой формулой выводится значение?
 
Тоже когда то встал на такой теме, только у меня столбцы были
через Find
Посмотрите пример
Изменено: Ham13 - 24.11.2022 23:09:14
Не копируются данные с неактивного листа VBA
 
Без файла тяжеловато
самое быстрое решение, в начале добавить строку выбора другого листа (select),  с которого макрос работает корректно, но это костыль конечно  
Макрос для подсчета раскрашенных непустых ячеек
 
На любой цвет
Копирование из Excel в другие приложения только выделенные ячейки
 
Я может не до конца понял, копирование выделенных ячеек на свободный участок в эксель (Например в ячейку AA1), а далее уже копирование в другое приложение
Range("AA1").CurrentRegion.Copy
Макрос для подсчета раскрашенных непустых ячеек
 
*
Горизонтальное протягивание формулы с шагом
 
*
Макрос "Прицел" выделение сроки-столбца, Доработать макрос, для возможности вкл/выкл через кнопку
 
*
Средний процент от процентов, которые свыше 100%, Средний процент от процентов, которые свыше 100%
 
Посмотрите пример
3 от 4 75%
15 от 20 тоже 75%
Команда "ВПР" работает не совсем до конца., не корректное значение команды ВПР
 
=ВПР(D1;B1:C15;2;)
Вывести данные по двум условиям, Нужно вывести данные: фио и номер телефона по двум условиям
 
*
Отключение системы безопасности
 
Файл - Параметры - Центр управления безопасности - Параметры центра управления безопасностью - Надежные расположения
добавьте папку, в которой лежит файл с макросом
также себя в надежные издатели добавьте.


Если на сетевом диске, через Пуск - свойства браузера
 
Открыть последний файл в папке по маске не по дате сохранения
 

Сложно понять, что нужно, ну вот вывод на "Лист 1" всех файлов, далее сортировка верхний твой далее GetObject
Код
Folder = "C:\Users\user\Documents\"
i = 1
  FileName = Dir(Folder & "/", vbNormal)
  Do While FileName <> ""
      Sheets("Лист 1").Cells(i, 1) = FileName
        i = i + 1
      FileName = Dir
  Loop
Макрос удаление символов в начале строки, Как удалить определенные символы в начале строки?
 
Выносишь в доп столбец (или в массив если макрос) первые два символа, там где в доп столбце символы равны ХХ, меняешь значение в основном столбце
ЛЕВСИМВ
ДЛСТР
ПРАВСИМВ
Гиперссылка в модуль формы и в модуль класса
 
Приложите пример, мы может не правильно вас понимаем?

=ГИПЕРССЫЛКА("#Proba.Proba";"75")

#Proba - модуль
Proba - процедура  
Гиперссылка в модуль формы и в модуль класса
 
Не заметил, через формулу надо?
=ГИПЕРССЫЛКА("#Proba.Proba";"75")
Гиперссылка в модуль формы и в модуль класса
 
***
Фильтрация по дате из выбранных ячеек
 
Тема стара, как мир

во вложении

Если так, дальше вешайте код с кнопки, на событие
Фильтрация по дате из выбранных ячеек
 
<01/05/2021

месяц/день/год  
Фильтрация по дате из выбранных ячеек
 
***
Изменено: Ham13 - 14.05.2022 09:16:45
С помощью формулы определить приоритеты выполнения заказа
 
tolikt, БМВ,
=ПОИСКПОЗ(C2&ДЛСТР(A2)&A2;СОРТ($C$2:$C$12&ДЛСТР($A$2:$A$12)&$A$2:$A$12)

сорт идет по дате, далее по кол-ву символов, далее только по номеру :)

все, я спать
Посчитать значения, исключая время в дате
 
У вас наоборот же
тогда так
=СЧЁТЕСЛИМН(D:D;">="&A1;D:D;"<"&A1+1)
Страницы: 1 2 3 След.
Наверх