Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Выбрать дату в календареВыбрать дату в календаре

Страницы: 1
Вставить формулу на лист средствами VBA, проблему вызвают адреса ячеек в формуле
 
Добрый день, уважаемые гуру! Прошу вашей помощи!

Есть таблица, по мере заполнения которой нужно вставлять из кода VBA в некоторые ячейки формулы.
особенность формул такова, что часть данных берется с текущего листа (PEE), а часть из другого (Данные)
Адреса ячеек в формулах то же надо как то менять, таблица то растет...
При выполнении процедуры возникает ошибка выполнения - мне кажется она связана с адресами ячеек.
Мне кажется нужно как то подменить адреса в формуле на переменные.. ну или я не знаю.. второй день лопачу интернет - похожего не вижу.
Прошу помощи!
использую Excel 2010

Код
Private Sub InsertFormula()
    With Sheets("PEE")
    .Cells(ActiveCell.Row, 4).Formula = "=ЕСЛИ(ЕОШИБКА(ВПР(B130;Данные!A:B;2;ЛОЖЬ));"";ВПР(B130;Данные!A:B;2;ЛОЖЬ))" 'для столбца  D
    .Cells(ActiveCell.Row, 8).Formula = "=ЕСЛИ(ЕОШИБКА(ВПР(D130;Данные!B:C;2;ЛОЖЬ));"";ВПР(D130;Данные!B:C;2;ЛОЖЬ))" 'для столбца H
    .Cells(ActiveCell.Row, 12).Formula = "ЕСЛИ(ЕОШИБКА(I130/(H130*0,82));"";I130/(H130*0,82))"                       'для столбца L
    End With
End Sub

Желаемый результат - вставка формулы в ячейку с учетом следующего правила: в функции ВПР адрес искомой ячейки - строка относительная столбец абсолютный
Страницы: 1
Наверх