Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Выбрать дату в календареВыбрать дату в календаре

Страницы: 1
VBA. Запись значения реестра в переменную
 
Добрый день, уважаемые форумчане!

Подскажите пожалуйста как записать значение из HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion­\Authentication\LogonUI в переменную VBA для дальнейшего использования в проекте?

Никак не пойму что я делаю не так?
Код
Public Sub ReadUserName()
Dim readUserValue As Object
Set readUserValue = My.Computer.Registry.GetValue("HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Authentication\LogonUI", "LastLoggedOnDisplayName", Nothing)
MsgBox ("The value is " & readUserValue)
End Sub
Коннект к защищенной паролем БД Access через PowerQuery, Как правильно задать строку подключения
 

Добрый день, уважаемые форумчане!  Возникла проблема: никак через не удается подключиться к БД Access защищенной паролем через PowerQuery. Через типовое подключение не удается подключиться вовсе, т.к. на этапе подключение ни одно из диалоговых окон не позволяет передать пароль от БД.  Через ODBC удается подключиться к БД и просмотреть ее содержимое, но при попытке перейти к какому либо объекту в панели навигации выдается сообщение об ошибке:

Код
DataSource.Error: ODBC: ERROR [42000] [Microsoft][Драйвер ODBC Microsoft Access] Ошибочный пароль.
Сведения:
    DataSourceKind=Odbc
    DataSourcePath=dbq=M:\Data\Ежедневная отчетность ЦСПКО\Нормирование ОБ\БД\Нормирование ОБ v.1.1c_be.accdb;driver={Microsoft Access Driver (*.mdb, *.accdb)};dsn=MS Access Database;exclusive=0;extendedansisql=1;readonly=1
    OdbcErrors=Table
Изменено: RomanNF - 20 Фев 2019 17:02:24
Добавление функции в запрос Power Query
 
Добрый день, уважаемые форумчане! Возник вопрос: возможно ли вставить в запрос Power Query функцию, которая бы отрабатывалась после консолидации данных из разных книг на одном листе?
Необходимо создать считалку (проект во вложении), в которой бы рассчитывались трудозатраты по операциям, выполняемым сотрудниками отдела в соответствии с утвержденными нормативами. Сами нормативы выведены в справочник, т.к. он будет дополняться новыми операциями и в котором будут меняться нормативы по существующим операциям. Вопрос: как и где произвести расчет трудозатрат (количество операций * утвержденный норматив)? Обработать таблицу с исходными данными или ввести доп. столбцы с расчетом в сводную таблицу?  
Извлечение даты в сводной таблице, Извлечение диапазона дат функцией "Получить.данные.сводной.таблицы"
 
Добрый день! Нужна помощь в решении задачки. Как модифицировать формулу ниже, чтобы с ее помощью можно было задавать диапазон дат, например с 24.04.2017 по 29.04.2017 г. для выгрузки из сводной таблицы?

=ЕСЛИОШИБКА(ПОЛУЧИТЬ.ДАННЫЕ.СВОДНОЙ.ТАБЛИЦЫ("Количество";'Сводная операции-нагрузка'!$A$3;"Дата";ДАТА($D$2;$C$2;$B$2);"Операция";[@Операция]);"")
Страницы: 1
Наверх