Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Выбрать дату в календареВыбрать дату в календаре

Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 31 След.
Извлечь из текста порядковые номера, которые начинаются с английской B, P, W и C
 
=СЖПРОБЕЛЫ(ВПР("*";ПСТР(A1;ПОИСК({"B":"P":"W":"C"};A1&"C");5);1;))
Изменено: АlехМ - 1 Ноя 2019 19:52:17
Алексей М.
Извлечь из текста порядковые номера, которые начинаются с английской B, P, W и C
 
Тема: Извлечь из текста порядковые номера, которые начинаются с английской B, P, W и C
Код
=ПСТР(A1;МИН(ЕСЛИ(ЕЧИСЛО(ПОИСК({"B":"P":"W":"C"};A1&"C"));ПОИСК({"B":"P":"W":"C"};A1&"C")));5)
Изменено: АlехМ - 1 Ноя 2019 10:59:25
Алексей М.
Извлечь из текста порядковые номера, которые начинаются с английской B, P, W и C
 
Atcdimon,  в примере в русских словах английские буквы.
В поиске буквы В и С русские.
Полагаю искать нужно английские, а русские слова должны быть из русских букв.
Алексей М.
Поиск в массиве известных значений промежуточных результатов
 
почти как у Ігор Гончаренко,

=СТОЛБЕЦ(A1)*$B4/10

я не прав. ошибка вышла

Изменено: АlехМ - 30 Окт 2019 20:35:02
Алексей М.
Внесение данных при равных условиях в разных листах, Внесение данных при равных условиях в разных листах
 
Так нужно?
Код
=ТЕКСТ(СУММПРОИЗВ((B$1=База!$A$2:$A$1000)*($A2=База!$G$2:$G$1000)*База!$H$2:$H$1000);"ч:мм:сс;;")
Алексей М.
Ссылка на именованный диапазон, имя которого меняется в зависимости от значения выпадающего списка.
 
Код
=ВПР(A2;ДВССЫЛ("Наим_"&B$1);6;0)
Алексей М.
Сумма ячеек со временами в формате чч:мм (перед часам может быть минус)
 
1. отрицательное время не бывает.
2. У вас в ячейках текст.
Что делать.
1. Копируете любую пустую ячейку.
2. Выделяете диапазон с данными.
3. кликнуть правой кнопкой мыши.
4. Выбрать "Специальная вставка"
5. Сложить, Ок.
6. Поставить диапазону формат Время часы и минуты

Отрицательное время суммироваться не будет, так как эти значения останутся текстом.

Сумму можно считать формулой массива
Код
=СУММ(ЕСЛИ(ЕЧИСЛО(-B1:B9);--B1:B9))-СУММ(ЕСЛИ(ЕОШ(-B1:B9);--ПРАВБ(B1:B9;5)))
Изменено: АlехМ - 2 Окт 2019 19:01:49
Алексей М.
Места по совокупности баллов и времени
 
Минус нельзя. Смотри пример
Алексей М.
Места по совокупности баллов и времени
 
Так нужно?
С дополнительным столбцом. Доп. столбец можно скрыть.
Алексей М.
Преобразование текстовых значений в числовые при сложении., сложение значений с пропусками, некоторые данные в скобках
 
Можно
Код
=A3+B3+ЕСЛИ(ДЛСТР(C3)<8;C3;ЛЕВБ(C3;ПОИСК("?(";C3&"(")))

а лучше так

Код
=A3+B3+ЛЕВБ(C3;ПОИСК("?(";C3&"("))
Изменено: АlехМ - 26 Сен 2019 20:28:59
Алексей М.
Преобразование текстовых значений в числовые при сложении., сложение значений с пропусками, некоторые данные в скобках
 
Код
=A3+B3+ЕСЛИ(ДЛСТР(C3)<8;C3;ПОДСТАВИТЬ(ПСТР(C3;ПОИСК("(";C3)+1;99);")";))
Алексей М.
извлечение числа из текста
 
manat78, летучая ДВССЫЛ() может тормозить, если числа извлекать из большого количества строк.
Алексей М.
извлечение числа из текста
 
БМВ, можно исправить, но в тексте может быть число и больше 15 знаков, например артикул. Для такого случая формула не подойдет, нужно править.
Поэтому я исправлять на 15 не стану.
Алексей М.
извлечение числа из текста
 
Код
=-ПРОСМОТР(;-ПРАВБ(ЛЕВБ(A3;ПРОСМОТР(2;1/ПСТР(A3;СТРОКА($1:$99);1);СТРОКА($1:$99)));СТРОКА($1:$19)))
Изменено: АlехМ - 19 Авг 2019 13:46:28
Алексей М.
Как осуществить поиск позиции значения в массиве снизу вверх
 
Код
=ПРОСМОТР(2;1/(C1:C6=C17);СТРОКА(C1:C6))
Алексей М.
[ Закрыто] ВПР, Товарищи помогите разобраться с фукцией ВПР, как просить что если ячейка не равно А то будет такое то значение.
 
Тема создана не по правилам форума
Алексей М.
Нумерация повторяющихся строк
 
Petrarkaa, еще вариант
Код
=ОТБР(СТРОКА(A3)/3)
Алексей М.
Формула для распределения смен к датам
 
Код
=ТЕКСТ(A2;"ДД/ММ/ГГГ ")&ЕСЛИ((ОСТАТ(A2;1)>=8/24)*(ОСТАТ(A2;1)<20/24);"день";"ночь")
Алексей М.
Номер строки из выпадающего списка., Как узнать номер строки из выпадающего списка при повторяющихся значениях
 
А может быть форма в помощь?
Алексей М.
Сложение промежутка чисел "от" и "до"
 
Еще можно формулу массива применить. Ввод Ctrl+Shift+Enter
Код
=СУММ(СУММЕСЛИ(B:B;{"<":"<="}&D2:D3;C:C)*{-1:1}) 

или обычную

Код
=СУММПРОИЗВ(СУММЕСЛИ(B:B;{"<":"<="}&D2:D3;C:C)*{-1:1})
Изменено: АlехМ - 22 Июл 2019 20:27:17
Алексей М.
Сложение промежутка чисел "от" и "до"
 
Еще так можно
Код
=СУММ(СМЕЩ(C14;ПОИСКПОЗ(D2;B14:B22;)-1;;D3-D2+1))
Алексей М.
Заменить символы на перенос строки, Чтобы каждый запрос после символов шёл с новой строки (ячейки снизу)
 
Цитата
Geineh написал:
появились лишние пробелы в конце фразы
тогда так
Код
=ПОДСТАВИТЬ(СЖПРОБЕЛЫ(ПСТР(ПОДСТАВИТЬ(A1;"!";);2;999));" -";СИМВОЛ(10))
Алексей М.
Заменить символы на перенос строки, Чтобы каждый запрос после символов шёл с новой строки (ячейки снизу)
 
Код
=ПОДСТАВИТЬ(ПСТР(ПОДСТАВИТЬ(A1;"!";);2;999);"-";СИМВОЛ(10))
Алексей М.
Вычисление максимального (наибольшего числа), когда критерии не вынесены с отдельную таблицу
 
Формула массива
Код
=ЕСЛИ(A2<>A1;МАКС((A$2:A$150=A2)*(B$2:B$150&0));"")
Алексей М.
Расчет сложных процентов без использования формул массива, функция ПРОИЗВЕД с несколькими условиями.
 
Года идут подряд, поэтому можно еще так
Код
=H6*ПРОИЗВЕД(D6:ИНДЕКС(D6:D10;G6-2019))

Еще можно с "летучей" СМЕЩ(), но вы от "летучей" ДВССЫЛ() отказались

Код
=H6*ПРОИЗВЕД(СМЕЩ(D6;;;G6-2019))
Изменено: АlехМ - 10 Июл 2019 10:11:19
Алексей М.
Расчет сложных процентов без использования формул массива, функция ПРОИЗВЕД с несколькими условиями.
 
Код
=H6*ПРОИЗВЕД(D6:ИНДЕКС(D6:D10;ПОИСКПОЗ(G6;C6:C10)))
Алексей М.
Поиск пустой ячейки в диапазоне
 
БМВ,
Цитата
nimon написал:
ячейки объединенные
Алексей М.
Поиск пустой ячейки в диапазоне
 
формула массива
Код
=ПОИСКПОЗ(1=1;A26:A58="";)+25

в макросе

Код
rf = Application.CountA(Range("A26:A58")) + 26
Алексей М.
Поиск пустой ячейки в диапазоне
 
Ищите пустую в диапазоне A26:A58
Приложите файл-пример
Алексей М.
замена определенных чисел в последовательности на другие.
 
Код
=ЕСЛИ(A2=0;--ЕЧИСЛО(ИНДЕКС(A3:A99;ПОИСКПОЗ(1;A3:A99;))*(ПРОСМОТР(2;1/(A$1:A1>0);A$1:A1)=1));A2)
Алексей М.
Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 31 След.
Наверх