Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Выбрать дату в календареВыбрать дату в календаре

Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 33 След.
Выделить ячейку по адресу, указанному в другой ячейке
 
Цитата
sokol92 написал:
изменить одновременно A1 и B1
Это можно заблокировать, вставив второй строкой
Код
If Target.Cells.Count > 1 Or IsEmpty(Target) Then Exit Sub
Хотя в задаче не говорилось о ставке нескольких ячеек, копированием и вставкой.
Написал адрес, можно без $ и перекинуло сразу при вводе.
Алексей М.
Выделить ячейку по адресу, указанному в другой ячейке
 
Код
Private Sub Worksheet_Change(ByVal Target As Range)
If Intersect(Target, Range("A1")) Is Nothing Then Exit Sub
Range(Target).Activate
End Sub
В модуль листа
Изменено: АlехМ - 3 Апр 2020 14:18:35
Алексей М.
Формула добавляющая число лишь один раз при многкратном срабатывании условия.
 
Код
=ЕСЛИ(A1=A2;B1+C1+(СЧЁТЕСЛИ(C$1:C1;">2")=1);0)
=ЕСЛИ(A1=A2;B1+C1+(СЧЁТЕСЛИ(C$1:C1;">"&B$1)=1);0)
=ЕСЛИ(A1=A2;B1+C1+A$1*(СЧЁТЕСЛИ(C$1:C1;">"&B$1)=1);0)

В А1 можно вписать что прибавлять 1 или 0,5 или др.
В В1 порог, при котором срабатывает условие.
Изменено: АlехМ - 2 Апр 2020 12:00:04
Алексей М.
Условное форматирование строк по ключевым словам
 
Вставьте формулу в ячейку, например G1 и протяните вниз. Это формула массива ввод тремя клавишами.
Код
=ПОИСКПОЗ(1=1;(МУМНОЖ(ТРАНСП(--ЕЧИСЛО(ЕСЛИ(Лист1!$J$3:$L$14<>"";ПОИСК(Лист1!$J$3:$L$14;результат!$B1))));СТРОКА(результат!$J$3:$K$14)^0)>0);)
Чтобы понимать работу формулы нужно видеть что происходит с массивами на каждом этапе. Для этого нужно выделить фрагмент формулы в строке формул и нажать F9.
Выделяем фрагмент --ЕЧИСЛО(ЕСЛИ(Лист1!$J$3:$L$14<>"";ПОИСК(Лист1!$J$3:$L$14;результат!$B1)))  нажимаем F9 и видим массив
{1;0;0:0;0;0:0;0;0:0;0;0:0;0;0:1;0;0:0;0;0:0;0;0:0;0;0:0;0;0:0;0;0:0;0;0} должна быть одна единица, а видим две, так как в первой категории два раза крючок.
С таким массивом работать сложно поэтому используем МУМНОЖ() Выделяем фрагмент
МУМНОЖ(ТРАНСП(--ЕЧИСЛО(ЕСЛИ(Лист1!$J$3:$L$14<>"";ПОИСК(Лист1!$J$3:$L$14;результат!$B1))));СТРОКА(результат!$J$3:$K$14)^0)
и получаем массив {2:0:0} что означает, в первой категории встретили два критерия. Как раз крючок.
Далее определяем позицию в массиве значения больше 0. Это позиция 1
Посмотрите те же фрагменты, где формула возвращает 2 и 3
Алексей М.
Условное форматирование строк по ключевым словам
 
Тут имя присвоено формуле, которая включает диапазон из трех столбцов и двенадцати строк
Алексей М.
Условное форматирование строк по ключевым словам
 
Так нужно?
Ключевые слова в категориях не должны совпадать.
У вас КЛАПАН в двух категориях.
Изменено: АlехМ - 1 Апр 2020 19:29:12
Алексей М.
Замена столбца при выборе из списка, Заменить столбец на значения из другого листа при выборе из списка
 
Код
=ГПР(A$10;Лист2!E$1:AT$13;МЕСЯЦ(1&B10)+1;)
Алексей М.
Расположить значения в порядке убывания их чисел
 
Если объединять, то ЕСЛИОШИБКА() не нужна
Код
=ЕСЛИ(СТРОКА(A1)>СЧЁТЕСЛИ(C:C;">0");"";ВПР(НАИБОЛЬШИЙ(C$2:C$29-СТРОКА(C$2:C$29)%;F2);ЕСЛИ({1;0};C$2:C$29-СТРОКА(C$2:C$29)%;B$2:B$29);2;))
Алексей М.
Вывод цены по приоритетности по заданным данным
 
Код
=ЕСЛИОШИБКА(ИНДЕКС(B6:E6*{1;1;0,97;1,03};ИНДЕКС(ПОИСКПОЗ(1=1;B6:E6>0;);));"Нет даных")

или массивная

Код
=ЕСЛИОШИБКА(ИНДЕКС(B4:E4*{1;1;0,97;1,03};ПОИСКПОЗ(1=1;B4:E4>0;));"Нет данных")
Изменено: АlехМ - 1 Апр 2020 16:38:39
Алексей М.
Расположить значения в порядке убывания их чисел
 
Цитата
dim284 написал:
Все равно не получается
Если вы используете формулу из сообщения №8 и она выводит значения против пустых ячеек, значит вы с излишком протянули номера в столбце F
Для номеров можно применить формулу. Для ячейки F2
Код
=ЕСЛИ(СТРОКА(A1)>СЧЁТЕСЛИ(C:C;">0");"";СТРОКА(A1))
Алексей М.
Расположить значения в порядке убывания их чисел
 
Цитата
dim284 написал:
А как же её (ЕСЛИОШИБКА()) в эту формулу
Если данных больше 100, то добавьте еще по одному % в двух местах
Код
=ЕСЛИОШИБКА(ВПР(НАИБОЛЬШИЙ(C$2:C$29-СТРОКА(C$2:C$29)%;F7);ЕСЛИ({1;0};C$2:C$29-СТРОКА(C$2:C$29)%;B$2:B$29);2;);"")
Изменено: АlехМ - 1 Апр 2020 14:10:30
Алексей М.
Расположить значения в порядке убывания их чисел
 
Без доп столбцов формула массива. Ошибку можно скрыть функцией ЕСЛИОШИБКА()
Код
=ВПР(НАИБОЛЬШИЙ(C$2:C$29-СТРОКА(C$2:C$29)%;F7);ЕСЛИ({1;0};C$2:C$29-СТРОКА(C$2:C$29)%;B$2:B$29);2;)
Алексей М.
Суммирование значений по нескольким параметрам
 
Код
=D3*СУММПРОИЗВ(ИНДЕКС(данные_сбора!$B$1:$G$99;ПОИСКПОЗ(B3;данные_сбора!$A:$A;);)*ЕЧИСЛО(ПОИСК(Процессы;C3)))
Алексей М.
Ранг по двум критериям, Необходимо выполнить ранжирование по двум столбцам
 
AGGREGATE() есть в Excel 2010 и выше, да и формула длиннющая получается.  ;)  
Алексей М.
Ранг по двум критериям, Необходимо выполнить ранжирование по двум столбцам
 
Вдруг угадал.
Код
=СУММПРОИЗВ(Ч(B$5:B$12-C$5:C$12%%%%<=B5-C5%%%%))
Алексей М.
Определить ближайшее для указанного числа
 
Формула массива
Код
=1/(1/МАКС(ЕСЛИ(A1:A8<=C1;A1:A8)))
Изменено: АlехМ - 29 Мар 2020 13:31:53
Алексей М.
Зеркальное изменение данных в таблице
 
Код
=ИНДЕКС(C$2:C$7;ЧСТРОК(C$1:C$7)-СТРОКА(A1))&""
Алексей М.
Найти нужное значение в массиве на основе вводных, а далее продолжить подбор значений из массива последовательно
 
Еще вариант для первого вопроса. Формула массива
Код
=ЕСЛИОШИБКА(НАИМЕНЬШИЙ(ЕСЛИ(ВПР($B12;$B$5:$I$8;СТОЛБЕЦ($B$5:$H$8);)>9;ВПР($B12;$B$5:$I$8;СТОЛБЕЦ($B$5:$H$8);));СТОЛБЕЦ(A1));"")
Изменено: АlехМ - 28 Мар 2020 20:19:42
Алексей М.
Знак тире отсутствует в строке формул.
 
При формате ячейки 0-00 число 665216 будет отображаться 6652-16
Алексей М.
Выбрать ячейки с буквами, Выбрать ячейки с буквами
 
Код
=ЕСЛИ(ЕОШ(-A1);A1;"")
Алексей М.
Как подтянуть правильное значение при соблюдении условия
 
Код
=ЕСЛИОШИБКА(ТЕКСТ(ВПР(A2;Прайс!A$2:B$999;2;);";;Ро\с\сия;@");"")
Изменено: АlехМ - 25 Мар 2020 13:08:39
Алексей М.
Как посчитать сумму сделок по отделу за год в Spreadsheet, В файле получается подсчитать, но те же самые данные в Гугл Таблицах не считает.
 
Настя_Nastya, А логотип Google таблиц. Ссылку поправил.
Алексей М.
Как посчитать сумму сделок по отделу за год в Spreadsheet, В файле получается подсчитать, но те же самые данные в Гугл Таблицах не считает.
 
В Google таблицах работает
Таблица
Изменено: АlехМ - 13 Мар 2020 18:05:15
Алексей М.
Как удалить строки ячейки которых содержат только буквы?
 
Решение формулой. Формула массива. Ошибку можно скрыть функцией ЕСЛИОШБКА().
А можно удалить строки с ошибкой.
Код
=ИНДЕКС(A:A;НАИМЕНЬШИЙ(ЕСЛИ(МУМНОЖ(--ЕЧИСЛО(-ПСТР($A$2:$A$15;СТОЛБЕЦ(A:I);1));СТРОКА($1:$9)^0);СТРОКА(A$2:A$15));СТРОКА(A1)))
Алексей М.
Процент износа оборудования
 
Исправил формулу.
Код
=МИН((МИН(РАЗНДАТ(B2;C2;"M");300)*70+МАКС(РАЗНДАТ(B2;C2;"M")-300;)*30)%/300;1)
Алексей М.
Процент износа оборудования
 
Еще вариант. Константы можно упростить.
Код
=МИН(РАЗНДАТ(B2;C2;"M")*ЕСЛИ(РАЗНДАТ(B2;C2;"M")>300;100/600;70/300);100)%

Столбец D и E для справки. В формуле не используются

Обнаружил ошибку. :-(

Изменено: АlехМ - 13 Мар 2020 12:24:23
Алексей М.
Как посчитать сумму сделок по отделу за определённый год
 
Настя_Nastya, а зачем вы в массиве создаете текстовые значения с помощью ЕСЛИ()?
Да и от массивного ввода можно уйти другой функцией.
Код
=СУММПРОИЗВ((ГОД($B$2:$B$12)=B$17)*($A$2:$A$12=$A18)*$C$2:$C$12)
Алексей М.
Как посчитать сумму сделок по отделу за определённый год
 
БМВ, согласен с Настя_Nastya и ее преподавателем. Лучше использовать денежный формат ячеек, чем текстовый. С ним больше хлопот.
Но у ovodremov наверно есть тоже преподаватель, который поставил задачу именно так.
Поэтому не смотря на трудности задачу нужно решить.
Алексей М.
Как посчитать сумму сделок по отделу за определённый год
 
Названия отделов должны совпадать в таблицах
Код
=СУММПРОИЗВ((ГОД($B$2:$B$12)=B$17)*($A$2:$A$12=$A18)*ПОДСТАВИТЬ(ПОДСТАВИТЬ($C$2:$C$12;"₽";);" ";))
Изменено: АlехМ - 11 Мар 2020 20:05:13
Алексей М.
Число лет, месяцев и дней с определённой даты до сегодня
 
Теперь можно свой вариант показать с прибавкой 400 лет
Доп. столбец В можно скрыть.
Алексей М.
Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 33 След.
Наверх