Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Выбрать дату в календареВыбрать дату в календаре

Страницы: 1
[ Закрыто] диагарамма ганта
 
привет.
ребята нужна помощь в формировании файла для визуализации планирования вахтовых команд (вахтовый метод работы, необходимо визуально в рамках года видеть когда сотрудник на работе, когда на отдыхе).
есть готовый файл в котором описано 6 вахтовых команд. при присвоении человеку номера вахтовой команды в рамках года рисуется вахтовая команда, т.е. периоды когда человек находится на вахте, а когда находится на отдыхе.
не могу сообразить как сделать подобный файл только условий больше... 28 вахтовых команд (пересменка на каждый день), т.е. необходимо чтобы например присвоили вахтовую команду 1 (пересменка 1 числа) и эксель прорисовал два месяца на вахте, месяц на отдыхе и все начиная с 1 числа, номер 2, пересменка со 2 числа и т.д.
сумбурно написал. но если посмотреть файл будет понятнее....
может макрос какой можно прописать...
за помощь готов заплатить
заранее спасибо за отзыв  
изменение даты от времени
 
Цитата
webley написал:
в общем, тогда так
=ЕСЛИ(B32-ЦЕЛОЕ(B32)<B31-ЦЕЛОЕ(B31);A31+1;A31)
webley, СУПЕР!!!! спасибо огромное!! все работает!
изменение даты от времени
 
Цитата
webley написал:
Код ? 1=ЕСЛИ(ИЛИ(B32<B31;B32=1);A31+1;A31)
webley,
спасибо за ответ, пробовал ее ранее, но после ячейки А38 не работает.... должно начаться 28.10, а эксель отображает 27.10
но мысль Вы мою поняли.... именно это я и хотел.. пробовал если.. но почему то не получается  
изменение даты от времени
 
Цитата
БМВ написал:
Да и с ним не лучше    andrey57k ,  Что и куда там тянуть? Если правильно понял, то при переходе дня для A34=A33+DAY(B34)-DAY(B33)
БМВ, эх, сложно блин описать... проще бы объяснить...
но попробую...
Возможно ли прописать какую-нибудь формулу в ячейку А32 и протянуть ее чтобы при изменении времени (в столбце В) до 00.00 изменялась дата +1 к предыдущей
переход между часами может меняться и количество времени замера тоже...  
изменение даты от времени
 
прошу прощения.
изменение даты от времени
 
Доброго дня. помогите решить вопрос.
Суть такова, есть столбец с указанием времени, какую прописать формулу чтобы дата автоматически менялась (при протягивании) при начале новых суток

Дата первая число сформировано по ссылке - дата начала замера. Дело в том, что время замера может меняться и количество временных замеров в рамках суток тоже. Попробовал через функцию ЕСЛИ... но что то не получается(
Буду очень признателен за помощь
Надеюсь понятно описал проблему свою
Дата замераВремя замера
26.10.201717:10
26.10.201719:00
26.10.201721:00
27.10.20170:00
27.10.20173:00
27.10.20177:00
27.10.201713:00
27.10.201719:00
28.10.20171:00
28.10.20177:00
28.10.201713:00
28.10.201719:00
29.10.20171:00
Страницы: 1
Наверх