Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Выбрать дату в календареВыбрать дату в календаре

Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 14 След.
Сравнить даты (без учета секунд) и определить дату, которой нет во втором столбце
 
Цитата
Тимофеев написал:
10 в минус
Ну, на результат не влияет. Хотя в принципе не беда и можно выкрутиться как-то так:
=--NOT(COUNTIFS(D:D;">"& (INT(A2*24*60)-10^-6)/24/60;D:D; "<"& (INT(A2*24*60+1)-10^-6)/24/60)>0)
Цитата
Тимофеев написал:
всегда одно значения выдают в разных версиях?
Сейчас нет возможности проверить, завтра на раб. компе посмотрю.
Изменено: memo - 20 апр 2021 23:12:23
Сравнить даты (без учета секунд) и определить дату, которой нет во втором столбце
 
Цитата
sokol92 написал:
Кнгига, содержащая формулу из #15, будет корректно пересчитываться в любой локализации.
Вот только с разделителями беда. Я сейчас пишу с бука супруги, у нее французская локаль и разделители идентичны русской версии.
На точки эксель заругался, а с запятыми выдает зеркально противоположный результат.
Сравнить даты (без учета секунд) и определить дату, которой нет во втором столбце
 
Вариант.
=ISERROR(MATCH(--TEXT(A2;"ДД/ММ/ГГГГ ч:мм");$E$2:$E$417;0))/1
Сортивка данных из столбцов с помощью формул, формулой
 
DJMC, Может так?
Упражнения по Excel
 
Юлия Якимчук,
Цитата
Юлия Якимчук написал:
Или же "трудно эффективно усвоить материал, если в обозримом будущем для него нет практического применения" (С) и на этом можно поставить жирную точку?
Вы видимо не до конца прочли мой пост, раз процитировали именно эту фразу. Уточню. Материал усваивать надо, но одновременно надо искать и применение для усвоенного.
Кстати, на эту тему у Азимова есть отличный рассказ "Sucker Bait", в русском переводе "Ловушка для простаков". Там как раз и затрагивается вопрос, что НАДО и КОГДА НАДО. На форуме каждый день появляются задачки, есть и довольно простые, с них и начните.
З.Ы. Даю подсказку по задачке которую подкинул Вам seggi.
Код
=CHAR(RANDBETWEEN(65;90))&RANDBETWEEN(1;9)&CHAR(RANDBETWEEN(97;122))...и т.д.

Не забудьте перевести формулы на русский, если у вас стоит русский офис.
Что это за числа 65-90 и 97-122 можно узнать тут. Удачи.
Изменено: memo - 18 апр 2021 02:33:08
Узнать дату первого и последнего обращения и построить сводную
 
Вот, взгляните, так устроит?
Поиск в строке числового значения меньшего чем заданное
 
Еще вариант.
=IF(A3:H3<=$B$1;SMALL(A3:H3;COUNTIF(A3:H3;"<="&$B$1));"Превышение лимита: "&MIN(A3:H3))
Вводить через CTRL+SHIFT+ENTER
Изменено: memo - 18 апр 2021 00:21:53 (Дополнение)
Пересчёт линейных размеров Длина*Ширина, находящихся внутри текста, в метры квадратные.
 
Цитата
БМВ написал:
тогда очень большие не обработает
22800м и обрабатывать не нужно, можно сразу класть дорожку для боулинга  :)
Пересчёт линейных размеров Длина*Ширина, находящихся внутри текста, в метры квадратные.
 
Цитата
БМВ написал:
размер меньше метра и гудбай
Черт, а ведь верно. Соорудил такой костыль, вроде работает.
=PRODUCT(TRIM(SUBSTITUTE(MID(B5;SEARCH("~*";B5)+1;4);"*";""));TRIM(SUBSTITUTE(MID(B5;SEARCH("~*";B5)+LEN(TRIM(MID(B5;SEARCH("~*";B5)+6;4)))+2;4);"*";"")))%%%
Кстати, у вас тоже надо бы подправить: MID(B5;SEARCH("~**~*";B5)+1;9)
У buchlotnik, изначально универсальный вариант.
Изменено: memo - 16 апр 2021 02:06:59
Пересчёт линейных размеров Длина*Ширина, находящихся внутри текста, в метры квадратные.
 
Еще вариант.
Код
=PRODUCT(TRIM(MID(B5;SEARCH("~*";B5)+1;4));TRIM(MID(B5;SEARCH("~*";B5)+6;4)))%%%
Поиск строки и столбца таблицы, содержащих заданное значение
 
Если по условию из ячейки J8 то, думаю, лучше так:
=ИНДЕКС($B$1:$B$7;НАИМЕНЬШИЙ(ЕСЛИ($D$4:$H$7=J8;СТРОКА($B$4:$B$7));1))
По заданному наименованию организации вывести список всех контактных лиц и их данные
 
Елена Дроздова,
Код
=IFERROR(INDEX(Лист1!$B$2:$E$100,AGGREGATE(15,6,ROW($A$1:$A$100)/(Лист1!$A$2:$A$100=$B$1),ROW(A1)),MATCH(A$2,Лист1!$B$1:$E$1,0)),"")
Разность значений ячеек между последней и текущей заполненными в динамическом диапазоне (без макросов и промежуточных вычислений)
 
Jim_Hawkins,
Вариант на основе формулы от Mershik. Нули скрыты пользовательским форматом.  0;-0;;@
Код
=СУММ(ЕСЛИОШИБКА(ЕСЛИ((C13<>"");C13-ПРОСМОТР(2;1/($C12:C$13<>"");$C12:C$13));ЕТЕКСТ(C13)*ПРОСМОТР(2;1/($C12:C$13<>"");$C12:C$13)-ИНДЕКС($C11:C$13;ПОИСКПОЗ(ЛОЖЬ;ЕПУСТО($C$13:$C$30);-1);1)))

Вводить как массивную.
Суммирование с разных листов
 
igor chernov,
AFAIK, ДВССЫЛ не поддерживает 3Д ссылки.
Сделать выборку из 5 самых критических форм с большим количеством брака
 
Да, в 2007 работать не будет - формула АГРЕГАТ появилась начиная с 2010 офиса. Для 2007 будет примерно так:
Код
=ИНДЕКС($B$4:$B$34;НАИМЕНЬШИЙ(ЕСЛИ(($C$4:$C$34=G4);(СТРОКА($C$4:$C$34)-СТРОКА($C$4)+1));СЧЁТЕСЛИ($G$4:G4;G4)))

Вводить тремя клавишами CTRL+SHIFT+ENTER.
Цитата
Роман Танков написал:
спасибо большое может я  в знак благодарность чуть на счет телефона денег кину
Не стоит, все ок. Рад был помочь.
Изменено: memo - 7 апр 2021 22:22:02
Сделать выборку из 5 самых критических форм с большим количеством брака
 
В смысле не протягивается и не вставляется? Покажите в файле.
Сделать выборку из 5 самых критических форм с большим количеством брака
 
Роман Танков,
Может так? И как быть с формами, попадающими в топ 5 и имеющими одинаковое кол-во трещин?
Изменено: memo - 7 апр 2021 20:22:03
Формула для суммирования произведений последовательных ячеек в строке
 
Oleg_k,
Вот вам чуть переделанные формулы по новому примеру. От vikttur, и из #5.
=СУММПРОИЗВ(ЕСЛИ($B$3:$M$3=$C$3,B4:M4)+ЕСЛИ($B$3:$M$3=$D$3,B4:M4))
=СУММПРОИЗВ((($C$13:$L$13=$C$13)*$C14:$L14)+(($D$13:$M$13=$D$13)*($D14:$M14)))

З.Ы. Еле зашел на форум
Изменено: memo - 7 апр 2021 17:45:31
Суммировать значения торговых точек, но не всех, а выборочно
 
Цитата
Роман Калина написал:
но для Гугл таблиц?
По-правде говоря этот вопрос к данному форуму практически никакого отношения не имеет, ибо продукты разные.
Но тем не менее эта конструкция будет работать.
Код
=(СУММПРОИЗВ(--(C2:C13="да");(--ЕЧИСЛО(ПОИСКПОЗ(A2:A13;A17:A18;0)));B2:B13))
Суммировать значения торговых точек, но не всех, а выборочно
 
Цитата
Роман Калина написал:
Почему он суммирует произведения. Произведение чего с чем в данном случае?
В данном случае функция использует логику ИЛИ. Т.е. возвращает две суммы 3 и 2. Выделите
Код
СУММЕСЛИМН($B$2:$B$13;$A$2:$A$13;A17:A18;$C$2:$C$13;"да")
, затем нажмите F9 и увидите два значения {3\2}
Их надо как-то просуммировать, что и делает СУММПРОИЗВ. Также, вместо диапазона можно указать массив констант:
Код
=SUMPRODUCT(SUMIFS($B$2:$B$13;$A$2:$A$13;{"A"\"B"};$C$2:$C$13;"да"))
- результат будет тот же.
Здесь поподробнее с примерами.
Суммировать значения торговых точек, но не всех, а выборочно
 
Роман Калина,
По вашему примеру:
Код
=SUMPRODUCT(SUMIFS($B$2:$B$13;$A$2:$A$13;$A$17:$A$18;$C$2:$C$13;"да"))
Вывод значений из строк, в которых значение ячеек столбца соответствуют заданному, как ускорить расчеты?
 
Цитата
iAlex написал:
а не массива формула будет быстрее или точно также отрабатывать?  
Например у меня, на довольно старом компе Q9550 c 8 гб ОЗУ, что массивные что нет, уже на 500 строках дают ощутимую задержку. С новыми пеньками, наверное, будет получше, но ненадолго.
Подстановка таблицы по выбранному условию
 
afanas,
По примеру.
Код
=INDEX(A$3:A$100;MATCH($H$3;$A$3:$A$100;)+ROWS($H$1:H3)-2)
Изменено: memo - 4 апр 2021 14:05:36
Выбрать строки по нескольким условиям
 
Цитата
iAlex написал:
смог вытащить только 1 строку
Потому что это формула массива и вводится через CTRL+SHIFT+ENTER. Вот немассивный вариант.
=INDEX(Links!A$2:A$500;AGGREGATE(15;6;ROW($B$1:$B$500)/(MATCH(Links!$E$2:$E$500;{"dofollow";"NA"};0))/(ISNUMBER(--Links!$F$2:$F$500));ROW(A1)))
Изменено: memo - 5 апр 2021 22:25:43
Подстановка значений в 3 ячейки по одному условию
 
Еще.
=ЕСЛИОШИБКА(ИНДЕКС($B$4:$E$6;АГРЕГАТ(15;6;СТРОКА($A$1:$A$100)/(($B$4:$E$6<>"")/($B$3:$E$3=$B$10));СТРОКА(A1));ПОИСКПОЗ($B$10;$B$3:$E$3;0));"")
Формула для суммирования произведений последовательных ячеек в строке
 
=СУММПРОИЗВ((($B$2:$H$2="Параметр1")*$B3:$H3)*(($C$2:$I$2="Параметр2")*($C3:$I3)))
получить данные в зависимости от значения и даты
 
Александр, В моем варианте, если выбирать указанные организации, то формула по этой усредненной дате находит перечисленных вами людей. Естественно, если указать дату больше/меньше окончания-начала работ, то нужные данные находиться не будут.
получить данные в зависимости от значения и даты
 
Александр,
Тогда конкретизируйте, на какой временной критерий опираться при поиске? Собственно, об этом вас спросил New, во втором сообщении.
получить данные в зависимости от значения и даты
 
Александр,

Может так?
Текст по столбцам по кол-ву символов.
 
Вариант:
Код
=MID($A1;INT((COLUMNS($A$1:A1)-1)/1)*4+1;4)
Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 14 След.
Наверх