Выбрать дату в календареВыбрать дату в календаре

Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 24 След.
Сумма чисел расположенных в ячейках через дробь или какой либо знак.
 
Цитата
Тимур Медоев написал:
Проверьте формулу и добавьте скобки где необходимо
Значит нужно проверить правильно ли вы ее скопировали. В том числе и из файла, который я выложил.
Цитата

как прописать в ячейке  AG27 чтобы все восьмерке сложились, т. е. и с дробью и без дроби
Немного изменил формулы. Для восьмерок. Двойки при этом будут игнорироваться.
Код
=SUM(IFERROR(INT(SUBSTITUTE($N27:$AF27;"/";","));)*($N27:$AF27<>2))

Для двоек. Здесь восьмерки будут в игноре.
Код
=SUM(IFERROR(--RIGHT(SUBSTITUTE($N27:$AF27;"/";REPT(" ";15));15);)*($N27:$AF27<>8))
Изменено: memo - 15.10.2021 14:27:38
Сумма чисел расположенных в ячейках через дробь или какой либо знак.
 
Тимур Медоев,
Массивные формулы, вводятся через CTRL+SHIFT+ENTER.
Код
=SUM(IFERROR(--LEFTB($N27:$AF27;SEARCH("/";$N27:$AF27)-1);))
 
Код
=SUM(IFERROR(--RIGHTB($N27:$AF27;LEN($N27:$AF27)-SEARCH("/";$N27:$AF27));))
Как транспонировать строку через каждые 8 столбцов ?
 
В А3 вправо и вниз.
2021-10-14_235059.png
Как рассчитать сколько дней прошло между датами в одной формуле, где для строк без данных берется текущая дата
 
Цитата
Ellen Ca написал:
как сделать то же самое в power query?
Поздно увидел. Вариант на Power Query.
Код
let
    Source = Excel.CurrentWorkbook(){[Name="Table1"]}[Content],
    Type = Table.TransformColumnTypes(Source,{{"Start", type date}, {"End or in progress", type date}}),
    Calc = Table.AddColumn(Type, "Custom", each if [End or in progress] = null then Date.From(DateTime.LocalNow()) - [Start] else [End or in progress] - [Start]),
    TypeTo = Table.TransformColumnTypes(Calc,{{"Custom", Int64.Type}}),
    Output = Table.RenameColumns(TypeTo,{{"Custom", "Total of Days"}})
in
    Output
Как рассчитать сколько дней прошло между датами в одной формуле, где для строк без данных берется текущая дата
 
=IF(ISBLANK(B2);TODAY()-A2;B2-A2)
Перечислить числа, указанные в диапазоне a-b
 
Цитата
Светлый написал:
Дальше будет врать.
Точно, забыл.
Цитата
обратный слэш
Сработало!
Перечислить числа, указанные в диапазоне a-b
 
Цитата
Светлый написал:
*Тогда с региональными:
С региональными съедается единица в начале, да и запятые пропали.
С региональными

Добавил ПОДСТАВИТЬ() работает, но опять без запятых.
Без запятых

Ну и в обоих случаях диапазон 1975-2020 обрывается на 81 году.
Перечислить числа, указанные в диапазоне a-b
 
Цитата
Светлый написал:
*И немного сокращённая формула БМВ.
На региональных настройках US не сработала.
Скрин
Перечислить числа, указанные в диапазоне a-b
 
Цитата
БМВ написал:
с textjoinто каждый может
Ну классно же)) И это ничуть не умаляя ваши заслуги, как замечательного формулиста :)
Перечислить числа, указанные в диапазоне a-b
 
Мой вариант (максимально оптимизировал формулу, прежний вариант оставлять не вижу смысла):
Код
=TEXTJOIN(", ";1;IFERROR(SMALL(IF(ISNA(MATCH(ROW(INDEX($A$1:$A$20000;MIN(0+LEFTB($D2;4));):INDEX($A$1:$A$20000;MAX(0+RIGHTB($D2;4));));NOT(ROW($A$1:$A$20000));0));ROW(INDEX($A$1:$A$20000;MIN(0+LEFTB($D2;4));):INDEX($A$1:$A$20000;MAX(0+RIGHTB($D2;4));)));ROW($A$1:$A$50));""))

Или короче, но отнюдь не лучше.
Код
=TEXTJOIN(", ";1;IFERROR(SMALL(IF(ISNA(MATCH(ROW(INDIRECT(MIN(0+LEFTB($D2;4))&":"&MAX(0+RIGHTB($D2;4))));NOT(ROW($A$1:$A$20000));0));ROW(INDIRECT(MIN(0+LEFTB($D2;4))&":"&MAX(0+RIGHTB($D2;4)))));ROW($A$1:$A$50));""))

Не мерял как там по производительности, но по краткости и читаемости the winner однозначно код от Тимофеев.
Можно даже чуточку сократить, совсем будет конфетка.
Код
=TEXTJOIN(", ";1;IFERROR(1/(1/ROW($A$1:$A$2021)*(ROW($A$1:$A$2021)>=--LEFT(D2;4))*(ROW($A$1:$A$2021)<=--RIGHT(D2;4)));""))

З.Ы. Поскольку у меня нет TEXTJOIN воспользовался найденной в сети UDF (источник в ней же и указан).
Изменено: memo - 11.10.2021 16:23:54
Копирование данных из диапазона через постоянный интервал
 
Вариант.
В К2 вправо и вниз.
Код
=ИНДЕКС($A$2:$B$25;ЦЕЛОЕ((СТРОКА(A1)-1)*3)+ОСТАТ(ЧИСЛСТОЛБ($A$1:A1)-1;2)+1;ЕСЛИ(И((ОСТАТ(ЧИСЛСТОЛБ($A1:A1)-1;4)+1)>0;(ОСТАТ(ЧИСЛСТОЛБ($A1:A1)-1;4)+1)<3);1;2))

Короче:
Код
=ИНДЕКС($A$2:$B$25;ЦЕЛОЕ((СТРОКА(A1)-1)*3)+ОСТАТ(ЧИСЛСТОЛБ($A$1:A1)-1;2)+1;ЦЕЛОЕ((ОСТАТ((ЧИСЛСТОЛБ($A1:A1)-1);4))/2)+1)
Изменено: memo - 04.10.2021 22:45:50
Суммирование по нескольким критериям прописанным на ячейке
 
БМВ, Данных, с применениями я думаю тормозить будут все функции.
Последний вариант чисто для коллекции.
Суммирование по нескольким критериям прописанным на ячейке
 
По правде говоря, SUMIFS мне чисто по ощущениям никогда не казался быстрым на относительно больших таблицах от 1000 строк и выше. Завтра вроде релиз 2021-го офиса, интересно было бы проверить там.
Ну и напоследок еще вариант:
Код
=SUMPRODUCT(SUMIFS($F$6:$F$9;$E$6:$E$9;FILTERXML("<j><i>"&SUBSTITUTE($E$3;", ";"</i><i>")&"</i></j>";"//i")))
Суммирование по нескольким критериям прописанным на ячейке
 
Еще вариант, до 15 условий.
Код
=SUMPRODUCT(SUMIFS($F$6:$F$9;$E$6:$E$9;TRIM(MID(SUBSTITUTE(E$3;", ";REPT(" ";99));ROW($1:$15)*99-98;99))))
ячейки с зада :), и такое бывает
 
PQ рассердился)).
Вывести первый номер товара за продавцом
 
Не массивная, но с хорошими шансами стать ею))
Изменено: memo - 30.09.2021 15:08:20
Протянуть значение с одного столбца до последнего значение c другого столбца и т.д. с каждой строки
 
Неправильно понял задачу. Но тогда встречный вопрос. Код от Mershik, выводит все промежутки серийников, и он вас устраивает, тогда зачем в файле указаны повторы?
рецепт, формула
 
Екатерина Апрелева, Боюсь, без файла с таблицей и ингредиентами, а также пятью видами теста, Вам здесь скорее всего не помогут
Подсчет количества уникальных по условию
 
Цитата
Денис Ш. написал:
под группой 1 у нас есть Т1 и Т3, получается два значения,
Так в чем проблема, я же во второй формуле явно указал диапазон для условий E2:F2 - прописываете туда нужные Т и будет вам подсчет.
Изменено: memo - 29.09.2021 14:48:18
Протянуть значение с одного столбца до последнего значение c другого столбца и т.д. с каждой строки
 
Здравствуйте. Так подойдет?
Код
=ИНДЕКС($A$2:$B$10000;ЦЕЛОЕ((СТРОКА(A1)-1)/2)+1;ОСТАТ(СТРОКА(A1)-1;2)+1)
Подсчет количества уникальных по условию
 
Вариант:
Код
=СУММПРОИЗВ((A$2:A$8=ЛЕВСИМВ(F13;ДЛСТР($F$13)-1))*($C$2:$C$8="Т1")/СЧЁТЕСЛИМН(A$2:A$8;A$2:A$8;C$2:C$8;C$2:C$8))

Или для массива условий, в том числе и Т2, когда оно появится в примере))
Код
=СУММПРОИЗВ((A$2:A$8=ЛЕВСИМВ(F13;ДЛСТР($F$13)-1))*($C$2:$C$8=$E$2:$F$2)/СЧЁТЕСЛИМН(A$2:A$8;A$2:A$8;C$2:C$8;C$2:C$8))
Какие возможности есть у ФИЛЬТР.XML ?
 
Выкладываю линк на сайт, где подробно разобраны примеры применения данной функции.
Кстати, не все конструкции составленные в Excel 2016 и выше будут работать в 2013, это связанно с поддержкой версий xPath.
Изменено: memo - 29.09.2021 10:09:40
Поиск табличного значения по 3 критериям
 
Можно так:
=ИНДЕКС($E$7:$H$41;ПОИСКПОЗ(1;ИНДЕКС(($A$7:$A$41=F3)*($B$7:$B$41=G3); ); );ПОИСКПОЗ(H3;$E$5:$H$5;))
Еще чисто для примера, массивная:
=ИНДЕКС($E$7:$H$41;МАКС(($A$7:$A$41=F3)*($B$7:$B$41=G3)*СТРОКА($A$7:$A$41)-СТРОКА($A$7)+1);ПОИСКПОЗ(H3;$E$5:$H$5;))
Изменено: memo - 28.09.2021 16:56:13
Умножить числа по условиям
 
Цитата
Бахтиёр написал:
можно ли решить это с помощьью АГРЕГАТ()
В данной функции условия, вроде, можно использовать, начиная с параметра 14 и выше.
Заполнение колонки с последовательным изменением числа, но внутри ссылки
 
chgm, По примеру.
Код
=LEFT($C$2;LEN($C$2)-SEARCH("-";$C$2)-6)&TEXT(ROW(A40);"\0000")&".jpg"
Изменено: memo - 26.09.2021 13:01:17 (Убрал лишний ноль)
Объединение данных в одну ячейку, Сбор повторяющихся значений
 
Цитата
Kumar написал:
#ЗНАЧ!
CTRL+SHIFT+ENTER жали при вводе?
Объединение данных в одну ячейку, Сбор повторяющихся значений
 
Kumar,
Увы, до понедельника не могу, 2019-ый стоит на рабочей машине.
Кстати, в вашем последнем файле показать все равно не получится - формула не может ссылаться на саму себя. Я так понимаю, у вас русский офис, сделал перевод формулы:
Код
=ОБЪЕДИНИТЬ(", ";ИСТИНА;ЕСЛИ(($A$3:$A$13=A18)*($C$3:$C$13=C18)*($D$3:$D$13=D18);$B$3:$B$13;""))

Введите в ячейку В18  из вашего первого примера.
Объединение данных в одну ячейку, Сбор повторяющихся значений
 
Kumar, Усли у вас офис 2019 или по подписке, то в данном случае лучше всего подойдет функция TEXTJOIN()
В ячейку В18, жмете CTRL+SHIFT+ENTER и тянете вниз.
Код
=TEXTJOIN(", ";TRUE;IF(($A$3:$A$13=A18)*($C$3:$C$13=C18)*($D$3:$D$13=D18);$B$3:$B$13;""))
Как вычислить количество определенного слова в разных ячейках
 
Формулами для коллекции.
Поменять местами первое и последнее слово
 
Еще вариант, длинно, но наглядно)
Код
=REPLACE(A1;1;LEN(A1);TRIM(RIGHT(SUBSTITUTE(A1;" ";REPT(" ";LEN(A1)));LEN(A1))))&" "&SUBSTITUTE(RIGHT(A1;LEN(A1)-SEARCH(" ";A1));TRIM(RIGHT(SUBSTITUTE(A1;" ";REPT(" ";LEN(A1)));LEN(A1)));REPLACE(TRIM(RIGHT(SUBSTITUTE(A1;" ";REPT(" ";LEN(A1)));LEN(A1)));1;LEN(A1);LEFT(A1;SEARCH(" ";A1))))
Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 24 След.
Наверх