Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Выбрать дату в календареВыбрать дату в календаре

Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 20 След.
При печати выравнивание текста нарушено, выравнивание
 
N Neo, пример бы закинули или, на худой конец, скрины. может кто и поможет
PQ значения из одного столбца перенести в три столбца согласно индексу
 
Андрей Лящук, ссылка на слове "этой"
PQ значения из одного столбца перенести в три столбца согласно индексу
Формула Date.WeekOfYear в Power Query
 
Цитата
Андрей VG написал:
Не проще ли
Здравствуйте. было бы проще, если б я знал эти функции)
раз не знаю, то я понатыкал кнопками, а потом в один шаг все собрал.

КОГДА ЗНАЕШЬ - ВСЕ ПРОСТО
Код
= Table.AddColumn(Источник, "Пользовательская", each Text.From(Date.Year([Столбец1])) & Number.ToText(Date.WeekOfYear([Столбец1]), "00"))
Изменено: artyrH - 21 Мар 2019 09:39:02
Формула Date.WeekOfYear в Power Query
 
еще вариант
Код
= Table.AddColumn(Источник, "Пользовательская", each if Text.Length(Text.From(Date.WeekOfYear([Столбец1]
), "ru-RU"))  = 1 then Text.From(Date.Year([Столбец1])) & "0" & Text.From(Date.WeekOfYear([Столбец1]
))  else Text.From(Date.Year([Столбец1])) & Text.From(Date.WeekOfYear([Столбец1]
)))
PQ значения из одного столбца перенести в три столбца согласно индексу
 
Андрей Лящук, спасибо
а, может, к каждой строке комментарии добавите
Поиск значения в диапазоне и возврат значения соответствующего диапазону
 
я вам показал фотку, вы говорите она левая. мне вас обманывать смысла нет. так то извиняйте если что :)  
Поиск значения в диапазоне и возврат значения соответствующего диапазону
 
у меня excel 2010. посмотрел в excel 2016, да, онлайн- справка другая.
dimavesna,  у вас хоть сомнения отпали что справка от майкрософта  
Поиск значения в диапазоне и возврат значения соответствующего диапазону
 
Цитата
dimavesna написал:
не из справки с сайта майкрософт
РЖУНЕМОГУ
Поиск значения в диапазоне и возврат значения соответствующего диапазону
 
.
Сравнить каждую строку в таблице с остальными строками, Выделить строки по нескольким условиям
 
Андрей Лящук, заметно что Вы хорошо знаете язык М, только, пожалуйста, давайте решения попроще. с пошаговым решением
а то не знаю, положу в копилку, а смогу ли потом применить
Изменено: artyrH - 20 Мар 2019 13:12:09
Поиск значения в диапазоне и возврат значения соответствующего диапазону
 
Цитата
dimavesna написал:
ВПР ищет точное совпадение
а вы проверьте так ли это
PQ значения из одного столбца перенести в три столбца согласно индексу
 
Максим Зеленский, Андрей VG, спасибо за Ваши решения. как еще вариант, можно, при возможности, сразу столбец с нужным индексом добавить  
PQ значения из одного столбца перенести в три столбца согласно индексу
 
здравствуйте. не допру как сделать :cry:  надо как на скрине, значения из одного столбца развернуть в три столбца согласно индексу. не могли бы показать как это делается. я уже видел, но не знаю как гуглить. вернее, что гуглить.
Подстановка значения из шапки таблицы
 
раз результат верный, то выложу еще вариант
Код
=1+ПОИСКПОЗ(A2;ИНДЕКС($E$2:$E$20;ПОИСКПОЗ(B2;$D$2:$D$20;0)):ИНДЕКС($K$2:$K$20;ПОИСКПОЗ(B2;$D$2:$D$20;0));-1)
Изменено: artyrH - 20 Мар 2019 08:21:28
Подстановка значения из шапки таблицы
 
Цитата
Сергей написал:
должна быть 4
только хотел написать об этом..
Посчитать сколько сотрудников выполнили план по нескольким продуктам
 
Цитата
belogorskayata написал:
Не сложно будет объяснить смысл формулы?
скрин для наглядности. нажмите на счетесли
Посчитать сколько сотрудников выполнили план по нескольким продуктам
 
добавил к решению из #2
Разбить текст на строки указанной длины без разрыва слов
 
Цитата
qwerty66 написал:
не смог
.
Разбить текст на строки указанной длины без разрыва слов
 
qwerty66, у АlехМ, правильный результат. ваша формула в первой строке не дает верный результат
еще одна фм
Код
=ЕСЛИОШИБКА(ПСТР(ПСТР($A$1;СУММ(ДЛСТР($A$3:A3))+1;НАЙТИ("/";ПОДСТАВИТЬ(ПСТР($A$1;СУММ(ДЛСТР($A$3:A3))+1;69+1);" ";"/";69+1-ДЛСТР(ПОДСТАВИТЬ(ПСТР($A$1;СУММ(ДЛСТР($A$3:A3))+1;69+1);" ";"")))));1;69);ПСТР($A$1;СУММ(ДЛСТР($A$3:A3))+1;69))
Изменено: artyrH - 19 Мар 2019 08:46:32
Помогите с шахматкой для брони для агенства
 
.
Помогите с шахматкой для брони для агенства
 
andreask, есть
Код
=И(B$1>=ВПР($A2;BZ!$A$2:$D$24;3;0);B$1<=ВПР($A2;BZ!$A$2:$D$24;4;0))
Разбить текст на строки указанной длины без разрыва слов
 
в А5 массивную
Код
=ЕСЛИОШИБКА(ПСТР($A$1;СУММ(ДЛСТР($A$4:A4))+1;НАЙТИ("/";ПОДСТАВИТЬ(ПСТР($A$1;СУММ(ДЛСТР($A$4:A4))+1;69);" ";"/";69-ДЛСТР(ПОДСТАВИТЬ(ПСТР($A$1;СУММ(ДЛСТР($A$4:A4))+1;69);" ";"")))));ПСТР($A$1;СУММ(ДЛСТР($A$4:A4))+1;69))
Объединить взаимосвязанные данные (Дата, Сумма, Номер) из нескольких столбцов в один
 
Цитата
Prostaya написал:
с помощью формул
попробуйте так
Объединить взаимосвязанные данные (Дата, Сумма, Номер) из нескольких столбцов в один
 
Примерно так
Объединить взаимосвязанные данные (Дата, Сумма, Номер) из нескольких столбцов в один
 
раз уж делал то выложу
Prostaya,  в power query можно соединить
Сортировка уникальных значений, Сортировка уникальных значений в хронологическом порядке по убыванию
 
еще вариант с допстолбцом
Отбор ячеек по заголовкам столбцов, перечисленных в отдельной таблице
 
Цитата
AlxndrAntnv написал:
определить максимальное из них
Код
=МАКС(ИНДЕКС(ЕСЛИ(СЧЁТЕСЛИ($B$7:$J$7;$B$2:$Q$2)=1;($B$3:$Q$4));ПОИСКПОЗ(A11;$A$3:$A$4;0)))
Наилучший способ передачи макросов пользователям
 
Цитата
Nordheim написал:
ничего сложного
и вправду. спасибо
Наилучший способ передачи макросов пользователям
 
Цитата
Nordheim написал:
с помощью RibbonXMLEditor сделать вкладку и вывести кнопки запуска макросов на нее
покажите как делать
Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 20 След.
Наверх