Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Выбрать дату в календареВыбрать дату в календаре

Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 49 След.
Условное форматирование ячеек, адреса которых указаны в других ячейках
 
Stalinsvami, может, так подойдет
Макрос автоматической отправки писем при открытии книги
 
adamm, не работает. извиняюсь. на активации листа, по моему, работает. а с книгой, не знаю почему, нет
Макрос автоматической отправки писем при открытии книги
 
adamm, можно так. название запроса(Запрос — Запрос2) смотреть в Данные->подключения->имя
Код
Private Sub Workbook_Open()
Application.DisplayAlerts = False
' Макрос1 Макрос
With ThisWorkbook.Connections("Запрос — Запрос2").OLEDBConnection
    .BackgroundQuery = False
    .Refresh
End With
Call Send_Mail_Mass
Application.DisplayAlerts = True
End Sub
Поиск в тексте нескольких числовых значений
 
Lowerty, вы так хотите?
Код
=ЕСЛИОШИБКА(ЕСЛИОШИБКА(ПСТР(выписка!U3;НАЙТИ(47;выписка!U3;1);10);ПСТР(выписка!U3;НАЙТИ(46;выписка!U3;1);10));"")
Формула для расчета ставок с множеством условий
 
Alyonushka_kim, мало чего понятно, но тем не менее может прикрутите
Поиск в столбце значений больше 30 и вывод значений
 
это обращение к модераторам
Изменено: artyrH - 9 Сен 2019 09:54:00
Поиск в столбце значений больше 30 и вывод значений
 
Код
=ИНДЕКС(A$1:A$5100;АГРЕГАТ(15;6;СТРОКА($A$1:$A$5100)/($B$1:$B$5100>30);СТРОКА(A1)))
если надо, то название темы: поиск в столбце значений больше 30 и вывод значений
Сведение многих таблиц в одну в power query, Как объединить много таблиц в одну
 
extrafant, путь, в этом случае, меняется так: идете по пути Формулы-> Параметры вычислений и галочку на Автоматически
Сопоставить названия категорий между собой
 
запрос для 100% совпадений
Код
let
    Source = Excel.CurrentWorkbook(){[Name="Таблица1"]}[Content],
    Index = Table.AddIndexColumn(Source, "Индекс", 0, 1),
    Inserted = Table.AddColumn(Index, "Пос", each Text.AfterDelimiter([Категории поставщика], ">", {0, RelativePosition.FromEnd}), type text),
    Inserted2 = Table.AddColumn(Inserted, "Маг", each Text.AfterDelimiter([Категории магазина], ">", {0, RelativePosition.FromEnd}), type text),
    Trimmed = Table.TransformColumns(Inserted2,{{"Пос", Text.Trim, type text}, {"Маг", Text.Trim, type text}}),
    Merged = Table.NestedJoin(Trimmed,{"Пос"},Trimmed,{"Маг"},"Extracted2",JoinKind.LeftOuter),
    Expanded = Table.ExpandTableColumn(Merged, "Extracted2", {"Категории магазина"}, {"Результат"}),
    Sorted = Table.Sort(Expanded,{{"Индекс", Order.Ascending}}),
    Removed = Table.SelectColumns(Sorted,{"Категории поставщика", "Категории магазина", "Результат"})
in
    Removed
Изменено: artyrH - 7 Сен 2019 16:19:56
Обновление Power Query и версии Excel 2016, Зависимость лицензии Excel и версии Power Query
 
скачать и запустить
Изменено: artyrH - 4 Сен 2019 16:55:26
Power Query выгрузка столбца из другого источника согласно 100% совпадению с данными из других столбцов
 
еще вариант
Код
let
    table1=Excel.CurrentWorkbook(){[Name="Таблица1"]}[Content],
    table2=Excel.CurrentWorkbook(){[Name="Таблица2"]}[Content],
    Renamed = Table.RenameColumns(table2,{{"Route IATA", "Route IATA_1"}}),
    Merged = Table.Join(table1,{"Route IATA"},Renamed,{"Route IATA_1"},JoinKind.LeftOuter),
    Removed = Table.RemoveColumns(Merged,{"Route IATA_1"})
in
    Removed
изменение структуры выведенной таблицы из 1С
 
bandit, нули и возвращаемые ошибки знаете как убрать?
в таблице еще и дата со временем текстом
Изменено: artyrH - 3 Сен 2019 11:35:49
PQ. Замена значений по нескольким условиям
 
Андрей VG, времени не было. параллельно вебинар смотрел
PQ. Замена значений по нескольким условиям
 
нашел у себя
изменение структуры выведенной таблицы из 1С
 
как вариант
Power Qwery: вопрос по работе фильтра, почему фильтр убрал <null>?
 
Андрей VG, здравствуйте. так я сначала хотел занести null, но решил не отклоняться от предложенного в описании
если честно, то не знал что и null исключит
Код
let
    Source = Table.FromRecords({
        [CustomerID = 1, Вид транспорта= "САМОЛЕТ", Phone = "123-4567"],
        [CustomerID = 2, Вид транспорта= null, Phone = "987-6543"] ,
        [CustomerID = 3, Вид транспорта= "АВИАКАРГО", Phone = "543-7890"] ,
        [CustomerID = 4, Вид транспорта= "Ringo", Phone = "232-1550"]
    }),
    #"Replaced Value" = Table.ReplaceValue(Source,null,"===",Replacer.ReplaceValue,{"Вид транспорта"}),
    #"Filtered Rows" = Table.SelectRows(#"Replaced Value", each not Text.Contains([Вид транспорта], "САМОЛЕТ") and not Text.Contains([Вид транспорта], "АВИАКАРГО")),
    #"Replaced Value1" = Table.ReplaceValue(#"Filtered Rows","===",null,Replacer.ReplaceValue,{"Вид транспорта"})
in
    #"Replaced Value1"
Изменено: artyrH - 29 Авг 2019 08:58:32
Power Qwery: вопрос по работе фильтра, почему фильтр убрал <null>?
 
GaliyaF, здесь не пропало
Код
= Table.SelectRows( Table.FromRecords({[CustomerID = 1, Вид транспорта= "САМОЛЕТ", Phone = "123-4567"],[CustomerID = 2, Вид транспорта= "(NULL)", Phone = "987-6543"] ,[CustomerID = 3, Вид транспорта= "АВИАКАРГО", Phone = "543-7890"] ,[CustomerID = 4, Вид транспорта= "Ringo", Phone = "232-1550"]}), each not Text.Contains([Вид транспорта], "САМОЛЕТ") and not Text.Contains([Вид транспорта], "АВИАКАРГО"))
Power Qwery: вопрос по работе фильтра, почему фильтр убрал <null>?
 
Цитата
GaliyaF написал:
вопрос "почему?
вопрос простой, только без примера с запросом будем дольше разбираться
Power Qwery: вопрос по работе фильтра, почему фильтр убрал <null>?
 
в приложенном файле все ok.
Копирование вставка таблицы, сохраняя форматирование, Таблица при вставке в книгу Excel размазана в одном столбике
 
Цитата
Рубикон написал:
будет это работать?
надо смотреть
Заполнение шаблона из таблицы, заполнить бланк
 
Цитата
almir2012 написал:
))
нет, не могу. все файлы по скважинам держите в одной папке. адрес папки пропишите в А1. видите в папке еще есть АВР ШАБЛОН Ц-1.. - таких файлов не должно быть в папке. иначе запрос может не сработать. только файлы с одинаковой структурой на листе Акт вып работ ТКРС (1 стор).
нажмите Ctrl+Alt+F5. если данные не объявились, то у вас, скорее всего, нет Power Query. гуглите Power Query что за зверь
Подборка функций пользователя
 
Цитата
Evgenyy написал:
для подсчёта объёма и веса нефти и нефтепродуктов в береговых резервуарах и танках нефтеналивных судов
молю бога дать возможность применить эту функцию в личных целях :)  
Заполнение шаблона из таблицы, заполнить бланк
 
Цитата
Jack Famous написал:
Как заполните - продолжим
собрано в Power Query. в А1 адрес папки со скважинами
Копирование вставка таблицы, сохраняя форматирование, Таблица при вставке в книгу Excel размазана в одном столбике
 
Рубикон, может размазанное править формулой
Код
=ИНДЕКС($A$1:$A$150;СТРОКА(A1)*4+ОСТАТ(СТОЛБЕЦ(A1)-1;4)-3)
Как перенести отдельные блоки одного столбца в разные столбцы?
 
Цитата
tamilla8484 написал:
например по 50 ячеек в каждом блоке, 50 блоков
нажимаем Ctrl+G -ввели конечную ячейку->нажимаем Shift+Enter->выделяем строку формул, вводим формулу и нажимаем Ctrl+Shift+Enter
главное поставить нужные числа в СТРОКА()-9; СТРОКА()-10; СТОЛБЕЦ()-2
Код
=ЕСЛИОШИБКА(ЕСЛИ(СТРОКА()-9<7;ИНДЕКС(Sheet1!R1C1:R50000C1;ОСТАТ(СТРОКА()-10;7)+1+(7*(СТОЛБЕЦ()-2))-7);"");"")
Изменено: artyrH - 25 Авг 2019 14:54:29
Как перенести отдельные блоки одного столбца в разные столбцы?
 
формулой и в Power Query
Код
=ЕСЛИ(СТРОКА(A1)<7;ИНДЕКС(Sheet1!$A$1:$A$50;ОСТАТ(СТРОКА(A1)-1;7)+1+(7*СТОЛБЕЦ(A1))-7);"")
Изменено: artyrH - 25 Авг 2019 10:45:58
Перенос ячеек на второй лист по заданным параметрам
 
Blondinka, не справитесь -пишите в личку
нули можно убрать по пути Файл-> Параметры-> Дополнительно. убрать галочку как на скрине. Ok
Перенос ячеек на второй лист по заданным параметрам
 
Цитата
Blondinka написал:
какие могут быть причины?
ну не знаю... исключили как надоевшую)
введите в ячейку =поиск    предложится  пару вариантов функций
Изменено: artyrH - 15 Авг 2019 23:08:39
Формула расчета с выбором по нескольким аргументам
 
Цитата
gabber24 написал: не получилось
copy-paste не получилось?
Формула расчета с выбором по нескольким аргументам
 
как понял
Код
=ЕСЛИ(B10="usd";C10;C10*ВПР(B10;$A$3:$E$5;1+МЕСЯЦ(A10);))
Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 49 След.
Наверх