Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Выбрать дату в календареВыбрать дату в календаре

Страницы: 1
Наличие определенных букв в ячейке с помощью функции АГРЕГАТ
 
Добрый день!

допустим есть ячейка, которая содержит какой-то текст, к примеру - ИваНов иВан ивановИЧ
также есть определенный список букв, которые необходимо проверить, на наличии хотя бы одной буквы в строке (пусть это будут заглавные буквы нашего алфавита)
с помощью функции массива - =СУММ(ЕСЛИОШИБКА(НАЙТИ(буквы;A2);0)), проблем нет, все считает верно
но ни как не могу понять почему формула =АГРЕГАТ(9;6;НАЙТИ(буквы;A2)) не работает
подскажите, пожалуйста.
Power Query - добавление столбца с данными из Json.Documen
 
Всем привет!

долго ломаю голову, как сделать
ситуация следующая есть столбец со значениями, к этому столбцу добавляется http ссылка + данные из первого столбца
и далее по каждой ссылке второго столбца необходимо вытянуть значения по Json.Document и вставить их в третий столбец

если в столбце только одно значение, то проблем нет вообще, все легко и просто, но есть в столбце более одного значения, не получается...

Код
let
    Источник = Excel.CurrentWorkbook(){[Name="animals"]}[Content],
    #"Повышенные заголовки" = Table.PromoteHeaders(Источник),
    #"Добавлен пользовательский объект" = Table.AddColumn(#"Повышенные заголовки", "Custom", each "https://data.gov.uk/api/3/action/package_search?q=" & [Животные]),
    z = Json.Document(Web.Contents(#"Добавлен пользовательский объект"[Custom]))
in
z
ошибка -
Код
Expression.Error: Не удается преобразовать значение типа List в тип Text.
Подробные сведения:
    Value=List
    Type=Type
подскажите, плиз, где ошибка и куда копать далее
Страницы: 1
Наверх