Превращение текстовой даты в полноценную функцией ДАТАЗНАЧ (DATEVALUE)

Если в вашей ячейке лежит дата в виде текстовой строки, например, "8 март 2013", то для Excel это, естественно, не дата, а текст. Чтобы преобразовать текстовую дату в полноценную (читай – в числовой код даты, т.к. внутри Excel любая дата представлена именно числовым кодом), можно использовать специальную функцию ДАТАЗНАЧ (DATEVALUE). Она умеет превращать в нормальную дату различные текстовые варианты ее написания:

Превращение текстовой даты в полноценную с ДАТАЗНАЧ

Как видно из скриншота, проблемы с преобразованием будут только у англоязычных дат (если у вас установлен русский Excel), с падежами месяцев (ибо их нет в английском языке в принципе) и с совсем уж невнятными цифровыми наборами типа "18 3 17". Со всем остальным эта функция замечательно справляется.

Если для ввода дат была использована не точка или косая черта, а запятая (что часто бывает при использовании дополнительной цифровой клавиатуры), то придется сначала заменить запятую на точку с помощью функции ПОДСТАВИТЬ (SUBSTITUTE) и потом уже использовать функцию ДАТАЗНАЧ для преобразования получившегося текста в реальную дату:

Дата с запятыми

Ссылки по теме




19.03.2017 00:52:08
Николай, доброго времени суток!
Большое спасибо за сайт и за приемы работы в Excel, которые Вы периодически публикуете! Многие из них применяю в своей работе.
Приведите, пожалуйста, пример, где возможно практическое применение функции ДАТАЗНАЧ (DATAVALUE), описанной в данной статье?
19.03.2017 23:24:14
Легко. Например, вы выгрузили здоровенную таблицу с данными из какой-нибудь 1C, где есть столбец с такими кривыми датами в текстовом формате. И надо преобразовать их в нормальные даты. Много раз такие ситуации встречал :)
Безусловно, есть и другие способы решения: макросы, Power Query, текст по столбцам и т.д. Эта функция - один из вариантов.
14.04.2017 14:36:26
Как-то сталкивался с обратной задачей: дату Excel перевести в Текст
Понятно, что можно формулой: =ТЕКСТ(Excel_Дата;"ДД.ММ.ГГГГ";)
– но проблема в том, что в английской версии Excel эта формула не работает из-за русского шаблона "ДД.ММ.ГГГГ".

А как без формулы дату Excel перевести в Текст? Я на уровне Excel решения не нашел вообще…
22.04.2017 10:46:39
Например, так:
=ЕСЛИ(ТЕКСТ(A1;"Д")="Д";ТЕКСТ(A1;"DD.MM.YYYY");ТЕКСТ(A1;"ДД.ММ.ГГГГ"))
24.04.2017 07:33:09
15.06.2017 15:09:29
Добрый день, нужна ваша помощь. Уже неделю бьюсь над этой задачей но решения не нашел. Существует 2 таблицы, в одну даты заносятся в виде "2 июня", в другой в виде "02.06.2017", и их необходимо сравнить и в зависимости от результат выставить другую дату. Возможно ли это сделать штатными средствами excel? Если что, во второй таблице даты так же можно заводить в формате "2 июня".

С уважением,
Сергей.
30.06.2017 12:22:23
Николай, добрый день!
еще два примера восстановления даты (преобразования формата) они у Вас в других темах тоже фигурируют:
1) проставить "--" (двойной минус) в начале формулы
2) +0 или 0+ (прибавить ноль) в начале или в конце формулы
05.08.2017 18:41:03
Николай добрый день! Спасибо за сайт, огромная работа.3 неделю просматриваю и переделываю программу. На данный момент очень хочется решить 2 вопроса. 1 это как мне быстрее забить дату и время в одной ячейке. Пример простой в ячейке я набираю 10 / 8 пробел 21 шифт : 00 enter получается 10.08.17 21:00.  Можно как нибудь забивать дату и время без шифта 10082100 ну что то в этом роде? А второй я разбил по группам в одной ячейке у меня видны Страны,а в другой команды футбольные их максимум 30 и вот когда нажимаю на галочку справа я вижу только 8 . Можно сделать что было все 30 видно сразу чтоб быстрее выбирать из списка? Спасибо.
15.09.2017 12:01:55
1) С дополнительным столбцом  =ДАТАЗНАЧ(СЦЕПИТЬ(ЛЕВСИМВ(A1;2);".";ПСТР(A1;3;2)))+ВРЕМЯ(ПСТР(A1;5;2);ПРАВСИМВ(A1;2);0), А1 ваше значение. Формат ячейки меняйте на ДД.ММ.ГГ ч:мм
или =ДАТАЗНАЧ(СЦЕПИТЬ(ЛЕВСИМВ(A1;2);".";ПСТР(A1;3;2);".";"2017";))+ВРЕМЯ(ПСТР(A1;5;2);ПРАВСИМВ(A1;2);0)
   2) С помощью "Элементы управления формы" на вкладке Разработчик.
13.11.2017 21:47:12
Добрый вечер!
Как преобразовать такой пример: 31 января 1947 года в дату в формате Ексель?!
01.12.2017 06:25:15
Добрый день!
Подскажите, пожалуйста, как преобразовать ячейки формата
03.11.2017 10:29
в обычную дату?
21.01.2018 03:08:56
Добрый день!
Подскажите пожалуйста как из номера сертификата в текстовом формате 156240402051217093 (где цифры с 10 по 15 это дата выпуска 051217)  извлечь эту дату? Эта функция также может быть полезна для извлечения даты из номера ГТД, например 10606050/011217/0016288.

Спасибо!
21.01.2018 03:21:15
Сам поразбирался и нашел. Может кому пригодится - извлечение даты из номера фитосанитарного сертификата, ГТД и других документов, если в номере "зашиты" эти данные.

=ДАТАЗНАЧ(СЦЕПИТЬ(ПСТР(A1;10;2);".";ПСТР(A1;12;2);".";ПСТР(A1;14;2)))
Наверх