Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Выбрать дату в календареВыбрать дату в календаре

Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 28 След.
Ошибка в запросе PQ, при добавлении второго источника, Не находит второй источник
 
Молодое_Поколение, в личку не пишите
Цитата
Молодое_Поколение написал:
Михаил вы хорошо разбираетесь в запросах?
Так себе
Цитата
Молодое_Поколение написал:
знаете в чем ошибка? Или как исправить?
Лист пустой, {0} возвращает ошибку. Исправить можно try and otherwise или так: [edges]{0}?[node]?
Изменено: Михаил Л - 12 Июл 2020 17:14:17
Ошибка в запросе PQ, при добавлении второго источника, Не находит второй источник
 
Цитата
Молодое_Поколение написал:
выдает пустой список
Не у всех же.
Цитата
Молодое_Поколение написал:
нужны еще какие-то уточнения для списка?
Нет, этого достаточно. Если список пустой, уточняй-не уточняй, все равно будет пустым
Изменено: Михаил Л - 12 Июл 2020 16:55:07
Ошибка в запросе PQ, при добавлении второго источника, Не находит второй источник
 
Цитата
Молодое_Поколение написал:
там все одинаково?
Пробуйте добавлять в скобках по одному. Сначала [data]. Посмотрите что получилось. Потом добавьте [user]. Посмотрите что получилось. И т.д.
Код
[data][user][edge_owner_to_timeline_media][edges]{0}[node]
Ошибка в запросе PQ, при добавлении второго источника, Не находит второй источник
 
Молодое_Поколение, смотрите последние четыре шага
Код
let
    Source = Excel.CurrentWorkbook(){[Name="Таблица1"]}[Content],
    Typed  = Table.TransformColumnTypes(Source ,{"Столбец1", type text}),
    Source2 = Excel.CurrentWorkbook(){[Name="Таблица2"]}[Content],
    Typed2  = Table.TransformColumnTypes(Source2 ,{"Столбец1", type text}),
    add = Table.AddColumn(Typed & Typed2, "a", each let
    Source = Json.Document(Web.Contents("https://www.instagram.com/graphql/query/?query_hash=472f257a40c653c64c666ce877d59d2b&variables={""id"":"&[Столбец1]&",""first"":50,"":"&[Столбец1]&":""XXXXXX"""))
in
    Source), 
    add3 = Table.AddColumn(add, "Публикации", each let
   data = [a][data][user],
   __typename= data[__typename]
in
    __typename),
    Custom1 = Table.FromColumns({Typed[Столбец1],Typed2[Столбец1]}),
    Custom2 = Table.AddColumn(Custom1, "a", each Json.Document(Web.Contents("https://www.instagram.com/graphql/query/?query_hash=472f257a40c653c64c666ce877d59d2b&variables={""id"":"""&[Column1]&""",""first"":12,""after"":"""&[Column2]&"""}"))),
    Custom3 = Table.AddColumn(Custom2, "b", each [a][data][user][edge_owner_to_timeline_media][edges]{0}[node]),
    Expand = Table.ExpandRecordColumn(Custom3, "b", {"__typename"}, {"__typename"})
in
    Expand
Изменено: Михаил Л - 12 Июл 2020 15:21:24
Смещение доходов и расходов на период
 
Формулу в N7
Код
=ЕСЛИОШИБКА(ИНДЕКС($C3:$F3;СТОЛБЕЦ(A1)-$N$2);"")
PQ. Неявное перечисление аргументов Text.Combine
 
Цитата
PooHkrd написал:
две функции с полностью идентичным функционалом
Насчет остального полностью не уверен, а вот по времени отработали запросы, можно сказать, одинаково
Смещение доходов и расходов на период
 
saltyzebra,если в ячейке N2 поставить 4, то как должна выглядеть таблица в диапазоне N6:R9 ?
Смещение доходов и расходов на период
 
saltyzebra,а не подойдет смещение названий столбцов?
В ячейку С2 и протянуть вправо
Код
=ИНДЕКС({"1 квартал":"2 квартал":"3 квартал":"4 квартал"};ОСТАТ(СТОЛБЕЦ(A1)+($N$2-2);4)+1)
График выхода сотрудников с чредовнием дневных и ночных смен
 
Dovletmurat,на мой взгляд, лучше на отдельном листе сделать график смен на весь год, а оттуда уже тянуть нужный месяц
График выхода сотрудников с чредовнием дневных и ночных смен
 
Цитата
Dovletmurat написал:
в каждую ячейку отдельно вставили формулу?Спасибо за старания
Вставил в одну ячейку и протянул. Но гораздо больше стараний уходит на разработку формулы
График выхода сотрудников с чредовнием дневных и ночных смен
 
Dovletmurat, на листе Механик так я и не разрулил
Требуется сотрудник для работы в Санкт-Петербурге
 
Цитата
Jack Famous написал:
Условия:  
• ЗП ~60 тыс (уточняется с начальником по итогам собеседования)  
...
• оформление по ТК
Я готов работать удаленно за половину озвученной зарплаты.
Оформление в устном порядке.
Power Query. Удаление подряд идущих дубликатов только в двух столбцах с сохранением строки
 
Еще вариант
Код
let
    ИСТОЧНИК = Excel.CurrentWorkbook(){[Name="Таблица2"]}[Content],
    ГРУППА = Table.Combine(Table.Group(ИСТОЧНИК, {"Столбец1"}, {{"a",
    each let a=_,b=Table.Combine(Table.Group(_,{"Столбец2"}, {{"b",
    each let a=Table.ToColumns(_),b= {List.FirstN(a{1},1),a{2}} in 
    Table.FromColumns(b)}})[b]),c={{a[Столбец1]{0}}}&Table.ToColumns(b) 
in  Table.FromColumns(c)}})[a]) in ГРУППА
PQ. Неявное перечисление аргументов Text.Combine
 
Student64, коротко не получилось
Код
= Table.AddColumn(Таблица, "Combine", (i)=> let a=Record.SelectFields(i,ColName) in Text.Combine(Record.ToList(a)," ") )
PQ. Неявное перечисление аргументов Text.Combine
 
Student64, я сам студент)
Изменено: Михаил Л - 10 Июл 2020 15:56:29
Определение стоимости поставки в зависимости от условия, заложенного в штрих-код, упрощение формулы
 
Еще вариант. Массивная формула
Код
=--ВПР("*"&R3&"*";""&$I$3:$P$5;8;)
Изменено: Михаил Л - 10 Июл 2020 07:58:45
Power Query. Слияние по совпадению начала номера договора.
 
Цитата
whateverlover написал:
вместо обычного слияния стало слияние по частичному совпадению
Сначала слияние, потом поиск частичного совпадения
Код
let
    Src = Table.AddIndexColumn(Table.Join(Excel.CurrentWorkbook(){[Name="Таблица1"]}[Content],
    {}, Excel.CurrentWorkbook(){[Name="Таблица2"]}[Content],{}),"id"),
    Flt = Table.SelectRows(Src, each Text.StartsWith([Договор в базе],  [#"Договор kak он уkaзaн в нaзнaчении"])),
    Srt = Table.RemoveColumns(Table.Sort(Flt,{{"Договор kak он уkaзaн в нaзнaчении",0},{"id",0}}),{"id"})
in
    Srt
Суммирование чисел, записанных с текстом
 
aslanbek75, решайте свою задачу формулой:
Код
=-4+--ПСТР(ПОДСТАВИТЬ(ГПР("*\н";$D5:$AG5;1;0);"\";ПОВТОР(" ";99));1;99)
Единственное, что в диапазоне, где нет "\н" в результирующей  ячейке пишет "н/д". Если нужно, чтобы ячейка оставалась пустой, то надо обернуть в соответствующую функцию:
Код
=ЕСЛИОШИБКА(-4+--ПСТР(ПОДСТАВИТЬ(ГПР("*\н";$D5:$AG5;1;0);"\";ПОВТОР(" ";99));1;99);"")
Изменено: Михаил Л - 10 Июл 2020 09:02:16
Отображение в выбранных ячейках дат из большой таблицы, таким образом, что бы даты из большой таблицы отображались через столбец
 
Цитата
Anna написал:
говорит что это не формула
Пробуйте формулы из сообщения #6
Отображение в выбранных ячейках дат из большой таблицы, таким образом, что бы даты из большой таблицы отображались через столбец
 
Цитата
Anna написал:
Пока только изучаю эксель
Код
=ИНДЕКС(R1C8:R1C247;;ПОИСКПОЗ(R1C3;R1C8:R1C247;)+СТОЛБЕЦ(RC[-3])*2)
Код
=ГПР(R1C;R1C8:R42C600;СТРОКА(RC[-1]);0)
Отображение в выбранных ячейках дат из большой таблицы, таким образом, что бы даты из большой таблицы отображались через столбец
 
Anna,не понятно что нужно. Может, я угадал?
Код
=ИНДЕКС($H$1:$IM$1;;ПОИСКПОЗ($C$1;$H$1:$IM$1;)+СТОЛБЕЦ(A1)*2)
Может, опять угадал и поправил другую формулу
Код
=ГПР(C$1;$H$1:$WB$42;СТРОКА(B2);0)
Изменено: Михаил Л - 8 Июл 2020 16:01:56
Вычисление интервалов дат Power Querry, Разница между двумя датами для уникального аргумента
 
Код
let
    Source = Excel.CurrentWorkbook(){[Name="Таблица1"]}[Content],
    Gr = Table.Group(Source,{"ID"},{{"a", each let a=_, b=
    Table.FromColumns({{0}&List.RemoveLastN(a[Date])}&{a[Date]},
    {"a","Date"}),c=Table.AddColumn(b, "Разница дней", each try [a]-
    [Date] otherwise null) in c[[Date],[Разница дней]]}}),
    Ex = Table.ExpandTableColumn(Gr,"a",{"Date","Разница дней"})
in
    Ex
Выгрузка данных из запроса PQ, несоответствие данных в сводной таблице из запроса
 
Цитата
Андрей VG написал:
Алгоритмы сортировки
Раз при небольшом количестве строк сортируется по-очередности, а при большом количестве сортируется не пойми как, то алгоритм сортировки либо отсутствует, либо алгоритм сортировки - хаос.
Должна быть какая то логика. Например, до двухсот строк - сортировка по-очередности, свыше двухсот - по-другому (и мы должны знать как именно именно по-другому)
Номер исходного столбца, в зависимости от значения ячейки.
 
Цитата
SaltaM написал:
Постаралась все сделать по образцу
Постарайтесь делать по правилам, прикладывайте пример. Массивная формула
Код
=ЕСЛИОШИБКА(--ИНДЕКС(формулы!$A$1:$Z$1;МИН(ЕСЛИ($B8=формулы!$H$2:$Z$28;СТОЛБЕЦ($H:$Z))));"")
Выбор расхода по линиям продаж в накладную
 
чернов, все дни на этом же листе
Код
=ЕСЛИОШИБКА(ПРОСМОТР(2;1/($B8=Лист1!$A$4:$E$14)/(Лист1!$B$4:$B$14=$I$1-1)/(Лист1!$D$4:$D$14=Лист2!G$7);Лист1!$E$4:$E$14);"")
Изменено: Михаил Л - 8 Июл 2020 06:25:45
Выгрузка данных из запроса PQ, несоответствие данных в сводной таблице из запроса
 
Цитата
RVA написал:
Как ни странно, но именно именно
Здесь PQ тоже отчебучил
Power Query - выделение в таблицах отключено, так как страница использует режим совместимости Internet Explorer
 
Цитата
PooHkrd написал:
он по идее для локального шэрпоинта должен работать, а не для облака на вандрайве
А у меня в Excel2016 только этот. Online нет
Power Query - выделение в таблицах отключено, так как страница использует режим совместимости Internet Explorer
 
Цитата
jeyhun написал:
Я прикрепил скриншот, где видно, что нет sharepoint
А вариант "Из других источников" рассматривали?
Или вам надо чтоб sharepoint был во вкладке "Из файла" ?
Непустые значения вертикального списка расположить горизонтально
 
Цитата
AndreyNew написал:
Пустота
Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист1!$B$1:$B$300;АГРЕГАТ(15;6;СТРОКА($A$1:$A$200)/(Лист1!$B$1:$B$180<>"");СТОЛБЕЦ(A1)));"")
Определение худшего по трем показателям, Необходимо вывести худшего работника в отдельную ячейку
 
VikTor, например, так:
Код
=ЕСЛИОШИБКА(ИНДЕКС($A$1:$A$6;НАИМЕНЬШИЙ(ЕСЛИ($B$4:$B$6<$B$9;СТРОКА($B$4:$B$6));СТРОКА(A1)));"")
Формула массивная
Изменено: Михаил Л - 7 Июл 2020 11:14:38 (Исправил, а то не понятно что за формула и как гуглить)
Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 28 След.
Наверх