Визуализация значками с функцией СИМВОЛ (CHAR)

В стандартном наборе шрифтов Windows есть много специальных символов, которые иногда весьма приятно и полезно было использовать на листе Excel:

  • всяческие звездочки для визуализации рейтингов
  • различные виды стрелок для отображения динамики, роста или падения
  • иконки человечков для иллюстрирования населения или количества сотрудников
  • символы различных объектов (автомобилей, самолетов, книг) для показа объема продаж и т.д.

В Microsoft Excel подобный трюк можно выполнить с помощью функция СИМВОЛ (CHAR), которая умеет выводить символ по его коду:

=СИМВОЛ(Код)

где Код - число от 0 до 255, внутренний код символа Windows.

Заметьте, что в разных шрифтах символы с одним и тем же кодом могут выглядеть по-разному. Поэтому для вывода нужного значка необходимо знать имя шрифта и код символа в нем. Проще всего это определить с помощью небольшой таблицы, которую можно сделать себе за пару минут и использовать потом как справочник:

Таблица кодов символов

Для всех ячеек столбца В установлен шрифт Arial, для столбца C - шрифт Webdings  и т.д. Так что одна и та же функция СИМВОЛ (CHAR) показывает нам символы с заданными кодами в каждом шрифте.

Обратите внимание, что первые три десятка кодов зарезервированы во всех шрифтах под системные нужды и в виде осмысленных символов не отображаются. А вот с остальными можно поиграться.

Также можно выбрать на вкладке Вставка команду Символ (Insert - Symbol), задать нужный шрифт и посмотреть код требуемого символа в нижей части окна:

Таблица символов

Вот так, например, можно визуализировать рост или падение продаж, используя символы с кодами 233 и 234 из шрифта Wingdings и простую проверку функцией ЕСЛИ (IF):

Использование стрелок для отображения динамики функцией СИМВОЛ

Цвет стрелок можно задать дополнительно, используя условное форматирование.

Или можно наглядно отобразить, например, количество персонала в каждом филиале компании, используя символ человечка (код 128 в шрифте Webdings) и функцию ПОВТОР (REPT), которая умеет повторять заданный символ икс раз:

Имитация диаграммы функциями СИМВОЛ и ПОВТОР

Ссылки по теме




22.03.2017 14:34:58
вот такие  вот статьи делают мои отчеты самыми красивыми и оригинальными среди всех сотрудников,другими словами : СПАСИБО за идею!
22.03.2017 14:44:57
Присоединяюсь!!!:D
26.03.2017 21:43:09
Здравствуйте!
А может кто-нибудь поделиться ссылочкой на скачивание шрифта?:)
Что-то Яндекс не дает совсем вариантов по "MicrChrt"  (Может я что-то не правильно ищу?)
А понял... Здесь в статье используется шрифт Webdings, а про "MicrChrt" я увидел в примерах надстройки PLEX...  (flib.xlsx)
Если кто знает ответ (по MicrChrt)  - подскажите!?)
Заранее спасибо!;)
27.03.2017 10:17:05
В статье все примеры на стандартных шрифтах (Webdings, Wingdings).
MicrChrt - это мой авторский шрифт, нарисованный специально для отображения микрографиков в старых версиях PLEX. Сейчас не актуален, т.к. с 2010 года в Excel есть спарклайны - то же самое, но лучше. Так что про MicrChrt можно забыть (но он есть в архиве с демкой PLEX, если что)
28.03.2017 07:07:38
Спасибо огромное Николай!
Будем пробовать! ;)
14.04.2017 15:31:47
Раньше часто в своих отчетах использовал данный метод!
Но, к сожалению, этот метод плохо сочетается со Сводными таблицами…
После появления в Excel адекватного «Условного форматирования» и «Спарклайнов» перестал использовать вообще…
Но в любом случае спасибо!
В случае поиска креатива и нестандартных значков это может помочь!
P/S
Кстати, возникла мысль формулу: =ЕСЛИ(C2>B2;СИМВОЛ(233);СИМВОЛ(234)) добавить в вычисляемое поле Сводной таблицы – но что-то не работает…
22.04.2017 10:37:29
Сергей, тут, скорее, нужно не вычисляемое поле, а вычисляемый объект добавлять с такой формулой (Calculated Item). Нужно же сравнить получившиеся итоги из сводной, а не исходные данные, правильно?
24.04.2017 07:42:08
Николай, вот так вычисляемое поле работает:
=ЕСЛИ('2015'>'2016';1;0)
А с подстановкой символов в вычисляемое поле не работает:
=ЕСЛИ('2015'>'2016';СИМВОЛ(233);СИМВОЛ(234))
=ЕСЛИ('2015'>'2016';"А";"Б")
Xat
09.10.2018 15:36:04
В примере , код и соответствующая формула сдвинуты на +1  
Наверх