Маркированный и нумерованный список в Excel как в Word

139861 10.11.2012 Скачать пример

В Microsoft Word есть замечательная команда в меню Формат - Список (Format - Bullets and Numbering), позволяющая быстро превратить набор абзацев в маркированный или нумерованный список. Быстро, удобно, наглядно, не надо следить за нумерацией. В Excel такой функции нет, но можно попробовать ее имитировать с помощью несложных формул и форматирования.

Маркированный список

Выделите ячейки с данными для списка, щелкните по ним правой кнопкой мыши и выберите Формат ячеек (Format Cells), вкладка Число (Number), далее - Все форматы (Custom). Затем в поле Тип введите следующую маску пользовательского формата:

wordlist1.png

Для ввода жирной точки можно воспользоваться сочетанием клавиш Alt+0149 (удерживая Alt, набрать 0149 на цифровой клавиатуре).

Нумерованный список

Выделите пустую ячейку слева от начала списка (на рисунке это С1) и введите в нее следующую формулу:

=ЕСЛИ(ЕПУСТО(D1);"";СЧЁТЗ($D$1:D1))

=IF(ISBLANK(D1);"";COUNTA($D$1:D1))

Затем скопируйте формулу на весь столбец. У Вас должно получиться примерно следующее:

numbered_list.gif

Фактически, формула в столбце С проверяет содержимое соседней справа ячейки (функции ЕСЛИ и ЕПУСТО). Если соседняя ячейка пустая, то не выводим ничего (пустые кавычки). Если не пустая, то выводим количество непустых ячеек (функция СЧЁТЗ) от начала списка до текущей ячейки, то есть порядковый номер.

 



27.03.2013 14:54:06
Здравствуйте, подскажите пожалуйста: в форматированной таблице можно ли задать нумерованный список, который будет работать по дате. Например справа будет не имя, а дата и нумерация только если дата одна и та же, но если другая, то счет начинается заново?
Я использовала немного другую формулу, но при добавлении строк она выдает ошибку.:

=СЧЁТ(ЕСЛИ(ТЕКСТ($D$2:D2;"ДДММГГччмм")=ТЕКСТ([@ДАТА];"ДДММГГччмм");СТРОКА($D$2:D2)))
 
Причем это массив.
10.04.2013 15:30:34
Ирина, по Вашему вопросу естьтакой вариант:

=ЕСЛИ(ЕПУСТО(B2);"";СЧЁТЕСЛИ($B$2:B2;B2))

При условии, что в колонке "А" нумерация, а в колонке "В" даты.
Ну и разумеется данные начинаются со второй строки, а в первой заголовки)
11.04.2013 07:31:18
07.07.2013 15:05:37
Здравствуйте. А как поступить, если в таблице (т.н. "умная" таблица msE'2010) часть строк периодически скрывается фильтром, а оставшиеся строки необходимо перенумеровать заново?
17.04.2015 14:29:43
vladjuha, здравствуйте,

Для перенумерации строк после фильтрации я применил вот такой способ:

=ЕСЛИ(B1="";"";АГРЕГАТ(3;5;B$1:B1))

В колонке "А" нумерация, в колонке "B" - данные, которые нумеруем.

Дополнительно:
В сторонней где-нибудь ячейке я пишу вот такую формулу, что добавляет информативности к таблице:
=ЕСЛИ(МАКС(A1:A1000)=СЧЁТЗ(B1:B1000);"Все фильтры сняты";"Отфильтровано  -  "&МАКС(A1:A1000)&"  строк")

Т.е.если включен фильтр, то вы всегда видите сколько строк отфильтровано фразой например: "Отфильтровано 365 строк".
Если же фильтры отключить, то отразится фраза "Все фильтры сняты".  
22.08.2013 11:08:51
А почему маркированный список работает только на букв? С числовым списком не получается.
09.10.2013 18:01:56
Кирилл, попробуйте в формате ввести  ● # вместо ● @, тогда для числового списка должно получиться.
Пример:
1вариант)      2вариант)
● @               ● #
● вася● 2
● петя● 3
● маша● 4
● саша● 5
08.10.2015 10:13:05
Здравствуйте, подскажите пожалуйста: можно ли задать нумерацию, отвечающую требованиям в ниже указанном примере без макросов
Пример:
1 Фарид
2 Саша
3 Иван
~ Вакансия
  Пустая ячейка
4 Павел
  Фарид
~ Вакансия
5 Дмитрий
 Фарид
И так:
1 В повторяющихся именах указать уникальную нумерацию ( Пример: Фарид )
2. Перед пустыми ячейками отсутствовала нумерация.
3. Перед ячейкой "Вакансия" присутствовал какой-нибудь символ.

Какая будет формула?

Спасибо!
Наверх